Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

iAtkos L2 na Lenovo X61 - nie jestem w stanie ponownie zainstalować


  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 Nasedo

Nasedo
  • Members
  • 11 postów

Napisano 27 styczeń 2015 - 21:15

Witam,

 

W przeszłości miałem już zainstalowanego i sprawnie działającego Hackintosha na moim Lenovo X61. Po pewnym czasie musiałem wykorzystać ten komputer i zainstalowałem na nim Windows 7 i Linuxa. Pomyślałem, że może znów warto skorzystać z Liona na tym komputerze.

 

Zakładam, że duża część wiedzy mi uleciała (bezpowrotnie?) i niestety, ale chyba robię coś źle.

 

Bazuję na poniższym poradniku:

 

http://blog.slor.net...-on-lenovo.html

 

Przed instalacją, w BIOSie przestawiam dysk na AHCI (chyba, że to jest moim błędem?) i wykonuję krok po kroku opisane czynności z poradnika. Przechodzę wszystko do punktu trzeciego włącznie. Natomiast przy punkcie czwartym, instaluję Combo Update 10.7.5, instaluję update fixer'a ponownie uruchamiam KextBeast'a i wykonuję restart - po wykonaniu oczywiście wszystkich koniecznych czynności - nigdy przed.

 

Po tym, komputer startuje, pojawia się plansza z jabłkiem, dysk pracuje intensywnie... po pewnym czasie pracuje bardzo rzadko ale system już nie wstaje. Wykonałem wszystkie te czynności dwukrotnie, za każdym razem jest taki sam rezultat, 100% powtarzalność. Zastanawiam się, czy może korzystałem kiedyś z innego poradnika, czy może sam wpadłem na jakiś pomysł, by wszystko działało poprawnie? Uprzednio system był z zainstalowanym update'm - działał przez miesiące u mnie bez jakiegokolwiek problemu, a teraz nie jestem w stanie go zainstalować. Być może dość niedokładnie opisałem wszystko - ale nie widzę celowości przepisywania procedur, które są w poradniku.

 

Czy ktoś z Was może mi pomóc? A może ewentualnie doradzić mi inną wersję OS'a która będzie z powodzeniem działać na tym sprzęcie? Będę wdzięczny za każdą poradę. Z góry dziękuję.



#2 PolishApple

PolishApple

    Trackpoint Fetish

  • Members
  • 1601 postów
  • LocationWrocław

Napisano 27 styczeń 2015 - 21:25

Przedewszystkim na seri 61 od lenovo instalowanie dystrybucji to czysty heretyzm :>, te lapki są banalne do odpaleni przy pomocy retail'a. Nawet audio odpalasz po applehda.

 

A co do instalacji:

1. ustaw protected memory na enable.

2. Zainstaluj retail'a i popraw DSDT wgraj odpowiednie kexty i nie używaj żadnych fixerów Multibestów i Kextbestów


  iwiczmX.gifsngnpc.jpg

 macOS 10.12 | Lenovo Thinkpad X220 | i7 2715qe 2.10Ghz | Intel QM67 | Intel HD3000 | - Quad MOD :>

 macOS 10.12 | Lenovo Thinkpad W530 | i7 3840qm 2.80Ghz | Intel QM77 | Nvidia k1000 | - Nowa płyta i Procek :>

 OSX 10.11 | Lenovo Thinkpad T440p | i5 4300m 2.60Ghz | Intel QM87 | Intel HD4600 | - na szczęście sprzedany

 OSX 10.11 | Lenovo Thinkpad X230 | i5 3320m 2.60Ghz | Intel QM77 | Intel HD4000 | - Zdechł

 macOS 10.2 | i7 2700k 5.00Ghz | AsUs P8P67 LE | ASUS GTX 980Ti |

OSX  10.9.5 | Lenovo Thinkpad L412 | i5 520m 2.44Ghz | Intel HM55 | Intel GMA HD | - Odpoczywa na półce

 OSX  10.8.5 | Lenovo Thinkpad T61 | C2D T9600 | Intel 965 | Intel GMA X3100 | - Zimuje :>


#3 Nasedo

Nasedo
  • Members
  • 11 postów

Napisano 27 styczeń 2015 - 21:37

Być może jest to heretyzm - nie neguję tego ;-) Jednak była to metoda, którą kiedyś znałem i z powodzeniem zastosowałem.

W tym co napisałeś widzę pewne przeszkody:

 

1. Co do "protected memory" - przyznam, że nie sprawdzałem, ale nie sądzę by zaszły w tym jakieś zmiany od poprzedniej instalacji

2. Nie posiadam wersji Retail dla Liona - posiadam Snow Leopard i posiadam Mountain Lion. Dlatego też bazowałem na iAtkos L2.

3. Moja wiedza może okazać się niewystarczająca aby poprawić DSDT i wgrać odpowiednie kexty - ale jeżeli nie takie jak posiadam, to jakie? Dlaczego nie używać narzędzia jak KextBeast - które to w przeszłości sprawdziło się?

 

Bardzo proszę o rozwinięcie.



#4 PolishApple

PolishApple

    Trackpoint Fetish

  • Members
  • 1601 postów
  • LocationWrocław

Napisano 27 styczeń 2015 - 21:50

1. w zakładce security albo advenced w sekcji memory

2. Jak i tak masz pirata iatkosa to ściągnij sobie lion'a

3. w google x61 osx86 i będzie wszystko albo u nas na forum poradnik astrael'a t61 dla SL-chodzi tylko o DSDT (t61 i x61 to bliźnicze konstrukcje z innym prockiem)


  iwiczmX.gifsngnpc.jpg

 macOS 10.12 | Lenovo Thinkpad X220 | i7 2715qe 2.10Ghz | Intel QM67 | Intel HD3000 | - Quad MOD :>

 macOS 10.12 | Lenovo Thinkpad W530 | i7 3840qm 2.80Ghz | Intel QM77 | Nvidia k1000 | - Nowa płyta i Procek :>

 OSX 10.11 | Lenovo Thinkpad T440p | i5 4300m 2.60Ghz | Intel QM87 | Intel HD4600 | - na szczęście sprzedany

 OSX 10.11 | Lenovo Thinkpad X230 | i5 3320m 2.60Ghz | Intel QM77 | Intel HD4000 | - Zdechł

 macOS 10.2 | i7 2700k 5.00Ghz | AsUs P8P67 LE | ASUS GTX 980Ti |

OSX  10.9.5 | Lenovo Thinkpad L412 | i5 520m 2.44Ghz | Intel HM55 | Intel GMA HD | - Odpoczywa na półce

 OSX  10.8.5 | Lenovo Thinkpad T61 | C2D T9600 | Intel 965 | Intel GMA X3100 | - Zimuje :>


#5 Nasedo

Nasedo
  • Members
  • 11 postów

Napisano 27 styczeń 2015 - 22:23

Mimo wszystko nie wyjaśnia to problemu, który najbardziej mnie nurtuje. Mogę się zgodzić, że dystrybucja iAtkos to heretyzm - mogę się zgodzić, że obecnie tego się nie stosuje. Ale mimo wszystko to kiedyś u mnie działało i nie mogę sobie ztym poradzić. A jeżeli chodzi o poradniki, również dla T61 - niestety, nie jest to dla mnie zbyt czytelne i zrozumiałe. Gotowe rozwiązanie, które zacytowałem było kompletne i działające - dlatego miałem nadzieję, iż ktoś zetknął się z podobnym problemem do mojego i wie jak sobie z tym poradzić.



#6 PolishApple

PolishApple

    Trackpoint Fetish

  • Members
  • 1601 postów
  • LocationWrocław

Napisano 27 styczeń 2015 - 22:41

Nie nie iAtkos jako dystrybucja był najleprzy (sam na nim zaczynałem na x61T), x61 jest bardzo łatwe do odpalenia z OSX to wszystko. Uważam że na retail'u nie będzie ci potrzeby fix po update. Jeśli chcesz to mogę ci pomóc cos tam jeszcze pamietam o x61.


  iwiczmX.gifsngnpc.jpg

 macOS 10.12 | Lenovo Thinkpad X220 | i7 2715qe 2.10Ghz | Intel QM67 | Intel HD3000 | - Quad MOD :>

 macOS 10.12 | Lenovo Thinkpad W530 | i7 3840qm 2.80Ghz | Intel QM77 | Nvidia k1000 | - Nowa płyta i Procek :>

 OSX 10.11 | Lenovo Thinkpad T440p | i5 4300m 2.60Ghz | Intel QM87 | Intel HD4600 | - na szczęście sprzedany

 OSX 10.11 | Lenovo Thinkpad X230 | i5 3320m 2.60Ghz | Intel QM77 | Intel HD4000 | - Zdechł

 macOS 10.2 | i7 2700k 5.00Ghz | AsUs P8P67 LE | ASUS GTX 980Ti |

OSX  10.9.5 | Lenovo Thinkpad L412 | i5 520m 2.44Ghz | Intel HM55 | Intel GMA HD | - Odpoczywa na półce

 OSX  10.8.5 | Lenovo Thinkpad T61 | C2D T9600 | Intel 965 | Intel GMA X3100 | - Zimuje :>


#7 Nasedo

Nasedo
  • Members
  • 11 postów

Napisano 28 styczeń 2015 - 12:38

Problem został rozwiązany:

 

Popełniałem błąd w tej części instrukcji:

 

 

- Prior to allowing the updater to restart your machine,
- Extract mac-os-x-lion-10.7.5-update-fixer.zip.
- Open up a Terminal session and change to the directory containing the fixer files.
- Use this command to run the fixer-upper:
sudo ./UpdateFixer.sh

 

Zamiast przejść do tego katalogu i w nim uruchomić skrypt, skrypt kopiowałem w zupełnie inne miejsce i tam jego uruchamiałem. Nie wiem dlaczego tak robiłem. Mam już działającego Hackintosha na moim Lenovo X61 Tablet - wraz z zainstalowaną aktualizacją do wersji 10.7.5

 

Dziękuję za zainteresowanie i myślę, że temat można zamknąć.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych