Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Problemy ze sleepem na kartach ATI/AMD Radeon R9 270X/280X i innych


  • Zaloguj się, aby dodać odpowiedź
60 odpowiedzi w tym temacie

#1 andy.lbn

andy.lbn
  • Members
  • 60 postów

Napisano 02 październik 2015 - 10:31

Witam wszystkich ;)

 

Ja jak i kilku użytkowników forum zaobserwowało problem dotyczący wybudzania ze sleepu na kartach z serii R9. Nie znalazłem na razie żadnego rozwiązania które było by skuteczne.

 

Testowane wersje:

El Capitan - wszystkie oficjalne bety, Golden Master RC, wersja oficjalna oraz beta 10.11.1

 

Jeżeli znajdziecie jakieś rozwiązanie tego problemu - dajcie znać dla potomych ;)


MSI Z97 MPOWER | Core i7 4790K | 8GB RAM Patriot SECTOR 5 CL8 1600 Mhz | XFX R9 280X Black Edition | Samsung EVO 128 GB + 2 x 750GB WD Green | CLOVER


#2 oswaldini

oswaldini
  • Moderators
  • 10397 postów
  • LocationBrzeszcze / Kraków

Napisano 02 październik 2015 - 10:35

Sprawdź z i bez injekcji. Przy injekcji sprawdź różne framebuffery. Po wyburzeniu połączenia się po vnc bo może komp stoi a obraz nie - kwestia connectorów w FB.

MacBook Pro 2012 MD103 15" | i7-3615QM | 8GB RAM | HD4000 + GT650M | Samsung 830 256GB
Hack Gigabyte H81N | i5-4460 | 8GB RAM | HD4600 | 640GB RAID0 Mac + 500GB Win | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#3 vdmesis

vdmesis
  • Donator
  • 186 postów
  • LocationKatowice

Napisano 02 październik 2015 - 18:47

Niestety sprawdziłem już różne opcje i nic nie pomaga.

Z tego co widać to ogólnie jest problem ze sleep z kartami AMD.

Slice napisał:
AMD graphics not wakes from sleep in ElCapitan. This is a task for research. 

Więcej, choć niezbyt dużo, w tym wątku:

http://www.insanelymac.com/forum/topic/308025-no-graphics-usb-audio-after-wake/

10.11.4+Clover3368+i72600K+AsusP8Z68Deluxe+AsusR9280X+NecEA274WMi+EizoL797+BenqW600+XonarU7+TechnicsRP-F10+Geil16GB+Plextor128GBM5S+3xSamsung500GBRAID0+CorsairCMPSU-650HXEU+iPad4+iPhone5S+FreeNAS9.3@8TBRAIDZ1


#4 Najrad

Najrad
  • Members
  • 543 postów
  • LocationPodhale

Napisano 02 październik 2015 - 19:48

10.11.1 również nie przynosi w tym temacie rozwiązania.


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; Asus R9 270X DCU II; Top; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.2

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; HIS 6870; mysz i klawiatura USB; SSD CrucialMX100-128GB; Yosemite 10.10.5

 


#5 Hector M. Wilde

Hector M. Wilde
  • Members
  • 62 postów
  • LocationWolin

Napisano 04 październik 2015 - 09:15

AMD Radeon 7950 też ma te problemy :/


Workstation | macOS Sierra 10.12.3 Core i7 4770 3,4GHz | ASRock Z87M Pro4 | 8GB RAM DDR3 | WD RED 2TB | SAPPHIRE AMD RADEON HD 7950 3 GB |
Home Server | macOS Sierra 10.12.3 | Intel Xeon E5410 2,33 GHz | Supermicro X7DCL-3 | 8GB DDR2 ECC | WD GREEN 1 TB (DATA) | NVIDIA GeForce GT 720 1GB PCI-E x8 |
Mobile | Windows 7 Professional Core i5 2520M 2,5GHz | Compaq CQ57-372RS | 8GB RAM DDR3 | WD Black 500GB Intel HD Graphics 3000 | [MARTWY]
Retro PC | Windows 98 Second Edition | Intel Celeron 333MHz 300 | ELPINA | EDO RAM 16MB | 10GB SEAGATES3 Trio64V+ |
iBook G4  | OS X 10.5.8 Leopard | PowerPC G4 1,07 GHz | 768 MB RAM DDR | 60GB Hitachi | AirPort Extreme | ATI Mobility Radeon 9200 32 MB |
Power Mac G4 MDD (Server)  | OS X 10.5.8 Leopard Server | Dual PowerPC G4 1GHz | 2GB RAM DDR | AirPort | ATI Radeon 9000 64 MB |


#6 Krymton

Krymton
  • Members
  • 41 postów

Napisano 04 październik 2015 - 11:51

Testowałem różne FB jak też z injekca, podłączone przez DVI,HDMI lub mDP nie naprawia problemu.


haMac | Asus Z97-Pro Gamer | Intel Core i3 4330@3,5Ghz | AMD R9 280x| FiiO E10 | i217V | AirPort Extreme BCM94360CD | 


#7 alex

alex
  • Members
  • 24 postów

Napisano 05 październik 2015 - 19:06

Temat znany, dotyczy chyba wszystkich kart AMD i rozkminiany na:

http://www.insanelymac.com/forum/topic/308025-no-graphics-usb-audio-after-wake/

U mnie dzieje się to na AMD 6670. Komputer wstaje i działa (mogę się zalogować via ssh) ale grafika martwa.

 

Tak na marginesie nie wyglada to ciekawie. Chyba wywalę AMD i kupię GT640.



#8 arielvanp

arielvanp
  • Donator
  • 1159 postów
  • LocationŻory PL / Cork IE

Napisano 05 październik 2015 - 19:43

No niestety moja R9 280x leci na sprzedaz w komputerze wyladowal GTX 760 ehhh ... , pierwszy raz kupilem radeona pod HAmaca wszystko bylo ladnie do czasu 10.11 


haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.11 & Clover

HaMAC C2D | MSI P45-8D | Core 2 Duo E7600 3.06GHz  | 4GB DDR2 677mhz | Seagate 500GB | Nvidia Quadro NVS295 256MB | ALC 888 | Realtek 8111C | AirPort Extreme BCM4321 | Mac OS X 10.6.8 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.11

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#9 Najrad

Najrad
  • Members
  • 543 postów
  • LocationPodhale

Napisano 06 październik 2015 - 11:05

Sleep ważny jest, bez dwóch zdań, ale co mają czynić ci od FCPX ?  Zostawić R9 i pogodzić się z bezsennością, czy zmieniać na Nvidię ( którą)?


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; Asus R9 270X DCU II; Top; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.2

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; HIS 6870; mysz i klawiatura USB; SSD CrucialMX100-128GB; Yosemite 10.10.5

 


#10 PolishApple

PolishApple

    Trackpoint Fetish

  • Members
  • 1602 postów
  • LocationWrocław

Napisano 06 październik 2015 - 11:47

A próbował ktoś zrobić rollback sterów?


  iwiczmX.gifsngnpc.jpg

 macOS 10.12 | Lenovo Thinkpad X220 | i7 2715qe 2.10Ghz | Intel QM67 | Intel HD3000 | - Quad MOD :>

 macOS 10.12 | Lenovo Thinkpad W530 | i7 3840qm 2.80Ghz | Intel QM77 | Nvidia k1000 | - Nowa płyta i Procek :>

 OSX 10.11 | Lenovo Thinkpad T440p | i5 4300m 2.60Ghz | Intel QM87 | Intel HD4600 | - na szczęście sprzedany

 OSX 10.11 | Lenovo Thinkpad X230 | i5 3320m 2.60Ghz | Intel QM77 | Intel HD4000 | - Zdechł

 macOS 10.2 | i7 2700k 5.00Ghz | AsUs P8P67 LE | ASUS GTX 980Ti |

OSX  10.9.5 | Lenovo Thinkpad L412 | i5 520m 2.44Ghz | Intel HM55 | Intel GMA HD | - Odpoczywa na półce

 OSX  10.8.5 | Lenovo Thinkpad T61 | C2D T9600 | Intel 965 | Intel GMA X3100 | - Zimuje :>


#11 robert999

robert999
  • Members
  • 241 postów

Napisano 06 październik 2015 - 11:59

... czy zmieniać na Nvidię ( którą)?

Na mojej 660 sleep działa (i po nim audio bez problemów zarówno zintegrowane, jak i zewnętrzne).


  • Sierra 10.12.1

#12 Najrad

Najrad
  • Members
  • 543 postów
  • LocationPodhale

Napisano 06 październik 2015 - 12:19

Na mojej 660 sleep działa (i po nim audio bez problemów zarówno zintegrowane, jak i zewnętrzne).

Nie chodzi mi wyłącznie o działanie, bardziej zależy mi na wydajności w FCPX (OpenCL). Jak już miałbym wymieniać 270X to na coś mocniejszego ( w sensie współpracy z FCPem) i tu właśnie się zastanawiam na co wymienić R9 ? Może warto jeszcze poczekać, w końcu R9 były dotychczas wspierane. Paradoksalnie, żona moja zażądała kategorycznie powrotu z Windows10 do starej siódemki bo przestał Jej działać sleep.... spisek jakiś czy co=P~


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; Asus R9 270X DCU II; Top; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.2

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; HIS 6870; mysz i klawiatura USB; SSD CrucialMX100-128GB; Yosemite 10.10.5

 


#13 wokie

wokie
  • Members
  • 315 postów

Napisano 06 październik 2015 - 12:51

Czy można tak zrobić, aby R9 służyła wyłącznie do obliczeń, a jakaś NV  do wyświetlania obrazu?


10.10.5/10.11.6 HaMac: Intel Core i5-4670K | ASRock Z87 Pro4 rev.C1| 2x8GB DDR3-1600 Crucial Balistic CL9 |SB Audigy2 ZS Gold| PX-128M5Pro |2x ST2000DM001 | iHAS124 |Pioneer BRD-208|Logitech -K750 MAC | BCM 94321MC| Asus R9 270X


#14 Krymton

Krymton
  • Members
  • 41 postów

Napisano 06 październik 2015 - 12:53

Chyba można odpalić dwie grafiki czyli 4600 i do tego R9


  • arielvanp lubi to

haMac | Asus Z97-Pro Gamer | Intel Core i3 4330@3,5Ghz | AMD R9 280x| FiiO E10 | i217V | AirPort Extreme BCM94360CD | 


#15 arielvanp

arielvanp
  • Donator
  • 1159 postów
  • LocationŻory PL / Cork IE

Napisano 06 październik 2015 - 14:12

Chyba można odpalić dwie grafiki czyli 4600 i do tego R9

mozna testowalem sleep dalej nie dziala przy odpalonych obu kartach

haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.11 & Clover

HaMAC C2D | MSI P45-8D | Core 2 Duo E7600 3.06GHz  | 4GB DDR2 677mhz | Seagate 500GB | Nvidia Quadro NVS295 256MB | ALC 888 | Realtek 8111C | AirPort Extreme BCM4321 | Mac OS X 10.6.8 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.11

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#16 Krymton

Krymton
  • Members
  • 41 postów

Napisano 06 październik 2015 - 18:23

nawet jak masz podłączony wyświetlacz do portu na płycie głównej ? Nie mam jak przetestować takiej opcji ponieważ brak mi przejściówki DVI-->HDMI mam tylko

mDP-->HDMI  

 

 | na 10.11.1 dalej bez zmian |


Użytkownik Krymton edytował ten post 06 październik 2015 - 23:44

  • arielvanp lubi to

haMac | Asus Z97-Pro Gamer | Intel Core i3 4330@3,5Ghz | AMD R9 280x| FiiO E10 | i217V | AirPort Extreme BCM94360CD | 


#17 arielvanp

arielvanp
  • Donator
  • 1159 postów
  • LocationŻory PL / Cork IE

Napisano 07 październik 2015 - 11:20

nawet jak masz podłączony wyświetlacz do portu na płycie głównej ? Nie mam jak przetestować takiej opcji ponieważ brak mi przejściówki DVI-->HDMI mam tylko
mDP-->HDMI

| na 10.11.1 dalej bez zmian |

dokladnie tak jeden monitor wpiety pod integre drugi do radka niestety po sleepie ciemnosc , radek i tak trafil juz do sprzedania czekam na szczesliwego kupca , jego miejsce zastapil gtx 760

haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.11 & Clover

HaMAC C2D | MSI P45-8D | Core 2 Duo E7600 3.06GHz  | 4GB DDR2 677mhz | Seagate 500GB | Nvidia Quadro NVS295 256MB | ALC 888 | Realtek 8111C | AirPort Extreme BCM4321 | Mac OS X 10.6.8 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.11

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#18 Najrad

Najrad
  • Members
  • 543 postów
  • LocationPodhale

Napisano 07 październik 2015 - 11:55

A w październiku 2014 kupiłen 270X nówkę pod FCPX ! Trochę jestem w rozkroku, nie wiem czy czekać na rozwiązanie czy zmieniać na inną kartę. Zależy mi na FCPX i OpenCL. Wstrzymam się do uaktualnienia FCP-a do wersji zoptymalizowanej pod ElCapitan. Może do tego czasu coś się zmieni w temacie Radków, albo zoptymalizują program do pracy z Nvidią. Nawet nie próbowałem poważnie pracować z FCPX+10.11, więc nie wiem czy brak wybudzania to jedyny problem związany z R9. 


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; Asus R9 270X DCU II; Top; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.2

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; HIS 6870; mysz i klawiatura USB; SSD CrucialMX100-128GB; Yosemite 10.10.5

 


#19 wujek_bogdan

wujek_bogdan
  • Members
  • 810 postów

Napisano 07 październik 2015 - 12:14

Sądzę, że warto poczekać, bo jeśli problem jest rozwiązywalny to myślę że prędzej czy później rozwiązanie się pojawi, ponieważ problem nie jest specyficzny dla jednego modelu, ale dotyczy wielu kart od AMD.

Na ten moment próbowałbym zrobić rollback kextów z 10.10.


Obecny:  10.11.2, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#20 Najrad

Najrad
  • Members
  • 543 postów
  • LocationPodhale

Napisano 07 październik 2015 - 13:42

Może i masz rację. Spróbuję testowo AMD7000Controller.kext wrzucić do kapitana. Myślałem o tym wcześniej, lecz tam jest jakiś nowy silnik graficzny "metal" i obawiam się komplikacji. Ale wieczorem spróbuję 


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; Asus R9 270X DCU II; Top; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.2

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; HIS 6870; mysz i klawiatura USB; SSD CrucialMX100-128GB; Yosemite 10.10.5

 





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych