Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Jak sprawdzić czy speed step działa w 100% poprawnie?

pm speed step

  • Zaloguj się, aby dodać odpowiedź
19 odpowiedzi w tym temacie

#1 wujek_bogdan

wujek_bogdan
  • Members
  • 843 postów

Napisano 18 październik 2015 - 22:09

Jako, że mój hackintosh działa poprawnie zaczynam drążyć szukając dziury w całym :)

 

Moja identyfikacja to iMac 14,2, a więc mnożniki skaczą między 8x a 36x (plus turbo 37, 38, 39, 40). Stanów pośrednich między min a max nie ma, ale już wiem, że to poprawne zachowanie dla tej identyfikacji. Zastanawia mnie natomiast to, że stan 8x pojawia się bardzo rzadko. Proc zdecydowaną większość czasu pracuje na mnożniku x38.

8x pojawia się tylko wtedy gdy wyłączę wszystkie aplikacje i przez dłuższy czas nie robię kompletnie nic. Wystarczy poruszać myszą, żeby mnożniki skoczyły do wyższych wartości.

 

Czy to jest normalne zachowanie i niepotrzebnie drażę?

 

SSDT wygenerowane oczywiście skryptem ssdtPRGen.sh. PM działa: komputer się usypia, budzi, etc, kexty: AppleLPC, X86PlatformPlugin załadowane.

 

PS

Zakładam w Hydeparku, bo żaden z działów mi nie pasuje do tego tematu. Moderacjo: przenieś wedle woli do odpowiedniego działu :)


Obecny:  10.11.5, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#2 reyder

reyder
  • Members
  • 358 postów

Napisano 18 październik 2015 - 22:30

Jeżeli się nie mylę używasz procesora "Haswell". Jeżeli tak to powinieneś używać -xcpm, dzięki temu będziesz miał stany od 16 do turbo. Clover nie wygeneruje ci poprawnie ssdt. Do tego, musisz użyć skryptu z tej strony, na angielskim języku bo na polskim są jakieś błędy czasami.

 

https://github.com/P...ha/ssdtPRGen.sh

 

Potem wgrywasz ssdt, dodajesz flagę w clover, sprawdzasz w konsoli czy nie ma żadnych błędów (szukaj po XCPM). Na koniec sprawdzasz kextem:

 

https://github.com/P.../AppleIntelInfo


  • sajpa lubi to

Core i5-3750K | Gigabyte GA-Z77-D3H | (Samsung Eco Green Sata II 500GB + Samsung 840 Pro SSD) Fusion Drive | Maxtor 160GB <-- Windows 10 | 3x4GB 1600MHz | Radeon 280X Asus | Sierra 10.12 | Clover


#3 AdamiPL

AdamiPL
  • Members
  • 647 postów
  • LocationPeterborough / UK

Napisano 18 październik 2015 - 22:32

Przypuszczam ze kolega ma wygenerowane ssdt przez skrypt pikera, co właśnie napisał ;-)


jakie masz opcje w zarządzaniu energia?
  • PolishApple lubi to

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#4 wujek_bogdan

wujek_bogdan
  • Members
  • 843 postów

Napisano 18 październik 2015 - 22:44

Jeżeli się nie mylę używasz procesora "Haswell". Jeżeli tak to powinieneś używać -xcpm, dzięki temu będziesz miał stany od 16 do turbo. 

 

Tak jak pisałem generuję stany za pomocą skryptu ssdtPRGen.sh. Nie używam Clovera do generowania SSDT. Ale używałem skryptu bez dodatkowych parametrów (tzn nie dodawałem flagi -xcpm). 

 

 

(...) Potem wgrywasz ssdt, dodajesz flagę w clover, sprawdzasz w konsoli czy nie ma żadnych błędów (szukaj po XCPM). 

 

XCPM jest OK:

cat /var/log/system.log | grep XCPM
Oct 16 09:25:58 localhost kernel[0]: XCPM: registered
Oct 16 09:25:58 localhost kernel[0]: IOPPF: XCPM mode
Oct 18 18:26:42 localhost kernel[0]: XCPM: registeredkXAudioDevice [HAL] db type: none [0]
Oct 18 18:26:42 localhost kernel[0]: IOPPF: XCPM mode

Więc tutaj nie mam zastrzeżeń. SSDT jest wygenerowane poprawnie. Zastanawia mnie tylko to, czy odpowiednie mnożniki są "aktywowane" w odpowiednim momencie. Podejrzane wydaje mi się to, że mnożnik x8 pojawia się tylko w momencie gdy zupełnie nic nie robię.

 

 

Na koniec sprawdzasz kextem: https://github.com/P.../AppleIntelInfo

Dzięki. Sprawdzę AppleIntelInfo.kext.

 

Na forum jest wiele wątków na temat zarządzania energią, ale brakuje wątku zbiorczego, w którym opisany byłby proces weryfikacji, czy wszystko na 100% działa poprawnie.

 

 

@AdamiPL
 

jakie masz opcje w zarządzaniu energia?

Screen w załączniku.

Załączone pliki

  • Załączony plik  pm.png   113,14 KB   2 Ilość pobrań

Obecny:  10.11.5, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#5 reyder

reyder
  • Members
  • 358 postów

Napisano 18 październik 2015 - 22:55

Masz włączone PM za pomocą AppleIntelCPUPowerManagment.kext.

 

Musisz specjalnie wygenerować ssdt z opcją -xcpm i dodać flage w cloverze. Więcej można poczytać o PM w haswellu i nowszym cpu tutaj:

 

https://pikeralpha.wordpress.com/2013/10/05/xnu-cpu-power-management/

 

To co masz też będzie działać, ale stany będziesz miał takie jak masz od 8x i turbo.


Core i5-3750K | Gigabyte GA-Z77-D3H | (Samsung Eco Green Sata II 500GB + Samsung 840 Pro SSD) Fusion Drive | Maxtor 160GB <-- Windows 10 | 3x4GB 1600MHz | Radeon 280X Asus | Sierra 10.12 | Clover


#6 wujek_bogdan

wujek_bogdan
  • Members
  • 843 postów

Napisano 18 październik 2015 - 22:58

Dzięki, poczytam.

 

BTW, warto by było taką informację przykleić na forum, bo z tego co widzę większość użytkowników generuje SSDT w ten sam sposób jak ja.

 

Dla pewności, mówiąc "dodać flagę w cloverze" masz na myśli:

<key>KernelAndKextPatches</key>
<dict>
   <key>KernelPm</key>
   <true/>
</dict>

Obecny:  10.11.5, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#7 reyder

reyder
  • Members
  • 358 postów

Napisano 18 październik 2015 - 23:14

Nie, musisz w arguments dodać opcje -xcpm. Tam gdzie dodaję się -slice, -x, -v itp.


Core i5-3750K | Gigabyte GA-Z77-D3H | (Samsung Eco Green Sata II 500GB + Samsung 840 Pro SSD) Fusion Drive | Maxtor 160GB <-- Windows 10 | 3x4GB 1600MHz | Radeon 280X Asus | Sierra 10.12 | Clover


#8 wujek_bogdan

wujek_bogdan
  • Members
  • 843 postów

Napisano 18 październik 2015 - 23:36

Porównałem diffem SSDT wygenerowane z flagą -x 1 i bez niej. Jak widać niczym się nie różnią.

Potem wygenerowałem jeszcze raz, tym razem ustawiając -x 0. Porównałem jeszcze raz

 

Jak widać jest zmiana w:

Store ("machdep.xcpm.mode....: 0", Debug)

Wniosek jest taki, że skrypt domyślnie uruchamiany jest z xcpm ustawionym na 1 i nie trzeba dodawać tej flagi (przynajmniej w przypadku mojego procesora czyli i7-4790k).

 

 

Po dodaniu -xcpm do argumentów Clovera również nie widzę żadnych zmian w mnożnikach. 


Obecny:  10.11.5, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#9 314TeR

314TeR

    Administrator

  • Administrators
  • 16584 postów
  • LocationWarszawa

Napisano 19 październik 2015 - 01:42

@reyder - dla Haswella i wyżej flaga "-xcpm" jest zbędna... Haswell i nowsze obligatoryjnie działają na XCPM. 

 

W stopce masz Z77 i na nim natywnie goniło się PM przez AppleIntelCPUPowerManagement.kext a nie przez XCPM. Tak działa na iMacach 13.x więc nie widzę powodu aby "poprawiać" oryginał. 

 

Czy XCPM działa OK? Jak ma się takie komunikaty w logu:

Oct 19 02:14:33 localhost kernel[0]: XCPM: registered
Oct 19 02:14:33 localhost kernel[0]: IOPPF: XCPM mode

To powinno być OK.

 

 

@wujek_bogdan - wysokie zegary - podziękuj Apple, że skopał PM na iMacach... niskie zegary bardzo rzadko widuję w HWMonitor, ale to też nie oznacza, że proc chodzi non-stop na pełnym gazie, bo taki nie jest. Popatrz w temperatury. 

 

Ten patch:

<key>KernelAndKextPatches</key>
<dict>
 <key>KernelPm</key>
 <true/>
</dict>

jest potrzebny jeśli UEFI płyty ma blokadę rejestrów MSR oraz masz CPU Haswella lub nowszy. 


  • wujek_bogdan i PolishApple lubią to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#10 wujek_bogdan

wujek_bogdan
  • Members
  • 843 postów

Napisano 19 październik 2015 - 07:55

Rozumiem, że w takim razie wszystko jest OK i niepotrzebnie drążę. Dzięki za rozwianie wątpliwości.

Odnośnie temperatur to są nieco za wysokie (od 30 w spoczynku do 70 w benchmarkach), ale mam boxowe chłodzenie, więc można powiedzieć, że są w normie.


Obecny:  10.11.5, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#11 314TeR

314TeR

    Administrator

  • Administrators
  • 16584 postów
  • LocationWarszawa

Napisano 19 październik 2015 - 08:03

Masz i7-4790k - to bardzo gorący CPU wymagający naprawdę dobrego chłodzenia aby utrzymać temperatury "w ryzach" pod obciążeniem. Puść sobie np OCCT pod Windowsem, to zobaczysz jak gotuje się CPU na boxie w 3 sekundy od włączenia. 


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#12 wujek_bogdan

wujek_bogdan
  • Members
  • 843 postów

Napisano 19 październik 2015 - 11:31

Planuję zmianę chłodzenia. Kupując nowy sprzęt łudziłem się, że może poprawili te boxowe chłodzenia. W ogóle dziwi mnie to, że gdzieś w okolicach Core 2 Duo zmienili radiatory na 2x niższe. Rozumiem cięcie kosztów... ale płacąc ~1000zł można oczekiwać czegoś lepszego. 


Obecny:  10.11.5, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#13 macsurf

macsurf
  • Members
  • 82 postów

Napisano 23 listopad 2016 - 17:29

U mnie co innego pokazuje Intel Power Gadget a co innego HWMonitor. Na oryginalnym maku krzywa dotycząca obciążenia skacze w zależności od obciążenia - co jest oczywiste. Na Hackintoshu i5 4460 Intel PG pokazuje skoki bez względu na obciążenie, HWMonitor jak jest obciażenie to ma x32 do max x34. Zrobiłem screnshoty ale widzę, że tutaj nie można dodawać obrazków.

 

Moje logi jeśli chodzi o XCPM:

Nov 23 11:36:35 localhost kernel[0]: XCPM: registered
Nov 23 11:36:39 Macsurfs-iMac kernel[0]: IOPPF: XCPM mode

Czy to wystarczy ?


OSX 10.11.6 / CPU: i5 4460 3.2GHz / MB: Gigabyte Z97X Gaming 3 / GPU: Gigabyte GTX 960 4GB VRAM / 16GB RAM / SSD Crucial MX300 275GB m.2 + SSD Samsung 840 EVO 128GB + SSD OCZ Agility 60GB + 2X 2TB HDD / PSU: Supremo L2 GOLD 550W


#14 javazlaz

javazlaz
  • Members
  • 1452 postów
  • LocationCzęstochowa

Napisano 23 listopad 2016 - 18:30

Oryginalnym Maku, ale czy jest to iMac Late 2013?


macOS 10.12.6 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Gigabyte HD 7770 1GB | Samsung 850 EVO 250GB | WD Red 1TB | Intel I218-V | Dell DW1510 | Asus USB-BT400 | ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium

Windows 7 Pro - HP tc4400 | 945GM | Core 2 Duo T7200 @ 2GHz | 3GB DDR2 667MHz CL5 | GMA950 | TeamGroup L7 Evo 120GB | BCM5753M | Intel 3945ABG | AD1981HD | Wacom Penabled


Windows 7 Pro - Lenovo "Kadłubek" ThinkPad T410 | QM57 | Core i5-520M | 1GB DDR3 1333MHz | NVS 3100M | Toshiba 500GB

iPhone SE 16GB Space Gray


#15 macsurf

macsurf
  • Members
  • 82 postów

Napisano 23 listopad 2016 - 18:47

Niestety nie mam imaca, testowałem pod mac mini i5 ( 2011 ) z ciekości jak na tej platformie jest to rozwiązane. Na imacach powyżej 13,2 są ponoc 2 stany speedstepu + turbo


OSX 10.11.6 / CPU: i5 4460 3.2GHz / MB: Gigabyte Z97X Gaming 3 / GPU: Gigabyte GTX 960 4GB VRAM / 16GB RAM / SSD Crucial MX300 275GB m.2 + SSD Samsung 840 EVO 128GB + SSD OCZ Agility 60GB + 2X 2TB HDD / PSU: Supremo L2 GOLD 550W


#16 314TeR

314TeR

    Administrator

  • Administrators
  • 16584 postów
  • LocationWarszawa

Napisano 23 listopad 2016 - 19:11

Mac mini ma bebechy mobilne i w nim prawidłowo działają stany pośrednie. Brak pośrednich stanów obserwowałem na iMacach od 11.x. 

 

PS Obrazki załączasz na forum dodając je jako załącznik. 


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#17 macsurf

macsurf
  • Members
  • 82 postów

Napisano 23 listopad 2016 - 20:07

Tak wiem, że mobilne tego nie da się nie odczuć szczególnie przy edycji video ;) Dlatego też zbudowałem sobie hackintosha :) Ok pokombinuje z tymi załącznikami chociaż w "Moje media" czegoś takiego nie było ale skoro jest to pewnie znajdę :)


OSX 10.11.6 / CPU: i5 4460 3.2GHz / MB: Gigabyte Z97X Gaming 3 / GPU: Gigabyte GTX 960 4GB VRAM / 16GB RAM / SSD Crucial MX300 275GB m.2 + SSD Samsung 840 EVO 128GB + SSD OCZ Agility 60GB + 2X 2TB HDD / PSU: Supremo L2 GOLD 550W


#18 314TeR

314TeR

    Administrator

  • Administrators
  • 16584 postów
  • LocationWarszawa

Napisano 23 listopad 2016 - 20:23

Skorzystaj z pełnej odpowiedzi a nie szybkiej i wstawia się załączniki jak na obrazku poniżej:

 

Załączone pliki


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#19 macsurf

macsurf
  • Members
  • 82 postów

Napisano 23 listopad 2016 - 20:58

OK, załączam pliki z Intel Power Gadget dla Mac Mini i5 2.3GHz ( wartość GT dla wbudowanego GPU ) i dla mojego Hackintosha z i5 4460 ( bez GT ). Co ciekawe temperatury na Hackintoshu o wiele niższe mimo 2 PStates :) tym bardziej, że Hack działa non stop a Mac Mini odpaliłem na testy i bardzo szybko się nagrzał. Nie sądzę, że to przez wbudowane GPU.

 

Obrazek nr 1: Hackintosh / nr 2: Mac Mini

Załączone pliki


OSX 10.11.6 / CPU: i5 4460 3.2GHz / MB: Gigabyte Z97X Gaming 3 / GPU: Gigabyte GTX 960 4GB VRAM / 16GB RAM / SSD Crucial MX300 275GB m.2 + SSD Samsung 840 EVO 128GB + SSD OCZ Agility 60GB + 2X 2TB HDD / PSU: Supremo L2 GOLD 550W


#20 macsurf

macsurf
  • Members
  • 82 postów

Napisano 23 listopad 2016 - 23:04

A tak wyglądają wykresy jęsli na SSDT wygenerowane przez skrypt pikera z wyłączoną sekcją SSDT w cloverze, nie wykluczone, że mogły być jakieś konflikty. Wcześniej były tylko wysokie spadki w bardzo wąskich przedziałach czasowych. A teraz to wygłąda nieco lepiej :)

 

Załączone pliki


OSX 10.11.6 / CPU: i5 4460 3.2GHz / MB: Gigabyte Z97X Gaming 3 / GPU: Gigabyte GTX 960 4GB VRAM / 16GB RAM / SSD Crucial MX300 275GB m.2 + SSD Samsung 840 EVO 128GB + SSD OCZ Agility 60GB + 2X 2TB HDD / PSU: Supremo L2 GOLD 550W






Również z jednym lub większą ilością słów kluczowych: pm, speed step

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych