Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Podział pendrive na partycje oraz bootowanie


  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 tomasz

tomasz
  • Members
  • 185 postów

Napisano 16 marzec 2016 - 23:04

Cześć,
Wpadłem ostatnio na pewien pomysł.
Czy była by możliwość podzielić pendrive na 3 partycje ? Czy może raczej Mission Imposible ?
Na jednej miał bym instalkę OS X na drugiej instalkę Windowsa a na trzeciej Clovera który pozwalał by mi wybrać co chcę odpalić.
I jeśli wgl da się coś takiego ogarnąć, to dobrze by było jak by te partycje były widziane przez Windowsa (ta z Cloverem oraz ta z instalką Windowsa).
Wielkie dzięki za wszelkie wskazówki.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#2 GrZeLa_82

GrZeLa_82
  • Members
  • 113 postów
  • LocationWicklow Town

Napisano 17 marzec 2016 - 14:41

Cześć Tomasz,

 

Myśle, że zawsze możesz trochę poeksperymentować i spróbować stworzyć takiego pendriva. Ja osobiście spróbowalbym to zrobić w nastepujący sposób, choć mogę sie mylić.

 

1. Spod OSX w Narzędzia Dyskowe zrobiłbympartycję o wielkości miedzy 7GB - 8GB sformatowaną w Mac OS Extended (kronikowany) i tablica partycji GUID.

2. Zainstalowłbym na wcześniej stworzonej partycji czystego Clovera i wrzucil do partycji EFi wszystko co potrzebuje do odpalenia instalacji OS X na moim sprzęcie.

3. Po instalacji Clovera wgrałbym instalke El Capitan na wyżej wymienionej partycji używajac tej komendy w terminalu:

sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/TutajNazwaTwojegoUSB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction 

4. Po zakończeni wrzucania El Capitan na USB, restart kompa do Windows i wgranie instalki Windowsa na pozostała cześć miejsca na USB.

5. Restart kompa Boot z USb i sprawdzam czy działa.

 

 Jeśli wyżej podany przykład mija sie z celem to z góry przepraszam. W razie potrzeby usunę moją odpowiedz aby nie śmiecić.


MacPro6.1 | OS X 10.11.3 | i7-3970X | Asus R4BE | 32GB HyperX Beast 2400Hz | 2x EVGA GeForce GTX 780 Ti | Samsung SSD 840 Evo 250GB | 


#3 tomasz

tomasz
  • Members
  • 185 postów

Napisano 17 marzec 2016 - 16:18

Właśnie OS X nie pozwala mi go podzielić na partycje. A jak dzielę przez Gparted to Windows nie widzi żadnej partycji :/.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#4 GrZeLa_82

GrZeLa_82
  • Members
  • 113 postów
  • LocationWicklow Town

Napisano 18 marzec 2016 - 12:25

To bardzo dziwne ale mój ma dokładnie ten sam problem na 10.11.3 co kolega wyżej. Na Snow Leopard 10.6.6 nie ma tego problemu mogę podzielić USB na partycje. Pogrzebie dokładnie w necie może znajdę rozwiązanie na El Capitan.


MacPro6.1 | OS X 10.11.3 | i7-3970X | Asus R4BE | 32GB HyperX Beast 2400Hz | 2x EVGA GeForce GTX 780 Ti | Samsung SSD 840 Evo 250GB | 


#5 tomasz

tomasz
  • Members
  • 185 postów

Napisano 18 marzec 2016 - 20:37

Ogólnie na windowsie też ciezko podzielić pedrive na partycje. Nie wiem czym jest to spowodowane.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#6 AdamiPL

AdamiPL
  • Members
  • 647 postów
  • LocationPeterborough / UK

Napisano 18 marzec 2016 - 23:26

Trzeba trochę pokombinować ale idzie. Sam tak tworze instalki dla klientów. Dziele pendrive na 2partycje. Jedna clover druga OS X

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#7 tomasz

tomasz
  • Members
  • 185 postów

Napisano 19 marzec 2016 - 19:00

Trzeba trochę pokombinować ale idzie. Sam tak tworze instalki dla klientów. Dziele pendrive na 2partycje. Jedna clover druga OS X

Jakim programem dzielisz pendrive na partycje ? Jeśli mogę wiedzieć.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#8 GrZeLa_82

GrZeLa_82
  • Members
  • 113 postów
  • LocationWicklow Town

Napisano 19 marzec 2016 - 19:49

Jakim programem dzielisz pendrive na partycje ? Jeśli mogę wiedzieć.

 

Podzielić możesz używajac komend w terminalu. W part 2 masz komendy do tworzenia partycji. Życzę miłej lektury:-D

 

Part 1 - http://www.theinstru...and-line-part-1

 

Part 2 - http://www.theinstru...and-line-part-2


MacPro6.1 | OS X 10.11.3 | i7-3970X | Asus R4BE | 32GB HyperX Beast 2400Hz | 2x EVGA GeForce GTX 780 Ti | Samsung SSD 840 Evo 250GB | 


#9 tomasz

tomasz
  • Members
  • 185 postów

Napisano 19 marzec 2016 - 21:48

Wszystko spoko 3 partycje. Tablica partycji GUID. OS X / Linux wyświetla. Tylko Windows nie raczy wyświetlić ani jednej partycji :/. Nawet tej sformatowanej jako Fat-32.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#10 GrZeLa_82

GrZeLa_82
  • Members
  • 113 postów
  • LocationWicklow Town

Napisano 20 marzec 2016 - 00:06

Wszystko spoko 3 partycje. Tablica partycji GUID. OS X / Linux wyświetla. Tylko Windows nie raczy wyświetlić ani jednej partycji :/. Nawet tej sformatowanej jako Fat-32.

No dokładnie tak jak piszesz, mam ten sam problem. Póki co rozwiązania nie znalazłem.


MacPro6.1 | OS X 10.11.3 | i7-3970X | Asus R4BE | 32GB HyperX Beast 2400Hz | 2x EVGA GeForce GTX 780 Ti | Samsung SSD 840 Evo 250GB | 


#11 bartulasdtv

bartulasdtv
  • Members
  • 57 postów

Napisano 20 marzec 2016 - 11:07

dlatego że jest partycja GUID


HaMacHome: El Capitan on MSI H77MA-G43 | i3-2100 | 4GB RAM | ATI Radeon HD6450 | ST3500312CS WDC WD10EZEX-22BN5A0

MACBook Unibody A1342 | 8GB RAM





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych