Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

UniBootX Clover - ASRock B85M Pro4


  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 javazlaz

javazlaz
  • Members
  • 1342 postów
  • LocationCzęstochowa

Napisano 16 październik 2016 - 21:14

Witam serdecznie!



Dość długo zabierałem się do utworzenia paczki dla UniBootX, ale stwierdzam, że mój Hack działa na tyle stabilnie, że mogę mój config upublicznić.

Mój hackintosh wygląda następująco:
Płyta główna: ASRock B85M Pro4 (UEFI w wersji 2.40, gdyż nowsze powodują problemy z wyłączeniem CSM przy nie-zintegrowanej karcie graficznej oraz z działaniem DVI)
Procesor: Intel Core i3-4330 3,5GHz
RAM: 4x4GB G.Skill RipJawsX 1600MHz CL7 1,5V
Chipset: B85
Karta graficzna: Palit GTX 750 Ti StormX OC 2GB
Kodek audio: ALC 892
Karta sieciowa: Intel I217-V
Karta Wi-Fi: AR5BXB72 (oryginalny AirPort z MacBooka z 2006 r)
Dyski: Samsung 850 Evo 250GB po SATA3 + WD Red 1TB po SATA2

Stabilność hacka w oparciu o El Capitana bardzo dobra, Yosemite również spisywał się nieźle, Mavericksa nie wspominam dobrze, a Sierry nie miałem jeszcze okazji przetestować.
USB 3.0 działa. Sleep/wake również działa, nie ważne czy uśpienie po określonym czasie, czy przez Jabłko > Uśpij.
Audio działa, LAN też. W configu włączony patch do TRIMu, więc możesz być być spokojny o swój SSD :)
 

Jakie kexty w paczce?



- FakeSMC.kext + sensory umożliwiające podgląd m.in. temperatur za pomocą HWSensors
- AppleALC.kext do uruchomienia zintegrowanego układu audio
- IntelMausiEthernet.kext do uruchomienia karty sieciowej

Nie trzeba niczego kopiować do /S/L/E, działa od strzała. Przygotowane dla 10.10, 10.11, 10.12.
 

Co zmienić w config.plist, aby ruszyła instalacja?



- Jeśli używasz tylko zintegrowanej grafiki HD 4600:
Usuń wpis nvda_drv=1 z sekcji Arguments, a w sekcji Graphics > Inject zmień Intel na true.

- Jeśli używasz niewspieranej oficjalnie grafiki NVidii:
Zmień nvda_drv=1 na nv_disable=1, po zainstalowaniu systemu, doinstaluj webowe sterowniki NVidii i podmień nv_disable=1 na nvda_drv=1.

- Jeśli używasz wspieranej grafiki NVidii - Kepler:
Usuń nvda_drv=1.

- Jeśli używasz wspieranej grafiki NVidii - Fermi i starsze:
Usuń nvda_drv=1, zmień Inject NVidia na true.

- Jeśli używasz wspieranej grafiki AMD - HD 7xxx i nowsze:
Usuń nvda_drv=1.

- Jeśli używasz wspieranej grafiki AMD - HD 6xxx i starsze:
Usuń nvda_drv=1, zmień Inject ATI na true.



Po zainstalowaniu systemu:



W config.plist w sekcji SMBIOS musisz podać prawidłowe dane, pomocny może okazać się Clover Configurator.
Usuń hashtag przy <key>#Board-ID</key> i zamiast UZUPELNIJ podaj prawidłowe dane. Tak samo zrób z <key>#SerialNumber</key> oraz <key>#SmUUID</key>.

W sekcji Boot w kluczu <key>DefaultVolume</key> zmień NONE na nazwę swojej partycji z OS X, aby Clover automatycznie z niej bootował. Oraz w kluczu Timeout wartość na 0, aby botoował od razu bez wyświetlania ekranu Clovera.

Paczka do użycia z UniBootX (do skopiowania do katalogu OEM): http://hamac.pl/file...e/21-b85m-pro4/
A w załączniku do tematu, kompletny Clover spakowany do .zip. Wystarczy wypakować na pendrive i można zabootować instalator uwzględniając zmiany z "Co zmienić w config.plist, aby ruszyła instalacja?:".

Załączone pliki


  • krzyssp lubi to
W domu: macOS 10.12.4 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Palit GTX 750 Ti StormX OC 2GB | Samsung 850 EVO 250GB | WD Red 1TBIntel I218-V Dell DW1510 | Asus USB-BT400ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium
 
W pracy: macOS 10.12.4 - Dell OptiPlex 960 SFF | Core 2 Duo E8400 | Hynix 8GB DDR2 800MHz CL6 1.8V | Sapphire HD6450 1GB LP | Sandisk SDSSDA120G | Intel 82567LM-3 | AD1984A
 
Przenośny: macOS 10.12.4 - Lenovo ThinkPad T410 | QM57 | Core i5-520M | GoodRAM 8GB DDR3L 1333MHz CL9 1.35V | NVS3100M 256MB | Sandisk SDSSDA120G | Intel 82577LM | Atheros AR5BXB72 | CX20585

 iPhone SE 16GB Space Gray

#2 jabi

jabi
  • Members
  • 142 postów

Napisano 12 styczeń 2017 - 18:08

Witam, 

Clover przestal wykrywac mi myszke i klawiature na tym configu na plycie ze stopki. Ma ktoś jakiś pomysł jak temu zaradzic?

 

Pzdr


Asrock B85 PRO4| i5-4460| B85| GTX780 3GB| 1 TB WD BLACK| San Disk SSD 128GB| GOODRAM C40 120GB| 8GB RAM| Win 10 && 10.11.6 | Philips 190CW + DELL P2414H

 

 

 MSI B75MA-E33| i3-3220 3.3ghz| B75 chipset| R9 280X 3GB | 1TB WD BLACK + 500 GB WD Elements USB + San Disk SSD 128GB (OSX) + GOODRAM C40 120GB (WIN10) |8GB RAM  |10.10 && Win 10| Philips 190CW + DELL P2414H


#3 javazlaz

javazlaz
  • Members
  • 1342 postów
  • LocationCzęstochowa

Napisano 13 styczeń 2017 - 18:22

A masz klawiaturę i myszkę na USB?


W domu: macOS 10.12.4 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Palit GTX 750 Ti StormX OC 2GB | Samsung 850 EVO 250GB | WD Red 1TBIntel I218-V Dell DW1510 | Asus USB-BT400ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium
 
W pracy: macOS 10.12.4 - Dell OptiPlex 960 SFF | Core 2 Duo E8400 | Hynix 8GB DDR2 800MHz CL6 1.8V | Sapphire HD6450 1GB LP | Sandisk SDSSDA120G | Intel 82567LM-3 | AD1984A
 
Przenośny: macOS 10.12.4 - Lenovo ThinkPad T410 | QM57 | Core i5-520M | GoodRAM 8GB DDR3L 1333MHz CL9 1.35V | NVS3100M 256MB | Sandisk SDSSDA120G | Intel 82577LM | Atheros AR5BXB72 | CX20585

 iPhone SE 16GB Space Gray

#4 jabi

jabi
  • Members
  • 142 postów

Napisano 13 styczeń 2017 - 18:46

Tak, działały w moim poprzednim komputerze w cloverze i osx. 2 razy udało mi sie wystartować system, ale potem juz nie wykrywa myszki i klawiatury. Wszystko bylo robione na efi, wiec teraz nie mam możliwości dostać sie do efi dopóki zadziała mi boot z usb.


Asrock B85 PRO4| i5-4460| B85| GTX780 3GB| 1 TB WD BLACK| San Disk SSD 128GB| GOODRAM C40 120GB| 8GB RAM| Win 10 && 10.11.6 | Philips 190CW + DELL P2414H

 

 

 MSI B75MA-E33| i3-3220 3.3ghz| B75 chipset| R9 280X 3GB | 1TB WD BLACK + 500 GB WD Elements USB + San Disk SSD 128GB (OSX) + GOODRAM C40 120GB (WIN10) |8GB RAM  |10.10 && Win 10| Philips 190CW + DELL P2414H





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych