Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

System bez tablic DSDT i SSDT?


  • Zaloguj się, aby dodać odpowiedź
13 odpowiedzi w tym temacie

#1 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 06 listopad 2016 - 17:49

Przez roztargnienie mam clover bez tych tablic i _na oko_ pracuje prawidłowo (usypianie, wybudzanie, restart, itd).

Używam trzech kextów (FakeSMC, IntelMausiEthernet i NullCPUPower...) + voodo dla ALC 662.

Jak sprawdzić prawidłowe działanie sprzętu - głównie procesor, jego stany, temperaturę, itd.?

Ps.

W clover mam:

-ACPI: Old way:FixDisplay, FixUSB, New way: AddHDMI

-Boot: Verbose -v, jext-dev-mode=1, rootless=0

-Devices: USB - inject, AddClockIDm FixOwnership

-Graphics - nie mam injectNVidia i działa

-Kernel and Kext Patches: Apple RTC - zaznaczone

-SMBIOS dla iMac 13.1 (bo z 12.1 karta grafiki nie pracuje

-System Par.: inject Kect Yes

 

Jak jest opinia sprawie używania DSDT i SSDT z moja płytą?

 


Mac Pro 3.1 - Sierra/Windows 10


#2 oswaldini

oswaldini
  • Moderators
  • 10321 postów
  • LocationBrzeszcze / Kraków

Napisano 06 listopad 2016 - 18:02

Nie działa prawidłowo, powód: NullCPUPowerManagement. Z tym kextem nie ma zarządzania energią co za tym idzie nie ma stanów turbo CPU.

Na twoim sprzęcie powinno wystarczyć generowanie stanów, powinno się obyć bez DSDT.


MacBook Pro 2012 MD103 15" | i7-3615QM | 8GB RAM | HD4000 + GT650M | Samsung 830 256GB
Hack Gigabyte H81N | i5-4460 | 8GB RAM | HD4600 | 640GB RAID0 Mac + 500GB Win | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#3 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 06 listopad 2016 - 19:55

Nie działa prawidłowo, powód: NullCPUPowerManagement. Z tym kextem nie ma zarządzania energią co za tym idzie nie ma stanów turbo CPU.

Na twoim sprzęcie powinno wystarczyć generowanie stanów, powinno się obyć bez DSDT.

Wywaliłem kext NullCPU.. jeżeli o to chodziło.

Do konfiguracji Clovera używam Configuratora, aw nim nie ma opcji, które sie wczytują na starcie w cloverze.

Zauważyłem, że w opcjach clovera (po boot) są zaznaczone opcje:

-CPUtuning:Halt Enabler, PStates, CStates. NIE SĄ zaznaczone: Enable C2 do C7

Czy o to chodzi w stanach procesora?

---

W listingu komunikatóe przy boot systemu w pierwszych liniach zauważyłem "NullCPUPowerManagment..... enabled"...

---

ACPI CPU do 6 są enabled.

-----

CZy jest jakieś narzędzie programowe do sprawdzenia stanów i innych "bajerów" procesora?


Mac Pro 3.1 - Sierra/Windows 10


#4 music

music

    Daniel

  • Members
  • 1108 postów
  • LocationZamość

Napisano 11 listopad 2016 - 15:59

Hwmonitor jest ciekawą aplikacją, polecam tylko kexty zainstaluj najlepiej w Clover http://www.hwsensors.com/releases

 10.12.3 + Clover 3974 config.plist -> http://pastebin.com/TMJczgiF + modyfikowane DSDT.aml 

Gigabyte GA-EP41-UD3L (FakeSMC.kext)

Intel Xeon E5410 (start z flagami "-v npci=0x2000 tscsync" + VoodooTSCSync.kext) 

Audio Realtek ALC888S-VD (AppleALC.kext) (audio device 0x808627D8, sub device 0x1458A002, codec id 0x10EC0888, revision 0x0001) 

LAN RTL8111 (AppleRTL8169Ethernet.kext + EFI String) 

EVGA Geforce 9400GT 512MB (DSDT.aml + NVDAStartup.kext z El Capitan 10.11.6)

 prawie od samego początku projektu hackintosh czyli 2006


#5 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 16 grudzień 2016 - 21:38

Hwmonitor jest ciekawą aplikacją, polecam tylko kexty zainstaluj najlepiej w Clover http://www.hwsensors.com/releases

Uciekł mi ten wątek. Nie bardzo sie łapię z wersjach strony. Są labo do OSX 10.10, albo do nowszych procesorów...

Mam HWMonitor, ale monitoruje mi tylko dyski twarde w zakresie temperatur (w sumie niezbyt przydatna opcja, bo rzadko mam mocno obciążone dyski).


Mac Pro 3.1 - Sierra/Windows 10


#6 javazlaz

javazlaz
  • Members
  • 1306 postów
  • LocationCzęstochowa

Napisano 16 grudzień 2016 - 21:52

Uciekł mi ten wątek. Nie bardzo sie łapię z wersjach strony. Są labo do OSX 10.10, albo do nowszych procesorów...

Mam HWMonitor, ale monitoruje mi tylko dyski twarde w zakresie temperatur (w sumie niezbyt przydatna opcja, bo rzadko mam mocno obciążone dyski).

 

A dlatego, że masz tylko FakeSMC w kexts/10.11. Musisz dorzucić sobie jeszcze sensory zależnie od tego na jakie podzespoły chcesz mieć oko. Pobierzesz je sobie ze strony, którą podał @music (Binaries). W .dmg będzie HWMonitor + FakeSMC + sensory.


W domu: macOS 10.12.3 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Palit GTX 750 Ti StormX OC 2GB | Samsung 850 EVO 250GB | WD Red 1TBIntel I218-V Dell DW1510 | Asus USB-BT400ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium
 
W pracy: macOS 10.12.3 - Dell OptiPlex 960 SFF | Core 2 Duo E8400 | Hynix 8GB DDR2 800MHz CL6 1.8V | Sapphire HD6450 1GB LP | Sandisk SDSSDA120G | Intel 82567LM-3 | AD1984A
 
Przenośny: Windows 7 Pro - Lenovo ThinkPad T410 | QM57 | Core i5-520M | GoodRAM 8GB DDR3L 1333MHz CL9 1.35V | HD Graphics (Arrandale) | Sandisk SDSSDA120G | Intel 82577LM | Intel 6200AGN | CX20585

 iPhone SE 16GB Space Gray

#7 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 16 grudzień 2016 - 22:32

A dlatego, że masz tylko FakeSMC w kexts/10.11. Musisz dorzucić sobie jeszcze sensory zależnie od tego na jakie podzespoły chcesz mieć oko. Pobierzesz je sobie ze strony, którą podał @music (Binaries). W .dmg będzie HWMonitor + FakeSMC + sensory.

Dzięki - faktycznie poszło. Doszła mi kolejna niewiadoma. Zaznaczyłem w pkg sensory, gdzieś się zainstalowały kexty, bo przy boot widzę, ale samych kextów nie mogę znaleźć. W kextach clovera nie ma (partycja EFI), Wyszukiwanie na dusku pod hasłem "sensor" nic nie dało. Chodzi mi o ewentualne odinstalowanie Monitora... :)


Mac Pro 3.1 - Sierra/Windows 10


#8 javazlaz

javazlaz
  • Members
  • 1306 postów
  • LocationCzęstochowa

Napisano 17 grudzień 2016 - 09:58

Ale jaki pkg? Napisałem binaries. Pobiera Ci się dmg, a w środku gołe kexty + HWMonitor.app i wrzucasz gdzie chcesz :) Może założył Ci katalog /Extra na HDD? Sam monitor powinien być IMO w Programach.


W domu: macOS 10.12.3 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Palit GTX 750 Ti StormX OC 2GB | Samsung 850 EVO 250GB | WD Red 1TBIntel I218-V Dell DW1510 | Asus USB-BT400ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium
 
W pracy: macOS 10.12.3 - Dell OptiPlex 960 SFF | Core 2 Duo E8400 | Hynix 8GB DDR2 800MHz CL6 1.8V | Sapphire HD6450 1GB LP | Sandisk SDSSDA120G | Intel 82567LM-3 | AD1984A
 
Przenośny: Windows 7 Pro - Lenovo ThinkPad T410 | QM57 | Core i5-520M | GoodRAM 8GB DDR3L 1333MHz CL9 1.35V | HD Graphics (Arrandale) | Sandisk SDSSDA120G | Intel 82577LM | Intel 6200AGN | CX20585

 iPhone SE 16GB Space Gray

#9 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 17 grudzień 2016 - 10:13

Ale jaki pkg? Napisałem binaries. Pobiera Ci się dmg, a w środku gołe kexty + HWMonitor.app i wrzucasz gdzie chcesz :) Może założył Ci katalog /Extra na HDD? Sam monitor powinien być IMO w Programach.

HWSensors.6.20.1410.pkg - trzecie binaries od góry z http://www.hwsensors.com/releases.


Mac Pro 3.1 - Sierra/Windows 10


#10 javazlaz

javazlaz
  • Members
  • 1306 postów
  • LocationCzęstochowa

Napisano 17 grudzień 2016 - 11:19

Pobierz klikając nie na [nazwa wersja] tylko na (Binaries)

Załączone pliki


W domu: macOS 10.12.3 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Palit GTX 750 Ti StormX OC 2GB | Samsung 850 EVO 250GB | WD Red 1TBIntel I218-V Dell DW1510 | Asus USB-BT400ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium
 
W pracy: macOS 10.12.3 - Dell OptiPlex 960 SFF | Core 2 Duo E8400 | Hynix 8GB DDR2 800MHz CL6 1.8V | Sapphire HD6450 1GB LP | Sandisk SDSSDA120G | Intel 82567LM-3 | AD1984A
 
Przenośny: Windows 7 Pro - Lenovo ThinkPad T410 | QM57 | Core i5-520M | GoodRAM 8GB DDR3L 1333MHz CL9 1.35V | HD Graphics (Arrandale) | Sandisk SDSSDA120G | Intel 82577LM | Intel 6200AGN | CX20585

 iPhone SE 16GB Space Gray

#11 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 17 grudzień 2016 - 11:28

Pobierz klikając nie na [nazwa wersja] tylko na (Binaries)

Dzięki - choroba, nie zauważyłem, że są to dwa różne linki. Starcza nieuwaga. :)
Swoją drogą nie mogę znaleźć miejsca gdzie zainstalowały się sensory z pkg. W HWMonitor chyba ich nie ma...

-----

Po odinstalowaniu monitora i zainstalowaniu samego programu, dalej mam odczyty wszystkich parametrów. Czyli sensory gdzieś się poukrywały. :)


Mac Pro 3.1 - Sierra/Windows 10


#12 javazlaz

javazlaz
  • Members
  • 1306 postów
  • LocationCzęstochowa

Napisano 17 grudzień 2016 - 11:34

Prawdopodobnie w /S/L/E/FakeSMC.kext/Contents/Plugins/


W domu: macOS 10.12.3 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Palit GTX 750 Ti StormX OC 2GB | Samsung 850 EVO 250GB | WD Red 1TBIntel I218-V Dell DW1510 | Asus USB-BT400ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium
 
W pracy: macOS 10.12.3 - Dell OptiPlex 960 SFF | Core 2 Duo E8400 | Hynix 8GB DDR2 800MHz CL6 1.8V | Sapphire HD6450 1GB LP | Sandisk SDSSDA120G | Intel 82567LM-3 | AD1984A
 
Przenośny: Windows 7 Pro - Lenovo ThinkPad T410 | QM57 | Core i5-520M | GoodRAM 8GB DDR3L 1333MHz CL9 1.35V | HD Graphics (Arrandale) | Sandisk SDSSDA120G | Intel 82577LM | Intel 6200AGN | CX20585

 iPhone SE 16GB Space Gray

#13 bogdanh

bogdanh
  • Members
  • 740 postów
  • LocationWarszawa

Napisano 17 grudzień 2016 - 12:08

Prawdopodobnie w /S/L/E/FakeSMC.kext/Contents/Plugins/

Wywaliłem go z /S/L/E - restartuję i sprawdzę.

Zgadza się - po wywaleniu FakeSMC z /S/L/E HW ma tylko temperaturę dysków. 

Po dodaniu sensorów do kextów Clovera działa prawidłowo.

Dziękuję. :)


Mac Pro 3.1 - Sierra/Windows 10


#14 music

music

    Daniel

  • Members
  • 1108 postów
  • LocationZamość

Napisano 17 grudzień 2016 - 19:51

Programem Pacyfist można podejrzeć gdzie będą instalowane pliki z instalatorów pkg (przydaje się on również jak chce się wydobyć jakieś pliki z pkg np. z Clovera można to zrobić). Przyda Ci się ten program w przyszłości, bo mi nie raz już pomógł.

 

http://www.charlessoft.com


  • bogdanh lubi to

 10.12.3 + Clover 3974 config.plist -> http://pastebin.com/TMJczgiF + modyfikowane DSDT.aml 

Gigabyte GA-EP41-UD3L (FakeSMC.kext)

Intel Xeon E5410 (start z flagami "-v npci=0x2000 tscsync" + VoodooTSCSync.kext) 

Audio Realtek ALC888S-VD (AppleALC.kext) (audio device 0x808627D8, sub device 0x1458A002, codec id 0x10EC0888, revision 0x0001) 

LAN RTL8111 (AppleRTL8169Ethernet.kext + EFI String) 

EVGA Geforce 9400GT 512MB (DSDT.aml + NVDAStartup.kext z El Capitan 10.11.6)

 prawie od samego początku projektu hackintosh czyli 2006





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych