Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Still waiting po reorganizacji partycji


  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 18 marzec 2017 - 01:49

Ponieważ będę instalował na moim ThinkPadzie trzeci system, musiałem przeorganizować trochę podział na partycje. Generalnie: do tej pory miałem EFI, HFS+ system, HFS+ recovery i 2x NTFS. W miejsce ostatniej partycji NTFS potrzebowałem utworzyć 3: swap, partycję pod Linuksa i mniejszą partycję NTFS.

 

Najpierw spróbowałem zrobić wszystko z poziomu macOS - na tyle, na ile da się w nowym Narzędziu dyskowym, tzn. sformatowałem partycję NTFS jako HFS+, po czym podzieliłem ją na 3, również HFS+ (w tej chwili z tego co widzę, nie można zostawić wolnego miejsca, niezbyt rozumiem ideę) coby nie tworzyć FAT32 i nie założyć przypadkiem hybrydowych tabeli. Po tych operacjach okazało się, że z poziomu Windowsa nie mogę jednej z nowo utworzonych partycji sformatować jako NTFS - więc usunąłem wszystkie 3 i dla testu zrobiłem restart do OS Xowego Recovery - normalnie się uruchomił i wyświetliłem w Narzędziu dyskowym obecny podział. Po czym spróbowałem uruchomić macOS - przy starcie dostałem Still waiting i od tego momentu nie mogę uruchomić ani systemu, ani recovery.

Pod Windowsem partycja systemowa macOS prawidłowo jest rozpoznawana (mam zainstalowane sterowniki do HFS z Boot Campa), także na wszelki wypadek zrobiłem z niej backup ważniejszych danych i dokończyłem podział na partycje (założyłem opisane wcześniej 3, ale z poziomu Windowsa). Na koniec, żeby zobaczyć co jest grane, odpaliłem instalator 10.9 (akurat pendrive z tym miałem pod ręką) - i co ciekawe, wygląda na to, że OS X nie rozpoznaje prawidłowo systemu plików na partycjach HFS+ - Narzędzie dyskowe wyświetla je bez nazwy, jako FAT32.

 

Macie pomysł co się dzieje i czy można coś z tym zrobić bez instalacji macOS od nowa? Tak jak pisałem, w razie czego mogę bez problemu backup z poziomu Windowsa zrobić i stawiać od nowa, ale nie chce mi się - a wygląda na to, że sam system plików jest w porządku, tylko gdzieś indziej coś się schrzaniło.

 

Edycja:

W załączniku: jak partycje są rozpoznawane przez Mac OS X, a jak przez Linuksa już po sformatowaniu swapa i przyszłej systemowej. Wygląda na to, że Linux widzi wszystko prawidłowo (to samo wyświetla gdisk).

Załączone pliki


Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#2 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 18 marzec 2017 - 20:37

OK, już wiem o co chodzi. Windows przy okazji operacji na partycjach poustawiał wszędzie (oprócz partycji EFI i swojej Microsoft reserved) flagę msftdata - dzięki czemu macOS w ogóle nie sprawdza, jaki system plików znajduje się na partycji, tylko z automatu uznaje ją za windowsową.

 

Wystarczyło za pomocą GParted wyrzucić flagę z tych partycji, gdzie być jej nie powinno - i wszystko zaczęło działać. Później jeszcze trzeba było ukryć z powrotem partycję recovery, ustawiając jako Apple_Boot - komenda:

sudo asr adjust --target /dev/diskXsX -settype Apple_Boot

gdzie diskXsX to numer naszej partycji (możemy sprawdzić za pomocą polecenia diskutil list).


Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#3 314TeR

314TeR

    Administrator

  • Administrators
  • 16602 postów
  • LocationWarszawa

Napisano 13 kwiecień 2017 - 00:09

Kochany windows - domyślnie zakłada, że jest jedyny słusznym systemem na komputerze. 

 

Innym babolem jest np formatowanie całej partycji efi z zawartością i w jej miejsce zakładanie mniejszej 100MB z tylko oczywiście bootloaderem windowsa. 

 

Jak ktoś oczywiście ma możliwość, to polecam zawsze stawiać windows na osobnym hdd/ssd wcześniej odpiąwszy wszystkie inne dyski. Zdarzało mi się też że instalator windows potrafił wrzucić np swój bootloader na dysk A, kiedy był instalowany na dysku B. Istny meksyk. 


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#4 oswaldini

oswaldini
  • Moderators
  • 10602 postów
  • LocationBrzeszcze / Kraków

Napisano 13 kwiecień 2017 - 14:21

Nie do końca istny meksyk. Ogólnie powinno być tak, że tylko jeden dysk ma partycję EFI, a na niej bootloadery. Inna sprawa w przypadku gdy chcemy zostawić tylko jeden z systemów na dysku na którym EFI nie mamy.

 

Ogólnie robię tak samo jak Ty, instalacja windowsa z odpiętymi innymi dyskami bo winda wrzuca swój bootloader na pierwszą wolną partycję EFI.


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | 250 GB + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych