Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

[Część 8] Sprawdzenie działania Power Managmentu (SpeedStep)


  • Zaloguj się, aby dodać odpowiedź
52 odpowiedzi w tym temacie

#41 wert

wert
  • Members
  • 105 postów

Napisano 05 kwiecień 2014 - 18:31

Dzieki za zainteresowanie.

 

qDzghSe.png

O97lubD.png

 

Próbowałem robić według tej rozpiski: http://olarila.com/f...php?f=28&t=1703

 

patch według tej: http://olarila.com/f....php?f=9&t=1003

 

W chameleon P i C-States na Yes.Tu na forum jest wzmianka o usunięciu NullCPUPowerManagement,tam nie ma nic o tym,ja w dalszym ciągu mam tego kexta i nie wiem czy po patchu należy go usunąć czy nie trzeba.

 

Wzmianka jest o poprawnym smbios.plist.Oto moja:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MP61.88Z.0116.B04.1312061508</string>
<key>SMboardproduct</key>
<string>Mac-F60DEB81FF30ACF6</string>
<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMoemcputype</key>
<string>2561</string>
<key>SMproductname</key>
<string>MacPro6,1</string>
</dict>
</plist>

Gigabyte GA-X79-UD3 (rev.1.0) v.F16 ||  INTEL Core i7-3930K 3.2GHz 12MB cache LGA2011 SSE1 do SSE4.1||  Intel X79 Express Chipset  ||  GTX550Ti Memory 1024mb GDDR5||  Realtek ALC898||  Intel GbE LAN (100/1000 Mbit)||  16Gb Kingston HyperX DDR3 1866MHz XMP CL10


#42 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 05 kwiecień 2014 - 22:17

Sprzęt ten co w stopce?

Na pewno musisz wygenerować SSDT skryptem. Dropienia w bootloaderze nie ustawiaj, nie ustawiaj też generowania stanów. NullCPUPM musisz usunąć, bo on specjalnie blokuje zarządzanie energią (żeby nie było problemów przy instalacji).

 

Zostaje tylko kwestia patcha AICPUPM. Nie jestem pewny jak sprawa wygląda przy tej płycie, ale pewnie jest potrzebny,


Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#43 wert

wert
  • Members
  • 105 postów

Napisano 05 kwiecień 2014 - 23:38

Bez P i C-States,bez Drop SSDT

 

Po wygenerowaniu SSDT i usunięciu NullCPUPM komputer po chwili się zawiesza.

Podczas generowania SSDT mam taki komunikat:

 

 Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <
System information: Mac OS X 10.9.2 (13C64)
Brandstring 'Intel(R) Core(TM) i7-3930K CPU @ 3.20GHz'
Warning: No ACPI Processor declarations found in the DSDT!
Using assumed Scope (\_SB) {}
Generating ssdt.dsl for a 'MacPro6,1' with board-id [Mac-F60DEB81FF30ACF6]
Sandy Bridge Core i7-3930K processor [0x206D7] setup [0x0a01]
With a maximum TDP of 130 Watt, as specified by Intel
Number logical CPU's: 12 (Core Frequency: 3200 MHz)
Number of Turbo States: 6 (3300-3800 MHz)
Number of P-States: 27 (1200-3800 MHz)
Injected C-States for C000 (C1,C3,C6,C7)
Error: board-id [Mac-F60DEB81FF30ACF6] not supported by Sandy Bridge – check SMBIOS data / use the -c option

nie wiem co zmienić w SMBios by poprawnie wygenerowało board-id.Być może to jest przyczyna i poprawny zapis załatwi sprawę.


Gigabyte GA-X79-UD3 (rev.1.0) v.F16 ||  INTEL Core i7-3930K 3.2GHz 12MB cache LGA2011 SSE1 do SSE4.1||  Intel X79 Express Chipset  ||  GTX550Ti Memory 1024mb GDDR5||  Realtek ALC898||  Intel GbE LAN (100/1000 Mbit)||  16Gb Kingston HyperX DDR3 1866MHz XMP CL10


#44 skowyrnie

skowyrnie
  • Members
  • 42 postów

Napisano 17 kwiecień 2014 - 18:14

U mnie w pozycji SMC_PlatformPlugin znajduję pozycję AICPMVers, brak natomiast GPUMetaStat, wszystkie inne chyba są OK. Nie posiadam również opcji CPUSensor, DSTD nie posiadam - dwa podejścia dały jedynie błędy, czysty DSDT posiadam ściągnięty z Windowsa według poradnika, ale zarówno auto-patcher, jak i podstawowe zmiany w pliku według danych na forum zawsze powodują błąd przy uruchomieniu i konieczność wywalenia DSDT.

 

Pytanie, jak rozumiem PM u mnie nie działa?


Mac OS X 10.9.4 64-bit on Sony VAIO VPC-EB1S1E | i5 430M 2.3GHZ(Intel HM55) | 4GB DDR3 | ATI HD5650 mobility | WLAN Atheros AR9285 | LAN not working | HD Audio ALC269


#45 tonguei

tonguei
  • Members
  • 88 postów

Napisano 27 kwiecień 2014 - 23:42

Słuchajcie, skąd wyczarować ten magiczny IORegistryExplorer? Czy jest jakieś inne źródło niż osx86.net, ponieważ wyczerpałem tam limit na dziś. Dzięki z góry za informacje.


CLOVER Retail 10.9.2| Gigabyte gaH67m-UD2H (Intel h67, ALC892) | i5-2300 2.8Ghz@3Ghz | SAPPHIRE HD 5570 XtendTV 1GB GDDR5 | NoName 2x2GB 1333 MHz DDR3 | Realtek 8168/8101E Gigabit Ethernet |1TB Hitachi HDS721010CLA332 OS X / 200 GB SAMSUNG SP2004C Media Win8


FlagaPL.gif Piszę poprawnie po polsku!


#46 314TeR

314TeR

    Administrator

  • Administrators
  • 16382 postów
  • LocationWarszawa

Napisano 28 kwiecień 2014 - 08:20

XCode. Alternatywnie możesz użyć IOJones.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#47 nowy_

nowy_
  • Members
  • 88 postów
  • LocationWrocław PL/ Witney UK

Napisano 28 kwiecień 2014 - 10:47

 IORegistryExplorer 

http://cl.ly/0f0O0m2l3h29

 10.11.2 | i5 4460 | Asus Maximus VI GENE | Crucial 8GB KIT DDR3 1600MHz CL9 Ballistix Sport | Kingston SSDNow V300 (120GB)| Logitech MK620
 10.6.8|10.7| P5QL-EM | C2D 1,86/2,24 6320 | 2x2GB 800/960MHz Kingston| Palit GF 9500GT DVI-HDMI-SUB|HDD 1TB WD-Green|DVDW SH-S182M|
Z-Cinema|IBM T221 3840×2400(WQUXGA)| MM+BELKIN BLUETOOTH USB ADAPTER CL. 1 |Wireless Keyboard K350|RTL8169Ethernet| ALC1200 /iMac7.1


#48 tonguei

tonguei
  • Members
  • 88 postów

Napisano 29 kwiecień 2014 - 12:44

edit: założyłem oddzielny temat.


CLOVER Retail 10.9.2| Gigabyte gaH67m-UD2H (Intel h67, ALC892) | i5-2300 2.8Ghz@3Ghz | SAPPHIRE HD 5570 XtendTV 1GB GDDR5 | NoName 2x2GB 1333 MHz DDR3 | Realtek 8168/8101E Gigabit Ethernet |1TB Hitachi HDS721010CLA332 OS X / 200 GB SAMSUNG SP2004C Media Win8


FlagaPL.gif Piszę poprawnie po polsku!


#49 AdamiPL

AdamiPL
  • Members
  • 642 postów
  • LocationPeterborough / UK

Napisano 07 czerwiec 2015 - 15:59

Ok w tutku napisane, że obecnie się pozmieniało z tymi zapiskami, wie ktoś może jak na yosemite teraz odczytać te wartości?


 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#50 patrex003

patrex003
  • Members
  • 287 postów
  • LocationŚwiętokrzyskie

Napisano 12 czerwiec 2015 - 22:47

u mnie w IORegistryExplorer w wersji 2.0 i 3.02 tak to się przedstawia w 10.10.3

 

chodzi mi sleep, restart, normalnie startuje, loguje, wylogowuje itp tylko w grach takie jak by spowolnienia ma pomimo dużej ilości fps'ów

 

aha i AppleLPC załadowane jak by ktoś się pytał

 

 

Załączone pliki

  • Załączony plik  1.png   217,58 KB   0 Ilość pobrań

Sierra - MacBook Pro 11,1: ASRock Z87 Extreme4 | Intel Z87 | Intel i3 4170 (Haswell) | Realtek ALC1150 | Intel I217V | Intel HD Graphics 4400 & AMD Radeon RX480 8GB - MSI Gaming X

 

El Capitan / Sierra - iMac 12,1: ASUS P8Z68-V PRO/GEN3 | Intel Z68 | Intel Core i3 2120 (Sandy Bridge) | Realtek ALC892 | Intel 82579 | AMD Radeon HD7770 1GB - Gigabyte rev2.0 \ AMD Radeon RX480 8GB - MSI Gaming X


Mavericks / Yosemite / El Capitan - iMac 12.1 na: Gigabyte GA-H61M-S1 rev2.1  | Intel H61 Express Chipset | Intel Celreon G550 (Sandy Bridge) | Realtek ALC887 | Realtek RTL8111F | AMD Radeon HD7770 1GB - Gigabyte rev2.0

 

Snow Leopard / Mavericks / Yosemite / El Capitan - MacBookPro5,1 na: Medion Akoya P6612 - MD97110  | Intel ICH9M | Intel Core 2 Duo P7350 | Realtek ALC663 | Realtek RTL8168/8111C | BCM94321MC - Apple '06 | GeForce 9600M GS 256MB -Wistron

 

co nowy hackintosh to coraz to różniejsze wyzwania i problemy..

​wszystko co piszę staram się opierać o własne doświadczenia..

 

mała polska grupa hackintosh'owa na FB

mój mały świat

 

Zdaje sobie sprawę że w dużej części piszę tak że mnie ciężko zrozumieć, ale już od nie pamiętnych czasów każdy mi to powtarza że "sporo wiem" ale nie umiem tej wiedzy już przekazać. Naprawdę się staram pisać tak aby każdy mnie zrozumiał.

Przepraszam za tą nie dogodność !


#51 AdamiPL

AdamiPL
  • Members
  • 642 postów
  • LocationPeterborough / UK

Napisano 13 czerwiec 2015 - 18:17

u mnie wygląda identycznie jak u Ciebie :D

 

Załączony plik  Zrzut ekranu 2015-06-13 o 18.16.12.png   193,63 KB   1 Ilość pobrań

 

 

CPUPLimitDict = CPUPLimit z opisu na 1 stronie? 


 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#52 patrex003

patrex003
  • Members
  • 287 postów
  • LocationŚwiętokrzyskie

Napisano 14 czerwiec 2015 - 02:39

zdaje mi się że CPUPLimitDict nie równa się CPUPLimit

 

ale na przykładzie laptopa oraz OSX 10.9.x i notatek które czasem sobie piszę zauważyłem że jeśli chodzi o działanie sleepu itp to powinny być wartości:

- powinno ładować się AppleLPC

- w IORegisteryExplorer powinny być te wartości

 - AICPMvers

 - IOPPEDiagDict tu wartość powinna się zmienić z 3 na 4

 - supportUpstreamASPM powinna mieć wartość Type: Boolen i Value: True

 

dawno nie włączałem laptopa więc nie jestem pewien czy coś się zmienia w 10.10.x ale na PC z którego korzystam nie mam supportUpstreamASPM tylko supportDownstreamASPM Type: Boolen i Value: False

 

 

jedyne co mi się nie kojarzy to "CSTLimit" nie wiem czy ta wartość powinna występować w nowszych OSX czy zastąpiła ją jakaś inna...

 

 

edit.

jak jesteś zainteresowany to mogę zrobić zrzuty z przed włączenia i po włączeniu na moim laptopie do porównania :)


Sierra - MacBook Pro 11,1: ASRock Z87 Extreme4 | Intel Z87 | Intel i3 4170 (Haswell) | Realtek ALC1150 | Intel I217V | Intel HD Graphics 4400 & AMD Radeon RX480 8GB - MSI Gaming X

 

El Capitan / Sierra - iMac 12,1: ASUS P8Z68-V PRO/GEN3 | Intel Z68 | Intel Core i3 2120 (Sandy Bridge) | Realtek ALC892 | Intel 82579 | AMD Radeon HD7770 1GB - Gigabyte rev2.0 \ AMD Radeon RX480 8GB - MSI Gaming X


Mavericks / Yosemite / El Capitan - iMac 12.1 na: Gigabyte GA-H61M-S1 rev2.1  | Intel H61 Express Chipset | Intel Celreon G550 (Sandy Bridge) | Realtek ALC887 | Realtek RTL8111F | AMD Radeon HD7770 1GB - Gigabyte rev2.0

 

Snow Leopard / Mavericks / Yosemite / El Capitan - MacBookPro5,1 na: Medion Akoya P6612 - MD97110  | Intel ICH9M | Intel Core 2 Duo P7350 | Realtek ALC663 | Realtek RTL8168/8111C | BCM94321MC - Apple '06 | GeForce 9600M GS 256MB -Wistron

 

co nowy hackintosh to coraz to różniejsze wyzwania i problemy..

​wszystko co piszę staram się opierać o własne doświadczenia..

 

mała polska grupa hackintosh'owa na FB

mój mały świat

 

Zdaje sobie sprawę że w dużej części piszę tak że mnie ciężko zrozumieć, ale już od nie pamiętnych czasów każdy mi to powtarza że "sporo wiem" ale nie umiem tej wiedzy już przekazać. Naprawdę się staram pisać tak aby każdy mnie zrozumiał.

Przepraszam za tą nie dogodność !


#53 dnee

dnee
  • Members
  • 88 postów

Napisano 29 listopad 2015 - 21:57

Jeżeli apka Intel Power Gadgets pokazuje mi, że taktowanie oraz temperatura procesora zmienia się zależnie od obciążenia procesora, to znaczy, że Power Managment działa poprawnie? W tej chwili w idle mam 35 stopni (SilentiumPC Fortis @800 RPM).

 

Zrzut z IOregistry:

Załączone pliki

  • Załączony plik  s.png   159,53 KB   2 Ilość pobrań

Mój problem z Kernel Panic podczas logowania. Jak masz czas i chęci, będę wdzięczny za pomoc.

 

OS X Yosemite Retail | Clover v2.3k UEFI | i5-4460 | ASRock H97 PRO4: ALC-892, Intel I218-V | XFX R9 280X DD





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych