Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

macOS Sierra na GA-Z170X & i7-7700K

i7-7700K GA-Z170X z170 GA-Z170X-Ultra Gaming

Najlepsza odpowiedź oswaldini , 14 lipiec 2017 - 14:28

Jak chcesz integrę to dodaj do sekcji KextToPatch to:

			<dict>
				<key>Comment</key>
				<string>10.11-SKL-1912000-4_displays</string>
				<key>Find</key>
				<data>
				AQMDAw==
				</data>
				<key>Name</key>
				<string>AppleIntelSKLGraphicsFramebuffer</string>
				<key>Replace</key>
				<data>
				AQMEAw==
				</data>
			</dict>

WYŁĄCZ injekcję dla intela i dodaj 2 kexty: Lilu.kext oraz IntelGraphicsFixup.kext: http://hamac.pl/topi...y-dla-lilukext/

 

Lepiej jednak wstawić GTX 980Ti, wyłączyć integrę i dodać dwa kexty: Lilu.kext oraz NvidiaGraphicsFixup.kext - link wyżej.

Przejdź do postu


  • Zaloguj się, aby dodać odpowiedź
27 odpowiedzi w tym temacie

#21 314TeR

314TeR

    Administrator

  • Administrators
  • 16607 postów
  • LocationWarszawa

Napisano 14 lipiec 2017 - 11:46

Jak masz poprawnie nazwany katalog z nazwą płyty w folderze OEM to clover bierze pod uwagę TYLKO jego zawartość. Nie ma nadpisywania jakiś configów jakimiś innymi. Dzięki tej metodzie możesz mieć jeden klucz USB który odpala wiele całkowicie wykluczających się konfiguracji. 

 

Zmiany wprowadzaj TYLKO do configu z katalogu OEM. 

 

Nie ma konieczności kasowania jakichkolwiek driverów z folderu Driavers64UEFI - każdy z tych driverów możesz wyłączy dodając wpis do sekcji DisableDrivers. Robione jest to po to aby mieć wszystkie drivery zawsze i nie myśleć który jest do którego configu, zwyczajnie wyłączasz te których NIE potrzebujesz.

 

Teraz wygląda jakby Ci nie startowała VGA, którą VGA odpalasz? Pokładową czy nvidię 980Ti? Masz jeden monitor czy więcej na raz podłączony? 


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#22 oswaldini

oswaldini
  • Moderators
  • 10602 postów
  • LocationBrzeszcze / Kraków

Napisano 14 lipiec 2017 - 11:55

Kolejność ładowania w przypadku gdy mamy komputer w UEFI

1. EFI/CLOVER/OEM/nazwa_mobo/UEFI/

2. EFI/CLOVER/OEM/nazwa_mobo

3. EFI/CLOVER/

 

Nic się nie nadpisuje i nie jest używane z innych lokalizacji jeżeli bootloader znajdzie określoną ścieżkę.

 

Co do zdjęcia - poza błędów związanych z PM nie widać problemu, wnioskuję, że nie odpala tryb graficzny. Uruchom z flagą nv_disable=1 jeżeli odpalasz z GeForce'a.

Pokaż zdjęcie z ustawienia grafiki w BIOSie.

 

EDIT: @314TeR - drivery kazałem kasować tylko dlatego aby się upewnić, że user nie miesza nic w configach - jak widać było namieszane i to fest.


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | 250 GB + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#23 gen.jusz

gen.jusz
  • Members
  • 72 postów
  • LocationWWA

Napisano 14 lipiec 2017 - 12:39

Jak masz poprawnie nazwany katalog z nazwą płyty w folderze OEM to clover bierze pod uwagę TYLKO jego zawartość. Nie ma nadpisywania jakiś configów jakimiś innymi. Dzięki tej metodzie możesz mieć jeden klucz USB który odpala wiele całkowicie wykluczających się konfiguracji. 
Zmiany wprowadzaj TYLKO do configu z katalogu OEM.


OK, teraz jest to dla mnie jasne :)
Z instrukcji tego nie wywnioskowałem
 

Nie ma konieczności kasowania jakichkolwiek driverów z folderu Driavers64UEFI - każdy z tych driverów możesz wyłączy dodając wpis do sekcji DisableDrivers. Robione jest to po to aby mieć wszystkie drivery zawsze i nie myśleć który jest do którego configu, zwyczajnie wyłączasz te których NIE potrzebujesz.

 
Dokładnie tak to zinterpretowałem. Nie kasowałem żadnych driverów, dlatego też dopytywałem, czy mam na pewno usunąć, czy wystarczy, że go dodam do tej sekcji.
 

Teraz wygląda jakby Ci nie startowała VGA, którą VGA odpalasz? Pokładową czy nvidię 980Ti? Masz jeden monitor czy więcej na raz podłączony?


Na razie robie wszystko na minimalnej konfiguracji, czyli bez 980Ti - odpalam pokładową.
Mam jeden monitor na ten moment.
 

Co do zdjęcia - poza błędów związanych z PM nie widać problemu, wnioskuję, że nie odpala tryb graficzny. Uruchom z flagą nv_disable=1 jeżeli odpalasz z GeForce'a.
Pokaż zdjęcie z ustawienia grafiki w BIOSie.

 
Ustawienia BIOSu takie jak podawałeś, ale popróbuję jeszcze inne w takim razie.
 
Znalazłem na Tonymac kogoś z podobną konfiguracją i podał takie ustawienia BIOSu:
 

XMCI Hand-off ->Enable
Super IO Configuration-> Disable
VT-d ->Disable
Windows 8/10 features -> Other OS
Storage Boot Option Control -> UEFI Only
Boot Option #1 -> USB drive


więc po robocie sprawdzę jeszcze dokładnie, czy takie mam, oraz wrzucę screen z ustawieniami karty.


MacBook Pro 15" ][ Core i7-4980HQ 2,8 GHz ][ 16 GB RAM DDR3 1600 ][ Radeon R9 M370X

haMac ][ Gigabyte GA-Z170X-Ultra Gaming ][ Core i7-7700K 4,2 GHz ][ 16GB DDR4 2400 ][ EVGA GTX 980 Ti


#24 314TeR

314TeR

    Administrator

  • Administrators
  • 16607 postów
  • LocationWarszawa

Napisano 14 lipiec 2017 - 12:52

VGA nie startuje - być może pokładówka w ogóle jest nie do ruszenia na tę chwilę - nie rozpoznawałem tematu kabylake.

 

Włóż 980Ti, wyłącz iGPU i powinien zaskoczyć tryb graficzny.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#25 oswaldini

oswaldini
  • Moderators
  • 10602 postów
  • LocationBrzeszcze / Kraków

Napisano 14 lipiec 2017 - 14:28   Najlepsza odpowiedź

Jak chcesz integrę to dodaj do sekcji KextToPatch to:

			<dict>
				<key>Comment</key>
				<string>10.11-SKL-1912000-4_displays</string>
				<key>Find</key>
				<data>
				AQMDAw==
				</data>
				<key>Name</key>
				<string>AppleIntelSKLGraphicsFramebuffer</string>
				<key>Replace</key>
				<data>
				AQMEAw==
				</data>
			</dict>

WYŁĄCZ injekcję dla intela i dodaj 2 kexty: Lilu.kext oraz IntelGraphicsFixup.kext: http://hamac.pl/topi...y-dla-lilukext/

 

Lepiej jednak wstawić GTX 980Ti, wyłączyć integrę i dodać dwa kexty: Lilu.kext oraz NvidiaGraphicsFixup.kext - link wyżej.


  • gen.jusz lubi to

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | 250 GB + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#26 gen.jusz

gen.jusz
  • Members
  • 72 postów
  • LocationWWA

Napisano 14 lipiec 2017 - 23:22

Dzięki oswaldini ! Po powyższych zmianach ruszyło z integry.

Wprawdzie generuje drobne artefakty, np. na zakładkach w Safari, ale działa :)

 

Teraz pora powalczyć z 980ti :)


MacBook Pro 15" ][ Core i7-4980HQ 2,8 GHz ][ 16 GB RAM DDR3 1600 ][ Radeon R9 M370X

haMac ][ Gigabyte GA-Z170X-Ultra Gaming ][ Core i7-7700K 4,2 GHz ][ 16GB DDR4 2400 ][ EVGA GTX 980 Ti


#27 gen.jusz

gen.jusz
  • Members
  • 72 postów
  • LocationWWA

Napisano 15 lipiec 2017 - 18:22

Operacja zakończona sukcesem. Po początkowych bojach, reszta poszła już w miarę sprawnie.

 

Po instalacji Web Driver'ów nVidia trzeba było jeszcze dokonać drobnych poprawek w config.plist:

 

1. W sekcji SystemParameters dodać:

<key>NvidiaWeb</key>
<true/>
 
2. W sekcji DisableDrivers wykomentować:
<string>#EmuVariableUefi</string>
 
3. W sekcji Boot dodać nvda_drv=1 :
<key>Arguments</key>
<string>kext-dev-mode=1 nvda_drv=1 -v</string>

 

Usunąłem też zmiany odpalające integrę.

 

Po wszystkim, zadziałał sleep, zadziałało audio (trzeba było w ustawieniach zmienić źródło na Internal Speakers) - miód malina.

Działa nawet USB 3.1.

USB-C jeszcze nie miałem jak przetestować.

 

Dzięki wszystkim za pomoc !

 

Geekbench 4 prezentuje się następująco: https://browser.prim.../v4/cpu/3416760

 

Na ten moment jeszcze stockowy cooler od Celeron'a, bo wszystko siedzi na kartonie na biurku.

W planach mam zakup NZXT 340 Elite White, wtedy założę chłodzenie Corsair H60 i podbiję trochę taktowanie.


MacBook Pro 15" ][ Core i7-4980HQ 2,8 GHz ][ 16 GB RAM DDR3 1600 ][ Radeon R9 M370X

haMac ][ Gigabyte GA-Z170X-Ultra Gaming ][ Core i7-7700K 4,2 GHz ][ 16GB DDR4 2400 ][ EVGA GTX 980 Ti


#28 gen.jusz

gen.jusz
  • Members
  • 72 postów
  • LocationWWA

Napisano 20 sierpień 2017 - 00:28

Dzisiaj udało mi się w końcu doprowadzić do współpracy Apple Thunderbolt Display.

Potrzebowałem przejściówki Thunderbolt 3 -> Thunderbolt 2 oraz ... 

podłączyć GTX'a do mini DP IN na płycie... 


MacBook Pro 15" ][ Core i7-4980HQ 2,8 GHz ][ 16 GB RAM DDR3 1600 ][ Radeon R9 M370X

haMac ][ Gigabyte GA-Z170X-Ultra Gaming ][ Core i7-7700K 4,2 GHz ][ 16GB DDR4 2400 ][ EVGA GTX 980 Ti






Również z jednym lub większą ilością słów kluczowych: i7-7700K, GA-Z170X, z170, GA-Z170X-Ultra Gaming

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych