Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

WhateverGreen - plugin dla VGA AMD


  • Zaloguj się, aby dodać odpowiedź
38 odpowiedzi w tym temacie

#21 marcinsa

marcinsa
  • Donator
  • 83 postów

Napisano 01 sierpień 2017 - 21:18

Stary Radeon HD 6850 działa perfect :)


10.10.5 | P8Z68 Deluxe/Gen3 | i7-2600k |HD6850 | 850 PRO 256 – MBP Retina 15


#22 HIDEE

HIDEE
  • Members
  • 22 postów

Napisano 08 sierpień 2017 - 17:22

A czy na RX4xx i 5xx jest już boot screen, czy dalej trzeba z iGPU ruszać?



#23 oswaldini

oswaldini
  • Moderators
  • 10680 postów
  • LocationBrzeszcze / Kraków

Napisano 08 sierpień 2017 - 18:07

Pierwszy punkt pierwsza strona - fix na wszystko.


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#24 314TeR

314TeR

    Administrator

  • Administrators
  • 16900 postów
  • LocationWarszawa

Napisano 10 sierpień 2017 - 01:29

Jest już wersja 1.0.3.

 

Kompilacje tego pluginu są dostępne tu: https://github.com/v...rGreen/releases


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#25 Najrad

Najrad
  • Members
  • 593 postów
  • LocationPodhale

Napisano 28 sierpień 2017 - 11:20

Jest już wersja 1.0.4.


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.6

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  10.11.6

FCPX, Compressor, Davinci Resolve.

 


#26 lulek2007

lulek2007
  • Members
  • 158 postów

Napisano 06 wrzesień 2017 - 08:34

Jak sam wspominałeś nie raz, podejrzewasz monitory. 

 

Usuń jeszcze z configu frambuffer i videoports. W FAQ WhateverGreen odradzają ustawiania ręcznego. Może być też tak, że np connectors masz inne niż faktycznie są na karcie i stąd masz takie jaja... ale z drugiej strony skoro problem był taki sam na NVIDII to chyba nie tu szukasz problemu. 

 

A te monitory np pod windows działają OK? Szukałeś czy nie aktualizacji firmware do monitora? 

 

 

Kable, Kable, Kable :)

 

W końcu działa OK

 

Zacząłem wgłębiać się w problem Display port i podłączenia do monitorów. Z lektury wynika że jest masa problemów z tym (np Dell 4k, moje iiama 27") i z wybudzaniem nawet w windowsach. Problem częściowo dotyczy pinu 19 i 20 i chyba firmware. Mając oryginalne kable od monitora iiama, tyle że mini display port do display port monitora znalazłem na ebayu coś takiego

 

 http://www.ebay.pl/i...872.m2749.l2649

 

No i po złożeniu wszystkiego tj. karta AMD RX580, DP, przejściówka DP  do mini DP, kabel oryginalny o monitora mini DP do DP, monitor wejście DP sleep działa :)

 

Pozdrawiam MK 


ASUS Gryphon Z87 | Intel Core i7-4770K | MacPro G5 mini-atx mod case  || ASUS Gryphon Z97 | Intel Core i5-4690K | MacPro G5 mini-atx mod case || MSI H81M-P33 | Intel Core i5-4690K | Mac G4 Quicksilver mini-atx mod case || Gigabyte H61M-DS@ DVI | Intel Core i5-2500K | Mac G3 mini-atx mod case || Gigabyte GA-Q87tn | Intel Core i7-4790K | Mac CUBE G4 mod case 


#27 314TeR

314TeR

    Administrator

  • Administrators
  • 16900 postów
  • LocationWarszawa

Napisano 06 wrzesień 2017 - 09:30

A widzisz, pewnie jakbyś kupił porządne kable, to by działało. To co często jest w sklepach jest to najtańszy najgorszej jakości chinol. 


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#28 lulek2007

lulek2007
  • Members
  • 158 postów

Napisano 06 wrzesień 2017 - 13:04

A widzisz, pewnie jakbyś kupił porządne kable, to by działało. To co często jest w sklepach jest to najtańszy najgorszej jakości chinol. 

 

 

No tak tylko kupiłem właśnie kable 2m po ok 45 zł Delocka wiec wydawały mi się w miarę dobre. Musiałbym je przedzwonić jak mają podpięty ten 19 pin i czy jego wyłączenie powoduje poprawnego działania.


ASUS Gryphon Z87 | Intel Core i7-4770K | MacPro G5 mini-atx mod case  || ASUS Gryphon Z97 | Intel Core i5-4690K | MacPro G5 mini-atx mod case || MSI H81M-P33 | Intel Core i5-4690K | Mac G4 Quicksilver mini-atx mod case || Gigabyte H61M-DS@ DVI | Intel Core i5-2500K | Mac G3 mini-atx mod case || Gigabyte GA-Q87tn | Intel Core i7-4790K | Mac CUBE G4 mod case 


#29 314TeR

314TeR

    Administrator

  • Administrators
  • 16900 postów
  • LocationWarszawa

Napisano 06 wrzesień 2017 - 13:39

Delock to rasowy chinol i to z tych co się cenią jak za złoto a pakują najtańszy szajs.

Z kabli jakie zrobiły na mnie pozytywne wrażenie polecam ednet. Porządne wykonanie, bezproblemowa praca, przystępna cena a do tego ładne.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#30 javazlaz

javazlaz
  • Members
  • 1480 postów
  • LocationCzęstochowa

Napisano 18 wrzesień 2017 - 11:06

Rewelacja, nie dość, że HD 7770 nareszcie działa poprawnie to jeszcze komputer z tą kartą ustawioną jako główną usypia i wybudza się elegancko. Oj chyba Radeony wróciły do łask... Ktoś chętny na GTX 750Ti?


macOS 10.13.1 - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | HD 4600 | Samsung 850 EVO 250GB | WD Red 1TB | Intel I218-V | Dell DW1510 | Asus USB-BT400 | ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium

iPhone SE 16GB Space Gray
 

Spoiler

#31 oswaldini

oswaldini
  • Moderators
  • 10680 postów
  • LocationBrzeszcze / Kraków

Napisano 10 listopad 2017 - 00:01

No i możemy pozbyć się WhateverGreen na rzecz opcji w Cloverze o nazwie RadeonDeInit - wymagany Clover min 4296.

	<key>Graphics</key>
	<dict>
		<key>RadeonDeInit</key>
		<true/>

 

A possibility to de-init Radeon cards.
It was very old problem since ElCapitan that AMD Radeon HD6xxx and up will not wake after sleep if used as first card.
If the card is secondary and CSM enabled then the card works fine. So the differences is initialisation.
The solution was found by vit9696 and used in private WhateverGreen.kext. Then Mieze proposed the solution as ACPI patch.

 

 

http://www.insanelym...ions/?p=2531908

http://www.insanelym...-to-its-origin/



MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#32 Najrad

Najrad
  • Members
  • 593 postów
  • LocationPodhale

Napisano 10 listopad 2017 - 14:10

Rzeczywiście działa, ale kartę RX580 widzi teraz jako R9 xxx 8192 MB. Nie wiem co lepsze? Z Lilu i WhateverGreen też nie jest tak perfekcjnie. Niby wszystko działa, ale niektóre pluginy do FCPX po wybudzeniu kompa nie chcą działać - nie wyświetlają okien edycyjnych. Pomaga jedynie reset kompa.


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.6

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  10.11.6

FCPX, Compressor, Davinci Resolve.

 


#33 oswaldini

oswaldini
  • Moderators
  • 10680 postów
  • LocationBrzeszcze / Kraków

Napisano 10 listopad 2017 - 14:47

A z RadeonDeInit problem z pluginami jest taki sam jak w przypadku WhateverGreen ? Nie ma co przywiązywać uwagi do kosmetyki w postaci nazwy, ważne aby dobrze działało.

 

PS: nazwę można zmienić przez patch w Cloverze - patchowanie domyślnego framebuffera. Podrzucę wieczorem bo mam kompa z RX 580 8GB

 

EDIT:

 

R9 xxx w HEX to 523920787878, RX 580 to 525820353830

R9 xxx w Base64 to UjkgeHh4, RX 580 to UlggNTgw

 

Patch powinien wyglądać tak:

<dict>
	<key>Comment</key>
	<string>Rename R9 xxx to RX 580</string>
	<key>Disabled</key>
	<false/>
	<key>Find</key>
	<data>UjkgeHh4</data>
	<key>Name</key>
	<string>AMD9500Controller</string>
	<key>Replace</key>
	<data>UlggNTgw</data>
</dict>

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#34 Najrad

Najrad
  • Members
  • 593 postów
  • LocationPodhale

Napisano 10 listopad 2017 - 15:26

Z tym problemem z wtyczkami ( ColorFinale, CrumplePop itp) to sprawa losowa, czasem po wybudzeniu działają, a czasem nie. Przed chwilą sprawdziłem z RadeonDeInit i działa wszystko OK, ale... Nie wiem co jest w tym Twoim Cloverze :) legalny ColorFinale domaga się ponownej aktywacji. Muszę odpalić ze starszej wersji Clovera i dezaktywować licencję, a następnie aktywować na nowym kompie - bo tak to właśnie wygląda, jakbym miał now/inny komputer. ICloud też mi zgłosił niemożność zalogowania się na konto - po podaniu hasła zalogował, ale jak odpalam kompa ze starego Clovera 4289 to ColorFinale jest aktywowany, a iCloud znów chciał hasła. Chyba mam "trudny dzień"  :)


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.6

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  10.11.6

FCPX, Compressor, Davinci Resolve.

 


#35 314TeR

314TeR

    Administrator

  • Administrators
  • 16900 postów
  • LocationWarszawa

Napisano 10 listopad 2017 - 15:33

Config.plist i sekcje smbios masz na 100% te same.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#36 Najrad

Najrad
  • Members
  • 593 postów
  • LocationPodhale

Napisano 10 listopad 2017 - 15:51

Ja tylko uaktualniam Clovera - mam taką nadzieję. Jeśli instalator czegoś nie zmienił, to musi być ta sama sekcja SMBIOS. Zaraz sprawdzę linia po linii. Ale przywróciłem poprzedniego Clovera - tak na chama kasując cały folder EFI i kopiując folder EFI z backupu i nic to nie dało. CF nadal domaga się aktywacji. Mam na szczęście na osobnym HDD kopię systemu ( robię raz w tygodniu klona CarbonCopyClonerem) i startując z niego, deaktywowałem licencję i aktywowałem na tym "niby nowym" kompie. Chcę się pobawić tym nowym sposobem RadeonDeInit, więc na kilka dni zostawię bez Lilu&Wh...

 

@Oswaldini zmiana nazwy działa z 9500, więc na razie tak zostawiam. Muszę zrobić jakiś test wydajności grafy czy te dwie metody mają jakiś wpływ na prawdziwą pracę, ale czas mnie strasznie goni... więc ciągle odkładam - nie mam nawet czasu na 10.13.1 żeby sprawdzić czy coś się zmieniło w stosunku do 10.13.0. Na pierwszej wersji FCPX miał kłopoty z zapamiętaniem preferencji.

 

Noż k...a burak ze mnie zapomniałem Ci podziękować.... dziękuję za podpowiedzi odnośnie RX580 :)


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  Sierra 10.12.6

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  10.11.6

FCPX, Compressor, Davinci Resolve.

 


#37 HIDEE

HIDEE
  • Members
  • 22 postów

Napisano 10 listopad 2017 - 22:40

Jest już oficjalnie nowsza wersja 4297

https://sourceforge..../cloverefiboot/



#38 oswaldini

oswaldini
  • Moderators
  • 10680 postów
  • LocationBrzeszcze / Kraków

Napisano 11 listopad 2017 - 01:39

Patch faktycznie działa, instalator i system działają jak na kextach.


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#39 roratoga

roratoga
  • Donator
  • 259 postów

Napisano 12 listopad 2017 - 09:19

czy tego Radeona HD7670M tez da rade uruchomic teraz ?


SAMSUNG NP350V5C-S0FPL / Intel® Core™ i5-3210M CPU @ 2.50GHz, 2494 MHz / Intel® 7 Series Chipset Family SATA AHCI Controller / Intel HD Graphics 4000 / AMD Radeon HD 7600M / Realtek ALC269 / Realtek PCIe GBE Family Controler / Atheros AR5B195





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych