Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

i7-7700 + asus z270 + NVMe

asus z270 NVMe i7-7700

  • Zaloguj się, aby dodać odpowiedź
13 odpowiedzi w tym temacie

#1 Grzegorz Worendan

Grzegorz Worendan
  • Members
  • 18 postów

Napisano 11 wrzesień 2017 - 20:02

Wiam.

 

W poprzednim wątku pomogliście mi z doborem komponentów. Wszystko zostało już zamówione i już czeka złożone na system ze stajni nadgryzionego jabłka.

Komponenty:
http://www.morele.ne...ry/info/L9CPrl/

 

Mobo: Asus Prime z270-a

Procesor: i7-7700

Grafika: GTX 1050 (na razie odpuszczamy, chcę najpierw ogarnąć instalację na zintegorwanej karcie, dlatego wymontowałem ją z komputera, tak na wszelki wypadek)

Dysk: NMVe + HDD

 

Pobrałem UniBootX, ale niestety po wgraniu na pendrive nic się nie działo. Czarny ekran - 0 clovera.
Być może to przez pendrive 16gb (widziałem jeden wątek na forum z tym związany), dlatego zacząłem robić podobnie do tego co jest na tej stronie:
http://hackintosher....s/ga-z270m-d3h/

 

System pobrałem jako *.hfs i nagrałem na pendrive.

 

Na drugim wgrałem clovera.

Aktualnie mam coś takiego jak na screenach. Gdy odpalam z flagą -v wtedy widzę co się dzieje.

 

Problem jest taki, że stoi na HID: Legacy shim 2, a następnie wywala "... root divice"
 

Próbowałem odszukiwać danego problemu, ale nic nie zdziałałem. Niby coś z portami USB (przepinałem na inne - nic nie dało).

 

Przedstawiam clovera w załączniku. Proszę o wskazówki co na pierwszy rzut oka się gryzie.

Załączone pliki



#2 314TeR

314TeR

    Administrator

  • Administrators
  • 16895 postów
  • LocationWarszawa

Napisano 11 wrzesień 2017 - 20:16

1. Na dysku NVMe bezproblemowo postawisz dopiero High Sierrę 10.13 - aktualnie końcówka bety - premiera pewnie przełom września i października.

2. UniBootX - ciekawe - warto sprawdzić inny pendrive.

3. Config z UniBootX weź od Z170, zmień w nim tylko identyfikację na iMac18.x.

4. Na Kabylake zainstalujesz względnie bez problemu dopiero 10.12.6 - jeśli nie masz takiej wersji instalacyjnej, to może być ciężko.

5. Paradoksalnie z 1050 może być łatwiej, powinna odpalić w VESA, ale świecić. 

6. W BIOSie jak masz to wyłącz takie rzeczy jak port szeregowy, cfg lock, vt-d. 


  • Grzegorz Worendan lubi to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#3 alpha

alpha
  • Members
  • 443 postów

Napisano 11 wrzesień 2017 - 20:18

1. Na dysku NVMe bezproblemowo postawisz dopiero High Sierrę 10.13 - aktualnie końcówka bety - premiera pewnie przełom września i października.

 

Wklejenie binpatcha do Clovera nie jest, aż tak dużym problemem ;)


 iHack 18,3 | High Sierra 10.13 | Asus H270I Strix | Intel i7-7700K 4.2Ghz | GeForce GTX 1060 | Samsung M.2 960 EVO | Seagate Barracuda 4TB | Fiio E10K Olympus 2 | FlagaPL.gif Piszę poprawnie po polsku!

iPhone 7 32GB Black 


#4 Grzegorz Worendan

Grzegorz Worendan
  • Members
  • 18 postów

Napisano 11 wrzesień 2017 - 20:43

1. Na dysku NVMe bezproblemowo postawisz dopiero High Sierrę 10.13 - aktualnie końcówka bety - premiera pewnie przełom września i października.

- Właśnie wyczytałem, że tam NVMe, będzie wspierane.

2. UniBootX - ciekawe - warto sprawdzić inny pendrive.

- nigdzie w sklepach nie było. Wszędzie minimu 16 gb.

3. Config z UniBootX weź od Z170, zmień w nim tylko identyfikację na iMac18.x.

- Teraz mam wpisaną identyfikację iMac17,1

4. Na Kabylake zainstalujesz względnie bez problemu dopiero 10.12.6 - jeśli nie masz takiej wersji instalacyjnej, to może być ciężko.

- próbowałem z wersją 10.12.7

5. Paradoksalnie z 1050 może być łatwiej, powinna odpalić w VESA, ale świecić. 
6. W BIOSie jak masz to wyłącz takie rzeczy jak port szeregowy, cfg lock, vt-d.

- mam wyłączone wszystko tak, ja w pierwszym temacie w linku co podałem.
 
Czy mogę próbować odpalić wersję beta High Sierra? Czy scena hackintosh jest już na to gotowa? Skoro ma być mniej problemów, to może łatwiej będzie zainstalować właśnie wczesną wersję?

#5 314TeR

314TeR

    Administrator

  • Administrators
  • 16895 postów
  • LocationWarszawa

Napisano 11 wrzesień 2017 - 22:38

Wklejenie binpatcha do Clovera nie jest, aż tak dużym problemem ;)

 

Można, ale miej świadomość jak działa ten patch i co z nim się wiąże - https://github.com/RehabMan/patch-nvme

Nawet RehabMan nie używa patcha, a podmienione kexty - właśnie po to aby nie stracić danych gdyby jakaś aktualizacja podmieniła kluczowe pliki. 

 

@Grzegorz Worendan - wystarczy inny pendrive - nie musi być 1, 2GB - spróbuj z inną sztuką nawet 32 czy 64GB. 

 

Nie ma wersji 10.12.7 i nie zapowiada się aby była.

 

Jak masz system 10.12.6, to właściwa identyfikacja jest iMax18.x - jak masz starsze to iMax17.x + patch do cpu - niestety nie mam pod ręką jaki, musisz poszukać na forum, był podawany. 

 

Aby odpalić High Sierrę musisz mieć nowego clovera - powalcz może wpierw z 10.12.6 jak Ci się uda, to nie obejrzysz się a już 10.13 będzie do pobrania. 


  • Grzegorz Worendan lubi to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#6 Grzegorz Worendan

Grzegorz Worendan
  • Members
  • 18 postów

Napisano 12 wrzesień 2017 - 23:17

Faktycznie. Mój błąd. Chodziło mi o 10.12.5

Pobrałem 10.12.6 oraz podłączyłem kartę graficzną i na tym configu poszło dalej. Instalacja przebiegła pomyślnie.

314TeR słyszałem, że od Ciebie będę mógł kupić kartę sieciową? Masz dalej jakieś na stanie, które są działające?

Po instalacji zauwazyłem, że:

+ Porty USB 3.0 działają.
+ Dźwięk z tyłu obudowy działa.
+ obraz z HDMI działa
+ obraz z DVI działa

- nie działają oba monitory jednocześnie
- maksymalna rozdzielczość to 1280x720
- nie działa dźwięk poprzez HDMI
- podczas instalacji nie wykrywało mojego dysku NVMe

Także zainstalowałem na razie na HDD i moje pytanie brzmi, czy gdy wyjdzie High Sierra, to normalnie pobieram z AppStore, robię update.
Następnie czy da się zrobić tak, aby cały dysk wrzucić na NVMe, a później wymazać HDD, czy jednak będe musiał proces instalacji przechodzić od początku?

Wydaje mi się, że instalacja sterownika graficznego rozwiąże kilka w/w problemów (ale jak się go instaluje? Czy tutaj są potrzebne jakieś kexty?)

Jutro zobaczę również, czy mam internet przez kabel.

#7 314TeR

314TeR

    Administrator

  • Administrators
  • 16895 postów
  • LocationWarszawa

Napisano 13 wrzesień 2017 - 00:40

W sprawie kart zapraszam na PW.

 

Zainstaluj sterowniki webowe, dodaj nvidiaweb do configu i powinno zadziałać. 

 

macOS High Sierra w wersji beta już możesz pobrać z Mac App Store, ale to wciąż wersja beta i może różnie działać. System z HDD to żaden problem przenieść, możesz też zainstalować 10.13 na SSD NVMe i zaimportować dane z HDD. Potem zawartość HDD można spokojnie skasować. 


  • Grzegorz Worendan lubi to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#8 Grzegorz Worendan

Grzegorz Worendan
  • Members
  • 18 postów

Napisano 14 wrzesień 2017 - 20:47

w config.plist mam następującą sekcję:

<key>SystemParameters</key>
<dict>
	<key>InjectKexts</key>
	<string>Yes</string>
	<key>InjectSystemID</key>
	<true/>
	<key>NvidiaWeb</key>
	<true/>
</dict>

Zainstalowałem także Nvidia WebDriver-378.05.05.25f01 i zakończyło się to sukcesem. Moja karta jest wykrywana w systemie, ale nadal uruchamia się tryb "OS X Default Graphices Driver"

 

Gdy chcę zmienić na Nvidia to następnie muszę zrestartować komputer. Po ponownym logowaniu dalej mam tryb "OS X Default Graphices Driver".

 

Próbowałem nawet z flagą bootowania nvda_dvr=1, ale to również nic nie dało (tym bardziej, że tą flagę powinno się ustawiać dla systemów <= 10.11.6.

 

Co robię źle? Ktoś miał taki przypadek? Tymczasem dalej będę szukał rozwiązania.

Edit: Zauważyłem, że dobra jestt tylko identyfikacja karty, lecz VRAM zamiast 4096 MB pokazuje 256 MB

 

Co do internetu przez kabel, to niestety w sprzęcie nie wykrywa mi karty sieciowej : /

Internet udostępniany z laptopa przez kabel działa.

Pomogło wgranie IntelMausiEthernet.kext

Załączone pliki

  • Załączony plik  1.png   2,31 MB   0 Ilość pobrań
  • Załączony plik  2.png   2,23 MB   0 Ilość pobrań


#9 314TeR

314TeR

    Administrator

  • Administrators
  • 16895 postów
  • LocationWarszawa

Napisano 14 wrzesień 2017 - 21:32

"OS X Default Graphices Driver" masz dla tego, że nie działa natywny zapis do nvram i sterowniki sprawdzając nvram nie znajdują tam odpowiedniego wpisu. Natomiast jak działa poprawnie karta to tym się nie przejmuj. 

 

Polecam później odpalić emulację NVRAM i wtedy przełącznik będzie pokazywał się prawidłowo. 


  • Grzegorz Worendan lubi to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#10 Grzegorz Worendan

Grzegorz Worendan
  • Members
  • 18 postów

Napisano 14 wrzesień 2017 - 21:48

"OS X Default Graphices Driver" masz dla tego, że nie działa natywny zapis do nvram i sterowniki sprawdzając nvram nie znajdują tam odpowiedniego wpisu. Natomiast jak działa poprawnie karta to tym się nie przejmuj. 

 

Polecam później odpalić emulację NVRAM i wtedy przełącznik będzie pokazywał się prawidłowo. 

 

Tutaj już nie chodzi o przełącznik, ale maksymalną szerokość jaką osiągam to 1280 (przez DVI na 22 calowym dellu FullHd oraz tak samo przez HDMI na dellu 2k 25 calowym). Oba monitory w formacie 16:9.

 

Z tą różnicą, że wyskość się zmienia. Dla monitora mniejszego wynosi ona 768, natomiast dla większego 1024. Szerokość natomiast zostaje 1280.

 

Moje marzenie to odpalenie FullHD i współpraca obu monitorów jednocześnie, ale z tym czuję, że będzie walka.

 

Edit: Wszystko jest ok i działa. Jutro opiszę szerzej co zrobiłem.

Przy CMS włączonym i wyłączonym działa identycznie. Bootuje na monitorze pod DVI, a logowanie mam już na obu monitorach.
Jutro powalczę z dźwiękiem przez HDMI, a następnie zamówię jeszcze kartę sieciową od Ciebie. Dzięki!

 

Edit: po 1 minucie. Jednak dźwięk przez HDMI również działa.

 

Edit: Z potrzebnych jeszcze mi rzeczy nie działa mikrofon.

 

Edit: Sleep również działa, zarówno monitory jak i internet.



#11 314TeR

314TeR

    Administrator

  • Administrators
  • 16895 postów
  • LocationWarszawa

Napisano 15 wrzesień 2017 - 07:03

PS, z karta się spiesz, bo dziś ostatni dzień w którym mogę ja wysłać i tylko paczkomat. Kurier już odpada.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#12 gen.jusz

gen.jusz
  • Members
  • 73 postów
  • LocationWWA

Napisano 15 wrzesień 2017 - 12:03

Ja musiałem u siebie oprócz nvda_dvr=1 włączyć driver EmuVariableUefi (wykomentować go z sekcji DisabledDrivers), wtedy wszystko poszło (chipset z170).


MacBook Pro 15" ][ Core i7-4980HQ 2,8 GHz ][ 16 GB RAM DDR3 1600 ][ Radeon R9 M370X

haMac ][ Gigabyte GA-Z170X-Ultra Gaming ][ Core i7-7700K 4,2 GHz ][ 16GB DDR4 2400 ][ EVGA GTX 980 Ti


#13 knara

knara
  • Donator
  • 129 postów
  • LocationWerl Germany

Napisano 15 listopad 2017 - 09:41

"OS X Default Graphices Driver" masz dla tego, że nie działa natywny zapis do nvram i sterowniki sprawdzając nvram nie znajdują tam odpowiedniego wpisu. Natomiast jak działa poprawnie karta to tym się nie przejmuj.

Polecam później odpalić emulację NVRAM i wtedy przełącznik będzie pokazywał się prawidłowo.


Jakie i do którego wpisu NVRAM odwołują się sterowniki?

Asrock z87e-itx, i5-4460


#14 314TeR

314TeR

    Administrator

  • Administrators
  • 16895 postów
  • LocationWarszawa

Napisano 15 listopad 2017 - 11:18

Musisz wyłączyć/skasować EmuVariableUefi i sprawdzić czy działa zapis. Robisz to w konsoli - polecenie nvram.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 






Również z jednym lub większą ilością słów kluczowych: asus z270, NVMe, i7-7700

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych