Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Clover- Msi Z170i Gaming AC


  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 m8kbv

m8kbv
  • Members
  • 284 postów

Napisano 11 grudzień 2017 - 09:50

Witam. Z racji iż w internecie na próżno szukać gotowego configu do płyty MSI z170i Gaming AC, zamieszczam gotowy folder EFI. 

 

Konfiguracja:

Intel i5 7600k 
8GB Ram
Intel HD630 + GTX 1060 6GB
Wifi podmienione na Dell DW1830 (zalecam jednak do tej płyty coś węższego o 2-3mm tak by karta była przykręcona śrubą a nie wisiała w powietrzu =D> )
ALC 1150

​Co działa:

- CPU (speedstep, turbo)
- grafika (Intel uruchomiony był przed podłączeniem GTXa, wydaje się więc że po podłączeniu do zintegrowanego układu graficznego grafika powinna uruchomić się bez problemu)
- dźwięk (Po uruchomieniu  "audio_cloverALC-130.sh" dostępnego w sieci). Działa również po wybudzeniu ze sleepu (nie wiem jak na złączu JACK, audio uruchamiam ze złącza optycznego). AppleALC.kext
- sieć LAN
- WiFi
- porty USB 3.0
- sleep (Poprawne wybudzanie po hibernacji występuje po zastosowaniu argumentu darkwake=0)

 
Choć konfiguracja mieszana, Smbios uruchomiony jako iMac 17.1.
Przed próbą uruchomienia imessages proszę o wpisanie unikalnego numeru seryjnego. 

 

System działa stabilnie, do uruchomienia 4k na GTX 1060 potrzebna jest instalacja Mac OS w wersji 10.12 lub 10.13. 

Wynik w geekbench 4 po podkręceniu do 4.3GHz wynosi na mojej konfiguracji 15000pkt. 

A oto wyżej opisana konfiguracja (w wersji poprawionej dzięki pomocy oswaldini oraz 314TeR):
http://hamac.pl/file...170i-gaming-ac/


OS X 10.13.1: Hackintosh- MSI h170i GAMING AC  i5 7600k  l 8GB Goodram DDR4 2400MHz l Dell DW1830.  l SM961 512 GB NVME l Silverstone SFX 500W l Fractal Node 202

OS X 10.12.5: MB Air 7.2 256GB 4GB RAM
OS X 10.12 : Hackintosh- MSI Z97m GAMING   l i5 4670k  l 8GB Kingston KVR16N11/8 l BCM94360CD l Plextor m6pro 128GB l Samsung SM951 l MSI GTX1060 6GB l 256GB l XFX XTR 650W l Bitfenix Phenom M l

OS X 10.11 : Hackbook: HP 720 G2  l i5 5200u l 4GB RAM l BCM94352Z l Samsung SSD  128GBl

OS X 10.9 : Hackintosh- Asrock Z87 Extreme 4  l i5 4670k  l 4GB Kingston  l BCM94360CD l Samsung 840 EVO l MSI GTX970 4GB l SPC Dzeus 550W l SPC Regnum L50 

 


#2 oswaldini

oswaldini
  • Moderators
  • 10846 postów
  • LocationBrzeszcze / Kraków

Napisano 11 grudzień 2017 - 10:17

Nie zrozum mnie źle, super, że pomagasz. Niestety jest masa rzeczy do poprawienia.

 

Co do audio to jedyny sterownik mający sens to AppleALC, jest odporny na aktualizacje.

 

Bajzel w kextach ! Masz je w w katalogach 10.xx oraz w Other - są zdublowane etc. Do integry potrzebny jest IntelGraphicsFixup oraz Shiki (z odpowiednią flagą shikigva=1), moim zdaniem FakePCIID_Intel_HD_Graphics jest zbędny.

 

W configu:

- HaltEnabler raczej do usunięcia

- zbędne flagi w Arguments: slide=0 dart=0 darkwake=0 npci=0x3000 rootless=0 keepsyms=1 (ja wywaliłbym wszystkie)

- generowanie stanów powinno być wyłączone i do pełnego działania PM wystarczy config.plist/ACPI/SSDT/Generate/PluginType=true

- sekcja AddProperties wpis IntelGFX do wywalenia po dodaniu IntelGraphicsFixup

- sekcja FakeID, opcja IntelGFX - po co fakeid jak stosujesz FakePCIID_Intel_HD_Graphics.kext ?

- kod języka zamiast pl:0 powinien być pl:30788

- po co używasz FakeCPUID=0x0506E3 ??!! Do kosza.

- KernelLapic i KernelPm na false (do weryfikacji ale na 99% zbędne)

- AppleRTC - do weryfikacji czy faktycznie konieczne

- sekcja KextsToPatch - patche do USB nie mają określonych  wersji systemów (MatchOS), może się rypnąć, Clover próbuje patchować kexty niezależnie od systemów


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | 2x mSATA SSD 32GB RAID0 (64GB) + SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi

HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#3 m8kbv

m8kbv
  • Members
  • 284 postów

Napisano 11 grudzień 2017 - 10:39

Dziękuję za wyszczególnienie elementów które mogą być nie tak, sprawdzę wieczorem i dam znać czy miałeś racje. 
Pozdrawiam


OS X 10.13.1: Hackintosh- MSI h170i GAMING AC  i5 7600k  l 8GB Goodram DDR4 2400MHz l Dell DW1830.  l SM961 512 GB NVME l Silverstone SFX 500W l Fractal Node 202

OS X 10.12.5: MB Air 7.2 256GB 4GB RAM
OS X 10.12 : Hackintosh- MSI Z97m GAMING   l i5 4670k  l 8GB Kingston KVR16N11/8 l BCM94360CD l Plextor m6pro 128GB l Samsung SM951 l MSI GTX1060 6GB l 256GB l XFX XTR 650W l Bitfenix Phenom M l

OS X 10.11 : Hackbook: HP 720 G2  l i5 5200u l 4GB RAM l BCM94352Z l Samsung SSD  128GBl

OS X 10.9 : Hackintosh- Asrock Z87 Extreme 4  l i5 4670k  l 4GB Kingston  l BCM94360CD l Samsung 840 EVO l MSI GTX970 4GB l SPC Dzeus 550W l SPC Regnum L50 

 


#4 314TeR

314TeR

    Administrator

  • Administrators
  • 17092 postów
  • LocationWarszawa

Napisano 11 grudzień 2017 - 14:51

Obejrzyj sobie zestaw po Z170 z UniBootX - tam popełniłem całkiem sensowną bazę do dalszego dostosowania.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#5 m8kbv

m8kbv
  • Members
  • 284 postów

Napisano 12 grudzień 2017 - 10:32

Zdublowane kexty oraz  FakePCIID_Intel_HD_Graphics usunięty, zamieszczony IntelGraphicsFixup w razie potrzeby odpalenia integry.

- Apple ALC odpalone;)

 

- HaltEnabler - usunięte

- Usunięte wszystkie flagi

- generowanie stanów - poprawione wg opisu wyżej

- sekcja AddProperties wpis IntelGFX- usunięte

- sekcja FakeID- poprawione

- kod języka zmieniony na pl:30788

-  FakeCPUID=0x0506E3  usunięte

- KernelPm - musi pozostać, bez niego nie odpala mi system.

- AppleRTC  i KernelLapic - usunięte

- sekcja KextsToPatch - patche do USB- poprawię dziś.

i działa;) Oswaldini po raz kolejny pomogłeś, dziękuję. Dziś zamieszczę poprawioną wersję.


OS X 10.13.1: Hackintosh- MSI h170i GAMING AC  i5 7600k  l 8GB Goodram DDR4 2400MHz l Dell DW1830.  l SM961 512 GB NVME l Silverstone SFX 500W l Fractal Node 202

OS X 10.12.5: MB Air 7.2 256GB 4GB RAM
OS X 10.12 : Hackintosh- MSI Z97m GAMING   l i5 4670k  l 8GB Kingston KVR16N11/8 l BCM94360CD l Plextor m6pro 128GB l Samsung SM951 l MSI GTX1060 6GB l 256GB l XFX XTR 650W l Bitfenix Phenom M l

OS X 10.11 : Hackbook: HP 720 G2  l i5 5200u l 4GB RAM l BCM94352Z l Samsung SSD  128GBl

OS X 10.9 : Hackintosh- Asrock Z87 Extreme 4  l i5 4670k  l 4GB Kingston  l BCM94360CD l Samsung 840 EVO l MSI GTX970 4GB l SPC Dzeus 550W l SPC Regnum L50 

 


#6 oswaldini

oswaldini
  • Moderators
  • 10846 postów
  • LocationBrzeszcze / Kraków

Napisano 12 grudzień 2017 - 11:17

Żeby pozbyć się KernelPM zmień w BIOSie opcję CFG lock.


  • m8kbv lubi to

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | 2x mSATA SSD 32GB RAID0 (64GB) + SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi

HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#7 m8kbv

m8kbv
  • Members
  • 284 postów

Napisano 12 grudzień 2017 - 22:06

Poprawiłem wszystkie błędy, usunąłem zbędne opcje- wszystko działa. Zamieszczam nowy plik na stronę. 
 


OS X 10.13.1: Hackintosh- MSI h170i GAMING AC  i5 7600k  l 8GB Goodram DDR4 2400MHz l Dell DW1830.  l SM961 512 GB NVME l Silverstone SFX 500W l Fractal Node 202

OS X 10.12.5: MB Air 7.2 256GB 4GB RAM
OS X 10.12 : Hackintosh- MSI Z97m GAMING   l i5 4670k  l 8GB Kingston KVR16N11/8 l BCM94360CD l Plextor m6pro 128GB l Samsung SM951 l MSI GTX1060 6GB l 256GB l XFX XTR 650W l Bitfenix Phenom M l

OS X 10.11 : Hackbook: HP 720 G2  l i5 5200u l 4GB RAM l BCM94352Z l Samsung SSD  128GBl

OS X 10.9 : Hackintosh- Asrock Z87 Extreme 4  l i5 4670k  l 4GB Kingston  l BCM94360CD l Samsung 840 EVO l MSI GTX970 4GB l SPC Dzeus 550W l SPC Regnum L50 

 





Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych