Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Po aktualizacji przestał działać dzwięk (AD1984)

dzwięk AD1984 Aktualizacja El Capitan

  • Zaloguj się, aby dodać odpowiedź
12 odpowiedzi w tym temacie

#1 Jarekhunter

Jarekhunter
  • Members
  • 13 postów

Napisano 01 luty 2018 - 15:07

Witam
Obecnie miałem wersje systemu mac os 10.11.5 - i Dzwięk na AppleALC id 11
Po ostatniej aktualizacji zabezpieczeń do 10.11.6 przestał działać system, dostawałem Kernel Panic, screena załączam w załączniku.
Pobrałem nowszą wersję AppleALC.kext z oficjalnego git’a. Problem z KP zniknął. Natomiast sam głośniczek jest nieaktywny, nie ma żadnych wejść,wyjść w preferencjach audio. Audio zawsze uruchamiane było przy pomocy AppleALC i ID 11 ustawionego w Cloverze. Czy ktoś może mi powiedzieć, co się zmieniło, że audio nagle przestało być osiągalne? 
 
Mój komputer:
Dell optiplex 755
Socket LGA775
Procesor Q6600 4x2,4Mhz
Ram: 4x2GB Kingston 800Mhz
Os: El Capitan detail
Bootloader: Clover
 
Audio to:
Audio Adapter:
Intel 82801IB ICH9 - High Definition Audio [A2] 
 
Audio Controller Hardware ID:
PCI\VEN_8086&DEV_293E&SUBSYS_02111028&REV_02 
 
High Definition Audio Codec:
Analog Devices AD1984 
 
Audio Codec Hardware ID:
HDAUDIO\FUNC_01&VEN_11D4&DEV_1984&SUBSYS_00000000 
 
[Driver Information] 
 
Driver Manufacturer:
Analog Devices 
 
Driver Description:
SoundMAX Integrated Digital HD Audio 
 
DeviceInstanceId
HDAUDIO\FUNC_01&VEN_11D4&DEV_1984&SUBSYS_10280211&REV_1004\4&178DEBBC&0&0001
(Załączam załącznik audio z HWinfo)
 
Dziękuję serdecznie za pomoc.

Załączone pliki



#2 314TeR

314TeR

    Administrator

  • Administrators
  • 17842 postów
  • LocationWarszawa

Napisano 01 luty 2018 - 18:42

Dograj jeszcze lilu.kext.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#3 Jarekhunter

Jarekhunter
  • Members
  • 13 postów

Napisano 01 luty 2018 - 21:36

Mam dograny najnowszy applealc oraz lilu i jest bez zmian
Wstrzykuje AppleAlc ale brak dźwięku całkowity.
Strzeliłem sobie w kolano z tą aktualizacją i szczerze ręce mi już opadają.
Co te pierniki zmienili że to nie działa?.
Pobrałem nawet źródło AppleAlc najnowsze i mój kodek jest na layoutsie 11 czyli nic nie powinno się zmieniać a jednak dźwięku brak.
Pomocy

#4 314TeR

314TeR

    Administrator

  • Administrators
  • 17842 postów
  • LocationWarszawa

Napisano 01 luty 2018 - 22:05

A może coś bzdurnego, jakieś śmieci w /S/L/E, nieprzebudowany cache.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#5 Jarekhunter

Jarekhunter
  • Members
  • 13 postów

Napisano 02 luty 2018 - 02:06

A może coś bzdurnego, jakieś śmieci w /S/L/E, nieprzebudowany cache.

Z cache faktycznie nie próbowałem chociaż dziwna była by to sprawa.

kexty mam w cloverze w katalogu kext/other - więc ręcznie niczego nie dorzucałem do /S/L/E

Przebuduje cache i zobaczę czy pomoże.



#6 man_of_the_oak

man_of_the_oak
  • R.E.D.
  • 819 postów
  • LocationKraków

Napisano 02 luty 2018 - 03:13

A może spróbuj je przenieść do folderu odpowiadającego danej wersji systemu?


ASUS Z97-Pro Gamer | Intel Core i7-4790K | 16 GB 2400 MHz CL10 RAM | ASUS GTX760-DC2T-2GD5-SSU | Samsung 850 PRO + Samsung HD103SJ | BCM94360CD | Aune T1 MK2 + Genalex Gold Lion E88CC | macOS Sierra 10.12.6

MacBook Pro 13,3" (Mid 2012) | Intel Core i7-3520M | 16 GB 1600 MHz CL11 RAM | Intel HD 4000 | Transcend 370S | macOS Sierra 10.12.6
Mac OS X Snow Leopard 10.6.8 Retail (64-bit) @ ASUS K50IN (SX152)
FlagaPL.gif Piszę poprawnie po polsku!


#7 314TeR

314TeR

    Administrator

  • Administrators
  • 17842 postów
  • LocationWarszawa

Napisano 02 luty 2018 - 13:40

Zaktualizuj clovera do najnowszej wersji.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#8 Jarekhunter

Jarekhunter
  • Members
  • 13 postów

Napisano 02 luty 2018 - 18:22

Najnowszy Clover i mam ciągle brak dzwięku.

config.plist - na nim poprzednio wszystko działało przed aktualizacją w wersji 10.11.5

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>Name</key>
			<string>DSDT.aml</string>
			<key>Patches</key>
			<array>
				<dict>
					<key>Comment</key>
					<string>EHC1 to EH01</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					RUhDMQ==
					</data>
					<key>Replace</key>
					<data>
					RUgwMQ==
					</data>
				</dict>
				<dict>
					<key>Comment</key>
					<string>EHC2 to EH02</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					RUhDMg==
					</data>
					<key>Replace</key>
					<data>
					RUgwMg==
					</data>
				</dict>
			</array>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>EnableC6</key>
			<true/>
			<key>Generate</key>
			<dict>
				<key>APLF</key>
				<true/>
				<key>APSN</key>
				<true/>
				<key>CStates</key>
				<true/>
				<key>PStates</key>
				<true/>
				<key>PluginType</key>
				<true/>
			</dict>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>kext-dev-mode=1</string>
		<key>Debug</key>
		<false/>
		<key>DefaultLoader</key>
		<string>boot.efi</string>
		<key>DefaultVolume</key>
		<string>LastBootedVolume</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>3</integer>
		<key>XMPDetection</key>
		<string>Yes</string>
	</dict>
	<key>CPU</key>
	<dict>
		<key>UseARTFrequency</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>11</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>AddClockID</key>
			<true/>
			<key>FixOwnership</key>
			<true/>
			<key>Inject</key>
			<true/>
		</dict>
	</dict>
	<key>GUI</key>
	<dict>
		<key>Hide</key>
		<array>
			<string>Dane HD</string>
			<string>HD2</string>
			<string>HD3</string>
		</array>
		<key>Language</key>
		<string>pl:0</string>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<false/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>ScreenResolution</key>
		<string>1920x1080</string>
		<key>Theme</key>
		<string>MavericksLogin</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>DualLink</key>
		<integer>1</integer>
		<key>FBName</key>
		<string>Shrike</string>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<false/>
			<key>NVidia</key>
			<true/>
		</dict>
		<key>NvidiaSingle</key>
		<false/>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleIntelCPUPM</key>
		<false/>
		<key>AppleRTC</key>
		<true/>
		<key>Debug</key>
		<false/>
		<key>DellSMBIOSPatch</key>
		<false/>
		<key>KernelCpu</key>
		<false/>
		<key>KernelLapic</key>
		<false/>
		<key>KernelPm</key>
		<false/>
		<key>KernelXCPM</key>
		<false/>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>External icons patch</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				RXh0ZXJuYWw=
				</data>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Replace</key>
				<data>
				SW50ZXJuYWw=
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>BooterConfig</key>
		<string>0x28</string>
		<key>CsrActiveConfig</key>
		<string>0x67</string>
		<key>MLB</key>
		<string>C02140302D5DMT31M</string>
		<key>ROM</key>
		<data>
		9lmCVDNK
		</data>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>08/08/17</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>IM101.88Z.00CF.B00.1708080133</string>
		<key>Board-ID</key>
		<string>Mac-F2268CC8</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardSerialNumber</key>
		<string>RM01005PE1RDW</string>
		<key>BoardType</key>
		<integer>10</integer>
		<key>BoardVersion</key>
		<string>1.0</string>
		<key>ChassisAssetTag</key>
		<string>iMac-Aluminum</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>0x0D</string>
		<key>Family</key>
		<string>iMac</string>
		<key>FirmwareFeatures</key>
		<string>0xE00DE137</string>
		<key>FirmwareFeaturesMask</key>
		<string>0xFF1FFF3F</string>
		<key>LocationInChassis</key>
		<string>Part Component</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>Mobile</key>
		<false/>
		<key>PlatformFeature</key>
		<string>0xFFFF</string>
		<key>ProductName</key>
		<string>iMac10,1</string>
		<key>SerialNumber</key>
		<string>RM01116Z5PE</string>
		<key>SmUUID</key>
		<string>44454C4C-4400-1032-8036-C7C04F54334A</string>
		<key>Trust</key>
		<true/>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>CustomUUID</key>
		<string>44454C4C-4400-1032-8036-C7C04F54334A</string>
		<key>InjectKexts</key>
		<string>Yes</string>
		<key>InjectSystemID</key>
		<true/>
	</dict>
</dict>
</plist>

Kextów ręcznie nigdzie nie musiałem kopiować jak również instalować wszystko zawsze działało z clovera

Zamieszczę jeszcze DSDT jeśli by to pomogło chociaż dziwne, wcześniej działało teraz nie :(

 

 

Załączone pliki



#9 javazlaz

javazlaz
  • Members
  • 1555 postów
  • LocationCzęstochowa

Napisano 02 luty 2018 - 20:31

W ostateczności zostaje VoodooHDA... Gdy pacyfikowałem OptiPlexa ciut tylko nowszego niż Twój, też nie mogłem dojść do ładu z dźwiękiem pod Sierrą. W końcu odpuściłem i wrzuciłem Voodoo. Lekki tuning w ustawieniach i jako systemowy brzęczek wystarczy. Cudów nie można się spodziewać, ale bardzo źle też nie jest.


macOS 10.14.1 + Windows 10 Pro - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Gigabyte RX 560 Gaming OC 4GB | Samsung 850 EVO 250GB | WD Red 1TB | Intel I218-V | Fenvi FV-T919 | ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium | Dell P2210

iOS 12.1 - iPhone SE 16GB Space Gray

ADM 3.1.3.RHU2 - Asustor AS1002T | 2x WD Red 3TB


#10 Jarekhunter

Jarekhunter
  • Members
  • 13 postów

Napisano 06 luty 2018 - 16:10

W ostateczności zostaje VoodooHDA... Gdy pacyfikowałem OptiPlexa ciut tylko nowszego niż Twój, też nie mogłem dojść do ładu z dźwiękiem pod Sierrą. W końcu odpuściłem i wrzuciłem Voodoo. Lekki tuning w ustawieniach i jako systemowy brzęczek wystarczy. Cudów nie można się spodziewać, ale bardzo źle też nie jest.

Dograłem VoodooHda oraz VoodooHdaPrefPanel - Ale za każdym razem muszę dzwięk na nowo ustawiać by trzasków nie było, ten kext to jest masakra !

Jest jakaś opcja by to ustrojstwo trzymało ustawienia ?



#11 314TeR

314TeR

    Administrator

  • Administrators
  • 17842 postów
  • LocationWarszawa

Napisano 06 luty 2018 - 18:18

Brzmi jakbyś używał jakiejś starej wersji voodoohda. Aktualna jest tu:

https://sourceforge....ects/voodoohda/

 

Natomiast często jest tak, że trzeba jeszcze je dostosować co nieco pod swój układ i pozmieniać parę opcji w info.plist znajdującym się w kextcie.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#12 Jarekhunter

Jarekhunter
  • Members
  • 13 postów

Napisano 07 luty 2018 - 03:12

Brzmi jakbyś używał jakiejś starej wersji voodoohda. Aktualna jest tu:

https://sourceforge....ects/voodoohda/

 

Natomiast często jest tak, że trzeba jeszcze je dostosować co nieco pod swój układ i pozmieniać parę opcji w info.plist znajdującym się w kextcie.

Dokładnie pobrałem z tej strony v2.9.1

Mogę prosić o jakieś namiary co muszę w tym kexcie pozmieniać.

Dźwięk jest, ale za każdym razem muszę wyciszać wejście liniowe i mikrofon bo inaczej mam przesterowania dźwięku, nie wiem czym jest to spowodowane..



#13 314TeR

314TeR

    Administrator

  • Administrators
  • 17842 postów
  • LocationWarszawa

Napisano 07 luty 2018 - 08:04

A szukałeś jakiego wątku z FAQ np na insanely?

Jak mnie pamięć nie myli, to ptzreba było tylko jakiś jeden parametr zmienić.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 






Również z jednym lub większą ilością słów kluczowych: dzwięk, AD1984, Aktualizacja, El Capitan

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych