Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Problem "globalny" z rx580 i eksportem h264 w FCPX


  • Zaloguj się, aby dodać odpowiedź
48 odpowiedzi w tym temacie

#21 olej7777

olej7777
  • Members
  • 147 postów

Napisano 22 luty 2018 - 10:53

Witam.

Obecnie nastąpiły spore zmiany w config, nie używam już ani shiki ani rad4200. Komp jest od 12h stabilny, wsparcie dla grafik jest, przy eksporcie działa procesor, intelgpu i rx580 (przy samym rx580 eksport był 2x dłuższy). Częstotliwość intela jest zmienna 0-1200MHz. Sleep działa w pełni nie ba problemów z budzeniem. Procesor po OC na 4,7GHz z AVX ON, CPU Cache 4,5 GHz, Balistix Sport po malym oc na 2666 (wiecej nie ciagnie bez miany timingow, tu dalem troche ciala z wyborem ramu), NMVe w raid 0 HFS+ - kopiowanie carbon copy cloner. Niebawem testy stabilnosci rx580 na windowsie i edycja biosu aby dać sztywne wartości oc. Całkowicie przerzuciłem już system na ten config z raid i będę go testował.

Będę dawał znać jak się temat rozwija.


  • man_of_the_oak i Najrad lubią to

Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#22 314TeR

314TeR

    Administrator

  • Administrators
  • 17588 postów
  • LocationWarszawa

Napisano 22 luty 2018 - 11:31

Czekamy z niecierpliwością na komplet informacji jak sobie poradziłeś.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#23 olej7777

olej7777
  • Members
  • 147 postów

Napisano 23 luty 2018 - 01:16

Teoretycznie caly dzien testow i komp dziala jednak mam pewne obawy co do wykorzystania radeona w FCPX 10.4 i compressor 4.4 badz moj config jest jeszcze do dopracowania.

Eksportujac film 1080/25p praktycznie goly klip 4:20

1) sam radeon obciazenie ponad 80% czas 1:25
2) cpu i oba gpu obciazenie ok 50% czas 45s
3) sam cpu obciazenie ponad 90% czas 5min
4) macbook 15 touchbar i7 z radeon pro 450 czas 1:05 obciazenie odobnie jak na hacu.

Skok jak widac jest spory jednak dlaczego radek i reszta obciazone sa w 50%? Na macbooku to samo, i nie jest to blad istat bo slychac po wiatrakach, jest bardzo cicho.

Podzespoly haca sa jednak tak srednio 2x mocniejsze a czas tylko 1.5x lepszy. Wydaje mi sie ze nie bede szukal dziury w caly a poczekam na update finala i compressora...

Zrobilem jeszcze flash radeona na wyzsze zegary ale nawet 1s to nie dalo, tak wiec karta nie jest w pelni obciazona. Przy reflashu wysypal mi sie eprom ale juz zyje - przydal sie intel uhd :P (flash karty jest raktycznie w 99.99% bezpieczny gdyby ktos sie bal, po wysypaniu majac integre do uratowani

Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#24 Michassdz

Michassdz
  • Members
  • 8 postów
  • LocationŁódzkie

Napisano 23 luty 2018 - 01:45

45 sek to bardzo dobry wynik. Ciekawe jak przy completnym projekcie będzie ze stabilnością i kulturą pracy? Exportujesz z tameline czy bezpośrednia z compressora.

Asrock z170 Extreme 4, I7 6700k 4,2, Radeon Rx580 8gb, Samsung evo 850 250GB, 4TB hdd, 16GB ddr4

macOS 10.13.3, fcpx 10.4

#25 olej7777

olej7777
  • Members
  • 147 postów

Napisano 23 luty 2018 - 14:28

Eksportuje z timeline, ze stabilnością nie było problemu film kompletny clipy z a7s2 i a 6300 bitrate 60 Mb/s 1080p/50p o długości filmu 73 min wyeksportował w pełni poprawnie w czasie 24min. Jeżeli uznajecie że te czasu są ok to nie będę dalej kombinował.

Bardzo mnie kusi podmienienie romu w moim Gigabythe rx580 gaming 8gb na ten z saphire rx580 pulse 8gb... Robiłem jednak już oc tej mojej i poprawy nie było. Jak dostane info że na 99,99% nie da się uwalić innym romem karty i ewentualnie przy problemach bez problemu wroce do ori romu to zrobie flash, wyjscia wygladaja identycznie (wczoraj tez przeszedłem nieudany flash, czarny ekran ale bez problemu odpalilem kompa na intelu i przeflashowalem z cmd).

I chętnie bym usłyszał co da mi ten rom, bo ponoć jest karta rozpoznawana i działa w płeni poprawnie bez whatever green itp ale chciałbym to potwierdzić.


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#26 reyder

reyder
  • Members
  • 476 postów

Napisano 23 luty 2018 - 15:02

Co ma dać podmiana romu na inny (innego producenta) ? Na anoraku masz bios dla tej karty z specjalnymi timingami do 2250 mhz. Max można podkręcić ten model do 2090 powyżej zaczyna sypać błędami pamięci. Pozatym modele 580x i cała ta seria ma strasznie niedopracowane biosy.

Core i5-3750K | Gigabyte GA-Z77-D3H | 3x4GB 1600MHz | Gigabyte Nvidia 1070  :: Radeon 280X Asus | High Sierra 10.13 | Clover

Core i5-8600K | Asrock Extreme 4 | 2x8GB 2500MHz | Gigabyte 580X | High Sierra 10.13 | Clover


#27 olej7777

olej7777
  • Members
  • 147 postów

Napisano 23 luty 2018 - 16:37

Tego właśnie do końca nie wiem ale ponoć karty saphire wystepuja w starownikach apple i sa natywnie rozpoznawane bez system. Jak jest naprawde nie wiem i chetnie uslyszalbym wyjasnienia czy gra jest warta swieczki ;)

Niestety na OC zaliczyłem zwiechę i zobaczyłem w jednym miejscu klipu artefakt, wróciłem więc do ustawień bez oc procka i testy trwaja dalej... pytanie czy OC pre dawać artefakty?


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#28 olej7777

olej7777
  • Members
  • 147 postów

Napisano 24 luty 2018 - 00:51

Testy bez oc procka i ramu zakonczyly sie pomyslnie, wiec teraz ponownie wrocilem do OC jednak troche nizej pamieci na 2500 a cpu na 4,6 bedzie ok to podniose procka, jak to procek to go opuszcze a ram dam w gore :)

Dla zainteresowanych moj clover
whitedreamstudio.pl/photo/CLOVERz370.zip

Jeżeli wylapiecie jakies zbędne rzeczy dajcie znać ;)


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#29 Najrad

Najrad
  • Members
  • 737 postów
  • LocationPodhale

Napisano 24 luty 2018 - 09:50

Działa Ci PM? Nie masz ani tabel SSDT, ani zaznaczonej opcji PluginType w Cloverze.


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  High Sierra 10.13.3

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  Sierra 10.12.6

FCPX, Compressor, Davinci Resolve.

 


#30 olej7777

olej7777
  • Members
  • 147 postów

Napisano 25 luty 2018 - 00:19

Mam drop tables ssdt CPUPM, częstotliwości skaczą jak trzeba ;) 

Z ciekawostek ustawiłem sobie predefiniowany profil OC na 4,5 GHz... i fajnie procesor dobija czasem do 4,5... ale za to integre pokazuje mi na 3,5 GHz :o ten intel power widget widzę też nie jest mega wiarygodny :)

Dodatkowo zauważyłem z jednym z kolegów z forum że mój config sprawdza się u wielu osób jako naprawdę stabilny, niestety występuje spadek wydajności w BruceX z 14 s do 18s u mnie ;)


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#31 olej7777

olej7777
  • Members
  • 147 postów

Napisano 25 luty 2018 - 22:30

Na configu zero zwiech bledow w obrazie, bledow w renderingu itd. wiec uznaje go za stabilny ;) wrocilem juz z oc procka, ram zostawilem w spokoju póki co i bede obserwowal dalej dajac znac co i jak ;) gdy tylko beda nowe whatevergreen czy shiki bede testowal bo wydajnosc w brucex musi byc na 14s i koniec ;)


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#32 oswaldini

oswaldini
  • Moderators
  • 10960 postów
  • LocationBrzeszcze / Kraków

Napisano 25 luty 2018 - 22:49

Z tego co ja tam widzę, to wyłączasz firmware integry, wtf jak to ma działać ? Strasznie mnie to dziwi i ciekawi.


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600 | mSATA SSD 32GB + SSD 120GB + SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi

HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 8GB RAM | 2x WD RED 2TB | Synology DSM 6.1.6 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#33 olej7777

olej7777
  • Members
  • 147 postów

Napisano 26 luty 2018 - 15:10

No właśnie dziwi mnie to także ale działa... i nic sie nie wiesza od 2 dni. Teraz jednak pracuje na macbooku u tutaj np przy stabilizacji obciazenie jest na 98% natomiast na hacu 75% max... wiec coś jest nie tak, jednak stabilność kosztem wydajności jest w tym wypadku ważniejsza.

Oswaldini chodzi Ci argument -disablegfxfirmware? Bez tego parametru system zachowuje się tak samo, eksport także 45s (powyżej wspomnianego klipu).


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#34 Najrad

Najrad
  • Members
  • 737 postów
  • LocationPodhale

Napisano 26 luty 2018 - 16:25

Zastanawiam się nad jeszcze jednym rozwiązaniem. Może odpalić system z obiema grafikami (PEG jako pierwsza) jeden monitor do RX, drugi do Intela i tak sprawdzić wydajność kodowania. Tak chyba mają prawdziwe iMaki ? Nie wiem tylko, która karta jest wtedy odpowiedzialna za wyświetlanie interfejsu Finala, bo o ile pamiętam, to na HD4600 na dwóch monitorach to responsywność interface była słaba.


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  High Sierra 10.13.3

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  Sierra 10.12.6

FCPX, Compressor, Davinci Resolve.

 


#35 314TeR

314TeR

    Administrator

  • Administrators
  • 17588 postów
  • LocationWarszawa

Napisano 26 luty 2018 - 18:41

Jak PEG będzie pierwsza przed iGPU to macOS w ogóle nie wstanie. iGPU musi być zawsze jako pierwsze. Natomiast desktop rysuje zawsze karta ta do której podpięty jest monitor.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#36 Najrad

Najrad
  • Members
  • 737 postów
  • LocationPodhale

Napisano 28 luty 2018 - 19:40

Nie ma chyba sensu więcej gmerać w konfigu. Dziś leżąc na kanapie wpadłem na pomysł sprawdzenia BruceX jeszcze raz na FCPX 10.3.4. W tym celu odpaliłem 10.12.6 i za pomocą softu FCS Remover odinstalowałem FCPX 10.4. W to miejsce "wydobyłem" ze starego obrazu dysku FCPX 10.3.4 i przeciągnąłem do folderu Aplikacje. Odpaliłem i uruchomiłem test. Wynik 12 sekund. Bebechy dokładnie te same, dyski te same, tylko Final inny. Niemal o połowę lepszy wynik ( poprzednio 22-25 sekund), pobawił bym się studniówką, ale niestety library mam z wersji 10.4 więc nie ma opcji żeby wczytał. Wniosek jest jeden, FCPX w wersji 10.4 jest wolny. Albo to poprawią, albo nie, bo będą chcieli sprzedać więcej "wypaśniejszego" sprzętu. Tym akcentem, kończę definitywnie erę testów 10.4 na HS czekam na update 10.4.1.

 

EDIT:

Drugi test z uruchomionym stoperem i recorderem ekranu dał wynik 17 sek, a trzeci test łapany stoperkiem z iphone 14 sek.


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  High Sierra 10.13.3

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  Sierra 10.12.6

FCPX, Compressor, Davinci Resolve.

 


#37 olej7777

olej7777
  • Members
  • 147 postów

Napisano 01 marzec 2018 - 10:17

No i wszystko jasne :) nie problem w hacu a w apple...

Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#38 olej7777

olej7777
  • Members
  • 147 postów

Napisano 04 marzec 2018 - 23:24

Potwierdzam że system stabiliny jak skała, zero zwiech, eksport kilku filmow wczesniej montaz itd itp. config jest ok :) 


Hacintosch i7-8700k @4,7GHz (AVX ON), Radeon RX580 8GB, ASRock z370m Pro4, 32GB ram 2666MHz, 2 x 256GB Samsung PM961 NMVe RAID 0 (Zapis 2 GB/s, odczyt 3GB/s) po wielu dniach działający Hardware Encoding na 10.13.2
Macbook Pro 15" TouchBar


#39 reyder

reyder
  • Members
  • 476 postów

Napisano 10 marzec 2018 - 15:34

Nowy plugin (IntelGraphicfixup) eliminuje wszystkie dodatkowe wpisy, których używacie.


Użytkownik reyder edytował ten post 10 marzec 2018 - 17:38

Core i5-3750K | Gigabyte GA-Z77-D3H | 3x4GB 1600MHz | Gigabyte Nvidia 1070  :: Radeon 280X Asus | High Sierra 10.13 | Clover

Core i5-8600K | Asrock Extreme 4 | 2x8GB 2500MHz | Gigabyte 580X | High Sierra 10.13 | Clover


#40 Najrad

Najrad
  • Members
  • 737 postów
  • LocationPodhale

Napisano 10 marzec 2018 - 15:57

Nowy plugin eliminuje wszystkie dodatkowe wpisy, których używacie.

 

Masz rację w zasadzie  DSDT patches można już odpuścić. Są też nowe Shiki i WeG 1.1.6


1.Asus Gryphon Z87; i74790k; 32GB DDR3 Crucial Sport; MSI RX 580 Armor 8GB; AudioLink II; mysz i klawiatura USB; SSD 850EVO-250GB;  High Sierra 10.13.3

2.Asus P8Z68-V_PRO; i72600k; 16 GB DDR3 Crucial Sport; Asus R9 270X 2GB; mysz i klawiatura USB; SSD CrucialMX100-128GB;  Sierra 10.12.6

FCPX, Compressor, Davinci Resolve.

 





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych