Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Porządek w kernel extension.

pytanie

  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 cshacked87

cshacked87
  • Members
  • 79 postów

Napisano 24 marzec 2018 - 09:39

Witam, chcę usunąć niepotrzebne .kexty, podzespoły komputerowe jakie posiadam: MSI H100I PRO, i3-6100, GTX 1060, Kingston DDR4, Realtek RTL 8111H Lan, Realtek ALC887.

Kexty, które mam zainstalowane:

AppleALC, 

AtherosE2200Ethernet,

FakeSMC,

IntelGraphicsFixup

IntelMausiEthernet,

Lilu,

NvidiaGraphicsFixup,

RealtekRTL8111.

Jeśli korzystam z Nvidi to IntelGraphicsFixup potrzebny ?

Co w przypadku IntelMausiEthernet i AtherosE2200Ethernet jeśli karta sieciowa to Realtek ?

Zauważyłem jeszcze problem, że co któreś uruchomienie nie startuje mi myszka (Corsair RGB), która jest podświetlona, ale żeby zaczęła działać muszę wyciągnąć przewód z USB i podłączyć, czy może to wynikać z brakującego rozszerzenia ?



#2 314TeR

314TeR

    Administrator

  • Administrators
  • 17889 postów
  • LocationWarszawa

Napisano 24 marzec 2018 - 23:16

Możesz wywalić kexty, ale nie musisz. To nie Windows.

 

Kext to rozszerzenie jądra, uruchamiane jest i ładowane tylko jak posiadasz takowy sprzęt. Tak jest skonstruowanym macOS, system ma kexty do całego sprzętu Apple, ale używane i ładowane są tylko te do sprzętu jaki posiadasz.


  • music lubi to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#3 cshacked87

cshacked87
  • Members
  • 79 postów

Napisano 27 marzec 2018 - 16:10

Rozumie, dla własnego spokoju wywaliłem IntelGraphicsFixup, AtherosE2200Ethernet, IntelMausiEthernet.

Czy któryś z tych .kextów może powodować problem z uruchamianiem połączenia internetowego ?

Zauważyłem, że mam problem przy pierwszym uruchomieniu komputera - domyślnie Clover ustawiony na startowanie z dysku Macos, uruchamia się bez dostępu do internetu.

Gdy wybiorę jako pierwsze uruchomienie Windows to następne uruchomienie macOS skutkuje połączeniem z internetem.

 

 
Dodatkowo:

Zauważyłem jeszcze problem, że co któreś uruchomienie nie startuje mi myszka (Corsair RGB), która jest podświetlona, ale żeby zaczęła działać muszę wyciągnąć przewód z USB i podłączyć, czy może to wynikać z brakującego rozszerzenia ?



#4 314TeR

314TeR

    Administrator

  • Administrators
  • 17889 postów
  • LocationWarszawa

Napisano 28 marzec 2018 - 12:50

A może zwyczajnie tak ma RTL8111.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#5 cshacked87

cshacked87
  • Members
  • 79 postów

Napisano 28 marzec 2018 - 14:25

A może zwyczajnie tak ma RTL8111.

Temat rozwiązany, problematyczne okazało się urządzenie od operatora.

 

W kwestii USB, widzę że brakuje mi USBInject.kext, który znajduje się w gotowej paczce na Skylake, czy może to być przyczyną, że nie widzi czasem myszki ?



#6 314TeR

314TeR

    Administrator

  • Administrators
  • 17889 postów
  • LocationWarszawa

Napisano 28 marzec 2018 - 20:10

Bardzo możliwe - po prostu nie masz aktywowanych wszystkich portów USB.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#7 cshacked87

cshacked87
  • Members
  • 79 postów

Napisano 28 marzec 2018 - 21:22

Zobaczmy czy coś się zmieni, dograłem rozszerzenie.

Czy jest gdzieś na forum rozpiska, do czego służą .kexty z gotowej paczki UnibootX?

Nie wiem do czego służy:

CPUSensors,

GPUSensors,

LPCSensors,

HDMIAudio,

SATA_Legacy.



#8 oswaldini

oswaldini
  • Moderators
  • 11018 postów
  • LocationBrzeszcze / Kraków

Napisano 29 marzec 2018 - 10:40

To akurat chyba logiczne:

CPUSensors - odczyt parametrów CPU

GPUSensors - odczyt parametrów GPU

LPCSensors - odczyt parametrów LPC (wentyle, etc)

HDMIAudio - audio po HDMI

SATA_Legacy - wstrzykuje nazwę kontrolera SATA (kosmetyka)


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000+GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600+GTX650 | 2xHP 24" + 1xDell 27" | mSATA SSD 32GB + SSD 120GB + SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi+BT

HomeSerwer: Dell 7010 | i3-3240 | 14 GB RAM | 2xWD RED 2TB | Synology DSM 6.1.7 @ Jun's bootloader | Virtual Machine Manager | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | Nie pomagam na PRIV


#9 cshacked87

cshacked87
  • Members
  • 79 postów

Napisano 29 marzec 2018 - 10:42

Dokładnie tak myślałem, chciałem się upewnić. 

Rozumiem, że te rozszerzenia są potrzebne w przypadku kiedy korzysta się z oprogramowania do odczytywania parametrów poszczególnych podzespołów w komputerze.

Co do SATA_Legacy nie ma znaczenia jeśli jest UEFI ?



#10 cshacked87

cshacked87
  • Members
  • 79 postów

Napisano 05 kwiecień 2018 - 11:19

Witam, co może być przyczyną, że nie zawsze zostaje odczytane urządzenie USB podłączone do przedniego panelu ?

Pod Windowsem działa bez problemu, na Siera w kratkę.

W kextach mam dorzucone USBinjectall.







Również z jednym lub większą ilością słów kluczowych: pytanie

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych