Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

AsRock Z370M Pro4 / i5-8600K / RX580 8GB - problem z USB I sleep


  • Zaloguj się, aby dodać odpowiedź
16 odpowiedzi w tym temacie

#1 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 14 wrzesień 2018 - 10:54

Witam,

długo mnie tu nie było, po dłuższej zabawie z iMac (late 2012/i7/32gb ram / 680mx 2GB) wróciłem do tematu hackintosha dla siebie.. iMac zaczął nie wyrabiać z grami na Winzgrozie..

A więc kupiłem taki zestaw:

 

AsRock Z370M Pro4

i5-8600K

32GB DDR4 3000mhz

RX 580 8GB Nitro+

BCM94360CS2

Samsung EVO 970 500GB nvme dla macOS

Adata 512GB nvme dla Windowsa

Fractal Define Mini C TG

 

Ogólnie odpaliłem znaczną większość, komp chodzi bardzo przyjemnie.. ale mam problem z LPC i USB.. o ile USB 3.0 chodzi, wykrywane są wszelakie porty.. tak jeśli podepne pendraka z przodu na obudowie to myszka po paru minutach zaczyna lagować  #-o z tyłu obudowy mam wpięty dysk twardy po USB 3.0 i mysz nie laguje.. wystarczy podpiąć coś extra z przodu budy i się zaczyna.. 

 

Z windowsa z managera urządzeń wynika że mam 200 series chipset,

Załączony plik  usb.PNG   45,49 KB   0 Ilość pobrań

 

więc co zrobiłem

Kexty:

Załączony plik  Screen Shot 2018-09-14 at 10.32.09.png   344,92 KB   0 Ilość pobrań

 

Sekcja ACPI w cloverze

Załączony plik  Screen Shot 2018-09-14 at 10.32.55.png   910,99 KB   0 Ilość pobrań

 

Sekcja device w cloverze

Załączony plik  Screen Shot 2018-09-14 at 10.33.52.png   742,37 KB   0 Ilość pobrań

 

Jak to wygląda w biosie

Załączony plik  IMG_1225.jpg   262,25 KB   0 Ilość pobrań

 

Sekcja USB w macOS

Załączony plik  Screen Shot 2018-09-14 at 10.35.17.png   1,16 MB   0 Ilość pobrań

 

Mogło by się wydawać, że wszystko ok.. ale jak wspomniałem wyżej nie jest :o

 

Zaraz będę się zabierał za stworzenie custom SSDT dla portów USB.. może to coś pomoże

 

 

https://www.tonymacx...ll-kext.211311/

 

Co do LPC:

Wygenerowałem SSDT poprzez ssdtprgen, co poskutkowało

 

Załączony plik  Screen Shot 2018-09-14 at 10.47.57.png   215,6 KB   0 Ilość pobrań

 

natomiast w terminalu:

Załączony plik  Screen Shot 2018-09-14 at 10.49.12.png   256,7 KB   0 Ilość pobrań

 

przy próbie sleep, w konsoli wywala, że obudził się przez XDCI XHC - więc powrót do USB...

 

Próbowałem zaaplikować łatkę do DSDT z forum jak i osobne SSDT z próbą załadowania AppleLPC.. efekt był taki, że przy DSDT system nie wstawał.. a przy SSDT nic się nie działo..

 

Załączam swój katalog clovera, jakby komuś się zachciało zerknąć.. 

 

Komp w pełni działający jest mi potrzebny wręcz na wczoraj.. przynajmniej z tymi USB ;/  jakieś sugestie co może być nie tak?

 

//

I jeszcze jedna zagadka.. macOS startuje z dysku nvme.. myślałem, że będzie odpalał się w mgnieniu oka - a Tu zajmuje mu to nieco dłużej niż staremu imacowi na zwykłym SSD ... 

 

 

--

Custom SSDT dla USB 3.0 widze że fajnie zaskoczyło:

Załączony plik  Screen Shot 2018-09-14 at 11.31.28.png   676,8 KB   0 Ilość pobrań

 

Pozostaje więc kwestia sleep i tego nieco wolnego uruchamiania się hacka.. 

 

Załączone pliki


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#2 wujek_bogdan

wujek_bogdan
  • Members
  • 908 postów

Napisano 14 wrzesień 2018 - 11:56

Zobacz ten wątek: http://hamac.pl/topi...5-usbinjectall/ Jest szansza, że problem powoduje USBInjectAll.


Obecny: 10.13.6, Asus Z87M-PLUS, i7-4790k, 16GB DDR3@1600, MSI GTX 960

Poprzedni:  10.12.6, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#3 reyder

reyder
  • Members
  • 497 postów

Napisano 14 wrzesień 2018 - 12:04

  • Twoje CPU nie potrzebuje generowania stanów procesora przez ssdtprgen. Najlepszym rozwiązaniem jest używanie CPUFriend, dzięki któremu ustawisz wszystko tak jak chcesz.
  • Wywal trim to zyskasz 10sec przy uruchamianiu. (jeśli masz włączony)
  • Masz 2 drivery do HFS, dlaczego ?
  • change HDAS to HDEF. >> dlaczego nie FixHDA ? Do tego to jest.
  • change HECI to IMEI >> od dawna to już jest nie potrzebne, zostało zintegrowane w ...green.kext
  • change GFX0 to IGPU >> to samo
  • PEGP to GFX0 >>> to samo
  • kext-dev-mode jest tylko dla starych OS X
  • useintelhdmi raczej nie powinno być włączone
  • Nie używaj Fakeid Intelgfx
  • Applertc patch jest nie potrzebny
  • Jak zrobiłeś sobie odpowiednie wpisy do portów usb to wyłącz patch kextów.

 

Teraz kexty: Shiki.kext nie są potrzebne. AppleLPC nie jest Ci potrzebny.


  • wujek_bogdan lubi to

Core i5-3750K | Gigabyte GA-Z77-D3H | 3x4GB 1600MHz | Gigabyte Nvidia 1070  :: Radeon 280X Asus | High Sierra 10.13 | Clover

Core i5-8600K | Asrock Extreme 4 | 2x8GB 2500MHz | Gigabyte 580X | High Sierra 10.13 | Clover


#4 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 14 wrzesień 2018 - 12:17

 

  • Twoje CPU nie potrzebuje generowania stanów procesora przez ssdtprgen. Najlepszym rozwiązaniem jest używanie CPUFriend, dzięki któremu ustawisz wszystko tak jak chcesz.
  • Wywal trim to zyskasz 10sec przy uruchamianiu. (jeśli masz włączony)
  • Masz 2 drivery do HFS, dlaczego ?
  • change HDAS to HDEF. >> dlaczego nie FixHDA ? Do tego to jest.
  • change HECI to IMEI >> od dawna to już jest nie potrzebne, zostało zintegrowane w ...green.kext
  • change GFX0 to IGPU >> to samo
  • PEGP to GFX0 >>> to samo
  • kext-dev-mode jest tylko dla starych OS X
  • useintelhdmi raczej nie powinno być włączone
  • Nie używaj Fakeid Intelgfx
  • Applertc patch jest nie potrzebny
  • Jak zrobiłeś sobie odpowiednie wpisy do portów usb to wyłącz patch kextów.

 

Teraz kexty: Shiki.kext nie są potrzebne. AppleLPC nie jest Ci potrzebny.

 

 

 

dzięki za wskazówki.. wywaliłem ssdt z ssdtprgen - muszę poczytać o tym CPUFriend..

 

dlaczego AppleLPC nie jest mi potrzebny? Ostatnim razem kiedy bawiłem się hackintoshami, było to wręcz wymagane aby sleep/wake poprawnie działało(?)

 

TRIM dla dysków nvme jest automatycznie odpalony.. nie mam żadnego patcha do tego.

 

Przy starcie najdłuzej zajmuje to:

Załączony plik  IMG_1227.jpg   781,09 KB   0 Ilość pobrań

 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#5 reyder

reyder
  • Members
  • 497 postów

Napisano 14 wrzesień 2018 - 12:31

APFS has its own built-in "TRIM" garbage collection that is optimized for SSDs. No reason to enable normal TRIM feature on APFS formatted SSDs.

 

 

dlaczego AppleLPC nie jest mi potrzebny? Ostatnim razem kiedy bawiłem się hackintoshami, było to wręcz wymagane aby sleep/wake poprawnie działało(?)

 

Kiedyś, teraz... czasy się zmieniają.

 

 

TRIM dla dysków nvme jest automatycznie odpalony.. nie mam żadnego patcha do tego

 

To już łatwo znaleźć w necie, wystarczy wpisać w google.


Core i5-3750K | Gigabyte GA-Z77-D3H | 3x4GB 1600MHz | Gigabyte Nvidia 1070  :: Radeon 280X Asus | High Sierra 10.13 | Clover

Core i5-8600K | Asrock Extreme 4 | 2x8GB 2500MHz | Gigabyte 580X | High Sierra 10.13 | Clover


#6 wujek_bogdan

wujek_bogdan
  • Members
  • 908 postów

Napisano 14 wrzesień 2018 - 12:32

 

Teraz kexty: Shiki.kext nie są potrzebne. AppleLPC nie jest Ci potrzebny.

 

Pod warunkiem, że @AdamiPL ma najnowsze Lilu. oraz WhateverGreen. Polecam ściągać bezpośrednio z Githuba:

 

https://github.com/a...rGreen/releases

https://github.com/acidanthera/Lilu

 

@AdamiPL 

Jeszcze jedna wskazówka - jako bazę dla konfigu Clovera użyj UnibootX Clover.


Obecny: 10.13.6, Asus Z87M-PLUS, i7-4790k, 16GB DDR3@1600, MSI GTX 960

Poprzedni:  10.12.6, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#7 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 14 wrzesień 2018 - 14:55

znalazłem winowajce wybudzania ze sleep.. jest to mój zaj#bisty dysk zewnętrzny, który ma w sobie hub - Seagate Backup Plus Hub 6TB...  oraz stojak RGB na słuchawki z wew kartą dźwiękową i również HUB'em usb 3.0 teraz jak to ogarnąć ;/ zamulanie USB też już ogarnąłem.. niestety nie mogę wywalić USBInjectAll bo wtedy USB nie działa, a samo SSDT bez tego kextu nie chce śmigać :o 

 

​oprócz tego nawet wybudzanie przez Apple Watch działa.. 

 

 

update..

 

ciekawe.. ale.. sleep zaczął chodzić normalnie, nawet z wpiętym stojakiem na słuchawki.. 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#8 wujek_bogdan

wujek_bogdan
  • Members
  • 908 postów

Napisano 14 wrzesień 2018 - 20:57

 nie mogę wywalić USBInjectAll bo wtedy USB nie działa, 

 

W poście, do którego linkowałem wyżej jest odnośnik do poradnika jak przygotować dedykowany konfig SSDT i pozbyć się USBInjectAll. Wpis jest napisany RehabMana czyli autora USBInjectAll. Nie bawiłem się tym jeszcze ale mam taki zamiar. Niestety, z tego co widzę, na tym forum chyba nikt nie ma doświadczenia w tworzeniu takiego SSDT.


Obecny: 10.13.6, Asus Z87M-PLUS, i7-4790k, 16GB DDR3@1600, MSI GTX 960

Poprzedni:  10.12.6, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#9 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 14 wrzesień 2018 - 21:08

W poście, do którego linkowałem wyżej jest odnośnik do poradnika jak przygotować dedykowany konfig SSDT i pozbyć się USBInjectAll. Wpis jest napisany RehabMana czyli autora USBInjectAll. Nie bawiłem się tym jeszcze ale mam taki zamiar. Niestety, z tego co widzę, na tym forum chyba nikt nie ma doświadczenia w tworzeniu takiego SSDT.

 
ogarnąłem ten SSDT dla USB:
 

/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20180427 (64-bit version)(RM)
 * Copyright (c) 2000 - 2018 Intel Corporation
 * 
 * Disassembling to non-symbolic legacy ASL operators
 *
 * Disassembly of iASLeiKMj0.aml, Fri Sep 14 21:02:02 2018
 *
 * Original Table Header:
 *     Signature        "SSDT"
 *     Length           0x000001D0 (464)
 *     Revision         0x02
 *     Checksum         0x40
 *     OEM ID           "hack"
 *     OEM Table ID     "UIAC-ALL"
 *     OEM Revision     0x00000000 (0)
 *     Compiler ID      "INTL"
 *     Compiler Version 0x20180427 (538444839)
 */
DefinitionBlock ("", "SSDT", 2, "hack", "UIAC-ALL", 0x00000000)
{
    Device (UIAC)
    {
        Name (_HID, "UIA00000")  // _HID: Hardware ID
        Name (RMCF, Package (0x02)
        {
            "8086_a2af", 
            Package (0x04)
            {
                "port-count", 
                Buffer (0x04)
                {
                     0x1A, 0x00, 0x00, 0x00                         
                }, 

                "ports", 
                Package (0x12)
                {
                    "HS01", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0xFF, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x01, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "HS07", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        Zero, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x07, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "HS08", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x08, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "HS09", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x09, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "HS11", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x0B, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "HS12", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x0C, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "SS04", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x14, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "SS05", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x15, 0x00, 0x00, 0x00                         
                        }
                    }, 

                    "SS09", 
                    Package (0x04)
                    {
                        "UsbConnector", 
                        0x03, 
                        "port", 
                        Buffer (0x04)
                        {
                             0x19, 0x00, 0x00, 0x00                         
                        }
                    }
                }
            }
        })
    }
}

 
Dodatkowo jest tam napisane:
 

Once your SSDT is working, you can remove or disable the port limit patch


 

ale, nie ma nic żeby usunąć też ten kext.. a bez niego powyższe SSDT nie wchodzi.. 

KEXT + SSDT = wszystko ok

Brak kexta + SSDT = wraca do poprzedniego stanu czyt. masa portów USB.

Kext + brak SSDT = j/w wraca do oryginału..

 

--

Wracając do tematu.. jednak ten pierdzielony hub z Crosair ST100 powoduje wybudzanie ze sleep... 

 

 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#10 reyder

reyder
  • Members
  • 497 postów

Napisano 14 wrzesień 2018 - 23:30

W poście, do którego linkowałem wyżej jest odnośnik do poradnika jak przygotować dedykowany konfig SSDT i pozbyć się USBInjectAll. Wpis jest napisany RehabMana czyli autora USBInjectAll. Nie bawiłem się tym jeszcze ale mam taki zamiar. Niestety, z tego co widzę, na tym forum chyba nikt nie ma doświadczenia w tworzeniu takiego SSDT.

 

Źle, nie pozbywasz się USBInjectAll, SSDT tylko nadpisuje wartości w Info.plist. Zapewniam Cię, że znajdzie się nawet nie jedna osoba potrafiąca zrobić takie SSDT.  Problem polega na tym, że trzeba dla każdego osobno rozpoznać, które porty chce się mieć włączone i nie można "zrobić to komuś" bo każda płyta może mieć inaczej. Przez USBInjectAll można dodać także USBX aby włączyć możliwość ładowania np ipada przez usb 3.0.


Core i5-3750K | Gigabyte GA-Z77-D3H | 3x4GB 1600MHz | Gigabyte Nvidia 1070  :: Radeon 280X Asus | High Sierra 10.13 | Clover

Core i5-8600K | Asrock Extreme 4 | 2x8GB 2500MHz | Gigabyte 580X | High Sierra 10.13 | Clover


#11 wujek_bogdan

wujek_bogdan
  • Members
  • 908 postów

Napisano 15 wrzesień 2018 - 10:07

 
ogarnąłem ten SSDT dla USB:
 

(...)

 

ale, nie ma nic żeby usunąć też ten kext.. a bez niego powyższe SSDT nie wchodzi.. 

 

 

Wybacz za wprowadzenie w błąd. 

 

Źle, nie pozbywasz się USBInjectAll, SSDT tylko nadpisuje wartości w Info.plist.

 

Rzeczywiście. Linkowany post czytałem ponad miesiąc temu. Musiałem źle zapamiętać. Chodziło u usunięcie patcha z Clovera, a nie usunięcie kexta.

 

Zapewniam Cię, że znajdzie się nawet nie jedna osoba potrafiąca zrobić takie SSDT.  Problem polega na tym, że trzeba dla każdego osobno rozpoznać, które porty chce się mieć włączone i nie można "zrobić to komuś" bo każda płyta może mieć inaczej. Przez USBInjectAll można dodać także USBX aby włączyć możliwość ładowania np ipada przez usb 3.0.

 
Nie wątpię w to, że niejedna osoba tutaj potrafi takie SSDT przygotować :) Miałem na myśli to, że ten temat nie jest u nas na forum zbyt popularny. Myślę, że warto tę kwestię poruszać ponieważ USBInjectAll może być przyczyną (bardzo częstych z resztą) problemów z zarządzaniem energią.
 
Bardzo możliwe, że moja poprzednia płyta Asrock Z87 Pro4, której się pozbyłem ze względu na problemy z usypianiem, była do odpalenia gdybym wtedy wiedział, że mogę pobawić się z SSDT. 

Obecny: 10.13.6, Asus Z87M-PLUS, i7-4790k, 16GB DDR3@1600, MSI GTX 960

Poprzedni:  10.12.6, Asrock Z87 Pro4, i7-4790k, 16GB DDR3@1600, MSI GTX 960, Audigy 2 ZS

Poprzedni: 10.10.4, ASUS P7P55D-E LX, i7-870, 8GB DDR3@1600, Saphire HD5770 1GB


#12 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 19 wrzesień 2018 - 08:52

Udało mi się mega przyśpieszyć start systemu.. za chiny ludowe nie mogłem wyłączyć TRIM'u przez

sudo trimforce disable 

niby na koniec pokazywało że ok.. ale po restarcie dalej był.. tak więc... przez Carbon Copy Cloner przerzuciłem cały system na drugi dysk (talerzowy... od ostatnich paru lat nie korzystałem z tych dysków jako systemowych.. co za różnica xD) przekopiowałem ręcznie EFI przełączyłem się na hacka z HDD sformatowałem dysk nvme na HFS+j następnie prze-formatowałem na APFS i przerzuciłem ponownie kopie systemu + efi.. efekt taki, że komp startuje w 14sekund.. 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#13 Ian

Ian
  • Members
  • 202 postów
  • LocationUSA

Napisano 19 wrzesień 2018 - 13:24

 

  • Wywal trim to zyskasz 10sec przy uruchamianiu. (jeśli masz włączony)

 

 

@reyder

Dlaczego zalecasz wyłączenie TRIM? Przecież jego włączenie przyśpiesza znacznie dyski SSD. Ja, po wyłączeniu TRIM nie zauważyłem przyśpieszenia przy uruchomianiu nawet o 0.1sec


hack1: ASUS H170M-Plus | i7-6700k 4GHz | Radeon RX 560 4GB | Mojave 10.14.x

hack2: Gigabyte H81M-H | i5-G3260 3.3GHz | NVIDIA  GeForce GT 710 1GB | Sierra 10.12.6

MacBook Pro Early 2015 | Mojave 10.14

PC: HP | NVIDIA GeForce GT 740 4GB | E8400 3GHz | Windows 10 1809

 


#14 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 19 wrzesień 2018 - 14:18

pewnie dlatego, że na niektórych dyskach SSD przez niego właśnie trwa dłużej start systemu ;) 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#15 Ian

Ian
  • Members
  • 202 postów
  • LocationUSA

Napisano 19 wrzesień 2018 - 16:25

pewnie dlatego, że na niektórych dyskach SSD przez niego właśnie trwa dłużej start systemu ;)

 

 

W Twoim przypadku chodziło raczej o ładowanie i instalowanie niemal wszystkiego, co tylko możliwe. ;)

Ja poczekałbym na wyjaśnienie tematu przez @reyder...


hack1: ASUS H170M-Plus | i7-6700k 4GHz | Radeon RX 560 4GB | Mojave 10.14.x

hack2: Gigabyte H81M-H | i5-G3260 3.3GHz | NVIDIA  GeForce GT 710 1GB | Sierra 10.12.6

MacBook Pro Early 2015 | Mojave 10.14

PC: HP | NVIDIA GeForce GT 740 4GB | E8400 3GHz | Windows 10 1809

 


#16 reyder

reyder
  • Members
  • 497 postów

Napisano 25 wrzesień 2018 - 00:02

Nie ma żadnego wyjaśnienia, apfs to zamknięty system plików i nie wiadomo jak to działa dopóki ktoś zrobi RE... ostatnio apple wydało dokumentacje, ale to raczej przypomina automatycznie generowany dokument niż coś przydatnego, niestety. Jak nie przeszkadzają dłuższe starty to lepiej zostawić trim włączony.


Core i5-3750K | Gigabyte GA-Z77-D3H | 3x4GB 1600MHz | Gigabyte Nvidia 1070  :: Radeon 280X Asus | High Sierra 10.13 | Clover

Core i5-8600K | Asrock Extreme 4 | 2x8GB 2500MHz | Gigabyte 580X | High Sierra 10.13 | Clover


#17 AdamiPL

AdamiPL
  • Members
  • 698 postów
  • LocationPeterborough / UK

Napisano 25 wrzesień 2018 - 05:31

Po upgrade do macos mojave usb 3.0 padło mimo utworzonego ssdt :/

 

a jednak wróciło samo do życia... 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych