Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Start systemu dysk nvme


  • Zaloguj się, aby dodać odpowiedź
20 odpowiedzi w tym temacie

#1 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 11 październik 2018 - 13:22

Hej,

mam wrażenie, że mój hack nieco długo startuje (MacOS Mojave), zajmuje mu to około 25sekund, sprzęt ze stopki.  Stary iMac z 2012r z SSD startuje chyba szybciej..

 

video:

http://adamipl.net/20181011_130129.mp4

 

 

config załączony.. coś wywala odnośnie USB.. patch poprawnie przygotowany.. w configu załączone injekcje usb - testowałem z nimi i bez nich.. jakby ktoś miał chwilkę zerknąć i ew doradzić coś..

Załączony plik  CLOVER.zip   6,88 MB   7 Ilość pobrań


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#2 314TeR

314TeR

    Administrator

  • Administrators
  • 17890 postów
  • LocationWarszawa

Napisano 11 październik 2018 - 17:46

System zainstalowany na czysto z działającym nvram? Zauważyłem, że jak system jest instalowany bez działającego natywnego zapisu do nvram, to później wstaje taki system dłużej niż zainstalowany z działającym zapisem. Co ciekawe uruchomienie zapisu do nvram wcale nie przyspiesza tak "źle" zainstalowanego systemu.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#3 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 11 październik 2018 - 20:23

Nie musiałem nic kombinowac z nvram. Jedynie osxaptiofix3 w driverach.

AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#4 314TeR

314TeR

    Administrator

  • Administrators
  • 17890 postów
  • LocationWarszawa

Napisano 11 październik 2018 - 21:44

To nie chodzi o kombinowanie a o to czy działa czy nie.

 

osxaptiofix3 też się już nie używa, od dawna jedynym "słusznym" jest AptioMemoryFix.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#5 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 12 październik 2018 - 10:53

ok, nvram śmiga na samym AptioMemoryFix.. a odnośnie wolnego startu systemu:

 

Załączony plik  Screenshot 2018-10-12 at 10.49.09.png   756,43 KB   3 Ilość pobrań

 

trim winowajca.. co ciekawe, nie da rady go wyłączyć przez sudo trimforce disable, terminal wypluwa że ok.. po resecie trim dalej widnieje.. 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#6 Ian

Ian
  • Members
  • 209 postów
  • LocationUSA

Napisano 12 październik 2018 - 12:23

ok, nvram śmiga na samym AptioMemoryFix.. a odnośnie wolnego startu systemu:

 

attachicon.gifScreenshot 2018-10-12 at 10.49.09.png

 

trim winowajca.. co ciekawe, nie da rady go wyłączyć przez sudo trimforce disable, terminal wypluwa że ok.. po resecie trim dalej widnieje.. 

 

 

A masz jakiś dysk SSD w systemie? Czy tylko NVME? Nie wiem, czy TRIM dla NVME da się w ogóle wyłączyć, nie próbowałem tego, bo i po co. Gdy już uda Ci się wyłączyć TRIM - sprawdź sobie benchmark dysku, w którym wyłączyłeś. Zobaczysz, czy warto było.

A co do czasu startu.. Też mam w systemie dysk NVME, a ponadto dwa inne dyski SSD oraz jeden HDD. Czas startu systemu: 22.4s. To nie jest długi czas. MacBookPro staruje w 38s.


hack1: ASUS H170M-Plus | i7-6700k 4GHz | Radeon RX 560 4GB | Mojave 10.14.x

hack2: Gigabyte H81M-H MSI H81M-E33 | i5-G3260 3.3GHz | NVIDIA  GeForce GT 710 1GB | Sierra 10.12.6

MacBook Pro Early 2015 | Mojave 10.14

PC: HP | NVIDIA GeForce GT 740 4GB | E8400 3GHz | Windows 10 1809

 


#7 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 12 październik 2018 - 12:47

mojo stary imac z 2012r z ssd startuje w podobnym czasie co hack xD

mam jeszcze jeden dysk nvme dla windowsa i chyba przez niego tyle trwa odpalanie trimu.. później go odłączę i sprawdzę.. na drugim hacku mam nvme i zwykły ssd i komp startuje sporo szybciej, tu masz porównanie na video po lewo z dwoma dyskami nvme, po prawo 1 x nvme i 1 x ssd sata:

 

http://adamipl.net/20181012_114959.mp4


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#8 oswaldini

oswaldini
  • Moderators
  • 11018 postów
  • LocationBrzeszcze / Kraków

Napisano 12 październik 2018 - 13:31

Nie masz patcha do trimu w config.plist ?


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000+GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600+GTX650 | 2xHP 24" + 1xDell 27" | mSATA SSD 32GB + SSD 120GB + SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi+BT

HomeSerwer: Dell 7010 | i3-3240 | 14 GB RAM | 2xWD RED 2TB | Synology DSM 6.1.7 @ Jun's bootloader | Virtual Machine Manager | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | Nie pomagam na PRIV


#9 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 12 październik 2018 - 13:34

nie, z tego co udało mi się doczytać.. dla dysków nvme w APFS macOS automatycznie włącza trim i nie ma bata, aby go wyłączyć 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#10 314TeR

314TeR

    Administrator

  • Administrators
  • 17890 postów
  • LocationWarszawa

Napisano 14 październik 2018 - 15:00

A ja się tak zapytam, co ma TRIM do apfs. Przecież TRIM to funkcja czyszczenia komórek dysk SSD aby były gotowe do ponownego zapisu. Bez tej funkcji każda komórka przed ponownym zapisaniem musi być wpierw skasowana aby można było ustawić jej nowa wartość. Bez sprawnie działającego TRIM zapis może spaść nawet do 1/3 deklarowanego. Dzięki TRIM system w wolnym czasie „czyści” skasowane komórki aby były gotowe do ponownego zapisu.
  • music lubi to

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#11 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 14 październik 2018 - 21:35

wstawiłem wyżej screenshot z filmiku, gdzie pokazuje że scan trim zajął 10s podczas uruchamiania systemu, więc domniemam że to on powoduje wolniejszy start.. na nvme /apfs nie trzeba popychać trimu, jest z automatu włączony dla nich.. doczytałem na innych forach, że to on powoduje wolny start u wielu osób.


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#12 Marecki_

Marecki_
  • Members
  • 294 postów

Napisano 17 październik 2018 - 20:01

Hej,

mam wrażenie, że mój hack nieco długo startuje (MacOS Mojave), zajmuje mu to około 25sekund, sprzęt ze stopki.  Stary iMac z 2012r z SSD startuje chyba szybciej..

 

video:

http://adamipl.net/20181011_130129.mp4

 

 

config załączony.. coś wywala odnośnie USB.. patch poprawnie przygotowany.. w configu załączone injekcje usb - testowałem z nimi i bez nich.. jakby ktoś miał chwilkę zerknąć i ew doradzić coś..

attachicon.gifCLOVER.zip

 

U mnie jest podobnie, no może start systemu nie trwa 25s ale dosyć długo. Zauważyłem że Yosemite startowało z dysku ssd zdecydowanie szybciej niż Sierra i HighSierra, trwało to dosłownie moment.

Dzisiaj zainstalowałem 10.13 na nowym 970 Pro 512gb w adapterze Asus hyper x4 mini. Dysk osiąga w benchmarkach około 3000 MB/s w odczycie na windowsie więcej, blisko prędkości ze specyfikacji dysku a system uruchamia się tak samo wolno jak na 850Pro na sata.

Trochę się zawiodłem bo liczyłem na zdecydowanie szybszy start. 


Asus Z97-Pro Wi-Fi AC I Core I5 4690K - Noctua U14S I GTX 980Ti Strix OC I G.Skill TridentX DDR3 2400 MHz CL10 (2x4GB) I SSD Samsung 850EVO 120GB & 850 PRO 250GB, HDD 500GB, WD Red 1TB I DVD-RW I Seasonic X-850 KM3 I Obudowa Fractal R5 Black I FP241W 24" I High Sierra I


#13 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 17 październik 2018 - 21:32

U mnie teraz nieco przyspieszylo od wybrania opcji w cloverze do pojawienia sie ekranu logowania jakies 16s.. przerzuciłem system na inny dysk przez carbon copy cloner sformatowalem na HFS+ i raz jeszcze na APFS i z 25s zrobiło się 16-17s..  tez liczyłem na start w granicach 10s.. no ale nie mam co narzekać.. 

 

U mnie takie wartości na EVO970 500 GB

Załączony plik  Screenshot 2018-10-17 at 21.31.57.png   2,59 MB   0 Ilość pobrań

 

 


AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#14 314TeR

314TeR

    Administrator

  • Administrators
  • 17890 postów
  • LocationWarszawa

Napisano 17 październik 2018 - 22:09

@AdamiPL - Twoja obserwacja jest bardzo trafna, za wydłużony start najprawdopodobniej odpowiada jakoś trim i możliwe że jakiś  błąd w nim. A poniżej moje obserwację z 2 szt Macbook Pro. Jeden starszy z zmienionym dyskiem HDD na SSD i nowszy już z dyskiem NVMe.

 

Sprawdziłem na moim Macbooku Pro 15" mid 2012 (nie retina), zainstalowana High Sierra na Samsungu 850 Pro. Nna dyskach firm trzecich, jak np Samsung 850 Pro TRIM NIE jest włączany. Zainstalowałem do testów czysty system - 10.13.6 z aktualizacjami. TRIM NIE działa - start systemu powiedzmy średnio 17 sekund. Pro włączeniu TRIM w konsoli komendą "sudo trimforce enable", start systemu wydłużył się dokładnie o około 10 sekund.

 

Przy starcie w konsoli przed włączeniem TRIM pojawiały się takie komunikaty (3 restarty):

2018-10-14 23:37:47.145257+0200 0x1ba      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 0.377896 s, trims took 0.000000 s
2018-10-14 23:39:15.132051+0200 0x1bb      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 0.376565 s, trims took 0.000000 s
2018-10-14 23:40:46.160379+0200 0x1ba      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 0.376619 s, trims took 0.000000 s

Po włączeniu TRIM (3 restarty):

2018-10-14 23:51:50.057491+0200 0x1c5      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 9.908814 s, trims took 9.506785 s
2018-10-14 23:51:50.063496+0200 0x1c5      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3017: 47633097 blocks free in 96402 extents
2018-10-14 23:51:50.070070+0200 0x1c5      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3025: 47633097 blocks trimmed in 96402 extents (98 us/trim, 10140 trims/s)
2018-10-14 23:51:50.076720+0200 0x1c5      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3028: trim distribution 1:39285 2+:20025 4+:15604 16+:8648 64+:4946 256+:7894
2018-10-15 00:06:15.060510+0200 0x1c4      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 9.909125 s, trims took 9.502640 s
2018-10-15 00:06:15.066567+0200 0x1c4      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3017: 47621945 blocks free in 96026 extents
2018-10-15 00:06:15.073209+0200 0x1c4      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3025: 47621945 blocks trimmed in 96026 extents (98 us/trim, 10105 trims/s)
2018-10-15 00:06:15.079857+0200 0x1c4      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3028: trim distribution 1:39111 2+:19894 4+:15523 16+:8644 64+:4961 256+:7893
2018-10-15 00:22:40.362188+0200 0x1ba      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 9.902719 s, trims took 9.492802 s
2018-10-15 00:22:40.362209+0200 0x1ba      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3017: 47621601 blocks free in 96444 extents
2018-10-15 00:22:40.362216+0200 0x1ba      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3025: 47621601 blocks trimmed in 96444 extents (98 us/trim, 10159 trims/s)
2018-10-15 00:22:40.362223+0200 0x1ba      Default     0x0                  0      0    kernel: (apfs) spaceman_trim_free_blocks:3028: trim distribution 1:39410 2+:19974 4+:15541 16+:8650 64+:4966 256+:7903

Wyłuskując esencję mamy:

kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 0.377896 s, trims took 0.000000 s

kontra:

kernel: (apfs) spaceman_trim_free_blocks:3009: scan took 9.908814 s, trims took 9.506785 s

A teraz ciekawostka. Na drugiej maszynie - Macbook Pro 15" mid 2015 - gdzie jest już dysk NVMe - TRIM jest domyślnie włączony i tam ten sam skan zajmuje jak patrzyłem poniżej 1,5s. Więc to nie tak, że TRIM NIE działa na maczkach, tylko włączenie go na dyskach "nie apple" powoduje znaczne spowolnienie startu.

 

Na półce leży mi stary 2,5" dysk Apple SSD - jest to o tyle dobry materiał do testów, ponieważ na nim domyślne odpala TRIM. Jak znajdę tylko czas to sprawdzę jak na nim wstaje system i czy bez popychania TRIM start systemu też będzie spowolniony.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#15 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 17 październik 2018 - 22:50

U mnie też na evo970 nvme trim domyślnie jest włączony. Nie musiałem włączać przez patch w cloverze czy trimforce. System sam z siebie go włączył. Obecnie trim scan zajmuje 1,5s.

AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#16 314TeR

314TeR

    Administrator

  • Administrators
  • 17890 postów
  • LocationWarszawa

Napisano 17 październik 2018 - 23:28

Subiektywnie wg mnie i tak macOS startuje relatywnie długo. Na tym samym sprzęcie Win10 jednak wstaje szybciej.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#17 AdamiPL

AdamiPL
  • Members
  • 721 postów
  • LocationPeterborough / UK

Napisano 17 październik 2018 - 23:33

Racja... Różnica czasu startu między zwykłym SSD a nvme nie jest tak drastyczna jak np operacje na plikach. W sumie takie marudzenie, ale jeśli taki nvme jest średnio 5 razy szybszy od zwykłego SSD, to mogłoby się wydawać że i sam start systemu taki będzie.. a tu takie rozczarowanie jak @Marecki_ napisał.

AsRock Z370M Pro4 MSI Z370m Mortar / i5-8600K / 32GB DDR4 / RX 580 8GB / BCM94360CS2 / Samsung EVO970 500GB NVMe & Adata 500GB NVMe / U28H750

 iMac 27" Late 2012 / i7 / 32GB DDR3 / GTX 680MX 2GB / 500GB SSD

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#18 Ian

Ian
  • Members
  • 209 postów
  • LocationUSA

Napisano 18 październik 2018 - 02:30

Windows 10 startuje w 2-3 s. więc nie ma nawet co porównywać. Faktem jednak jest, że start Mojave w 22s (u mnie) na Samsungu 970 jest taki sam, jak na Samsungu 850. Ciekawostką jest, o czym wspomniałem wyżej, że na oryginalnym MacBookPro 2015 Mojave startuje w 38s. Taki więc urok macOS'ów. No cóż, ja wyłączam komputery wyłącznie w celu resetu, czyli sporadycznie. 


hack1: ASUS H170M-Plus | i7-6700k 4GHz | Radeon RX 560 4GB | Mojave 10.14.x

hack2: Gigabyte H81M-H MSI H81M-E33 | i5-G3260 3.3GHz | NVIDIA  GeForce GT 710 1GB | Sierra 10.12.6

MacBook Pro Early 2015 | Mojave 10.14

PC: HP | NVIDIA GeForce GT 740 4GB | E8400 3GHz | Windows 10 1809

 


#19 314TeR

314TeR

    Administrator

  • Administrators
  • 17890 postów
  • LocationWarszawa

Napisano 18 październik 2018 - 14:53

No ale czemu jest taka różnica w czasie startu po włączeniu TRIM na 10.13.x i w górę? Wydaje mi się że na 10.12.x nie było to takie widoczne i odczuwalne.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#20 Marecki_

Marecki_
  • Members
  • 294 postów

Napisano 18 październik 2018 - 15:05

10.10 na ssd sata u mnie uruchamiał się trzy razy szybciej niż 10.12 i 10.13. Pamiętam że odrazu po instalacji zwróciłem na to uwagę i szukałem przyczyny ale nie znalazłem.

Asus Z97-Pro Wi-Fi AC I Core I5 4690K - Noctua U14S I GTX 980Ti Strix OC I G.Skill TridentX DDR3 2400 MHz CL10 (2x4GB) I SSD Samsung 850EVO 120GB & 850 PRO 250GB, HDD 500GB, WD Red 1TB I DVD-RW I Seasonic X-850 KM3 I Obudowa Fractal R5 Black I FP241W 24" I High Sierra I





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych