Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Problem z wolnym transferem w sieci LAN - Rozwiązanie


  • Zaloguj się, aby dodać odpowiedź
Brak odpowiedzi do tego tematu

#1 scg32

scg32
  • R.E.D.
  • 430 postów

Napisano 10 lipiec 2010 - 17:26

Witam
Czasami mamy do czynienia z wolnym transferem danych w sieci LAN pomiędzy dwoma komputerami lub dyskiem sieciowym jak w moim przypadku :)
Mam dysk Iomega Screen Play Pro HD to w zasadzie kombajn multimedialny z mini systemem operacyjnym podlączony do routera WiFi i do telewizora poniewaz nie lubie oglądać filmow na monitorze komputera nabyłem takie coś:):)
Transfer po USB odbywa sie bez problemu chodzi o kopiowanie plików z dysku jak i na dysk
natomiast po sieci tylko upload plików na dysk jest w miarę przyzwoity,ściąganie ,słuchanie muzyki np w iTunes czy nawet leżąc w łóżku z lapem i obejrzenie jakiegoś filmu jest w zasadzie nie do realizacji
Dotyczy to tylko systemu Mac OSX , pod Windows nie napotkałem żadnych problemów.
Cała komunikacja oparta jest o protokół SMB czyli popularną Sambe


Rozwiązanie okazało się bardzo proste :):)
wystarczy w terminalu wydać komendę ,ustalając odpowiednią zmienna i mamy z głowy

sudo sysctl -w net.inet.tcp.delayed_ack=0

i to w zasadzie wszystko możemy pokusić się o dopisanie polecenia do skryptów startowych albo stworzyć własny aby nie wpisywać za każdym razem

Pozdrawiam

ASUS P8P67 16Gb RAM i5 HD7750 2GB  250 SAMSUNG SSD system Yosemite 10.10.5 start przez Clover

DELL Inspiron 1720 Yosemite 10.10.5 Upgrade Procesora i RAM dysk SSD start Chameleon 

iMac 17 2006 Ubuntu 12.04 Server - robi za serwer :)

PowerBook G4 PPC Leopard 10.5.8 - do sprzedania  





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych