Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Naprawa problemu synchronizacji czasu Mac Os X/Windows7


  • Zaloguj się, aby dodać odpowiedź
32 odpowiedzi w tym temacie

#1 arielvanp

arielvanp
  • Donator
  • 1160 postów
  • LocationŻory PL / Cork IE

Napisano 12 sierpień 2010 - 20:52

Naprawa problemu synchronizacji czasu Mac Os X/Windows7/Vista

20109_tarcza_zegar.jpg


Użytkownicy którzy na bieżąco korzystają na komputerze z dwóch systemów czyli Mac Os X i Windowsa 7 bądź Visty zauważyli pewnie problem z dziwna synchronizacją czasu w komputerze. Ot typowy przykład – pracujemy na Snow Leopardzie czas mamy ustawiony dobrze, potrzebujemy na chwile Windowsa, robimy szybki restart komputera, odpalamy Windows i… nagle okazuje się że zegar systemowy jest przesunięty o np. dwie godziny do przodu (albo do tyłu – już nie pamiętam). Przyczyna jest prozaiczna, otóż Mac Os zapisuje w biosie czas UTC, Windows czas lokalny. Tak więc jakby tego nie ustawić to zawsze po restarcie się rozjedzie. Jest na to bardzo dobre rozwiązanie. Robimy mała zmianę w rejestrze Windowsa i problem mamy z głowy.

1. Klikamy w Windowsie w przycisk Start -> Uruchom -> Regedit

2. Szukamy teraz gałęzi HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\TimeZoneInformation

3. W prawej części okna regedit klikamy prawym przyciskiem myszy i wybieramy NOWY -> Wartość DWORD (32bitowa)

4. Nadajemy tej wartości nazwę „RealTimeIsUniversal” (oczywiście bez cudzysłowów), klikamy Enter

5. Teraz dwa razy klikamy lewym przyciskiem myszki na tej nowa utworzonej wartości i zmieniamy zawartość pola „Dane wartości” z 0 na 1. Klikamy OK i zamykamy Regedita

6. Teraz restartujemy komputer i ładujemy Mac Os X’a. Ustawiamy tam prawidłowy czas i to wszystko. Od teraz zarówno Mac Os jak i Windows będą miały właściwą godzinę i nie będą się rozjeżdżać.


Źródło - szkielkoioko.xsk.pl


EDIT 314TeR
W złączniku przygotowany przeze mnie gotowy wpis do rejestru, wystarczy "rozklikać", zrestartować system i ustawić prawidłowo czas.

Załączone pliki


  • Dark Raven lubi to

haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.11 & Clover

HaMAC C2D | MSI P45-8D | Core 2 Duo E7600 3.06GHz  | 4GB DDR2 677mhz | Seagate 500GB | Nvidia Quadro NVS295 256MB | ALC 888 | Realtek 8111C | AirPort Extreme BCM4321 | Mac OS X 10.6.8 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.11

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#2 oswaldini

oswaldini
  • Moderators
  • 10495 postów
  • LocationBrzeszcze / Kraków

Napisano 12 sierpień 2010 - 20:59

Juz jest o tym topic, jak sobie ktos zyczy moge zamiescic zrobione przeze mnie pliki reg ktore wystarczy odpalić, nie trzeba bawic sie w reczne edytowanie.

Zrobilem regi do wlaczenia AHCI po zainstalowaniu juz windowsa (Vista, Win 7) oraz reg do zmiany czasu.

PS. Dobrze w sumie ze zrobiles krotki tutek, obecnie jest tylko podpieta rozmowa z rozwiazaniem w srodku

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 16 GB RAM | HD4600 | 250 GB macOS + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#3 energy910

energy910
  • Members
  • 29 postów

Napisano 06 sierpień 2011 - 21:55

Zrobiłem tak jak piszesz ale to nie pomaga. Jakieś inne rozwiązania ?
 Lion 10.7.3 iAtkos7 & W7 Ultimate x64|Asus P5Q-PRO |Intel Core Duo 2 E8400 |8GB Ram (2x4) DDR2| Gainward 9600GT 512mb|

#4 314TeR

314TeR

    Administrator

  • Administrators
  • 16044 postów
  • LocationWarszawa

Napisano 07 sierpień 2011 - 11:36

Zrobiłem tak jak piszesz ale to nie pomaga. Jakieś inne rozwiązania ?

Jedno - przeczytaj jeszcze raz i zrób dokładnie jak jest napisane a zacznie działać.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#5 energy910

energy910
  • Members
  • 29 postów

Napisano 09 sierpień 2011 - 12:43

http://www.fotosik.pl/pokaz_obrazek/8b00e8b6d30652c4.html

Robiłem to pare razy bo myślałem że może coś źle robie ale tak nie jest (daje s creena powyżej)
I nie działa.
Nie wiem, może coś źle na macu robie ? Czy w tym wypadku jeśli mam automatyczną synchronizacje wystarczy odpalić snowa i tyle czy ustawić tam ręcznie czas ? dodam że próbowałem tego i tego i nic.

[ Komentarz dodany przez: 314TeR: 2011-08-09, 18:20 ]
Proszę o zapoznanie się z regulaminem
 Lion 10.7.3 iAtkos7 & W7 Ultimate x64|Asus P5Q-PRO |Intel Core Duo 2 E8400 |8GB Ram (2x4) DDR2| Gainward 9600GT 512mb|

#6 314TeR

314TeR

    Administrator

  • Administrators
  • 16044 postów
  • LocationWarszawa

Napisano 09 sierpień 2011 - 17:22

Nic nie widać na tych screenach.

Powtórzę jeszcze raz, w/w metoda działa, jest sprawdzona osobiście przeze mnie na paru komputerach i jeśli Ci coś nie działa to nie z winy w/w poradnika a widać coś przeoczyłeś lub są inne powody o których pojęcia nie mamy.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#7 energy910

energy910
  • Members
  • 29 postów

Napisano 10 sierpień 2011 - 16:29

Linki są niezgodne z regulaminem (za co dałes mi ostrzeżenie) wieć dokładniejszego już nie dam.

Powtórze że mi ona nie działa. W Windowsie mam zrobienie wszystko poprawnie tak jak pisze więc tutaj anpewno nie mam problemu. Niech mi ktoś powie co trzeba zrobić na macu z ustawieniem tej godziny ? Bo osobiście zmieniam tam automatczną synchronizacje na ręczną i tyle. Robie coś źle ?

P.S po instalacji maca nie robiłem tylko tego DSTT bo z tego co czytałem jest to wogóle mi nie potrzebne. Może to być winą problemu ?
 Lion 10.7.3 iAtkos7 & W7 Ultimate x64|Asus P5Q-PRO |Intel Core Duo 2 E8400 |8GB Ram (2x4) DDR2| Gainward 9600GT 512mb|

#8 janek202

janek202
  • Moderators
  • 3008 postów

Napisano 10 sierpień 2011 - 16:33

Masz ustawione odpowiednie strefy czasowe w obu systemach?

Sierra|Gryphon Z87|i5-4670K|16GB RAM|GTX 1070
Sierra|MacBookPro12,1
Kext Wizard|Chameleon Wizard|HDA Wizard


#9 pc-qwerty

pc-qwerty
  • Members
  • 1168 postów

Napisano 10 sierpień 2011 - 16:46

Linki są niezgodne z regulaminem (za co dałes mi ostrzeżenie) wieć dokładniejszego już nie dam.

Niezgodne z regulaminem są tylko linki prowadzące poza forum nie ujęte w tagach code.

P.S po instalacji maca nie robiłem tylko tego DSTT bo z tego co czytałem jest to wogóle mi nie potrzebne. Może to być winą problemu ?

Gdzie to wyczytałeś? :shock:

U mnie również ta metoda działa bez problemów. Zobacz jeszcze czy Windows synchronizuje czas przez internet - jest to w ustawieniach daty i godziny na którejś z zakładek.

#10 energy910

energy910
  • Members
  • 29 postów

Napisano 17 sierpień 2011 - 00:02

Przejrzałem temat z tym co on oferuje i stwierdziłem że jest mi to nie potrzebne. Obecnie mam skonfigurowanego maca do mojej pracy i jest ok, więc nie narzekam.
Windows nie synchronizuje automatycznie bo wyłączyłem to podczas testów ale z odpaloną opcją też nie działa.

Janek202, możesz mi przyblizyć jakie te strefy mają być ? Na Windowsie mam strefe UTC +1 (Opcja z Warszawą) A na Leopardzie jedyną polską szczecińską ale to raczej jest prawidłowo co nie ?

[ Dodano: 2011-12-03, 22:01 ]
up, ponawiam bo problem nadal jest. A wykonuje wszystko idealnie dobrze jak w poradniku.
 Lion 10.7.3 iAtkos7 & W7 Ultimate x64|Asus P5Q-PRO |Intel Core Duo 2 E8400 |8GB Ram (2x4) DDR2| Gainward 9600GT 512mb|

#11 max00r

max00r
  • Members
  • 19 postów

Napisano 24 luty 2012 - 19:20

@oswaldini, załącz REGi. Interesuje mnie szczególnie ten z AHCI. Wywala mi się windows, wcześniej instalowany bez ;) Ale czas równie ważny :)

OS X 10.9.2 RETAIL | GIGABYTE EX58-UD5 (ICH10, AZL889A) | i7 @ 920 2.8 MHz | Geforce GTX 760 2048 MB ZOTAC AMP! | 24 GB RAM |
max00R


#12 oswaldini

oswaldini
  • Moderators
  • 10495 postów
  • LocationBrzeszcze / Kraków

Napisano 26 luty 2012 - 20:31

A wybaczcie, całkiem zapomniałem o tym. W załaczniku pliki rejestru. AHCI jest dla Windowsa Vista i 7.

Załączone pliki


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 16 GB RAM | HD4600 | 250 GB macOS + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#13 Siepietu

Siepietu
  • Donator
  • 133 postów

Napisano 13 marzec 2012 - 00:12

Heh. Ale banał :) Dzięki oswaldini, za pliki.
 MacBook Pro 9.2
 Samsung r 610 Intel Core 2 Duo P7350 2GHz SSE3 ICH9
| Mac OS X 10.6.8 Retail 32-bit |1 TB Seagate| 3Gb RAM DDR 2 800 MHz |
NVidia GeForce 9200M GS 512 Mb | PCIe ALC262 |BCM 4311|Magic Mouse| Dołączona grafika Piszę poprawnie po polsku!

#14 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 27 marzec 2012 - 12:59

Warto dodać, że w przypadku Windowsa XP opisana tu metoda nie działa - po wybudzeniu pokazuje czas UTC. Trzeba zastosować wtedy alternatywne rozwiązanie, np. to:
http://osx86.co/f85/solution-for-time-clock-issue-between-windows-vista-t945/post11461.html

Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#15 314TeR

314TeR

    Administrator

  • Administrators
  • 16044 postów
  • LocationWarszawa

Napisano 27 marzec 2012 - 14:33

MKjanek32, działa.. Tylko trzeba zrobić między restart do OS X, aby zegar sprzętowy prawidłowo ustawił się na UTC.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#16 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 27 marzec 2012 - 15:01

Chyba źle się zrozumieliśmy. Chodzi mi o to, że metoda niby działa, ale po uśpieniu i wybudzeniu ze sleepa XP zaczyna pokazywać czas w UTC dopóki się go nie zrestartuje.

[ Dodano: 2012-03-28, 17:35 ]
Musiałem jednak poszukać innego rozwiązania, bo to które podlinkowałem powodowało opóźnianie zegara. Ostatecznie wykorzystałem wyciągnięty z którejś wersji Boot Campa plik AppleTime.exe. I teraz działa jak trzeba.

Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#17 314TeR

314TeR

    Administrator

  • Administrators
  • 16044 postów
  • LocationWarszawa

Napisano 13 kwiecień 2013 - 15:10

W pierwszym poście załączyłem gotowy wpis do rejestru, wystarczy tylko rozklikać.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#18 HardcoreQ

HardcoreQ
  • Members
  • 233 postów
  • LocationRadzionków

Napisano 17 lipiec 2013 - 00:18

Ja mam ten problem w Windows 8 i metoda w pierwszym poście nie działa. W OS X czas jest ustawiony dobrze, ale w Windowsie się zmienia 2h w przód ;P

Acer FMP55 | i3 530 (2,93GHz) | 3GB 1333MHz | Gigabyte R9 270X | FSP Group 500W | Samsung 500GB | OS X Yosemite 10.10.1| & Windows 8.1 PRO|


#19 314TeR

314TeR

    Administrator

  • Administrators
  • 16044 postów
  • LocationWarszawa

Napisano 18 lipiec 2013 - 08:44

Nie wydaje mi się aby w Win8 namieszali tak. aby nie było tych kluczy w rejestrach... wprowadziłeś aby na pewno poprawnie tę poprawkę? Zrobiłeś pełne dwa restarty kompa po win?

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#20 Bart Dawes

Bart Dawes
  • Members
  • 25 postów

Napisano 25 kwiecień 2014 - 10:38

Wiem czemu niektórym nie działa opisany sposób, sam miałem z tym problem, robiłem jak w opisie i nic. Rozwiązaniem jest uruchomienie rejestru w trybie administratora (napiszcie o tym w 1 poście).

Start -> Uruchom -> wpisujemy "Regedit" potem PPM i "uruchom jako administrator" dalej lecimy według tutka, robimy wpis w rejestrze następnie uruchom ponownie i odpalamy OS X, ustawiamy prawidłowy czas znowu uruchom ponownie i do windows`a. Czas jest taki sam w obu systemach.


10.9.5|Core i5 3570K|GA-Z77X-D3H|16GB RAM DDR3|HD4000|Samsung 840 PRO 128GB|Corsair TX 650W| A1048





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych