Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Legacy kext dla kart WiF Atheros


  • Zaloguj się, aby dodać odpowiedź
32 odpowiedzi w tym temacie

#21 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 10 październik 2011 - 18:22

A dla AR5007 nie ma i nie będzie nadzieji żeby to jakoś normalnie działało???

Jeżeli karta jest wewnętrzna a nie na USB, to powinno się dać. Odczytaj vendor i device id twoje karty i dodaj te wartości do sekcji Standard Atheros SnowLion w Info.plist. Jeżeli zadziała, to daj znać.

Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#22 balawejder01

balawejder01
  • Members
  • 305 postów

Napisano 10 październik 2011 - 18:24

Zapomnij ! Legacy jest tylko dla kart na PCI/PCIe. Żadna USB (o ile się nie mylę) nie zaskoczy choćby się woda paliła.

ale ono jest na mini pcie

Lion 10.7.5: Acer Emachines E510: C2D T6600, ICH8-M, 3GB DDR2, X3100, SAMSUNG 250 SATA, ALC268, DVD ATA, LAN BCM5906M, WLAN BCM4311,
Lion 10.7.5: Acer Aspire 5738G: C2D P8600, ICH9-M, 4GB DDR2, HD4570, WDS 500 SATA, ALC888s, DVD SATA, LAN BCM5784, WLAN AR928X,

Lion 10.7.5: GA-945P-S3, C2D E4300, ICH7, 2,5GB DDR2, GF 7900GS, WDC 250 SATA, ALC883, DVD ATA, LAN RTL8111/8168B


#23 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 10 październik 2011 - 18:26

To zrób to, o czym napisałem wyżej. oswaldini raczej pisał o przypadku Sipera.

Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#24 janek202

janek202
  • Moderators
  • 3008 postów

Napisano 10 październik 2011 - 18:27

Ja miałem AR5007EG i nic jej nie ruszało. Jej DevID nawet było w systemowych kextach.

Sierra|Gryphon Z87|i5-4670K|16GB RAM|GTX 1070
Sierra|MacBookPro12,1
Kext Wizard|Chameleon Wizard|HDA Wizard


#25 balawejder01

balawejder01
  • Members
  • 305 postów

Napisano 10 październik 2011 - 18:31

A dla AR5007 nie ma i nie będzie nadzieji żeby to jakoś normalnie działało???

Jeżeli karta jest wewnętrzna a nie na USB, to powinno się dać. Odczytaj vendor i device id twoje karty i dodaj te wartości do sekcji Standard Atheros SnowLion w Info.plist. Jeżeli zadziała, to daj znać.


Własnie miałem pisać że narazie nie mam jak przez najblizsze około 3tyg. Jak wroce do POL to napewno spróbuję i dam znać:)
A jak się nie da to peszek

Lion 10.7.5: Acer Emachines E510: C2D T6600, ICH8-M, 3GB DDR2, X3100, SAMSUNG 250 SATA, ALC268, DVD ATA, LAN BCM5906M, WLAN BCM4311,
Lion 10.7.5: Acer Aspire 5738G: C2D P8600, ICH9-M, 4GB DDR2, HD4570, WDS 500 SATA, ALC888s, DVD SATA, LAN BCM5784, WLAN AR928X,

Lion 10.7.5: GA-945P-S3, C2D E4300, ICH7, 2,5GB DDR2, GF 7900GS, WDC 250 SATA, ALC883, DVD ATA, LAN RTL8111/8168B


#26 314TeR

314TeR

    Administrator

  • Administrators
  • 16109 postów
  • LocationWarszawa

Napisano 10 październik 2011 - 20:22

Z AR5007EG jest problem w tym, że kexty z Mac OS X obsługują starszy HAL (firmware) w karcie niż jest w kartach z PC i przez to karta nie jest poprawnie inicjalizowana. Dawno nie sprawdzałem tego tematu, warto by sprawdzić czy np Lion nie ma już poprawionych kextów do atherosa.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#27 MietasSR

MietasSR
  • Members
  • 1245 postów

Napisano 10 październik 2011 - 20:26

Próbowałem, niestety - karta jak nie działała tak nie działa. Jedną nawet przebrandowałem na Apple - niestety nic.
Ciekawe czy dałoby się przeflashować firmware.

Asus P8Z77-V LX | Celeron G550 2.6GHz | 4GB DDR3 | 320GB HDD | GeForce G210 1GB | SB Live! 5.1 | OS X Yosemite DP1/Win8.1 Eval

FlagaPL.gifPiszę poprawnie po polsku!


#28 oswaldini

oswaldini
  • Moderators
  • 10529 postów
  • LocationBrzeszcze / Kraków

Napisano 22 grudzień 2011 - 22:15

Bardzo proszę o pomoc i rozbudowanie kexta do wszelkich możliwych DZIAŁAJĄCYCH/POTWIERDZONYCH DevID kart WiFi - moderacja wie dlaczego, reszta dowie się później.

Na bieżąco będę podawał kolejne karty.

Tutaj znalazłem ładny zbiór DevID:
http://www.osx86.net/downloads.php?do=file&id=763
pci106b,0086 
pci106b,1c
pci168c,1014
pci168c,13
pci168c,14
pci168c,15
pci168c,16
pci168c,17
pci168c,18
pci168c,19
pci168c,1a
pci168c,1b
pci168c,1c
pci168c,1d
pci168c,23
pci168c,24
pci168c,2a
pci168c,52
pci168c,55
pci168c,57
pci168c,58
pci168c,58a
pci168c,86
pci168c,87
pci168c,ff1c
pci168c,ff1d

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 16 GB RAM | HD4600 | 250 GB macOS + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#29 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 23 styczeń 2013 - 15:46

Wrzuciłem te ID które podałeś do kexta. U mnie działa jak powinno, specjalnie szukałem tego częściowo walniętego dysku z OS X'em.
No to wygląda na to, że kext dostał już ID większości kart działających na AirPortAtheros21, teraz trzeba by poszukać kart działających na nowszych kextach (AirPortAtheros9388/40), z tego co wiem to przede wszystkim seria 9xxx.

Paczkę wrzuciłem do pierwszego posta.
23.12.2011

Edit 23.01.2013:
Mam pytanie o ogólną zasadę działania legacy kextów. Czy dane z klucza w legacy (w tym przypadku IONameMatch) zastępują te podane w kluczu w prawdziwym kexcie, czy są do nich dodawane?

Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#30 314TeR

314TeR

    Administrator

  • Administrators
  • 16109 postów
  • LocationWarszawa

Napisano 23 styczeń 2013 - 22:50

Zastępują jak pamiętam.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#31 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 23 styczeń 2013 - 23:58

Dzięki za informację. Czyli będzie kolejny powód do aktualizacji kexta.

Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#32 floward

floward
  • Members
  • 1 postów
  • Locationelektronik producent

Napisano 05 luty 2013 - 16:34

Witam. Mam kartę Wl Wn 722N 9271 cf3 Bcd: 108 z Chipsetem Atheros na Usb.
OSX 10.8 -Chameleon 2.2 svn r2171 na Mainboard: Asrock G41M-S3
Proc: Q6600 Core 2 Quad/ Fsb: 1333 Mhz / 4Gb Ram
Próbowałem ze sterownikami do kart Asusa na chipsetach AR, Patche DSDT,
dumpowałem FW/Hexametry z karty i próbowałem dodać do bootloadera/kextów.

Jedyne nieinwazyjne rozwiązanie to uruchomienie Linuxa - Polecam Ubuntu, Fedore
w trybie wirtualnym i korzystanie rownoległe z OSX/Linux. :/
Przy uruchomieniu wirtualnego Windows'a (FMW Fusion) Internet w ogóle nie zaskakuje
w OSX (ustawienie Native lub udostępnianie łącza do OSX z Windows)
nawet przez Boot Camp nie przynosi efektu - Karta się instaluje natomiast internetu brak.
Jak by OSX blokował zasilanie dla tego urządzenia -karty Usb Wifi.
Może stworzenie polaczenia VPN z wirtual linuxem, albo jakiś pallalel załatwił by sprawę,
ew. FPGA - chwilowe odwracalne przeprogramowanie,
tych metod jeszcze jednak nie sprawdziłem.

Jest Firmware do linuxa Ath9 htc, ale wyczytałem, że niektóre z tych kart nie działają
po ingerencji w Firmware / Flashowaniu. Karty mi szkoda zepsuć a mam internet tylko przez Wifi,
bez stałego łącza, więc nie zaryzykuję jej uszkodzenia .. wtedy tylko zakup drugiej - już ew. na PCIE.


Jest na YT film jak koleś bodajże włoch z poziomu linuxa wrzuca kilka komend z termanala,
uruchamia Ath wl wn 722n USB, nie niszcząc oprogramowania instaluje ją z wirtualnego Linuxa
na OSXie w wyniku czego karta jest wykrywana w OSX i zaczyna w pełni działać na samym OSX.

Wypróbowałem wiele metod, chociaż jeszcze nie wszystkie, szkoda że athlegacykext
nie działa dla Wifi USB, ale w sumie dobra motywacja, żeby stworzyć jakiś sposób
na łatwe uruchomienie. Jak na razie znalazłem tylko różne skomplikowane metody,
wymagające znajomości podstaw programowania, lub struktury programowej sieci OSX.

PS. Jeśli mi się uda napisze, jeśli komuś się uda proszę o info, muszę korzystać z windows
dla sprawnego korzystania z internetu. Na VM muli i problem z zapisywaniem danych do partycji OSX,
a nie ma sensu dla mnie szukać i instalować setki usprawnień do Virtuala, żeby omijał uprawnienia,
wysyłał sygnał internetowy itd. - To tylko tymczasowe rozwiązanie awaryjne.
Dla odważnego / zainteresowanego wyślę Firmware Atheros9 Htc, solucje i zapisy stron z metodami
uruchamiania tej karty + programy do flashowania, kexty, filmik włocha z YT. Pozdrawiam.

#33 roratoga

roratoga
  • Donator
  • 203 postów

Napisano 09 kwiecień 2017 - 20:52

witam

bedzie jakas aktualizacja tego kexta ?


SAMSUNG NP350V5C-S0FPL / Intel® Core™ i5-3210M CPU @ 2.50GHz, 2494 MHz / Intel® 7 Series Chipset Family SATA AHCI Controller / Intel HD Graphics 4000 / AMD Radeon HD 7600M / Realtek ALC269 / Realtek PCIe GBE Family Controler / Atheros AR5B195





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych