Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

Intel HD3000 - artefakty


  • Zaloguj się, aby dodać odpowiedź
60 odpowiedzi w tym temacie

#1 Zeke

Zeke
  • Members
  • 38 postów

Napisano 29 lipiec 2012 - 21:23

Witam, powoli tracę cierpliwość co do wyżej wymienionej grafiki, czasami pojawiają mi się artefakty. Wczoraj się ucieszyłem, gdyż poprawnie udało mi się uruchomić Power Management (24 stany) i ilość artefaktów się zmniejszyła, lecz nadal występują, praktycznie zawsze w podglądzie wideo w iMovie. Kończą mi się pomysły co można z tym zrobić i chciałem się poradzić Was drodzy forumowicze. Dodam, że mam 10.8 Mountain Lion'a GM. W kextach od grafiki nic nie było ruszane. Proszę o pomoc.

#2 czyzo

czyzo
  • Members
  • 188 postów
  • LocationWarszawa

Napisano 30 lipiec 2012 - 07:27

Te artefakty będą chyba naszą zmorą, na tą chwile nikt nie zdziałał raczej cudu z nimi.

#3 tomasz

tomasz
  • Members
  • 185 postów

Napisano 30 lipiec 2012 - 07:31

A wyłączyłeś dedykowaną kartę w DSDT ?
Po tej czynności artefakty są znikome.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#4 Zeke

Zeke
  • Members
  • 38 postów

Napisano 30 lipiec 2012 - 09:47

Tak wyłączyłem, dodałem też wpis do GFX0. Może dopieszczenie DSDT coś da? Chodzi mi o np. zamianę GFX0 na IGPU itd.

#5 karid

karid
  • Members
  • 73 postów

Napisano 31 lipiec 2012 - 18:20

A wyłączyłeś dedykowaną kartę w DSDT ?
Po tej czynności artefakty są znikome.


Nie robi to praktycznie zadnej roznicy.
Mountain Lion 10.8.2 + Windows 8 | Asus X53SV | i7-2630QM | HD3000 | 4GB DDR3 1333MHz | HM65 | 500GB 5400RPM | ALC269 | AR9002WB

#6 Astarael

Astarael
  • R.E.D.
  • 1672 postów

Napisano 31 lipiec 2012 - 18:40

RevoGirl opisała modyfikacje pomocne przy HD 3000, w tym zmniejszające problem artefaktów, m.in. edycję ilości VRAM (MacBook Pro 8,1 ma przypisane chyba 512, czyli znacznie więcej niż hacki), ale ta wiedza przepadła...
Snow Leopard 10.6.8 Retail on Lenovo ThinkPad R61i 8932-FDG - This one is resting in peace now.
Lenovo ThinkPad Edge E420s 4401-6YG | Core i5-2430M | HM65 | Intel HD 3000 | Conexant CX20590 | Realtek RTL8111/8168B | Intel Centrino 1000
MacBook Pro 13" Mid 2012 Intel Core i5 | HD 4000 | Wszystko działa OTB!
Dołączona grafika Piszę poprawnie po polsku!

#7 Zeke

Zeke
  • Members
  • 38 postów

Napisano 31 lipiec 2012 - 20:06

Z tego co wiem przy 4GB RAM'u HD3000 ma pamięci 384MB (tyle mam) zaś przy 8GB 512MB. Może dołożenie RAM'u coś zmieni.

#8 tomasz

tomasz
  • Members
  • 185 postów

Napisano 31 lipiec 2012 - 20:32

Ja mam 8gb. Ale Artefakty występują. W późniejszych wersjach Liona całkowicie umnie zniknęły.
Niestety po update do ML znów powróciły.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#9 karid

karid
  • Members
  • 73 postów

Napisano 31 lipiec 2012 - 20:41

Z tego co wiem przy 4GB RAM'u HD3000 ma pamięci 384MB (tyle mam) zaś przy 8GB 512MB. Może dołożenie RAM'u coś zmieni.


@AdamiPL ma 8GB ramów. Z tego co się orientuję, to hangów nie ma wcale, a artefaktów baaaaaaardzo mało i są sporadyczne. Ale on to od Liona uzywa tylko OS X.
Mountain Lion 10.8.2 + Windows 8 | Asus X53SV | i7-2630QM | HD3000 | 4GB DDR3 1333MHz | HM65 | 500GB 5400RPM | ALC269 | AR9002WB

#10 Astarael

Astarael
  • R.E.D.
  • 1672 postów

Napisano 31 lipiec 2012 - 20:42

Ja mam 8gb. Ale Artefakty występują. W późniejszych wersjach Liona całkowicie umnie zniknęły.

U mnie (4GB) w Lionie (10.7.2+update grafiki lub 10.7.3) zniknęły, ML nie testowałem.
Jaką ilość VRAM pokazuje Ci About this mac?
Snow Leopard 10.6.8 Retail on Lenovo ThinkPad R61i 8932-FDG - This one is resting in peace now.
Lenovo ThinkPad Edge E420s 4401-6YG | Core i5-2430M | HM65 | Intel HD 3000 | Conexant CX20590 | Realtek RTL8111/8168B | Intel Centrino 1000
MacBook Pro 13" Mid 2012 Intel Core i5 | HD 4000 | Wszystko działa OTB!
Dołączona grafika Piszę poprawnie po polsku!

#11 karid

karid
  • Members
  • 73 postów

Napisano 31 lipiec 2012 - 20:45

Ja mam 8gb. Ale Artefakty występują. W późniejszych wersjach Liona całkowicie umnie zniknęły.

U mnie (4GB) w Lionie (10.7.2+update grafiki lub 10.7.3) zniknęły, ML nie testowałem.
Jaką ilość VRAM pokazuje Ci About this mac?


4GB ramu i 384MB VRAM.

Siedziałem dość długo na Lionie 10.7.3 z najnowszym FakeSMC - masa artefaktów i bardzo częste hangi systemu. Teraz na ML hanga póki co nie miałem a artefakty to tylko drobne linie.

PS. Chociaż filmów we flashu (YT) nie ma opcji oglądać. Wszędzie linie.
Mountain Lion 10.8.2 + Windows 8 | Asus X53SV | i7-2630QM | HD3000 | 4GB DDR3 1333MHz | HM65 | 500GB 5400RPM | ALC269 | AR9002WB

#12 tomasz

tomasz
  • Members
  • 185 postów

Napisano 31 lipiec 2012 - 20:54

Jaką ilość VRAM pokazuje Ci About this mac?

VRAM 512MB

[ Dodano: 2012-07-31, 21:57 ]
Ostatnio podłączyłem Monitor do Laptopa. I artefakty znikneły. Możliwe że to był tylko przypadek. Bo po ponownym uruchomieniu wróciły.
Retail El Capitan 10.11  | Maximus VI Gene |  Magic Mouse iOS 9  | iPhone 6 |

#13 Ravven

Ravven
  • Members
  • 140 postów
  • LocationWarszawa

Napisano 01 sierpień 2012 - 12:33

Mam taką teorię, że artefakty występują w wyniku hangów w main graphics engine (choć nie w wyniku każdego hanga) - można to sprawdzić w konsoli. U mnie pojawiają się wyłącznie, kiedy poprzedzi je freez graficzny systemu i pojawia się informacja o tym w konsoli. Podobnie jest u wielu innych osób.

Hangów i artefaktów można się pozbyć przez podłączenie zewnętrznego urządzenia do laptopa, np. poprzez HDMI, DVI, czy DP. Takie podłączenie zewnętrznego wyświetlacza powoduje prawidłowe działanie wyświetlacza laptopowego (LVDS) - tzn. brak jest artefaktów i hangów. Nie potrafię wytłumaczyć, dlaczego tak się dzieje.

Ostatnio na insanelymac pojawił się post, który sugeruje, że hangi i artefakty są winą matrycy wyświetlacza i że wymiana na inny całkowicie je usuwa. Sam tego nie sprawdzałem, ale forumowicz, który tak twierdził wymienił swoją matrycę i problem u niego zniknął.

Mac OS X Yosemite 10.10.5 - ASUS X73SV-TY424V || i7-2670QM | HM65 | 2x4GB 1333MHz | Intel HD Graphics 3000 + GeForce GT 540M (Optimus) | ALC269 | AR8151 | AR9002WB-1NG (AR5B195 combo / AR9285 + AR3011) |
Mac OS X SL 10.6.8 - COMPAL FL90 || c2d-T71000 | ICH8M | 2x2GB 600MHz | GeForce 8600M GT | ALC268 | BCM5787 | BCM94311MCG |  \\ R.I.P. \\


#14 czyzo

czyzo
  • Members
  • 188 postów
  • LocationWarszawa

Napisano 06 sierpień 2012 - 22:05

PS. Chociaż filmów we flashu (YT) nie ma opcji oglądać. Wszędzie linie.


U mnie śmiem powiedzieć, że działają bardzo dobrze nawet lepiej niż na W7.
Co to artefaktów to pojawiają się naprawdę rzadko, najczęściej przy przeglądaniu zdjęć bądź zmianie tapety pozostanie większy pasek.

#15 AdamiPL

AdamiPL
  • Members
  • 647 postów
  • LocationPeterborough / UK

Napisano 08 sierpień 2012 - 10:58

Z tego co wiem przy 4GB RAM'u HD3000 ma pamięci 384MB (tyle mam) zaś przy 8GB 512MB. Może dołożenie RAM'u coś zmieni.


@AdamiPL ma 8GB ramów. Z tego co się orientuję, to hangów nie ma wcale, a artefaktów baaaaaaardzo mało i są sporadyczne. Ale on to od Liona uzywa tylko OS X.


Defakto korzystam z zewnętrznego monitora, artefakty baaaaaaaaaaaardzo rzadko się pojawią, w postaci małych białych kresek na tapecie.
Teraz jestem na wyjeździe i korzystam tylko z ekranu laptopa - brak jakich kolwiek artefaktów.

Fajnie by było, gdyby można było zwiększyć ilość vramu, obecnie mam 512 i czasami odczuwam braki - np w programach do obróbki wideo Adobe premier przy większych projektach :/

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#16 Ravven

Ravven
  • Members
  • 140 postów
  • LocationWarszawa

Napisano 08 sierpień 2012 - 14:49

RevoGirl podała na to sposób. ;)

W załączniku masz jego kopię z jej bloga.

Załączone pliki


Mac OS X Yosemite 10.10.5 - ASUS X73SV-TY424V || i7-2670QM | HM65 | 2x4GB 1333MHz | Intel HD Graphics 3000 + GeForce GT 540M (Optimus) | ALC269 | AR8151 | AR9002WB-1NG (AR5B195 combo / AR9285 + AR3011) |
Mac OS X SL 10.6.8 - COMPAL FL90 || c2d-T71000 | ICH8M | 2x2GB 600MHz | GeForce 8600M GT | ALC268 | BCM5787 | BCM94311MCG |  \\ R.I.P. \\


#17 AdamiPL

AdamiPL
  • Members
  • 647 postów
  • LocationPeterborough / UK

Napisano 08 sierpień 2012 - 17:57

Wiedziałem, że raz coś udostępnionego w necie już z niego nie zginie.. :) Metoda działa, poniżej screen:

Dołączona grafika

 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#18 karid

karid
  • Members
  • 73 postów

Napisano 08 sierpień 2012 - 18:02

Jakieś widoczne zmiany po zwiększeniu VRAM?
Mountain Lion 10.8.2 + Windows 8 | Asus X53SV | i7-2630QM | HD3000 | 4GB DDR3 1333MHz | HM65 | 500GB 5400RPM | ALC269 | AR9002WB

#19 AdamiPL

AdamiPL
  • Members
  • 647 postów
  • LocationPeterborough / UK

Napisano 08 sierpień 2012 - 18:06

hmm tak jakby płynniej chodziło (choć nie wiem czy to jest realne, czy tylko moje takie odczucie po zrobieniu czegoś :mrgreen:) , nieco większy wynik w NovaBench.

Tam jest też dodany ważny komentarz na samym końcu.
Pozwolę go sobie zacytować:

Hello again…On my second Hackintosh I lost artifacts just by editing native color profile in system settings -) monitors (screens) and not see them already 7 hours…but still testing…That is why, now i’m not sure about editing kext…May be it will work on rest hacked machines??? If U also have artifacts try this method….


 MacBook Pro 15" 2012 / i7 2,6 Ghz / 8GB DDR3 / GT650M 1GB + HD4000 1,5GB / 500GB SSD + 640GB data

Asus Z87 Pro (V edition), Intel Core I3-4170, Thermalrigh Macho rev. B, Gigabyte GeForce GTX650TI 2GB, Dell P2310HC, 20GB DDR3@2400, Z87 , I217V, ALC1150, BCM94360CD, Crucial MX100 128GB - OSX, Samsung EVO 850 250GB - Windows, Fractal R5 - Sierra 10.12.2
Sun Ultra 27 Workstation : Intel Quad Core Xeon 2.93 GHz (W3540),1Gb AMD ATI FirePro V4900 / AMD Radeon 5750 1GB (JUNIPER) / Gigabyte GeForce GTX650 TI 2GB, Dell P2310Hc, 12GB DDR3@1600, X58, Intel 82567LM-2 , BCM94360CD, ALC889A , SB X-fi Surround 5.1 Pro USB, CRUCIAL MX100 128GB Magic Mouse A1296 - Yosemite 10.10.5
Dell Precision T3400 : Intel Core 2 DUO 3GHz (e8400), AMD Radeon 5750 1GB (JUNIPER), Broadcom NetXtreme BCM5722D, WDC WD1502FYPS-02W3B0, 4 x 2GB DDR2 GEIL - Mavericks 10.9.5
ASUS X53SJ : Intel Core i7 (2630qm), OPTIMUS Intel HD 3000 + GeForce GT520m, 2 x 4 GB - Mountain Lion 10.8.5

facebook.pnghackintosh #Polska #Poland (Grupa FB)   / UK HACKINTOSH SUPPORT - MORE ON PM


#20 Ravven

Ravven
  • Members
  • 140 postów
  • LocationWarszawa

Napisano 08 sierpień 2012 - 20:27

Bardzo szkoda bloga RevoGirl. Miała tam genialne teksty. Cieszę się, że pomogło. :D

Daj znać, za jakiś czas, czy lepiej działa grafika. ;)

Mac OS X Yosemite 10.10.5 - ASUS X73SV-TY424V || i7-2670QM | HM65 | 2x4GB 1333MHz | Intel HD Graphics 3000 + GeForce GT 540M (Optimus) | ALC269 | AR8151 | AR9002WB-1NG (AR5B195 combo / AR9285 + AR3011) |
Mac OS X SL 10.6.8 - COMPAL FL90 || c2d-T71000 | ICH8M | 2x2GB 600MHz | GeForce 8600M GT | ALC268 | BCM5787 | BCM94311MCG |  \\ R.I.P. \\





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych