Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

LegacyHDA ALC882 888 889 892 898 1150 1200 on ASUS, MSI...

LegacyHDA ALC882 ALC888 ALC1200 ALC889 ALC892 ALC898 ALC1150

  • Zaloguj się, aby dodać odpowiedź
173 odpowiedzi w tym temacie

#21 wokie

wokie
  • Members
  • 316 postów

Napisano 13 październik 2013 - 10:48

Potwierdzam działanie ALC892 na AsrockZ87 Pro4 na OS X 10.8.5 i 10.9.

10.10.5/10.11.6 HaMac: Intel Core i5-4670K | ASRock Z87 Pro4 rev.C1| 2x8GB DDR3-1600 Crucial Balistic CL9 |SB Audigy2 ZS Gold| PX-128M5Pro |2x ST2000DM001 | iHAS124 |Pioneer BRD-208|Logitech -K750 MAC | BCM 94321MC| Asus R9 270X


#22 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 17 październik 2013 - 16:17

Sound odpalam z paczki ALC889-v.16-f.micML.10.8.3. Popycham to wpisem w DSDT (w czystym DSDT nie ma „Device HDA”). Dźwięk jest b.dobry. Na wyjściu mam: trzy wyjścia liniowe i jedno Wyjście cyfrowe. Na wejściu: jedno Wejście liniowe. Czyli w sumie wszystko dobrze. Niepokoją mnie jednak :

Sound assertion in AppleHDAWidget at line 4240
Sound assertion in AppleCodecGeneric at line 1374, oba błędy w Mavericku.

I: Sound assertion in AppleHDAEngine at line 599
Sound assertion in AppleHDAWidget at line 4172
Sound assertion in AppleCodecGeneric at line 1332, trzy błędy w Mountain Lionie.

Może to są tylko jakieś sprawy kosmetyczne. Próbowałem innego sposobu odpalenia dźwięku, tzn: „Script to auto-patch the AppleHDA binary for osx10.7 thru 10.9” z Insanelymac forum, ale bez powodzenia.Tzn Sound assertion było więcej i nie wykrywało urządzenia dźwiękowego.
_____________________________
Retail 10.8.5, 10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

#23 iStig

iStig
  • R.E.D.
  • 648 postów

Napisano 17 październik 2013 - 16:36

jeden z błędów zlikwidujesz jak dodasz wpis z MaximumBootBeepVolume

Edit:
masz widoczne wyjścia dźwięku po HDMI ? - jak nie to pewnie to są kolejne błędy

ASUS MAXIMUS VI GENE | i7-4770K | Corsair H80i + 2x Noctua NF-F12 PWM | 16GB (2x8GB) DDR3 Patriot PV316G240C0KRD | 2x Samsung 840 PRO 256GB + Samsung 1TB F3 + WD 2TB WD20EVDS | Sony AD-7690H | GeForce GTX 780 | Seasonic SS-760XP | Silverstone FT03 Black + 2x Noctua NF-S12A PWM | ACD 27" | Apple 802.11ac WiFi + BT 4.0 | Sierra & Windows 10

 

ASUS Z170 PRO GAMING | i5-6500 | 16GB (2x8GB) DDR4 Kingston HX421C14FBK2/16 | Intel 750 400GB SSDPEDMW400G4X1 | GeForce GTX 750Ti | Apple 802.11ac WiFi + BT 4.0 | Sierra


#24 oswaldini

oswaldini
  • Moderators
  • 10577 postów
  • LocationBrzeszcze / Kraków

Napisano 17 październik 2013 - 16:37

13741332 jest chyba od źle odpalonego HDMI.

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 16 GB RAM | HD4600 | 250 GB macOS + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#25 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 17 październik 2013 - 17:40

Macie rację, HDMI jest źle odpalony, gdyż moja grafika nie ma takiego gniazda! Czyli został by błąd z linii 4240/4172 i aby się go pozbyć, trzeba dodać wpis z MaximumBootBeepVolume? Co to zmieni?




_____________________________
Retail 10.8.5,10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

#26 iStig

iStig
  • R.E.D.
  • 648 postów

Napisano 17 październik 2013 - 17:55

to jest odpowiedzialne za blad 599

co do gniazda HDMI - nie musisz go miec - dzwiek moze byc wypuszczony w gniezdzie DVI na karcie

ASUS MAXIMUS VI GENE | i7-4770K | Corsair H80i + 2x Noctua NF-F12 PWM | 16GB (2x8GB) DDR3 Patriot PV316G240C0KRD | 2x Samsung 840 PRO 256GB + Samsung 1TB F3 + WD 2TB WD20EVDS | Sony AD-7690H | GeForce GTX 780 | Seasonic SS-760XP | Silverstone FT03 Black + 2x Noctua NF-S12A PWM | ACD 27" | Apple 802.11ac WiFi + BT 4.0 | Sierra & Windows 10

 

ASUS Z170 PRO GAMING | i5-6500 | 16GB (2x8GB) DDR4 Kingston HX421C14FBK2/16 | Intel 750 400GB SSDPEDMW400G4X1 | GeForce GTX 750Ti | Apple 802.11ac WiFi + BT 4.0 | Sierra


#27 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 17 październik 2013 - 18:23

Mam iMaca 11.1, To jaką wartość trzeba wpisać (bo spotkałem różne: 0x4D, 0x40, 0x5D). Ta pierwsza wartość jest dla nowszych iMaców. Czy to coś daje, czy to tylko kosmetyka?
A jak zabrać się za to HDMI?




edit: HDAInjection w Cloverze nic nie daje... zarówno string "Detect" jak i "12"


_____________________________
Retail 10.8.5,10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

#28 314TeR

314TeR

    Administrator

  • Administrators
  • 16405 postów
  • LocationWarszawa

Napisano 18 październik 2013 - 14:37

Na 100% zrobiłeś binpatch na czystym niemodyfikowanym wcześniej AppleHDA? Pozostałe pliki na 100% są poprawnie wgrane? ALC889 testowałem na P8Z68 Deluxe i wersji GEN3 i tam wszystko działało.

Na wyjściu mam: trzy wyjścia liniowe i jedno Wyjście cyfrowe. Na wejściu: jedno Wejście liniowe.

No tak nie do końca, wyjścia OK, ale z wejść powinien być 1xMic-In i 1xLine-In. Przy czym jak wetkniesz Mic z tyłu komputera w różowe wejście, to Mic-In zamienia się w Line-In i masz w preferencjach dwa Line-In.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#29 oswaldini

oswaldini
  • Moderators
  • 10577 postów
  • LocationBrzeszcze / Kraków

Napisano 18 październik 2013 - 15:26

Jeżeli nie widac Mic w preferencjach to znaczy, że kolega nie wgrał LegacyHDA, sam się na tym złapałem.

MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000 + GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 16 GB RAM | HD4600 | 250 GB macOS + 500 GB + 1 TB | Raijintek Metis | SFX-L 500W | WiFi
HomeSerwer: HP G7 N54L | 2.2GHz (800-2200Mhz) | 4GB RAM | 2x WD RED 2TB | Synology DSM 6.0.2 @ Jun's bootloader | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | CloverEFI | Nie pomagam na PRIV


#30 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 18 październik 2013 - 16:03

[quote name="314TeR"]Na 100% zrobiłeś binpatch na czystym niemodyfikowanym wcześniej AppleHDA? Pozostałe pliki na 100% są poprawnie wgrane?

Tak, zrobiłem na czystym. Pozostałe pliki wgrałem poprawnie. Na Twoich plikach powinno HDMI działać? Nie dałem wpisu HDMI do DSDT.

oswaldini
Nie mam LegacyKexta, mam wpis w DSDT. Może czegoś tam brakuje!

_____________________________
Retail 10.8.5,10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

#31 314TeR

314TeR

    Administrator

  • Administrators
  • 16405 postów
  • LocationWarszawa

Napisano 18 październik 2013 - 16:16

Nie mam LegacyKexta, mam wpis w DSDT. Może czegoś tam brakuje!

#-o
Przeczytaj instrukcję... bez legacy nie działa poprawnie.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#32 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 18 październik 2013 - 22:07

Ok. Zainstalowałem. Rzeczywiście błędy zniknęły, został tylko Sound assertion in AppleHDAEngine at line 581. Wcześniej koledzy podpowiedzieli że dotyczy on wpisu "MaximumBootBeepVolume" i teraz mam dylemat czy wpisać wartość '0x4D', bo wyczytałem iż dotyczy on iMaca 12.1 i nowszych. Ja mam identyfikację iMac 11.1

_____________________________
Retail 10.8.5,10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

#33 314TeR

314TeR

    Administrator

  • Administrators
  • 16405 postów
  • LocationWarszawa

Napisano 18 październik 2013 - 22:09

Sprawdź HDAInjection 12 w Cloverze.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#34 iStig

iStig
  • R.E.D.
  • 648 postów

Napisano 19 październik 2013 - 07:44

Ok. Zainstalowałem. Rzeczywiście błędy zniknęły, został tylko Sound assertion in AppleHDAEngine at line 581. Wcześniej koledzy podpowiedzieli że dotyczy on wpisu "MaximumBootBeepVolume" i teraz mam dylemat czy wpisać wartość '0x4D', bo wyczytałem iż dotyczy on iMaca 12.1 i nowszych. Ja mam identyfikację iMac 11.1


tyczyly bledu 599... a co do wartosci to nie ma znaczenia - i tak nie beepnie :-D

ASUS MAXIMUS VI GENE | i7-4770K | Corsair H80i + 2x Noctua NF-F12 PWM | 16GB (2x8GB) DDR3 Patriot PV316G240C0KRD | 2x Samsung 840 PRO 256GB + Samsung 1TB F3 + WD 2TB WD20EVDS | Sony AD-7690H | GeForce GTX 780 | Seasonic SS-760XP | Silverstone FT03 Black + 2x Noctua NF-S12A PWM | ACD 27" | Apple 802.11ac WiFi + BT 4.0 | Sierra & Windows 10

 

ASUS Z170 PRO GAMING | i5-6500 | 16GB (2x8GB) DDR4 Kingston HX421C14FBK2/16 | Intel 750 400GB SSDPEDMW400G4X1 | GeForce GTX 750Ti | Apple 802.11ac WiFi + BT 4.0 | Sierra


#35 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 19 październik 2013 - 08:09

iStig, 599 to był błąd w Snow Leopardzie, a 581 jest w Mavericksie.

314TeR, HDAInjection '12' lub 'Detect' (jak jest w dokumentacji) nic nie daje.


_____________________________
Retail 10.8.5,10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

Smbios Mac Pro4.1, Retail 10.10.5 10.11.6 Clover 3330, P55-GD85, Intel Xeon Quad-Core X3440, GTX 970, ALC 889, RTL 81xx.


#36 314TeR

314TeR

    Administrator

  • Administrators
  • 16405 postów
  • LocationWarszawa

Napisano 19 październik 2013 - 12:11

Spróbuj z iniekcją z DSDT w takim razie. Daj znać czy się udało.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#37 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 19 październik 2013 - 13:51

Injekcja w DSDT cały czas jest:
         Device (HDEF) 
{
Name (_ADR, 0x001B0000)
Method (_PRW, 0, NotSerialized)
{
Return (Package (0x02)
{
0x0D,
0x05
})
}

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x0E)
{
"AAPL,slot-name",
Buffer (0x09)
{
"Built In"
},

"built-in",
Buffer (One)
{
0x00
},

"device_type",
Buffer (0x06)
{
"AUDIO"
},

"name",
Buffer (0x0F)
{
"Realtek ALC889"
},

"model",
Buffer (0x27)
{
"Realtek ALC889HD High Definition Audio"
},

"layout-id",
Buffer (0x04)
{
0x0C, 0x00, 0x00, 0x00
},

"PinConfigurations",
Buffer (Zero) {}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}


#38 314TeR

314TeR

    Administrator

  • Administrators
  • 16405 postów
  • LocationWarszawa

Napisano 19 październik 2013 - 14:46

A gdzie masz "MaximumBootBeepVolume"?

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#39 oknow

oknow
  • Members
  • 109 postów
  • LocationRadom

Napisano 19 październik 2013 - 16:59

Dopisałem, nie chce skompilować:

dsdt.dsl 4640: Store (Package (0x0E) Error 4047 - Initializer list longer than declared package length ^
I co teraz? Przyznam że nie jestem specem od kompilacji...

_____________________________
Retail 10.8.5,10.9, Chameleon 2251, P55-GD85, Intel Xeon Quad-Core X3440, XFX Radeon HD 4890, ALC 889, RTL 81xx.

Smbios Mac Pro4.1, Retail 10.10.5 10.11.6 Clover 3330, P55-GD85, Intel Xeon Quad-Core X3440, GTX 970, ALC 889, RTL 81xx.


#40 314TeR

314TeR

    Administrator

  • Administrators
  • 16405 postów
  • LocationWarszawa

Napisano 20 październik 2013 - 11:22

Zamiast:
Store (Package (0x0E)
Wpisz:
Store (Package ()
Kompilator sam uzupełni właściwą wartość.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 






Również z jednym lub większą ilością słów kluczowych: LegacyHDA, ALC882, ALC888, ALC1200, ALC889, ALC892, ALC898, ALC1150

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych