Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Szybki tutek jak mieć snoła retail'a na Asusie P5Q


  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 laborman

laborman
  • R.E.D.
  • 889 postów

Napisano 09 wrzesień 2009 - 20:37

Jest to bardzo robocza i szybka wersja tutka. Instalacja oparta jest o metodę 314TeR'a retaila Leoparda.
Potrzebne pliki:
a) obraz SL
b)chameleon2 RC3
c) paczka E/E przygotowana przeze mnie
d) dsdtpatchergui
e) szczęście

1. Musimy mieć na innym dysku, lub partycji zainstalowanego Leoparda 10.5.x, Tygrysa 10.4.x (ja instalowałem z dysku USB) bo z niego będziemy instalować SL.
2. Montujemy obraz i instalujemy na dysku docelowym korzystając w tej części z tutka 314TeR'a Szczegóły tutaj
3. Nie resetujemy tylko instalujemy chameleona2 (ja zastosowałem najnowszy wypust RC3 bo nie trzeba podmieniać pliku boot)
4. Do katalogu E/E, który utworzy chameleon kopiujemy zawartość paczki, którą przygotowałem. Jest ona wzbogacona o injectory lanu pokladowego, obsługi dysków, sleep, openhaltrestart i dźwięku (oczywiście wszystko 64bit). Z tym, że nie wiem dlaczego ale plik AppleHDA musi być w S/L/E a nie w E/E bo inaczej nie działa dźwięk.
5. Generujemy za pomocą DSDTpatchera DSDT.aml i ładujemy go na docelowy dysk.
6. Restart i w zasadzie powinien system wstać. Mi wstał
Oczywiście nie muszę przypominać , że instalowałem SL na zupełnie osobnym dysku SATA, że AHCI w biosie i takie tam mają być włączone itp.
W paczce znajdują się także com.apple.boot.plist ze stringiem mojej grafy i chyba siecówki ale nie jestem pewny no i plik smbios.plist który oczywiście można przeedytowac do swoich potrzeb.

Paczka:
http://rapidshare.com/files/277821041/Extra.zip

HaMaK1: Asus P6T Deluxe, Intel Core i7 920, GF GTX460 , 8GB RAM----OSX 10.12.3
HaMak2: Asrock Conroe1333-D667; Intel C2D E6300, GF 8600GTS----OSX 10.6.8
FlagaPL.gif Piszę poprawnie po polsku!


#2 AB76

AB76
  • Members
  • 180 postów

Napisano 29 wrzesień 2009 - 15:27

No niestety mi nawet installer nie chce dojść do końca tą metodą, dochodzi do jakiś 90% i wywala że nie może zapisać plików na dysku docelowym ?
Lion 10.7.3
Gigabyte EP45 UD3 (ICH10), C2Q 9300, 6GB RAM, SSD OCZ Agility 3 60GB, HDD 2x Barracuda 12 500GB, SerialATA 300 , Lan Realtek 8111C, ALC889a, GeForce GTX 460 1GB, Philips SPC1030NC (OOTB), Asus WL-138g v2 (AirPort)

#3 rzooff

rzooff
  • R.E.D.
  • 5235 postów
  • LocationWarszawa

Napisano 29 wrzesień 2009 - 19:51

Odznacz pozycję "printer drivers".

#4 laborman

laborman
  • R.E.D.
  • 889 postów

Napisano 29 wrzesień 2009 - 20:13

Oraz Rosete.

HaMaK1: Asus P6T Deluxe, Intel Core i7 920, GF GTX460 , 8GB RAM----OSX 10.12.3
HaMak2: Asrock Conroe1333-D667; Intel C2D E6300, GF 8600GTS----OSX 10.6.8
FlagaPL.gif Piszę poprawnie po polsku!


#5 AB76

AB76
  • Members
  • 180 postów

Napisano 30 wrzesień 2009 - 14:42

No wielkie dzięki, po odznaczeniu powyższych pozycji instalacja za kończona pomyślnie. Po dorzuceniu kilku kextów system nawet wystartował.
Teraz jeszcze mam pytanko w jaki nalepszy sposób odpalić dzwięk na płycie Gigabyte EP-35 DS3L (reset i usypianie) no i kartę graficzną GeForce 9600GT. Zainstalowane mam Chameleon 2.0 RC3 + DSDT + następujące kexty (fakesmc.kext, NullCPUPowerManagement.kext,IOAHCIBlockStorageInjector,LegacyAppleAHCIPort, LegacyIOAHCIBlockStorage,PlatformUUID.kext)
Lion 10.7.3
Gigabyte EP45 UD3 (ICH10), C2Q 9300, 6GB RAM, SSD OCZ Agility 3 60GB, HDD 2x Barracuda 12 500GB, SerialATA 300 , Lan Realtek 8111C, ALC889a, GeForce GTX 460 1GB, Philips SPC1030NC (OOTB), Asus WL-138g v2 (AirPort)

#6 kipero

kipero
  • Members
  • 30 postów

Napisano 09 listopad 2009 - 21:05

Wszystko dziala z wyjatkiem IDE. Jak mzna uruchomic naped DVD na snow 64-bit i plycie Asus P5Q?

--edit
Działa! Poczatkowo nie dzialalo na AppleVIAATA, ktory niby byl przeznaczony na x64, ale w koncu, po ktorejs z kolei probie sciagniecia kext'a z internetu, zadzialalo.

#7 rzooff

rzooff
  • R.E.D.
  • 5235 postów
  • LocationWarszawa

Napisano 18 grudzień 2009 - 23:28

Poczatkowo nie dzialalo na AppleVIAATA, ktory niby byl przeznaczony na x64, ale w koncu, po ktorejs z kolei probie sciagniecia kext'a z internetu, zadzialalo.

Tylko zdradź proszę czemu miałby służyć ten kext, na płycie, która nie posiada chipsetu VIA ?

/ Edit: Już się dowiedziałem, to wbrew nazwie on uruchamia IDE Marvell'a :)

#8 Yurek3

Yurek3
  • Members
  • 27 postów
  • LocationZadymiarz

Napisano 24 styczeń 2010 - 01:10

Czy na innej partycji tego samego HDD ,na ktorym jest Leopard pojdzie zainstalowac Snow Leopard.

#9 herkules

herkules
  • Members
  • 400 postów

Napisano 24 styczeń 2010 - 01:57

Czy na innej partycji tego samego HDD ,na ktorym jest Leopard pojdzie zainstalowac Snow Leopard.

mi sie nie udalo tak uczynić
Compal FL90 | Intel Core 2 Duo T7300 | NVIDIA GeForce 8600M GT 256 | Asus WL-270N MiniPCI-E | ST9500325AS SATA 3Gb/s 500GB 5400 |
System:OSX Lion 10.7.1

#10 bakuz

bakuz
  • Members
  • 53 postów

Napisano 05 luty 2013 - 09:58

Czy ktoś mógłby wrzucić tutaj kexty potrzebne do uruchomienia Snow Leoparda pod P5Q? Niestety link z pierwszego postu jest już nie nieaktywny, a mam problem np. z "FakeSMC: key not found BEMB. length - 1" lub "IOATAController device blocking bus." System wstaję jednak nie widać urządzeń USB, CD-ROMu... po za tym, po zainstalowaniu chameleon nie potrafi uruchomić systemu, muszę korzystać z bootcda. Niestety nie wiem czego konkretnie brakuję.

#11 rzooff

rzooff
  • R.E.D.
  • 5235 postów
  • LocationWarszawa

Napisano 05 luty 2013 - 10:17

http://hamac.pl/topi...eria-vt1602.htm
+
Jeśli masz indywidualne problemy z instalacją, to proszę założyć osobny temat zgodnie z porządnym opisem wg tego tematu:
http://hamac.pl/topi... ... vt5156.htm




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych