Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie

Sleep Dell D630


  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 dee

dee
  • Members
  • 122 postów

Napisano 20 luty 2014 - 17:53

Dzien dobry... nie bylo mnie na forum ze 3 lata :) ale wygrzebalem ostatnio starego Dell'a i zainstalowalem retail 10.7.4 wszystko dziala jak nalezy power management natywnie doslownie wszystko z jednym wyjatkiem .. sleep.. 

po zamknieciu klapy zapada w sleep po czym momentalnie wybudza sie a po restarcie jeszcze dodatkowo reset CMOS'u... 

  Recent Contents:	Power Management ASL logs.
-> All messages with "com.apple.message.domain" key set to "com.apple.powermanagement".)

 * Domain: sleep
 - Message: Sleep: Success - AC 100 - Clamshell Sleep
 - Time: 2/20/14 9:34:46 AM GMT+ 
 - Signature: Success
 - UUID: A8A5FDA2-0D19-4A56-BF54-CB59AB8A20B3
 - Result: Success
 - Sleep count : 0

 * Domain: wake
 - Message: Wake: Success - AC 100 - PBTN LID
 - Time: 2/20/14 9:34:54 AM GMT+ 
 - Signature: Success
 - UUID: A8A5FDA2-0D19-4A56-BF54-CB59AB8A20B3
 - Result: Success

DSDT ma poprawke na RTC 

   Device (RTC)
                {
                    Name (_HID, EisaId ("PNP0B00"))
                    Name (RT, ResourceTemplate ()
                    {
                        IO (Decode16,
                            0x0070,             // Range Minimum
                            0x0070,             // Range Maximum
                            0x10,               // Alignment
                            0x02,               // Length
                            )
                        IO (Decode16,
                            0x0072,             // Range Minimum
                            0x0072,             // Range Maximum
                            0x02,               // Alignment
                            0x06,               // Length
                            )
                    })
                    Method (_CRS, 0, NotSerialized)
                    {
                        Return (RT)
                    }
                }

Power Management dziala natywnie CPUPlimit w IOReg = 0x0 

byc moze komus cos sie obilo o uszy jak poradzic sobie z tym problemem.. jezeli jest ktos chetny do dyskusji zapraszam...dawno sie nie udzielalem a chetnie bym sobie podziubal ..

 

pozdr


Dell D630 (Macbook5,1) Core2Duo 1.8Ghz/X3100/ Lion Retail 10.7.4 


#2 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 21 luty 2014 - 11:52

W przypadku Liona patch w DSDT może nie wystarczyć. Trzeba zrobić binpatch AppleRTC, jeżeli używasz Clovera, to wystarczy włączyć go w config.plist, jeżeli nie to poszukaj jak powinien wyglądać dla 10.7.4.

Ten problem występuje też na sprzęcie, na którym wcześniej nie było problemu z resetami CMOSu, mam tak np. na moim T61.


Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel


#3 dee

dee
  • Members
  • 122 postów

Napisano 21 luty 2014 - 17:35

Problemem samym w sobie nie jest reset biosu ale natychmiastowe wybudzanie ze sleep'u z informacja 

 

Wake: Success - AC 100 - PBTN LID 

 

nie wiem jak mam ugryzc temat
sprawdzalem DSDT sekcje 

 

     Scope (\_SB)
        {
            Device (LID)
            {
                Name (_HID, EisaId ("PNP0C0D"))
                Method (_LID, 0, NotSerialized)
                {
                    Store (SMI (0x84, Zero), Local0)
                    Return (Local0)
                }

                Name (_PRW, Package (0x02)
                {
                    0x17, 
                    0x03
                })
                Method (_PSW, 1, NotSerialized)
                {
                    PSW (Arg0, 0x02)
                }
            }

            Device (PNLF)
            {
                Name (_HID, EisaId ("APP0002"))
                Name (_CID, "backlight")
                Name (_UID, 0x0A)
                Name (_STA, 0x0B)
            }

            Device (PBTN)
            {
                Name (_HID, EisaId ("PNP0C0C"))
                Name (_PRW, Package (0x02)
                {
                    0x17, 
                    0x04
                })
                Method (_PSW, 1, NotSerialized)
                {
                    PSW (Arg0, One)
                }
            }

            Device (SBTN)
            {
                Name (_HID, EisaId ("PNP0C0E"))
            }
        }

patch do RTC tez testowalem ale nie daje rezultatow po tym wybudzeniu brutalnym :) 

 


Dell D630 (Macbook5,1) Core2Duo 1.8Ghz/X3100/ Lion Retail 10.7.4 


#4 dee

dee
  • Members
  • 122 postów

Napisano 22 luty 2014 - 10:31

Sprawa rozwiazana.. przyczyna tkwi w implementacji ACPI .. z voodoomini.kext nie ma problemu ze sleepem...jedynym problemem po wybudzeniu jest reset CMOSu ktorego nie poprawia binpatch ani patchowane AppleRTC tu nie wiem o co common..z vanilliowym ACPI sleep niestety nie dziala mi i chyba jest to cena dzialajacego natywnie speedstepa...nie wiem jakie sa roznice pomiedzy tymi dwoma ACPI narazie popatrze sobie na temp. bo stepping procka jest w obu przypadkach taki sam...moze byc roznica tylko w podawanym napieciu..

chyba tyle... 
pozdro


Dell D630 (Macbook5,1) Core2Duo 1.8Ghz/X3100/ Lion Retail 10.7.4 


#5 MKjanek32

MKjanek32
  • Moderators
  • 1942 postów
  • LocationMysłakowice / Wrocław

Napisano 25 luty 2014 - 17:53

Dziwne, u siebie mam natywne ACPI i nie mam problemów ze sleepem. Na początku były jaja z wybudzaniem przez USB, ale wystarczył fix w DSDT. Ale, że u Ciebie podaje jako przyczynę wybudzenia przycisk (którego nie wciskasz), to nie rozumiem.


Izerpad2: Lenovo ThinkPad T420 - macOS 10.12.5 | Intel Core i5-2520M 2,5 GHz | 4GB DDR3 | Intel HD 3000 | Intel QM67 | Conexant CX20672 | Broadcom BCM4322 | Intel 82579LM
Wcześniej: Lenovo ThinkPad T61 - Mac OS X 10.6.8 | Intel Core 2 Duo T7300 2 GHz | 2GB DDR2 | GMA X3100 | ICH8-M | SoundMAX AD1984 | Atheros AR5BXB6 | Intel 82566MM
FlagaPL.gif Piszę poprawnie po polsku! | Legacy kext dla kart Atheros | LegacyHDA AD1984 | Regulacja podświetlenia dla kart Intel





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych