Skocz do zawartości

haMac.pl używa cookie. Przeczytaj Privacy Policy aby dowiedzieć się więcej. Aby usunąć tę wiadomość, proszę kliknąć w przycisk po prawej:    Akceptuję użycie cookie

Zdjęcie
- - - - -

AppleHDA dla ALC 892 - Szybka instalacja

ALC892 AppleHDA ALC 892

  • Zaloguj się, aby dodać odpowiedź
27 odpowiedzi w tym temacie

#1 arielvanp

arielvanp
  • Donator
  • 1160 postów
  • LocationŻory PL / Cork IE

Napisano 02 maj 2014 - 19:56

AppleHDA dla ALC 892 
 
Config.plist Clovera sekcja Audio:
W configu naszego boot loadera nalezy ustawic Audio na Inject 12

EFI/CLOVER/config.plist

	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>12</string>
		</dict>
	</dict>
 

Kopiowanie kextu do clovera

otwieramy folder „Kext do Clovera” kopiujemy kext „ALC892-v.6-f.mic.ML.kext”  na partycje EFI lub pendrive z boot loaderem 
EFI/CLOVER/Kext/10.X
10.X - osatnia cyfra po kropce oznacza nasza wersje systemu.
 
 
Montowanie partycji EFI
Uruchamiamy aplikacje Terminal (Aplikacje/Narzedzia/Terminal.app)
Identyfikujemy dysk startowy z partycja EFI podajac komende:
diskutil list
image.png
 
Ustalamy punkt montowania partycji EFI komenda:
mkdir /Volumes/efi
 
Montujemy partycje EFI komenda:
sudo mount -t msdos /dev/diskXsZ /Volumes/efi
 
w miejscu:
X - Wpisujemy numer dysku
Z - Numer partycji
 
 
2xz.png
 
wpisujemy haslo i zatwierdzamy enterem ,  partycja zostala zamontowana 
 
image.jpg
 
Instalacja kextu programem „Kext Wizard”
 
Otwieramy folder „Kext AppleHDA do systemu” nastepnie aplikacje znajdujaca sie wewnatrz „Kext Wizard.app”
Przechodzimy do zakladki „Instalacja” przeciagamy „AppleHDA.kext” do programu  znajdujacy sie rowniez w tym samym folderze.
Zrzut_ekranu_2014_05_02_o_19_28_31.png
Klikamy instaluj , podajemy haslo klikamy ok.
Czekamy na komunikat o zakonczeniu instalacji.
Zrzut_ekranu_2014_05_02_o_19_29_34.png
Przebudowa Cache oraz naprawa uprawnien w programie Kext Wizard
 
Otwieramy folder „Kext AppleHDA do systemu” nastepnie aplikacje znajdujaca sie wewnatrz „Kext Wizard.app”
Program automatycznie uruchamiany jest w pierwszej zakladce czyli „Konserwacja”.
Zaznaczamy Napraw Uprawnienia oraz Przebuduj cache , klikamy wykonaj , czekamy na ukonczenie konserwacji .
Zrzut_ekranu_2014_05_02_o_19_33_05.png
Zrzut_ekranu_2014_05_02_o_19_34_34.png
 
Po pomyslnie wykonanym zadaniu nalezy zrestartowac komputer po tej czynnosci mozemy cieszyc sie dzialajacym dzwiekiem.
 
__________________________________
Kext AppleHDA pochodzi z systemu 10.9.3 zostal spaczowany metoda 314Ter’a - http://hamac.pl/topi...00-on-asus-msi/
Post bedzie uaktualniany po kazdej aktualizacji systemu 10.9 wraz z nowym AppleHDA

Załączone pliki


  • kycek75 i madmak lubią to

haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.12 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.13

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#2 kycek75

kycek75
  • Banned
  • 73 postów
  • LocationWrocław

Napisano 02 maj 2014 - 20:49

zrobiłem wszystko dokładnie krok po kroku i dźwięku niestety nadal nie mam

 

EDIT

 

 

zrobiłem drugi raz i działa :)



#3 misqkrk

misqkrk
  • Members
  • 81 postów
  • LocationSEO/SEM

Napisano 16 maj 2014 - 12:01

Czy komuś po aktualizacji OS X 10.9.3 przestał działać dźwięk na tej karcie ?

kext ponownie wgrałem do /S/L/E oraz są na /efi

 

NIEAKTUALNE

po wgraniu pliku z tego postu ponownie działa, na mojej modyfikacji było coś nie tak


Hamac - OS X 10.12.2  i7 3770k (OC 4.4GHz), MSI Z77A-G45, Corsair 4x4GB 1600MHz 1.5V (OC 2000MHz), SSD Samsung 830 128GB, Intel HD4000 +NVIDIA GeForce GTX 750, 2x Monitor, 1x Projektor

Macbook Air 13" - OS X 10.10 i5 1.7GHz, 4GB

Macbook Pro 13" - OS X 10.12.3 SSD 128GB, 8GB

Air Time Capsule 2 TB ac

iPhone 7 - iOS 10.3, 128GB


#4 kubas121

kubas121
  • Members
  • 19 postów

Napisano 06 lipiec 2014 - 21:07

zrobiłem wszystko pokoleji (parę razy wręcz) i nie dość że na os x'e nie mam dźwięku (tylko pisk w słuchawkach) to na windowsie 8.1 dzwiek padl totalnie - nie pomogło reinstalowanie sterowników czy przywracanie systemu

jakies pomysły gdzie zrobiłem błąd i jak się z tego wykaraskać? Z góry dziękuję



#5 Grzesiek13

Grzesiek13
  • Moderators
  • 1758 postów
  • LocationNowy Sącz

Napisano 06 lipiec 2014 - 21:28

Miałem podobny przypadek, stery zostaw w spokoju.  Wyłącz zasilacz, odłącz z prądu i poczekaj parę minut. Ewentualnie zresetuj bios zworką po tym zabiegu i jeszcze raz wyłącz zasilacz . Nie wiem czym to jest spowodowane, sam zachodziłem w głowę, nawet chciałem słać mobasa do serwisu, jak widać niepotrzebnie 


Macbook Pro 13 2017 AOC Q2577PWQ

Jeśli naprawdę myślisz że "piszesz poprawnie po polsku" to wróć się do każdego swojego posta i popraw źle użyte apostrofy
Nawet nie próbuj męczyć mnie na PW, od tego jest forum


#6 kubas121

kubas121
  • Members
  • 19 postów

Napisano 07 lipiec 2014 - 07:20

Wyłączyłem komputer i odpiąłem kabel na około minutę. Po włączeniu wrócił głos do Wndowsa :) Ale na maku dalej cisza (szara ikonka głosniczka). Będe walczył dzisiaj jeszcze i dam zna ć co było nie tak. Pozdr



#7 madmak

madmak
  • Members
  • 12 postów

Napisano 09 lipiec 2014 - 14:29

Asus H87M-PRO, dźwięk działa perfekcyjnie, zero trzasków, szumów itd... Dzięki.   =D&gt;


haMac 14,2  10.10.1 Core i3 4330 Asus H87M-PRO 2x8GB RAM DDR3 Hynix nVidia Quadro FX1700 CUDA SyncMaster T22B300 | BlackMagic Intensity Pro Samsung SSD 840 EVO 120GB Toshiba 1TB Microsoft ARC Keyboard Microsoft Wireless Mobile Mouse 1000 | Wacom BAMBOO Pen | CC 2014

 


#8 arielvanp

arielvanp
  • Donator
  • 1160 postów
  • LocationŻory PL / Cork IE

Napisano 09 lipiec 2014 - 14:57

bede mial chwile to dodam aktualizacje z AppleHDA z 10.9.4


haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.12 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.13

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#9 madmak

madmak
  • Members
  • 12 postów

Napisano 12 lipiec 2014 - 12:40

Wszystko fajnie działa, ale czy jest jakieś rozwiązanie polegające na tym, żeby nie podmieniać oryginalnego kexta AppleHDA?


haMac 14,2  10.10.1 Core i3 4330 Asus H87M-PRO 2x8GB RAM DDR3 Hynix nVidia Quadro FX1700 CUDA SyncMaster T22B300 | BlackMagic Intensity Pro Samsung SSD 840 EVO 120GB Toshiba 1TB Microsoft ARC Keyboard Microsoft Wireless Mobile Mouse 1000 | Wacom BAMBOO Pen | CC 2014

 


#10 oswaldini

oswaldini
  • Moderators
  • 11018 postów
  • LocationBrzeszcze / Kraków

Napisano 14 lipiec 2014 - 10:44

http://hamac.pl/topi...00-on-asus-msi/


MacBook Pro 2012 MD103 15" | i7-3615QM | 8 GB RAM | HD4000+GT650M | Samsung 830 256 GB
Hack Gigabyte H81N | i5-4460 | 8 GB RAM | HD4600+GTX650 | 2xHP 24" + 1xDell 27" | mSATA SSD 32GB + SSD 120GB + SSHD 500 GB | Raijintek Metis | SFX-L 500W | WiFi+BT

HomeSerwer: Dell 7010 | i3-3240 | 14 GB RAM | 2xWD RED 2TB | Synology DSM 6.1.7 @ Jun's bootloader | Virtual Machine Manager | Time Machine + PLEX + CouchPotato + SickRage + masa innych

iPhone 7 32GB Black
FlagaPL.gif Piszę poprawnie po polsku! | Nie pomagam na PRIV


#11 madmak

madmak
  • Members
  • 12 postów

Napisano 14 lipiec 2014 - 11:34

Właśnie według tej instrukcji uruchomiłem dźwięk na 10.9.4.

W config.plist Clovera zmieniłem inject layout na 12.

ALC892-v.6-f.mic.ML.kext skopiowałem  do katalogu z kextami Clover'a.

Potem skopiowałem layout12.xml.zlib i Platforms.xml.zlib do /System/Library/Extensions/AppleHDA.kext/Contents/Resources/ (pierwsza ingerencja w oryginał). 

Wykonałem bin patch /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA (druga ingerencja w oryginał).

Na koniec przebudowa cache'u i uprawnień. 

 

I teraz jak wykonać powyższe, ostatnie dwie operacje w locie (pewnie przy pomocy Clovera) podczas ładowania systemu,  zamiast wykonywać je trwale na oryginalnym AppleHDA.kext?


haMac 14,2  10.10.1 Core i3 4330 Asus H87M-PRO 2x8GB RAM DDR3 Hynix nVidia Quadro FX1700 CUDA SyncMaster T22B300 | BlackMagic Intensity Pro Samsung SSD 840 EVO 120GB Toshiba 1TB Microsoft ARC Keyboard Microsoft Wireless Mobile Mouse 1000 | Wacom BAMBOO Pen | CC 2014

 


#12 NorMan

NorMan
  • Members
  • 73 postów

Napisano 23 lipiec 2014 - 15:36

Ja zawsze po combo update musiałem uruchamiać multibestię aby odpalić dźwięk. Przy 10.9.4 nie zadziałało. Więc spróbowałem tej metody - DZIĘKI ! Wszystko już gra :)


Hakuś : 10.12.3 || MSI Z68A-G45(G3) || i5-2500K || 8GB Kingston HyperX || GF 9600GT || Patriot SSD 120GB || Samsung 1TB @ PowerMac G5 Case || WDC 1TB (zewnętrzny) || Apple Cinema HD 23" || Clover UEFI
Makuś : MacBook Pro 13" | MC700PL/A


#13 javazlaz

javazlaz
  • Members
  • 1562 postów
  • LocationCzęstochowa

Napisano 23 lipiec 2014 - 17:19

MultiBeast? Do 892? Zbrodnia! :P


macOS 10.14.1 + Windows 10 Pro - Asus Z97-C (v2403) | Core i3-4330 | G.Skill RipjawsX 16GB DDR3 1600MHz CL7 1.5V | Gigabyte RX 560 Gaming OC 4GB | Samsung 850 EVO 250GB | WD Red 1TB | Intel I218-V | Fenvi FV-T919 | ALC 892 | be quiet! Pure Power L8-300W | SPC HE924v2 | Fractal Design Define R4 Titanium | Dell P2210

iOS 12.1 - iPhone SE 16GB Space Gray

ADM 3.1.3.RHU2 - Asustor AS1002T | 2x WD Red 3TB


#14 314TeR

314TeR

    Administrator

  • Administrators
  • 17889 postów
  • LocationWarszawa

Napisano 23 lipiec 2014 - 19:17

@madmak, nie da się. Aktualizacja nadpisuje plisty. O ile sam binpatch jest do zrobienia o tyle podłożenie Layout i Platform nie da rady za pomocą clovera.

 

Na forum oswaldini podawał przykład skryptu jaki można wrzucić sobie do systemu, który to sprawdza przy wyłączaniu czy AppleHDA nie został przywrócony do oryginału, jak został to wykonuje binpatch i kopiuje plisty. Skrypt prosty i skuteczny.


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#15 arielvanp

arielvanp
  • Donator
  • 1160 postów
  • LocationŻory PL / Cork IE

Napisano 30 sierpień 2014 - 16:54

Aktualizacja - wersja z 10.9.5 w zalaczniku

Załączone pliki


haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.12 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.13

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#16 314TeR

314TeR

    Administrator

  • Administrators
  • 17889 postów
  • LocationWarszawa

Napisano 30 sierpień 2014 - 19:46

Aktualizacja - wersja z 10.9.5 w zalaczniku

 

10.9.5? To nie pomyka?


ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#17 arielvanp

arielvanp
  • Donator
  • 1160 postów
  • LocationŻory PL / Cork IE

Napisano 30 sierpień 2014 - 22:01

10.9.5? To nie pomyka?

Załączone pliki


haMAC i7 | ASUS Z87 Gryphon | Core i7-4790k | 16 GB DDR3 1600MHz | Toshiba Q series 128GB SSD x2 (raid0) & Seagate ST1000DM003-9YN162 1TB HDD | Asus Geforce GTX 760 2GB | ALC 892 | FiiO E10 | i217V | AirPort Extreme BCM94360CD | Apple IR & Bluetooth 4.0 | Apple Magic Mouse | Logitech K750 MAC | Dell UltraSharp U2913WM + Dell Professional P2210H | Mac OS X 10.12 & Clover

MacBookPro8,1 | Core i5 2415M | 8GB DDR3 1066MHz | Samsung 840 PRO 128GB SSD | HD3000 | Mac OS X 10.13

HTPC - Intel NUC DN2820FYKH | Intel Celeron 2820 | 4GB DDR3 | 64GB SSD | Intel HD Graphics | ALC283 | OpenELEC


#18 Estrax

Estrax
  • Members
  • 1107 postów
  • LocationToronto, ON, Canada

Napisano 30 sierpień 2014 - 22:59

Nie, to nie pomyłka.

Załączone pliki


Spoiler

#19 314TeR

314TeR

    Administrator

  • Administrators
  • 17889 postów
  • LocationWarszawa

Napisano 31 sierpień 2014 - 10:53

Nie, to nie pomyłka.


Ok, instalujecie wersje devloperskie, a nie finalne. Finalnej jeszcze nie ma. Dodajcie na przyszłość info o tym.

ASUS MAXIMUS VII IMPACT | Core i7-4790K | 16GB DDR3 2400 CL10 | GTX 980 Ti | FiiO E10 | OS X Retail via UniBootX Clover

ASUS Z87M-PLUS | Core i5-4590T | 8GB DDR3L 1333 | HD4600 | OS X Retail via UniBootX Cloverbyłe haMac'i: ASUS P5W DH DeluxeASUS P7P55 WS Supercomputer | ASUS P8Z68 Deluxe/GEN3 | ASUS P8Z77-V PRO THUNDERBOLTJak uruchomić na wypasie ALC 882/888/889/1200 | STOP Gigafail | P5W DH Deluxe - perfekcyjny hackintosh | Piszę poprawnie po polsku!

Co daje kalibracja monitora - zobacz jak można poprawić jakość obrazu.

 

Najszybszy hackintosh na świecie za procesorem 12C identyfikujący się jako Mac Pro (Late 2013) wg rankingu Geekbench: 37000 pkt

 

Pomogliśmy Tobie - pomóż nam - przekaż darowiznę na utrzymanie forum.

 


#20 Grzesiek13

Grzesiek13
  • Moderators
  • 1758 postów
  • LocationNowy Sącz

Napisano 31 sierpień 2014 - 11:07

Ok, instalujecie wersje devloperskie, a nie finalne. Finalnej jeszcze nie ma. Dodajcie na przyszłość info o tym.

Dokładnie, jak dla mnie to sztuka dla sztuki bo często brakuje zmian pomiędzy betami. Z resztą spodziewajmy się jeszcze 10.8.6 i na tym koniec


Macbook Pro 13 2017 AOC Q2577PWQ

Jeśli naprawdę myślisz że "piszesz poprawnie po polsku" to wróć się do każdego swojego posta i popraw źle użyte apostrofy
Nawet nie próbuj męczyć mnie na PW, od tego jest forum






Również z jednym lub większą ilością słów kluczowych: ALC892, AppleHDA, ALC, 892

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych