Jump to content

All Activity

This stream auto-updates     

  1. Past hour
  2. O, to wszystko wyjaśnia! Wielkie dzięki! Rozumiem, że gdyby w przypadku mojej płyty głównej było wsparcie dla USB-BC, nie musiałbym niczego szczególnego robić, aby działało pod macOS?
  3. @man_of_the_oak o ile samo zasilanie przez interfejs USB 2.0 to 5V/0.5A, a w przypadku USB 3.0 5V/0.9A, o tyle wielu vendorów dorzuca też wsparcie dla USB-BC (USB battery charging) w tych portach. USB-BC daje dodatkowe 5V/1A w przypadku standardu USB 2.0 z transferem danych, lub 5V/1.5A przy samym ładowaniu. W przypadku USB 3.0 jest to 5V/1.5A przy transferze danych i maksymalnie 5V/5A przy samym ładowaniu baterii. W rezultacie, można osiągnąć następujące wyniki poboru prądu z gniazda: - USB 2.0 z transferem danych - 5V/1.5A - USB 2.0 z samym ładowaniem - 5V/2A - USB 3.0 z transferem danych - 5V/2.4A - USB 3.0 z samym ładowaniem - 5V/5.9A (w teorii; w praktyce jednak maksymalnie 5V/3A)
  4. Rzeczywiście, sprawdziłem i wedle standardu jest 500 mA. Ciekawi mnie jednak do czego w takim razie odnosił się producent w tym fragmencie:
  5. Natężenie 500 mA wynika ze standardu USB 2.0. Dopiero USB 3.0 pozwala na 900 mA.
  6. Today
  7. Na Twoim miejscu rozważyłbym jednak użycie OpenCore. Osobiście uważam, że jest zdecydowanie lepszym rozwiązaniem niż Clover, a jego dokumentacja powinna Ci w zupełności wystarczyć do postawienia systemu. https://dortania.github.io/OpenCore-Install-Guide/
  8. Edit: Sprawa wyjaśniona - problem nie był związany z samym Hackintoshem. Okazało się, że winowajcą był kabel, którego używałem w formie przedłużenia do zbyt krótkiego kabla dołączonego z interfejsem. Udało mi się znaleźć sposób reprodukcji opisywanego problemu poprzez wysyłanie wiadomości MIDI - gdy łączyłem się z wykorzystaniem wspomnianej przedłużki, po paru chwilach od wysyłki pierwszych wiadomości interfejs przestał je przetwarzać, a później zaczynały się dziać inne cuda (np. brak przesyłu dźwięku na monitory, pomimo obecności urządzenia w systemie). Wystarczyło jednak podpiąć się bezpośrednio, z użyciem innego, krótszego kabla i wszystko wróciło do normy. Daję znać dla potomnych ^_~ Co prawda nie podejrzewałem, abym coś źle ustawił przy użyciu USBMap, natomiast zrobiłem od nowa mapowanie z Hackintool. Rozpiska, którą przygotowałem dla swojej płyty przy tej okazji: Trochę dziwne są dla mnie pary HS09/SS05 i HS10/SS06, gdyż z tego co widzę w tutorialach, zawsze numeracja HS**/SS** jest zgodna, ale upewniłem się wielokrotnie i nie zrobiłem tutaj błędu. Finalny rezultat mapowania: Zasadniczo dokładnie to samo, co uzyskałem z USBMap. Tam również ustawiłem PR11, PR21 jako internal, do tego HS06, pod które mam podpięty Bluetooth. Porty wyłącznie USB 2.0 (HS13, HS14) connector jako USB 2.0, zaś dla HS** będących przy tym częścią USB 3.0, pozostawiłem to samo co dla odpowiadającego SS**. Co jednak zwróciło moją uwagę, gdy grzebałem w sieci: https://support.focusrite.com/hc/en-gb/articles/360003921499-Scarlett-4i4-3rd-Gen-power-requirements O ile dla urządzeń USB 3.0 jestem w stanie uzyskać 900mA, o tyle z interfejsem dostarczony został kabel USB-C na USB 2.0 (dopiero teraz się zorientowałem), a na nim mam taki rezultat: Przykład dla pendrive USB 3.0 podpiętego do tego samego portu: Mamy dostępne natężenie 900 mA... Co więcej, zwróćcie uwagę, że magistrale USB 2.0 (to chyba u mnie PR11 i PR21) nadal nie są używane, pomimo podpięcia myszy i klawiatury do portów USB 2.0 (HS13, HS14, dla przypomnienia). Z tego co jednak widzę, jest to standardowe działanie (cytat z https://www.tonymacx86.com/threads/a-beginners-guide-to-creating-a-custom-usb-ssdt.272505/ ) Nie powinno mieć to jednak wpływu na działanie portów, przynajmniej tak sądzę. Czy istnieje możliwość "podbicia" dostępnego natężenia dla USB 2.0, skoro w teorii powinno być dostępne? W przeciwnym razie chyba zaopatrzę się w kabel USB-C -> USB 3.0 i spróbuję w ten sposób... Z ciekawości sprawdziłem na MacBooku i tam także wbija dostępne dla tego urządzenia natężenie 500 mA...
  9. Nadal jest to Haswell, więc konfig z UnibootX to dobry punkt startowy.
  10. Jest to laptop więc config zapewne będzie inny. Model to M4800
  11. Yesterday
  12. Skorzystaj po prostu z forumowego UniBootX - jest tam ogólny config pod Z87 i Z97.
  13. Last week
  14. Witajcie, czy sa jakieś fixy polecane właśnie dla Haswell? u mnie to aktualnie wyglada tak : AddDTGP FixShutdown FixHDA FixRegions FixMutex w Generate Options Generate PStates Generate CStates PluginType w Kernel and Kext Patches posiadam KernelPM AppleIntelCPUPM DellSMBIOSPatch Oraz czy powinno sie nadal generować plik ssdt od cpu??? podobno powyższe opcje generale c i p States pozwalają ominąć owy plik Na mackintosh-polska znalazłem coś takiego
  15. Chyba najwygodniejszy sposób robienia mapy USB w kext/SSDT umożliwia Hackintool, warto spróbować.
  16. Kartę wyciągasz. Używasz configu z iGPU z linka, który Ci wysłałem. W Biosie oczywiście iGPU właczone. Ta płyta ma Display Port IN - nie out!!!
  17. Focusrite Scarlett 4i4 Tak nawiasem, zwróciłem uwagę, że urządzenia podpięte pod USB 2.0 znajdują się na magistrali USB 3.0 - to normalne?
  18. Zanim spróbuję z Big Sur, to chciałbym jeszcze sprawdzić zrobienie aktualizacji Cataliny na wbudowanej karcie graficznej i potem uruchomienie Radeona 5700 - czy to zły pomysł? Tu mam pytanie, czy żeby to zrobić, to powinienem fizycznie wyjmować kartę, czy mogę zablokować jej działanie systemowo? Rozumiem, że aby posłużyć się tylko iGPU, to muszę: - przełączyć w BIOSIE sygnał grafiki z pci-e na iGPU - AAPL,ig-platform-id - 07009B3E - rozumiem, że w boot-args NVRAM powinienem wyrzucić agdpmod=pikera ? Czy w boot-args NVRAM powinienem używać argumentu: -wegnoegpu ? Czy jeśli go użyję to nawet jeśli nie wyjmę karty z płyty głównej, to zostanie ona wyłączona za pomocą tego argumentu? Czy coś jeszcze powinienem zrobić, żeby wykorzystać tylko iGPU? Płyta główna dysponuje wyjściem HDMI i DisplayPort. Czy DisplayPort musi być uruchamiany w jakiś szczególny sposób, bo widzę sygnał na monitorze tylko po podłączeniu z HDMI? Proszę o wyrozumiałość, jeśli pytania są z grupy bardzo podstawowych, ale cel mam taki, żeby jednak ten komputer wykorzystać w mojej pracy montażysty:) Chociaż widzę, że błędem był zakup 5700xt zamiast sprawdzonych Radeonów montowanych w seryjnych Macach. Dzięki za pomoc
  19. U mnie tylko interfejs audio przestaje dawać sygnał, więc re-plug.
  20. Tzn. gdy problem występuje, nagle przestają działać wszystkie urządzenia podpięte na USB. Nie miałem okazji testować komputera bez podpiętego interfejsu, gdyż jest mi on potrzebny cały czas, a problem jest tak randomowy, że ciężko np. wybrać jeden dzień w weekend na testy i liczyć, iż akurat się uda... Jak w takim razie sobie z tym radzisz?
  21. Problem dotyczty tylko interfejsu audio czy każdego urządzenia na USB? Jeśli tylko interfejsu audio, to miałem to na H61, mam na Z390 i MBA 2012, więc problem nie jest związany z USB, a przynajmniej nie z hackintoshem.
  22. Dzięki! No to widzę, że chyba można wykluczyć, gdyż jedyne urządzenia na USB 2.0 jakich używam to mysz i klawiatura, idą one bezpośrednio do portów USB 2.0, natomiast interfejs jest na USB-C, wpięty po do portu USB 3.0 po odpowiedniej przejściówce (wedle zaleceń producenta).
  23. https://www.tonymacx86.com/threads/success-gigabyte-designare-z390-thunderbolt-3-i7-9700k-amd-rx-580.267551/page-2368#post-2151796
  24. Sprawdź czy masz podłączone urządzenia USB2.0 i USB 3.0 do tego samego kontrolera jeśli nie to - nie tędy droga. Ale widzę interface audio USB, a to urządzenie pewnie USB2.0. Jak doskonale pewnie wiesz jeden kontroler na płycie obsługuje np. 2 porty.
  25. Dzięki za odpowiedź! Nie do końca jednak rozumiem co masz na myśli - mógłbyś rozwinąć? W jaki sposób sprawdzić czy to taki przypadek?
  26. Zobacz czy nie miksujesz urządzeń USB2.0 z 3.0 w obrębie tego samego kontrolera. Na niektórych płytach robią się wtedy krzaki. Zaleca się wtedy odpalanie USB2.0 za pomocą Huba wpiętego w dedykowany wybrany jeden port. Może u Ciebie jest podobny problem.
  27. Hej, Ostatnio udało mi się doprowadzić do perfekcji działanie mojego Hackintosha, a przynajmniej tak sądziłem... Na sprzęcie ze stopki (Z97), w zupełnie losowych momentach (np. raz na tydzień) porty USB przestają działać. Wygląda to jednak o tyle dziwnie, że zasilanie wydaje się być nadal dostarczane (świecą się diody np. na interfejsie audio), ale sprzęt nie działa. Z uwagi na losowość występowania, udało mi się sprawdzić niewiele kombinacji umożliwiających "ożywienie" portów - zauważyłem, że odpięcie i podpięcie ponownie interfejsu, po czym np. wciśnięcie klawisza na klawiaturze pomaga. Zaznaczam, że ani razu nie spotkałem się na tej instalacji z KP, samoczynnymi restartami itd. Nie wiem na ile może mieć to znaczenie, ale aby zasilanie portów USB nie było dostarczane po wyłączeniu systemu, ustawiłem w BIOS-ie ErP na "Enabled in S4+S5". Uprzedzając pytania - nie korzystam z USBInjectAll czy "fixów" usuwających limit 15 portów. Wykonałem natomiast mapowanie (https://github.com/corpnewt/USBMap), schodząc do optymalnej ich ilości - aktualnie wygląda to tak: Logi: Sep 24 22:34:36 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.mdworker.shared.03000000-0200-0000-0000-000000000000[1548]): Service exited due to SIGKILL | sent by mds[113] Sep 24 22:34:53 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.mdworker.shared.0F000000-0400-0000-0000-000000000000[1547]): Service exited due to SIGKILL | sent by mds[113] Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: Entered:_AMMuxedDeviceDisconnected, mux-device:81 Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: Entered:_AMMuxedDeviceDisconnected, mux-device:81 Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:81 Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - BootedOS mode device disconnected Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:81 Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: tid:1b1f - BootedOS mode device disconnected Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: tid:1a17 - Invalid ECID passed to make key with Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: tid:1a17 - Failed to create ecid key for RSD device Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - Invalid ECID passed to make key with Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - Failed to create ecid key for RSD device Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: tid:1a17 - Failed to get ECID from MDRemoteService device Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: tid:1a17 - Invalid ECID passed to make key with Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - Failed to get ECID from MDRemoteService device Sep 24 22:34:58 iMac-Jakub MobileDeviceUpdater[1281]: tid:1a17 - Couldn't generate a deviceKey for an MDRemoteServiceDeviceRef. Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - Invalid ECID passed to make key with Sep 24 22:34:58 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - Couldn't generate a deviceKey for an MDRemoteServiceDeviceRef. Sep 24 22:35:01 iMac-Jakub systemstats[97]: assertion failed: 19G2021: systemstats + 664509 [7B7F7B73-FFF4-3CB7-9C6F-CBD9A3397587]: 0x7fd269707300 Sep 24 22:35:01 iMac-Jakub xpcproxy[1552]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1553]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1554]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1555]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1556]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1557]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1558]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub xpcproxy[1559]: libcoreservices: _dirhelper_userdir: 557: bootstrap_look_up returned (ipc/send) invalid destination port Sep 24 22:35:01 iMac-Jakub MobileDeviceUpdater[1281]: Entered:_AMMuxedVersion2DeviceConnected, mux-device:82 Sep 24 22:35:01 iMac-Jakub AMPDeviceDiscoveryAgent[368]: Entered:_AMMuxedVersion2DeviceConnected, mux-device:82 Sep 24 22:35:01 iMac-Jakub MobileDeviceUpdater[1281]: tid:1a17 - unable to query device capabilities Sep 24 22:35:01 iMac-Jakub AMPDeviceDiscoveryAgent[368]: tid:7a2b - unable to query device capabilities Sep 24 22:35:03 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.activateSettings.1561): Failed to bootstrap path: path = /System/Library/PrivateFrameworks/SystemAdministration.framework/Versions/A/Resources/activateSettings, error = 2: No such file or directory Sep 24 22:35:15 iMac-Jakub AccountProfileRemoteViewService[1564]: objc[1564]: Class AOSUISpyglassAccountChangeHelper is implemented in both /System/Library/PrivateFrameworks/AOSUI.framework/Versions/A/AOSUI and /System/Library/PrivateFrameworks/AOSUI.framework/Versions/A/XPCServices/AccountProfileRemoteViewService.xpc/Contents/MacOS/AccountProfileRemoteViewService. One of the two will be used. Which one is undefined. Sep 24 22:35:15 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.pid.walletAvailabil.1571): Failed to bootstrap path: path = /System/Library/PreferencePanes/Wallet.prefPane/Contents/Resources/walletAvailabilityCheckTool, error = 2: No such file or directory Sep 24 22:35:15 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.bsd.dirhelper[1581]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.bsd.dirhelper Sep 24 22:35:15 iMac-Jakub Finder[354]: libcoreservices: __create_or_fix_relative_directory: 1002: __dirhelper_create_relative_with_error: error Operation not permitted Sep 24 22:35:20 iMac-Jakub syncdefaultsd[1592]: objc[1592]: Class SYDClient is implemented in both /System/Library/PrivateFrameworks/SyncedDefaults.framework/Versions/A/SyncedDefaults and /System/Library/PrivateFrameworks/SyncedDefaults.framework/Support/syncdefaultsd. One of the two will be used. Which one is undefined. Sep 24 22:35:20 iMac-Jakub syncdefaultsd[1592]: objc[1592]: Class SYDJournal is implemented in both /System/Library/PrivateFrameworks/SyncedDefaults.framework/Versions/A/SyncedDefaults and /System/Library/PrivateFrameworks/SyncedDefaults.framework/Support/syncdefaultsd. One of the two will be used. Which one is undefined. Sep 24 22:35:41 iMac-Jakub bluetoothd[145]: BUG in libdispatch client: read, monitored resource vanished before the source cancel handler was invoked { 0x7fe89bf16170[source], ident: 12 / 0xc, handler: 0x10473faa0 } Sep 24 22:35:58 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.mdworker.shared.0F000000-0600-0000-0000-000000000000[1589]): Service exited due to SIGKILL | sent by mds[113] Sep 24 22:35:58 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.mdworker.shared.07000000-0700-0000-0000-000000000000[1591]): Service exited due to SIGKILL | sent by mds[113] Sep 24 22:37:53 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.mdworker.shared.02000000-0200-0000-0000-000000000000[1593]): Service exited due to SIGKILL | sent by mds[113] Sep 24 22:39:17 iMac-Jakub com.apple.xpc.launchd[1] (com.apple.mdworker.shared.02000000-0300-0000-0000-000000000000[1594]): Service exited due to SIGKILL | sent by mds[113] Sep 24 22:40:45 iMac-Jakub Spotlight[432]: assertion failed: 19G2021: libxpc.dylib + 92759 [3E243A41-030F-38E3-9FD2-7B38C66C35B1]: 0x89 Sep 24 22:40:46 iMac-Jakub diagnosticd[1606]: Posting empty stream filter Sep 24 22:40:46 iMac-Jakub diagnosticd[1606]: no EOS device present Sep 24 22:40:46 iMac-Jakub diagnosticd[1606]: allowing Console (1602) access to stream due to admin status Sep 24 22:40:46 iMac-Jakub diagnosticd[1606]: Posting stream filter: "{ global = 47245099008; }" Zastosowane kexty: Byłbym wdzięczny za sugestie!
  1. Load more activity
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.