Jump to content

djseban

Members
  • Content Count

    74
  • Joined

  • Last visited

  • Days Won

    1

djseban last won the day on January 6 2016

djseban had the most liked content!

Profile Information

  • Gender
    Male
  • Location:
    Bełchatów/Tarnopol
  1. Sprawdzone, przy powyższej konfiguracji wywala mnie na stronę help.netflix.com z Silverlightem.
  2. Hejka, niedawno gdy próbowałem pooglądać Netflixa na macOSie pojawił się problem. Na początku Netflix przekierowywał mnie na stronę z prośbą o instalację Silverlight - szybko zorientowałem się, że nie mam H.264, więc poszukałem i odpaliłem iGPU - jeden problem rozwiązany. Teraz oglądając przez Safari wywala mi error S7363-1260-FFFFD089 (prawdopodobnie coś o HDCP), a przez Chrome w niektórych filmach uzyskuję 1080p (głównie Netflix Originals), reszta jest w 480p. Miał ktoś może podobny problem i mógłby posłużyć radą ? W załączniku config.plist z Clovera. To co już próbowałem: flagi -shikioff, shikigva=4, -rad4200 (oczywiście nie wszystkie na raz) - zero zmian zupełne wyłączenie IGPU - netflix przekierowuje na Silverlighta Wszystkie kexty od Lilu w najnowszych wersjach. config.plist.zip
  3. Witaj Jeśli chodzi o laptopy i macOS, to jak dla mnie jedynym słusznym wyborem jest MacBook. Gdy byłem jeszcze na polibudzie, to po akcji z laptopem ASUSa (nówka, wyłożył mi się po dwóch tygodniach) kupiłem MPB z Retiną z 2012 (HD4600 + GTX650M). Korzystałem rok i mogę z pewnością stwierdzić, że był to jedyny komputer przenośny w moim życiu, z którego byłem tak zadowolony. Używałem go do programowania (również w pracy), i pierdół typu gitara, przeglądanie netu, filmy etc. Można było od czasu do czasu również zagrać (przeszedłem na nim GTA V i DB: Xenoverse), ale grzała się cholera niemiłosiernie (procek dochodził do 9x *C). Jedyne co mnie w nim denerwowało, to świrowanie Bluetootha z Magic Mousem, od czasu do czasu dawała znać o sobie matryca odblaskowa, no i oczywiście brak mocnej, dedykowanej grafiki (to już raczej kwestia stricte laptopowa, zresztą jak pisałeś, nie będziesz używał laptopa do grania). Co do matrycy w MBA niestety się nie wypowiem, bo z MBA miałem okazję korzystać tylko krótką chwilę, jednak jak już brać jakiekolwiek MB to z Retiną.
  4. djseban

    MSI Z97 Mate

    Z tego co pamiętam, to Z97 Mate jest bardzo podobna w budowie do Z97-G43. Zapraszam do tematu http://hamac.pl/topic/12810-unibootx-clover-msi-z97-g43-i5-4690k-r9-390/. R9 270 jak najbardziej odpalisz, musisz tylko wstrzyknąć odpowiednie ID w Cloverze.
  5. Nie licząc sytuacji, w której ustawimy IGPU na Primary w BIOSie Wystarczy ustawienie Timeouta w Cloverze na 0 i zmiana ustawień grafiki na takie, jak dałem na screenach. Pomiędzy Windowsem a OS X możemy wtedy przełączać się przez opcję "Dysk startowy" w Preferencjach Systemowych. Sposób sprawdzony, działa jak w zegarku, tyle że oczywiście nie widzimy ładowania systemu ani BIOSowego bootsplasha. Do tego, tak jak już pisałem w poradniku, jeżeli mamy dwa monitory, to możemy podłączyć jeden pod Radeona, a drugi pod Intel HD, wtedy problem blind-boota znika. Podsumowując, dwie opcje niezbędne do działającego sleepa na Radeonach, w wypadku Z97-G43: Windows 8/8.1/10 Feature: Disabled Initiate Graphic Adapter: IGD
  6. 1. Konfiguracja sprzętowa: Wersja systemu: Mojave 10.14.x, Płyta: MSI Z97-G43, Chipset: Z97, Procesor: Intel Core i5-4690k, GPU: AMD Radeon R9 390, Audio: Intel High Definition Audio (ALC892) / Radeon HDMI Audio (AAC8), LAN: Realtek RTL8111 Gigabit Ethernet. 2. Zastosowane kexty: RealtekRTL8111.kext - pod kartę sieciową, SATA_Legacy.kext - LegacySATA z UniBootX, VoodooTSCSync.kext - z niewiadomych mi przyczyn po wybudzenu ze Sleepa występowały problemy z synchronizacją timera TSC, ten kext to załatwia, Z97LPC.kext - LegacyLPC z UniBootX, USBInjectAll.kext - kext załatwiający problemy z limitami USB, Lilu.kext - nowinka ze świata OSx86 od vit9696 pozwalająca na patchowanie kextów/bibliotek/frameworków w locie, WhateverGreen.kext - pod R9 390, AppleALC.kext - ALC892 (Intel HDA) + AAC8 (HDMI Audio). FakeSMC.kext + sensory - wiadomo po co, tym razem od RehabMana. Niestety, jak zwykle, nie działa sensor od GPU i pokazuje 0*C Nowsze wersje FakeSMC działają sztos, IOath3kfrmwr.kext - gratis kext do dongli/kart bluetooth Atherosa AR3011. 3. Sposób odpalenia grafiki: Grafika rusza po wstrzyknięciu ID z Radeona R9 290 i odpowiedniego Framebuffera, włącznie ze sleepem bez blind boota oraz HDMI Audio. Polecam ustawić w BIOSie Primary GPU na PEG, na sam początek ten sposób jest najmniej problemogenny. Za odpowiednią obsługę grafiki odpowiedzialny jest Lilu.kext i WhateverGreen.kext. Działa M-M, wybudzanie ze sleepa i wszystko czego dusza mogłaby zapragnąć od karty graficznej. Jeżeli ktoś nie ma Hawaii, to odsyłam na githuba, żeby sprawdzić, czy mamy wspieraną grafę: https://github.com/vit9696/WhateverGreen. Na załączonym configu powinny ruszyć R9 290/290X/390/390X, przy czym 390-tki potrzebują wstrzyknięcia ID przez Clovera. Jeśli kogoś korciłoby żeby odpalić również integrę (HD4600), to jak najbardziej taka możliwość istnieje. Wchodzimy w UEFI, zmieniamy Primary GPU na IGP. W Cloverze dajemy konfigurację pod HD4600, którą można znaleźć w plikach z UniBootX. 4. Sposób odpalenia Audio: Odpalone przez AppleALC.kext (wymaga Lilu.kext), Inject ID w Cloverze: 1. Działają wszystkie outputy. Co do HDMI Audio: dodanie HDAU do karty graficznej w DSDT (AddHDMI) + GFX0->IGPU, za resztę odpowiada WhateverGreen.kext i AppleALC.kext. 5. Sposób instalacji: Wrzucamy folder MS-7816 do katalogu /EFI/CLOVER/OEM, instalujemy system. Uzupełniamy swój SMBIOS i ROM w RtVariables. Co do sposobu generowania SMBIOSa krążą różne opinie. U mnie działa najprostszy sposób - generacja poprzez Clover Configurator. 6. USB: Od El Capitana wzwyż mamy standardowo ograniczoną liczbę portów USB. Na High Sierrze/Mojave potrzebny jest patch AppleUSBXHCIPCI, który oczywiście jest już w configu. 7. Procesor (SpeedStep): Nie bawiłem się tym razem w ssdtPRGen.sh, bo mam podkręcony procesor. W configu zaznaczone Generate PStates, Generate CStates i EnableC6, także SpeedStep jest w pełni działający. Jeżeli komuś nie pasuje takie rozwiązanie, to oczywiście wystarczy wyłączyć te opcje w configu i zrobić to swoją drogą. Tak czy tak, SpeedStep powinien ruszać od kopa, nieważne na jakim procu. Na dzień dzisiejszy konfiguracja skopiowana z UniBootX - SpeedStep działa od kopa, bez bawienia się w skrypty 8. Możliwe problemy/Protipy: W Cloverze musimy mieć wrzuconą wtyczkę APFS.efi (drivers64UEFI), bo tego systemu plików używa domyślnie 10.13/10.14, i bez tego macOS nam nie ruszy. Po całą procedurę uzyskania rzeczonego pliczku odsyłam do wujka Google, W załącznikach zostawiam stare wersje paczki do Clovera, jednak w tym temacie zajmuję się jedynie najnowszą dostępną wersją macOS. Starsze paczki mogą mieć błędy i coś może nie działać, choć wcale nie musi, Na odpalaniu Nvidii niestety się nie znam i cały setup jest zrobiony pod kartę, którą obecnie posiadam (R9 390). Jeżeli ktoś nie ma grafiki AMD to na sam początek polecam wyłączyć w configu spoof id dla ATI i opcję InjectATI, Mobo Z97-G43 ma spartaczone synchronizowanie timera TSC - jeżeli ktoś miałby okazję odpalać tę konfigurację na innym Z97, to może spróbować usunąć kext VoodooTSCSync.kext, bo może on okazać się niepotrzebny, Ostatnia wersja Clovera, na której konfiguracja była sprawdzana to build 4700. 9. Konfiguracja BIOSu Link do galerii: http://s10.photobucket.com/user/seban_12/library/OSX Wszystko było robione na najnowszym BIOSie, który jest dostępny na stronie MSI. 10. Edycje tematu 22.10.2018 - update wszystkich kextów do wersji najnowszej w stanie na dzień 22.10, edycja kilku ustawień na takie same jak w UniBootX, załatwienie problemu z przechodzeniem w hibernację, przystosowanie całego setupu pod Mojave. @314TeR: Dzięki Co do EAPDFix.kext, to faktycznie, sprawdziłem i 2.2 działa z Clovera, także opis poprawiony. MS-7816-10.13.zip MS-7816-10.14.zip
  7. W AMD8000Controller.kext->Info.plist->aty_properties zmień: <key>PP_MclkActivityTarget</key> <integer>5</integer> na <key>PP_MclkActivityTarget</key> <integer>0</integer> Później standardowo napraw uprawnienia kextów (np. przez Kext Utility). W efekcie zniknie migotanie, ale twoja karta będzie miała odrobinę wyższą temperaturę, bo powyższa zmienna jest jedną z tych od Power Managementu.
  8. djseban

    MSI Z97-G43

    Wystarczy ściągnąć najnowszą wersję z oficjalnego tematu na OSXLatitude: http://forum.osxlatitude.com/index.php?/topic/3084-eapdjack-sense-fix-no-audiojack-sense-issue-after-sleep/ i dodać taką samą konfigurację Info.plist jak w kexcie od 314TeR'a. To rozwiązuje problem KP na El Capitanie.
  9. djseban

    MSI Z97-G43

    Audio ALC892 odpalane metodą od 314TeR. Były problemy z poziomem głośności, na co pomógł EAPDFix.kext. Po sleep działa poprawnie.
  10. djseban

    MSI Z97-G43

    Jeżeli chodzi o sleepa, to w moim przypadku po wybudzeniu zawsze napotykałem KP - rozwiązaniem problemu było dodanie VoodooTSCSync.kext do kextów ładowanych przez Clovera - w ten sposób kext zawsze zdążał poprawić TSC zanim wystąpił kernel panic.
  11. W AMD8000Controller zamieniamy: 000400000403000000010300120403030004000004030000000101001102010100040000040300000001020021030202000400000403000000010400220504040004000004030000000105001000050500040000040300000001060020010606 na: 000800000402000000010300220503030004000004030000000101001204010100040000040300000001020021030202040000001402000000010400110204040004000004030000000105001000050500040000040300000001060020010606 Myślę, że dobrze będzie też podać konfigurację portów, dla których patch jest stworzony: Port 1: HDMI Port 2: DisplayPort Port 3: Nic Port 4: DVI-D Port 5: DisplayPort Port 6: DisplayPort chociaż posiadanie nawet identycznych portów nie gwarantuje, że po patchu każdy z nich będzie działał od kopa - ten sam układ od różnych producentów może znacząco różnić się wartościami txid, senseid, co uniemożliwi korzystanie z portu/-ów. W takim wypadku odsyłam do tutoriala, do którego linka podałem kilka postów wyżej. Nawiązując do konfiguracji multi-monitor przy PEG ustawionym na Primary - nie działa. Wygląda na to, że ustawienie IGP na Primary w BIOSie jest natenczas jedynym prawidłowym sposobem odpalenia R7/R9 wraz ze wszystkimi funkcjonalnościami.
  12. Doszedł kabel HDMI do TV, także mogę potwierdzić, że multi-monitor działa - tutaj warto nadmienić, że przy ustawieniu IGP na primary (co naprawia sleep), także komputer włączamy "na ślepo". Nie wiem jak ze standardowym ustawieniem PEG na primary. Framebuffer: patchowany Baladi, chociaż na normalnym "Radeon" też działało.
  13. Próbowałeś różnych framebufferów i na wszystkich portach? Jeżeli tak, i na wszystkich nie działa, to możliwe, że będziesz potrzebował zrobić patch framebuffera: http://www.insanelymac.com/forum/topic/303186-how-to-modification-of-amd-fb-clover-injection/
  14. Jeżeli chodzi o niektóre konstrukcje R9 290 i 390 (włącznie z moją), to na 10.10.4-10.10.5, o ile w ogóle się je odpali, glitchują do tego stopnia, że wyłącza się ekran. Na El Capitanie większość R9 działa bez większych problemów, oprócz oczywiście sleepa.
  15. Mały update. Zmieniłem framebuffer na "Radeon", do tego działa HDMI. KP przy wybudzaniu nie było związane z kartą graficzną, tylko problemem z synchronizacją TSC procesora (załatwiłem to przez VoodooTSCSync.kext injectowane przez Clovera), ale tutaj będzie już trzeba się doprosić stosownego update'u BIOSa od producenta. Po wybudzeniu systemu możliwy jest dostęp przez SSH, jednak sama karta graficzna widocznie się nie budzi. Niedługo będę miał możliwość sprawdzenia na dwóch monitorach i zdam "sprawozdanie". Z tego co czytałem na reddicie, to dual-monitor może działać na DisplayPortach. Co do Yosemite, to idzie na nim odpalić sleepa?
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.