Jump to content

fingerr

Members
  • Content Count

    11
  • Joined

  • Last visited

  1. Witam, co do tego "hackintosh hardware analyser", może być ten ze strony http://www.projectosx.com/forum/index.php?showtopic=1341 i czy uruchamiać go pod MacOS czy pod jakimś linux'em (mam zainstalowany Ubuntu 13.04 64 bit).. Z góry dzięki i pozdrawiam, fingerr. [ Komentarz dodany przez: MKjanek32: 2013-10-21, 00:20 ] Linki zewnętrzne podajemy w znacznikach CODE.
  2. Witam, mam do Was pytanie, czy też czasem tak macie że działacie pod MacOS a później rebootujecie do Windowsa 8 to ten się zwiesza bez żadnej przyczyny, po prostu zwiecha (freeze), żadnych BSOD itp. Miałem chwilę i przeniosłem się na Clover+GPT+UEFI niestety wczoraj miałem właśnie wyżej wspomniany problem. Szlag mnie już trafia bo o ile pod MBR wystarczyła zmiana partycji aktywnej na tą z ubuntu i spowrotem na prtycje Windows tak pod GPT straciłem pół dnia aby się Windows odpalił. p.s. udało mi się uruchomić multiboot Win8/ML/Ubuntu nie według poradnika z forum ale w następujący sposób: - standardowa instalacja Win8 (zostawienie miejsca na MacOS i Ubuntu) - po instalacji Win8 założyłem partycje HFS, ext4 i linux swap przy użyciu gparted z jakiegoś livecd, - instalator MacOS podczas instalacji stwierdził że nie ma kronikowania na uprzednio utworzonej partycji, oczywiście nie pozwolił wymazać partycji (Mediakit stwierdził że mało miejsca) ale można to rozwiązać włączając kronikowanie spod terminala (diskutil -enablejournal /dev/diskXsY - pisze z pamięci więc do sprawdzenia) - po tej operacji można już było zainstalować MacOS, - ubuntu zainstalowane z USB wersja x64 - bez problemu z automatu zamontował partycje EFI i dorzucił swój loader (przy wyborze gdzie instalować bootloader podczas instalacji wybrałem (w moim przypadku) /dev/sda6, czyli 1-szy sektor partycji) - później skopiowałem pliki Clover'a na partycje EFI - dodałem wpisy w biosie dla bootowania UEFI dla Clover'a i Ubuntu z partycji EFI (wpis dla bootownia Win8 UEFI pojawił się po zainstalowaniu Windowsa) Podsumowując nie mam hybrydowego MBR tylko protective a rozkład partycji wygląda następująco: 1. MS Recovery 2. EFI 3. MSR (Microsoft Reserved) 4. Windows 8 5. Dane (NTFS) 6. HFS+ 7. Ubuntu 8. Linux Swap -- pozdrawiam fingerr
  3. Witam MKjanek32, w załączeniu AppleHDA, który podesłał mi jeden gościu na innym forum i udało mu się odpalić wyjście. Niestety problem jest z mikrofonem. W systemie go widać, w ustawieniach dźwięku -> "Wejście", "Poziom wejściowy" pokazuje aktywność, niestety jak nagrywam coś (Audacity) albo wykonam testową rozmowę Skype'm to głosu nie słychać, a jak mocno stukam palcami w obudowę to coś można usłyszeć ale zaszumione i ciche na maksa. Coś tak jakby czułość mikrofonu była ustawiona na bardzo małą wartość (mikrofon jest OK bo sprawdziałem w Ubuntu i Windowsie)i nie było "odszumiania". Layout-id użyty to 12 (0x0C). Z góry dzięki za zainteresowanie i pomoc! -- pozdrawiam fingerr AppleHDA.kext.zip
  4. Witam, posiadam notka z ALC269, zainstalowany ML 10.8.5 niestety nie udało mi się odpalić AppleHDA. Wykrywa Intel High Definition Audio: Audio ID: 28 Głośnik: Połączenie: wewnętrzny Wejście liniowe: Połączenie: Jack 1/8 cala Mikrofon wewnętrzny: Połączenie: wewnętrzny ale urządzeń już nie. Sprawdziłem już parenaście kextow niestety bez efektu. Po przeglądnięciu poradników modyfikacji AppleHDA zmiękłem, to nie na moje siły. Jeżeli ma ktoś chwilę czasu i mógłby pomóc to bardzo bym o to prosił. W załączeniu zrzut kodeka z ubuntu. Z góry wielkie podziękowania i pozdrawiam. -- fingerr [/code] intelcodec0.zip
  5. Obawa zupełnie bezpodstawna, i tak w OS X wszystkie partycje z NTFS są tylko do odczytu. Można włączyć zapis, ale wymaga to grzebnięcia po configach, ale obsługa zapisu jest niepełna, pewnie wzorowana na NTFS-3g i niestety ułomna, od problemów z błędami, do nawet utraty danych. Strzeżonego .... Zrobiłem tak dla świętego spokoju, ponieważ tak jak wspomniałem miałem spore problemy z Win8 podczas zabaw z instalacją ML. -- pozdrawiam fingerr
  6. Witam, Jeżeli chcesz korzystać z Grub2 (w moim przypadku Ubuntu 13.04) a nie chcesz mieszać w MBR (boot0) rozwiązanie z Chameleon/Chimera jest banalnie proste. Wystarczy utworzyć plik /etc/grub.d/40_custom a jeśli plik istnieje to dodać na końcu następujący wpis: menuentry "MacOS X ML" { insmod hfsplus set root=(hd0,4) multiboot /boot } dostosowując wpis (hdX,Y) do swoich potrzeb (wskazując partycję z Mac OS'em), gdzie X - numer dysku (0 -> 1-szy dysk), Y - numer partycji (tutaj numeracja od 1, czyli 1-sza partycja to numer 1), oraz zakładając że plik "boot" chameleon/chimera jest w katalogu głównym (/) partycji z Mac OS (pamiętamy o "sudo update-grub" po każdej edycji). Bardzo łatwo można odpalać różne wersje chameleon/chimera, tworząc wiele wpisów z różną nazwą ("MacOS X 1,2,3...n" lub swoją nazwą) i plikiem boot (boot1, boot2 itd), albo jak już pojawi się menu grub'a, wskazujemy wpis bootujący Mac OS i naciskamy klawisz "e", przchodzimy do wpisu /multiboot i zamiast boot, wpisujemy nazwę nowego pliku boot, po czym naciskamy kombinację "CTRL+x" aby rozpocząć bootowanie. Jeżeli korzystacie z Windows 8, jego partycja zawsze musi być aktywna, ZAWSZE. Jeżeli aktywna będzie inna partycja to nie będzie już tylko problemu z hibernacją (tak jak to miało miejsce z Win7) ale ogólnie z działaniem systemu. Przez zabawy z Grub'em ustawiłem partycje z MacOS jako aktywną i całkiem o tym zapomniałem, co zaowocowało problemem z działaniem Windowsa (zwieszki przy logowaniu, albo zaraz po załadowaniu pulpitu). Wyłączyłem też "szybkie uruchamianie" opcjach Zasilania Energia, checkdisk nie znikał z ekranu przy startowaniu windowsa i przeważnie komp się restartował a próba naprawy BCD kończyła się niepowodzeniem. Szczerze to byłem w szoku bo z Windows 7 nie było takich problemów (oprócz wspomnianej hibernacji) Nie wiem czy wcześniej nie trzeba będzie dodać boot1h do 1-go sektora partycji z ML (sudo dd=boot1h of=/dev/rdiskXsY - X i Y jak opisano powyżej) bo u mnie na pewno był ponieważ zabawy z Grubem trwały 2 dni. Dodatkowo mam dysk z 4k sektorami więc próbwałem też polecenia "sudo dd=boot1h of=/dev/rdiskXsY bs=4096" ale to już sprawdzicie jak się ML nie odpali po dodaniu samego wpisu do menu Grub'a. Mój podział partycji (MBR): sda1 - ntfs (windows) sda2 - ntfs (dane) sda3 - ext4 (ubuntu) sda4 - HFS (OSX ML) p.s. jako że nie chcę aby MacOS przypadkiem coś nie namieszał w partycji z NTFS usunąłem ntfs.kext z /S/L/E dla pewności i przebudowałem cache. p.s.1 probowałem też odpalić Clovera, niestety blik boot (boot6, boot7) nie zadziałał z Grubem, wyskakuje błąd w stylu (piszę z pamięci) "no multiboot signature found". -- pozdrawiam fingerr Asus U30JC, Core i5-560M, 6GB RAM, 1st Gen HD Graphics, Nvidia 310M (wyłączona modyfikacją w DSDT), 500GB HDD
  7. Dzięki za info, ale na razie zaczekam jeszcze, może ktoś będzie miał jakiś pomysł na Grub'a. BTW: korzystałem też z boot0af i boot0ss. Szkoda że nie można do automatycznie dodanej przez gruba pozycji do odpalenia Mac OS dodać opcji żeby załadował dane dotyczące SMBIOS. Po reinstalacji grub'a odpalić się odpalił (chyba nawet zaczytał DSDT.aml), ale Mac wykrywa jako go jako U30Jc. ---EDIT--- Jeszcze jedno pytanie. Nie che mieszać z MBR na HDD (komputer używany codziennie do pracy) i przyszedł mi do głowy taki pomysł, tylko nie wiem czy da się to zrobić. Zainstalować Clover na pemdrive USB (są takie fajne że niewiele wystają z portu USB, np. SanDisk Cruzer Fit albo TDK Micro) z tablicą partycji GPT i z niego bootować ML zainstalowanego na HDD? Czy da się wtedy odpalać jako EFI (Bios obsługuje EFI [Aptio])? Nie wiem czy dobrze ogarniam Clover EFI ale z tego co napisane jest w info: obsługa RuntimeServices <- może ktoś wyjaśnić o co biega i jakie są plusy tego rozwiązanie i czy mój pomysł EFI z USB ale ML odpalany z HDD zadziała. Z góry bardzo dziękuję i pozdrawiam. p.s. proszę nie "bić" jeśli mój pomysł jest idiotyczny, ale już się pogubiłem po tygodniu czytania i odpalania Mac OS na dwóch kompach. -- pozdrawiam fingerr [ Dodano: 2013-09-30, 09:24 ] Witam, piszę jako osobny post bo może się przydać na przyszłość. Rozwiązanie z Chameleon/Chimera okazało się banalnie proste i skuteczne w 100%, wystarczyło utworzyć plik /etc/gub.d/40_custom oraz dodać wpis menuentry "MacOS X" { insmod hfsplus set root=(hd0,1) multiboot /boot } dostosowując wpis (hdX,Y) do swoich potrzeb, gdzie X - numer dysku (0 - 1-szy dysk), Y - numer partycji (tutaj numeracja od 1, czyli 1-sza partycja to numer 1), oraz zakładając że plik "boot" chameleona jest w katalogu głównym (/) partycji z Mac OS (pamiętamy o "sudo update-grub" po każdej edycji). Bardzo łatwo można odpalać różne wersje, tworząc wiele wpisów z różną nazwą ("Mac Os X 1,2,3...n" lub swoją nazwą) i plikiem boot (boot1, boot2 itd), albo jak już pojawi się menu grub'a, wskazujemy wpis bootujący Mac OS i naciskamy klawisz "e", przchodzimy do wpisu /multiboot i zamiast boot, wpisujemy nazwę nowego pliku boot, po czym naciskamy kombinację "CTRL+x" aby rozpocząć bootowanie. Jeżeli korzystacie z Windows 8, jego partycja zawsze musi być aktywna, ZAWSZE. Jeżeli aktywna będzie inna partycja to nie będzie już tylko problemu z hibernacją (tak jak to miało miejsce z Win7) ale ogólnie z działaniem systemu. Przez zabawy z Grub'em ustawiłem partycje z MacOS jako aktywną i całkiem o tym zapomniałem, co zaowocowało problemem z działaniem Windowsa (zwieszki przy logowaniu, albo zaraz po załadowaniu pulpitu). Wyłączyłem też "szybkie uruchamianie" opcjach Zasilania Energia, checkdisk nie znikał z ekranu przy startowaniu windowsa i przeważnie komp się restartował a próba naprawy BCD kończyła się niepowodzeniem. Szczerze to byłem w szoku bo z Windows 7 nie było takich problemów (oprócz wspomnianej hibernacji) p.s. niestety blik boot z Clovera nie zadziałał z Grubem, wyskakuje błąd w stylu (piszę z pamięci) "no multiboot signature found". p.s.1 moje pytanie odnośnie bootwania EFI z pendrive'a pozostaje aktualne. -- pozdrawiam fingerr
  8. Witam, odświeżę temat bo mam problem właśnie z dyskiem 4k (ST500LM000). Po wczorajszej całodziennej walce z uruchomieniem zintegrowanej grafiki (Intel HD Graphics 1st gen.) zachciało mi się pozbyć pendrive'a z Cloverem coby się Mac OS odpalał bezpośrednio z HDD. Chciałem zostawić obecny Grub2 jako bootloader i chainload'ować boot0 do odpalenia Chameleona/Chimery/Clovera (nie znalazłem info czy da się Clovera odpalić z Grub2, ale jak powiadają próba nie strzelba). Próbowałem już chyba wszystkiego co znalazłem w sieci, czyli dd if=boot1h of=/dev/sda4 (/dev/rdisk0s4) bs=4096 (bez bs) (z instalera Mac OS, z innej instalacji Mac OS w trybie single user, z Ubuntu (nie LiveCD bo mam zainstalowany na HDD)) i niestety zawsze kończy się tak samo: Boot0: Done Boot: Error Podział partycji (MBR): sda1 - ntfs (windows) sda2 - ntfs (dane) sda3 - ext4 (ubuntu) sda4 - HFS (OSX ML) Jakieś pomysły? -- pozdrawiam fingerr Asus U30JC, Core i5-560M, 6GB RAM, 1st Gen HD Graphics, Nvidia 310M (wyłączona modyfikacją w DSDT), 500GB HDD
  9. Wielkie dzięki za info. Niestety nie mogę skompilować niezmodyfikowanego dsdt.dsl (ponad 200 błędów kompilacji...) Założyłem nowy temat http://hamac.pl/topics36/speedstep-na-a ... vt3875.htm może ktoś już walczył z tym notkiem. p.s. Może za jakiś czas ktoś wymyśli jak podmienić/pchnąć LPC z poziomu com.apple.Boot -- EDIT Jeszcze jedno pytanie: czy wpisy w IOregu CPUPLimit i CSTInfo są widoczne tylko przy załadowanym AppleIntelCPUPM.kext? Chodzi mi o sprawdzenie czy system jest 'PM ready' Jak wrzuce AppleIntelCPUPM i dostaje KP to musze odpalac z plytki instalacyjnej zeby usunac tego kext'a a to chwile trwa ... -- EDIT 2 Udało się... Wygląda że moim przypadku wpis GraphicsEnabler ustawiony na Yes w com.apple.Boot powodował całe zamieszanie... Przy okazji, czy "poprawne załadownie" LPC można zweryfikować tylko po widoczności opcji restart on power failure w ustawieniach 'Power Settings'? Podziękowania za pomoc. Pozdrawiam, fingerr
  10. Witam, posiadam następujący sprzęt niestety za nic nie mogę odpalić SpeedStep'a. Podczas ładowania systemu dostaje KP podczas ładowania AppleIntelCPUPowermanagement.kext. Poniżej dane sprzętu 1. Asus U30JC, BIOS U30Jc.215 (12/23/2010) 2. Intel® Core i5 CPU M 560 @ 2.67GHz (x86, x86-64, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, AES) 3. HM55 4. Brak dodatkowego 5. Intel GMA HD / NVIDIA GeForce 310M (512 MB) (Nvidia Optimus) 6. Realtek ALC269 @ Intel Ibex Peak PCH 7. Atheros AR8131 PCI-E Gigabit Ethernet Controller 8. Atheros AR9285 Wireless Network Adapter 9. 5 Series 4 Port SATA AHCI Controller, WDC WD5000BEVT-80A0RT0, MATSHITA DVD-RAM UJ890AS 10. Wbudowana - Klawiatura oraz TouchPad PS/2 W załączeniu tabele acpi z everest'a (próbowałem skompilować bez modyfikacji ale dostaję ponad 200 błędów) Proszę o pomoc i wskazówki jak się do tego zabrać. -- EDIT Udało mi się poprawić i skompilować DSDT.aml niestety dalej nie widzę w IORegu CPUPLimit i CSTInfo. W DSDT w sekcji SBRG poprawiłem device-id na takie jak mam u siebie - 3B09 (0x09, 0x3B, 0x00, 0x00 ). Mój smbios.plist ?xml version="1.0" encoding="UTF-8"?> SMbiosvendor Apple Inc. SMbiosversion IM111.88Z.0034.B00.0910301727 SMbiosdate 10/30/09 SMboardmanufacturer Apple Computer, Inc. SMboardproduct Mac-F2268DAE SMfamily iMac SMmanufacturer Apple Inc. SMproductname iMac11,1 SMserial G81013257W87 SMsystemversion 1.0 -- EDIT 2 Wysłany: Wczoraj 14:26 rzooff napisał/a: Pchnąć LPC = zrobić stosowną poprawkę w DSDT, która podmienia DeviceID LPC. dodać wpisy CST PST = dodać je (GeneratePStates=Yes i GenerateCStates=Yes) do apple.com.Boot.plist, a resztę załatwia Chameleon. Bez tego, w przypadku kopmuterów gdzie nie ładowały się poprawnie owe stany procesora, trzeba było dopisywać wszystko ręcznie jako nową sekcję procesora (dość uciążliwe i czasochłonne). Uruchomienie natywnego PM zawsze wiąże się z poprawianiem DSDT. Tylko tych poprawek może być mniej lub więcej, zależnie od sprzętu, biosu... SMBIOS należy dobrać wg. konfiguracj jaką posiadasz. Przede wszystkim chodzi o identyfikację typu maszyny - przykłądy działających: Kod: MacPro3,1 MacBookPro5,1 iMac11,1 SMbiosversion wynika z identyfikacji sprzętu, a reszta to już kosmetyka. Jeśli masz pytania związane konkretnie ze swoim sprzętem, to pytaj w odzielnym wątku. W takim wypadku podaj konfigurację wg poradnika (link np. w mojej stopce). Wielkie dzięki za info. Niestety nie mogę skompilować niezmodyfikowanego dsdt.dsl (ponad 200 błędów kompilacji...) Założyłem nowy temat http://hamac.pl...560m-vt3875.htm może ktoś już walczył z tym notkiem. p.s. Może za jakiś czas ktoś wymyśli jak podmienić/pchnąć LPC z poziomu com.apple.Boot -- EDIT Jeszcze jedno pytanie: czy wpisy w IOregu CPUPLimit i CSTInfo są widoczne tylko przy załadowanym AppleIntelCPUPM.kext? Chodzi mi o sprawdzenie czy system jest 'PM ready' Jak wrzuce AppleIntelCPUPM i dostaje KP to musze odpalac z plytki instalacyjnej zeby usunac tego kext'a a to chwile trwa ... -- EDIT 2 Udało się... Wygląda że w moim przypaku wpis GraphicsEnabler ustawiony na Yes w com.apple.Boot powodował całe zamieszanie... Z góry dziękuję i pozdrawiam, fingerr. Everest.zip
  11. Witam, miałbym do Ciebie prośbę abyś trochę jaśniej opisał: - pchnąć LPC, (jak ot sprawdzić czy działa) - dodać wpisy GenerateCState i GeneratePState Czy przy tej metodzie nie jest wymagane paczowanie DSDT? Jakie opcje w com.apple.Boot (DropSSDST... itp) Jakie wpisy w smbios.plist (SMbiosversion, SMproductname, itp... ) i czy zależne od typu procka (mój i5-560M). Jeśli możesz to napisz jakieś krok po kroku jak to odpalić. Staram się od paru dni odpalić vanilla AppleIntelCPUPowerManagement na 10.6.6 i zawsze kernel panic Mój sprzęt: Asus U30JC, i5-560M, 4GB RAM Z góry dziękuję i pozdrawiam, fingerr.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.