Jump to content

Camerimage

Members
  • Content Count

    29
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Zanim spróbuję z Big Sur, to chciałbym jeszcze sprawdzić zrobienie aktualizacji Cataliny na wbudowanej karcie graficznej i potem uruchomienie Radeona 5700 - czy to zły pomysł? Tu mam pytanie, czy żeby to zrobić, to powinienem fizycznie wyjmować kartę, czy mogę zablokować jej działanie systemowo? Rozumiem, że aby posłużyć się tylko iGPU, to muszę: - przełączyć w BIOSIE sygnał grafiki z pci-e na iGPU - AAPL,ig-platform-id - 07009B3E - rozumiem, że w boot-args NVRAM powinienem wyrzucić agdpmod=pikera ? Czy w boot-args NVRAM powinienem używać argumentu: -wegnoegpu ? Czy jeśli go użyję to nawet jeśli nie wyjmę karty z płyty głównej, to zostanie ona wyłączona za pomocą tego argumentu? Czy coś jeszcze powinienem zrobić, żeby wykorzystać tylko iGPU? Płyta główna dysponuje wyjściem HDMI i DisplayPort. Czy DisplayPort musi być uruchamiany w jakiś szczególny sposób, bo widzę sygnał na monitorze tylko po podłączeniu z HDMI? Proszę o wyrozumiałość, jeśli pytania są z grupy bardzo podstawowych, ale cel mam taki, żeby jednak ten komputer wykorzystać w mojej pracy montażysty:) Chociaż widzę, że błędem był zakup 5700xt zamiast sprawdzonych Radeonów montowanych w seryjnych Macach. Dzięki za pomoc
  2. Bios sprawdzę jeszcze raz, ale siedziałem już nad tą kwestią i wydaje mi się, że wszystko jest Ok. A może to jest kwestia SMBIOS? Znalazłem taki przykład na YouTube: https://youtu.be/0lGEmID3Dew W tym przykładzie jest dokładnie taka karta graficzna jak moja. Co prawda system zainstalował bez niej, ale później rozpoznaje ją jak należy i działa bez kłopotów. Z tym że za każdym razem podkreśla, że SMBIOS TO Mac 1,1 pro. Czy w moim zestawie mogę użyć powyższego SMBIOS? Czy to nie tędy droga?
  3. Config który zrobiłem przy użyciu powyższego narzędzia zatrzymuje zupełnie proces uruchamiania komputera bez wyłączenia. W załączniku moje EFI i log, który pojawia się przy nieudanej aktualizacji Cataliny. Chyba jutro zacznę od nowa studiowanie tematu. Na obecna chwilę nie mam pomysłu co dalej:) Dziękuje za pomoc EFI.zip Installer Log 22-Sep-2020.txt
  4. Aktualizacja się rozpoczyna, ale w pewnym momencie bez restartu i wyłączenia komputera zapada czarny ekran. Rozumiem, że to znowu jakiś kłopot z pracą karty graficznej? Co powinienem w tej sytuacji jeszcze sprawdzić, zmienić? Dzięki za pomoc
  5. Zaktualizowałem Bios. Odblokowałem rejestr MSR 0xE2, chciaż w ustawieniach Biosu nie pojawiło się pole "CFG Lock" (screen w załączniku) i nie wiem dlaczego??? Kiedy wpisywałem komendę sprawdzającą stan CFG-Lock podczas aktualizacji Biosu, to wyskakiwała mi informacja jak na dołączonym screenie, z której wynika, że wartość dla 0x5C1 jest 0. Kiedy sprawdzam ten rejestr za pomocą narzędzi HakintoshTool (creen w załączniku), to widzę, że CFG Lock ma wartość "MSR not locked". Tak czy inaczej MSR 0xE2 rozumiem, że został odblokowany, chociaż nie mogę sterować CFG Lock z poziomu ustawień Biosu? Czy teraz mogę przeprowadzić aktualizację Cataliny? Czy mam zrobić nowa instalację z pendriva z wersją 10.15.6?
  6. Udało się! Na pendrive instalacyjnym USB miałem Catalinę w wersji 10.15.3. Po zamianie na wersję podstawową 10.15 instalacja poszła bez kłopotu. Jak najlepiej przeprowadzić aktualizację do 10.15.6?
  7. Jeszcze raz zrobiłem Config.plist używając OpenCore-0.6.1-RELEASE. Config sprawdziłem przez OpenCore Sanity Checker. Wszystko wygląda ok. Niezależnie od tego czy włączam czy wyłączam iGPU ciągle jest ten sam kłopot. Komputer wyłącza się. Tuż przez pojawia się plansza z postępem instalacji, a po niej screen (w postaci dwóch fotografii w załączniku). Nie ma za bardzo pomysłu gdzie szukać problemu. Czy to jest kwestia poszukiwania właściwego AAPL,ig-platform-id? Czy kwestia SMBIOS, czy może źke przygotowałem pliki ACPI? A może powinienem najpierw zainstalować system na wbudowanej karcie graficznej i wyjętej głównej? Pomocy! Dołaczam EFI. EFI.zip
  8. W najnowszych wersjach OC jest katalog Bootstrap z plikiem Bootstrap.efi. Za co on odpowiada? Jak jest z włączaniem/wyłączaniem SIP przy instalacji Cataliny?
  9. Zmieniłem AAPL na 0300913E, ale to nie zmieniło sytuacji. Pojawia mi się jeszcze dłuższa pauza przy tekście na załączonym screenie.
  10. Argument agdpmod=piker dopisałem, ale to nie zmieniło sytuacji. iGPU w Biosie jest Enable, a Radeona ustawiłem jako główną, a reszta parametrów zmiennych dotyczy rezerwacji pamięci. iGPU jako headless czyli co powinienem zrobić? Wydaje mi się, że przejrzałem poradnik, ale będę wdzięczny za wskazanie gdzie dokładnie w treści poradnika, bo może przegapiłem. W tej chwili instaluję bez kekstu EverGreen, ale widzę, że najnowsza wersja tego kekstu jest umieszczana z dodatkami dwóch plików DSDT - w jakim celu, do jakich sytuacji? Co do dysku, to dorzuciłem NVMeFix, ale chyba z Samsungiem 970 pro nie ma problemu, zresztą na obecną chwilę instaluję na ssd. Taktowanie RAMU mam na 2666.
  11. Wyrzuciłem kext: WhateverGreen i instalator poszedł dalej. Rozumiem, że grafika i bez niego sobie poradzi? Pliki Cataliny skopiowały się na dysk twardy, ale po restarcie i kolejnym etapie instalacji komputer się wyłącza (koncowy skreen w załączniku). Czy zmienić wersję OC i zacząć od nowa, czy pracować na tym samym EFI? EFI_2.zip
  12. Jednak potrzebuję większej pomocy, niż myślałem.:) Dzięki za poradniki. Według nich przygotowałem USB, opracowałem config - EFI w załączniku. Ale w pewnym momencie instalacji pojawia się czarny ekran, ale komputer nie restartuje (ostatni zrzut ekranu z tekstem instalatora w załączniku). Do tego przy starcie biosu wyświetla sie lista komunikatów (zrzut w załączniku). Nie mogłem też znaleźć informacji o prawidłowych ustawieniach APFS w konfigu ( czy takie jak w sreenie w załączniku?). Mam jeszcze zasadnicze pytanie co do tworzenia DSDT. Jeśli zastosuję narzędzie acpidump.efi z poziomu UEFI Shell, to na USB zostają wygenerowane pliki dsdt.dat - jest ich aż 256 ponumerowanych od o do 255. Dlaczego powstaje ich aż tyle? Co mam dalej z nimi zrobić i jak ich użyć? Jak rozumiem jest to najlepsza metoda, żeby zbudować własne DSDT? I jeszcze jedno pytanie. Być może to od niego powinienem zacząć: jest kilka aktualizacji Open Core - ostatnio 0.6.1. Której należy użyć? Pracowałem na tej ostatniej. Ta najnowsza nie potrzebuje odrębnego pliku do APFS? pozdrawiam i dziękuję za pomoc EFI.zip
  13. Dziękuję za odpowiedź. Chętnie spróbuję OpenCore, ale przyznam szczerze, że mam minimalną wiedzę o OC. Nie wiem, czy to właściwe miejsce na zadawanie takich pytań, ale od czego powinienem zacząć zabawe z OpenCore? Jakie najlepsze źródło wiedzy? Rzuciłem okiem w necie i pierwsze pytanie jakie mam, to na jakim komputerze najlepiej przygotować te wszystkie pliki butujące? W tej chwili mam pod ręką Maka z Maverickiem, na którym mam virtualną maszyne z Windows 8 i Linuxem. No i nowy komputer, na którym chciałem zainstalować Catalinę. Czy warto instalować na tymże nowym komputerze na przykład windowsa, żeby na tym konkretnym urządzeniu, na którym będzie docelowy system, sporządzić instalacyjnego USB? Dziękuję za pomoc i pozdrawiam
  14. Witam serdecznie, mam taki zestaw: Intel i9-9900K Gigabyte Z390 Designare Pamięć (128GB) G.Skill Trident Z RGB, DDR4, 4x32GB, 3200MHz, CL16 MSI Radeon RX 5700 XT Gaming X Dysk M2 Samsung 970 pro 500GB Dysk M2 WD 500GB chłodzenie procesora Fractal Design Celsius s36. Chcę na nim zainstalować Cataline. Bios płyty głownej zaktualizowałem z wersji F8 do F9b. Czy to dobrze, czy źle? Według informacji producenta zmiana dotyczyła: Enhance RAID AIC compatibility Fix CPU Vcore and power behavior Ustawienia Biosu zrobiłem według dostępnej wiedzy internetowej. Tutaj mam pytanie, czy wewnętrzna karta grafiki powinna być włączona na czas instalacji? Przygotowałem pedriva z Cloverem. EFI w załączniku. Sa tam dwie wersje, o czym niżej. Wydaje mi się, że Clover ładuje wszystko jak należy. Uruchamia się instalator Cataliny - wybieram dysk do instalacji, następuje kopiowanie plików na dysk. Na około 2 minuty (według paska postępu) następuje restart: przez chwilę kręci się kółeczko postępu, a następnie uruchomienie ponowne komputera i instalator chce od początku robić całą instalacje. Spróbowałem uruchomić instalacje z tych plików, które już zostały skopiowane na dysk twardy, ale tutaj dochodzi do momentu kiedy na chwilkę pojawia się plansza z początkiem pasku postępu instalacji Cataliny i następuje restart. W czym jest problem? Wersja EFI_0 była moją początkową, a EFI po kilku modyfikacjach w pliku config Clovera i dodaniu dodatkowych patchów, driverów (podmieniłem AptioMemoryFix.efi na OsxAptioFix3Drv.efi) i kextów. Różnica w efekcie końcowym jest taka, że wcześniej tam, gdzie teraz następuje restart komputera, to było zawieszenie się komputera (tak wnioskuję, bo bezczynność była godzinna i zamrożenie myszki). Czy powodem może być nieodpowiedni smbios? Czy instalację Cataliny należy zacząć od wersji 15.0, czy może to być na przykład 15.3, bo taką mam na USB instalacyjnym? Czy to może być powód? Pozdrawiam EFI_0.zip EFI.zip
  15. Wystarczy mi nawet jedno złącze TB. Dzięki za wskazanie płyty i pomoc!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.