Jump to content

DKnoto

Members
  • Content Count

    292
  • Joined

  • Last visited

  • Days Won

    6

Everything posted by DKnoto

  1. Tu masz przewodnik jak należy do tego podejść na Mojave https://www.tonymacx86.com/threads/guide-intel-framebuffer-patching-using-whatevergreen.256490/
  2. Konfiguruję system po instalacji stosując się do zaleceń z tego przewodnika. Dojechałem do punktu 7b) DSDT Patching: zrobiłem dekompilację przy pomocy załączonego iasl 20161210-64 wczytałem plik DSDT.dsl do programu MaciASL i zgodnie z poradą wykonałem kompilację. I tu mocno się zdziwiłem, plik nie skompilował się, dostałem następujące błędy: W związku z tym sprawdziłem co uzyskam dekompilując te na Fedorze, iasl 20181213. Oto co uzyskałem, Plik z macOS: If (PM6H) { CreateDWordField (BUF0, \_SB.PCI0._Y0C._LEN, ECLN) // _LEN: Length Store (Zero, ECLN) } If (LEqual (PM6H, One)) { CreateBitField (BUF0, \_SB.PCI0._Y0C._RW, ECRW) // _RW_: Read-Write Status Store (Zero, ECRW (If (PM0H) { CreateDWordField (BUF0, \_SB.PCI0._Y0D._LEN, F0LN) // _LEN: Length Store (Zero, F0LN) })) } Plik z Linuks/Fedora 29: If (PM6H) { CreateDWordField (BUF0, \_SB.PCI0._Y0C._LEN, ECLN) // _LEN: Length ECLN = Zero } If ((PM6H == One)) { CreateBitField (BUF0, \_SB.PCI0._Y0C._RW, ECRW) // _RW_: Read-Write Status ECRW (If (PM0H) { CreateDWordField (BUF0, \_SB.PCI0._Y0D._LEN, F0LN) // _LEN: Length F0LN = Zero }) = Zero } Różnica: Różnice wynikają głównie ze zmian w składni ale sens chyba jest taki sam i na pierwszy rzut oka to powinno się chyba skompilować? Co ciekawe kompilacja tego co zrzucił iasl na Linuksie też się nie powiodła: iasl DSDT.dsl: Intel ACPI Component Architecture ASL+ Optimizing Compiler/Disassembler version 20181213 Copyright (c) 2000 - 2018 Intel Corporation Compiler aborting due to parser-detected syntax error(s) DSDT.dsl 3939: ECRW (If (PM0H) Error 6126 - ^ syntax error, unexpected PARSEOP_IF, expecting PARSEOP_CLOSE_PAREN or ',' DSDT.dsl 3940: { Error 6126 - ^ syntax error, unexpected '{' DSDT.dsl 3943: }) = Zero Error 6126 - ^ syntax error, unexpected PARSEOP_CLOSE_PAREN DSDT.dsl 17175: If (LIDS (^GFX0.GLID (0x03), Else Error 6126 - ^ syntax error, unexpected PARSEOP_ELSE, expecting PARSEOP_CLOSE_PAREN or ',' DSDT.dsl 17202: Error 6126 - syntax error, unexpected PARSEOP_METHOD, expecting $end and premature End-Of-File ASL Input: DSDT.dsl - 17202 lines, 993672 bytes, 6305 keywords Co w takim przypadku radzicie zrobić?
  3. Gdyby kogoś interesowało czy się da to melduję, że po trzech dniach walki udało mi się zainstalować Mojave 10.14.3 na wyżej wymienionym sprzęcie. Planuję przygotować szczegółowy raport ale chcę jeszcze przetrenować ponownie instalację, aktualizację do 10.14.4 i odpalenie karty Wi-Fi. Na ten ostatni element muszę niestety poczekać, oryginalna karta Intela nie działa z macOS.
  4. Do katalogu EFI/CLOVER/drivers64UEFI musisz dograć plik AptioMemoryFix-64.efi. Do wyboru są trzy wersje tego pliku, eksperymentalnie trzeba wybrać jedną z nich.
  5. W Cloverze dodaj w opcjach "-v" to wtedy będziesz miał więcej komunikatów i zobaczysz co się dzieje.
  6. Chętnie bym tak robił gdyby silnik forum robił znaczniki czasowe kiedy wstawiałem dany tekst i łączyło to w jedno. Co do „niepisanych” zasad to skoro nie są spisane to nie są zasadami tylko zwyczajami.
  7. @314TeR @reyder Możliwe, że przegięcie, nie zastanawiałem się nad zwyczajami panującymi na forum. Jestem „w ciągu” i chciałem w rozsądnym czasie uzyskać jakiś efekt a tu czego się człowiek nie dotknie to pod górkę PS. Zaraz scalę te posty w jeden.
  8. Może przydałoby się łączenie na żądanie. Co do spamu to chyba nie ma obowiązku czytania?
  9. @314TeR Czy da się osadzić link do zewnętrznego obrazka tak aby miniatura określonych rozmiarów była widoczna jako obrazek? Coś w stylu [image=link_do_obrazka;width=rozmiar]Opis pod obrazkiem[/image].
  10. Na to nie wpadłem, zaraz sprawdzę.
  11. U mnie też się ładnie wszystko zainstalowało ale potem klikam na ikonę i nic. Coś mignie i znika.
  12. Nie miałem złych intencji w tym pytaniu o karty, myślałem, że kolega sam to przygotował. Ja wybieram zawsze wariant minimalistyczny przy instalacji bo przy maksymalistycznym zawsze coś mi nie grało
  13. Wrzuciłeś kexty do trzech różnych rodzin kart sieciowych dlatego pytam.
  14. To WiFi to jakaś totalna masakra. Pod Linuksem widzę sieci ale co ciekawe nadajnik, który mam 30 cm od NUC'a ma prawie zerowy poziom sygnału. Z drugiej strony próbowałem znaleźć coś na miejscu, co jest polecane że działa, np. Broadcom BCM94352HMB ale to praktycznie w Polsce produkt niedostępny. Jak tak dalej pójdzie to będę musiał zamówić kartę w AliExpress i czekać na dostawę do połowy czerwca
  15. @314TeR Zauważyłem na niektórych instalacjach, że w czasie bootowania mniej więcej w połowie, zamieniają się kolory z jasnego na ciemne. Czy to można jakoś włączyć? Bo w tej chwili na NUC mam cały czas jasne jabłko i pasek postępu na ciemnym tle. Skończyłem walkę z kartą Atheros AR9462: dorzuciłem kexty ATH9KFixup i ATH9KInjector - po tej operacji pojawił się Bluetooth w systemie, tzn. ikona w preferencjach i info w raporcie; przegrałem kext AirPortAtheros40.kext z 10.13.6; przebudowałem cache kextów - tu dostałem dziwny błąd: Kext with invalid signatured (-67054) allowed: <OSKext 0x7f8aeebf3800 [0x7fff9c1ec8f0]> { URL = "IO80211Family.kext/ -- file:///System/Library/Extensions/", ID = "com.apple.iokit.IO80211Family" } zrestartowałem maszynę i zobaczyłem obsługę WiFi w systemie. Wydawało się, że odniosłem pełen sukces ale to było niestety złudzenie System nie wykrywa żadnego urządzenia Bluetooth ani żadnej sieci WiFi 😭 PS. Zaraz sprawdzę tę kartę pod Linuksem.
  16. O Logitechu wiem, używam ich oprogramowania do MX Master 25. Generalnie kupa bajerów ale czułości dobrze ustawić się nie dało.
  17. @Maidenman spróbuję zmienić myszkę, mam jeszcze jednego Logitecha. Przepięcie w „w locie” zadziałało, przewijanie też działa poprawnie, szybkość muszę tylko podregulować.
  18. @314TeR może nieprecyzyjnie się wyraziłem, ponieważ efekt był bardzo dziwny. Jak wszedłem w edytor to dostałem treść ostatniego wpisu i myślałem, że się połączą. Okazało się, jednak, że się nie połączyły ale uwagę zostawiłem abyś wiedział co się dzieje.
  19. Witam, Mam dosyć dziwną sytuację z Cloverem. Jeżeli włączę komputer i niczego nie dotykam to po trzech sekundach od pojawienia się planszy startowej Clovera odpala mi się ładowanie systemu, dochodzi do pokazania jabłka, potem chwila jest czarno i następuje restart maszyny. Cały proces powtarza się. Jeżeli jednak przed upływem 3 sekund nacisnę ENTER to system ładuje się poprawnie. W przypadku gdy ruszę strzałkami i przesunę podświetlenie na inną partycję, np. Recovery, i ponownie wrócę do partycji domyślnej to start systemu jest losowy, raz się restartuje a kiedy indziej startuje normalnie. Czy coś da się poprawić z tym automatycznym startem czy zostaje tylko czekanie na poprawionego Clovera?
  20. Jeśli chcesz to ukryć to w sekcji GUI jest grupa Hide: <key>GUI</key> <dict> <key>Hide</key> <array> <string>Preboot</string> </array>
  21. Dzięki @AdamiPL, nie wiem jakim cudem ale tego nie zauważyło moje wyszukiwanie Już sprawdzam. +10 minut Sprawdzone, aplikacja się instaluje ale na 10.14.4 nie odpala PS. Czy można jakoś wyłączyć to łączenie wypowiedzi oddzielonych czasowo więcej niż np. minuta bo jak dla mnie to robi się mocno IRYTUJĄCE.
  22. Dzięki @AdamiPL, nie wiem jakim cudem ale tego nie zauważyło moje wyszukiwanie Już sprawdzam.
  23. Karta pracowała pewnie w trybie VESA, wtedy pokazuje tylko ile ma bufor ramki obrazu 1440 x 900 x 3B = 3 888 000B.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.