Jump to content

brx

Members
  • Content Count

    14
  • Joined

  • Last visited

  1. Ok, poszło. Prawdopodobnie jakieś problemy z pendrivem lub inicjacją portów USB podczas instalacji, bo po przełożeniu do innego, wszystko poszło bezproblemowo. Dzięki.
  2. Mogę prosić o udostępnienie Twojego EFI. Mam bardzo podobną konfigurację i trochę problemów z uruchomieniem Mojave.
  3. Cześć, Na wstępie chciałbym podziękować wszystkim osobom za czas poświęcony w przygotowanie tego forum i narzędzia (UniBootX). Po rozsypaniu dysku SSD z El Captain udało mi się postawić HS 10.13.2 i wygląda na to, że działa wszystko co powinno. Poniżej moja konfiguracja sprzętową wraz z opisem modyfikacji jakie wprowadziłem. Sprzęt: Procesor: i5-4690K (Haswell), Grafika (zintegrowana): Intel HD4600 Płyta: MSI Z97 Gaming 3 (MS-7918) Dźwięk (zintegrowana): Realtek ALC1150 Karta sieciowa (zintegrowana): Killer E2200 Gbit Ethernet RAM: 2x Crucial Ballistix 1600 DDR3 8GB Dyski: Samsung SSD 850 EVO 250GB (macOS) Samsung SSD 840 EVO 250GB (backup) Crucial SSD M4 128GB (WIN 10) Soft: 1. Pendrive 8GB z instalką High Sierra pobraną z App Store (10.13.2): Odpalamy Terminal i wpisujemy: diskutil list lub ls /Volumes/ by wyszukać nazwę nazwę pen'a pod jaką został zamontowany w naszym systemie. Następnie tworzymy bootowalne USB z instalką systemu, wpisując w terminalu: /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/nazwa_dysku --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction gdzie 'nazwa_dysku' to nazwa pendrive (sprawdzona wcześniej). Czekamy kilka/kilkanaście minut i gotowe. 2. Pendrive 16GB przygotowany zgodnie z poradnikiem http://hamac.pl/topic/11716-unibootx-clover-oficjalny-uniwersalny-bootloader-hamacpl/ z drobnymi zmianami: Pkt 4.1. Nazwa płyty ustawiona na MS-7918 (zmieniona nazwa katalogu Haswell Z97). Pkt 4.4. Nr wygenerowane przez Clover configurator (SMBIOS dla iMac14,2). Pkt 4.5. pomimo proca Haswell nie generowałem tabeli SSDT ani skryptem pike'a ani w żaden inny sposób. Pkt 4.6. W domyślnej konfiguracji dźwięk działa tylko do uśpienia. Po wybudzenia macOS z uśpienia, dźwięk jest na bardzo niskim, prawie niesłyszalnym poziomie. Jak sobie z tym poradzić opiszę poniżej. INSTALACJA SYSTEMU Właściwie wszystko poszło bezproblemowo. System zainstalowany, uruchomiony, działa iMessage, App Store i wszystko inne. W celu przygotowania systemu do uruchomienia z dysku a nie pendrive, zainstalowałem Clover EFI r4359 na partycji EFI dysku, na którym jest zainstalowany system i skopiowałem zawartość katalogu EFI z pendrive z UniBootX. MODYFIKACJE Ponieważ domyślny konfig zawiera trochę więcej kext'ów niż jest wymagane przez moją konfigurację, usunąłem z katalogu: /Volumes/EFI/EFI/CLOVER/OEM/MS-7918/kexts następujące pliki: HDMIAudio IntelMausiEhternet RealtekRTL8111 SATA_Legacy WhateverGreen Z97LPC CPUSensors LPCSensors GPUSensors USBInjectAll ewentualnie można zmienić config: /Volumes/EFI/EFI/CLOVER/OEM/MS-7918/config.plist wpisując: <key>DisableDrivers</key> <array> <string>VBoxHfs</string> <string>OsxAptioFixDrv</string> <string>OsxLowMemFixDrv</string> <string>DumpUefiCalls</string> <string>EmuVariableUefi</string> <string>FSInject</string> <string>DataHubDxe</string> <string>CsmVideoDxe</string> <string>PartitionDxe</string> <string>CPUSensors</string> <string>GPUSensors</string> <string>LPCSensors</string> <string>HDMIAudio</string> <string>IntelMausiEthernet</string> <string>RealtekRTL8111</string> <string>SATA_Legacy</string> <string>USBInjectAll</string> <string>WhateverGreen</string> <string>Z97LPC</string> </array> Kilka zaktualizowałem: AppleALC do wersji 1.2.2 FakeSMC I trzeba było kilka dodać: FakeSMC_ACPISensors FakeSMC_CPUSensors FakeSMC_GPUSensors FakeSMC_LPCSensors CodecCommander Słowo komentarza odnośnie ostatniego kexta a mianowicie CodecCommander. Ten sterownik miał rozwiązywać problem z dźwiękiem po wyjściu z uśpienia systemu. Niestety domyślna konfiguracja nic nie zmieniła i dopiero po modyfikacji zawartości pliku: /Volumes/EFI/EFI/CLOVER/OEM/MS-7918/kexts/Other/CodecCommander.kext/Contents/Info.plist uzyskałem właściwy efekt. Wprowadzone zmiany dla klucza Realtek ALC1150 poniżej: <key>Realtek ALC1150</key> <dict> [...] <key>Sleep Nodes</key> <true/> <key>Update Nodes</key> <true/> </dict> Na chwilę obecną nie zauważyłem żadnych problemów. Dla osób, które mają podobną konfigurację, zamieszczam swój katalog EFI ze wszystkimi zmianami opisanymi powyżej. Usunąłem tylko nr seryjne płyty - można je sobie ponownie wygenerować. Jeżeli macie jakieś pytania, to śmiało. Może uda mi się pomóc. EFI.zip
  4. Hej, Mam praktycznie taką samą konfigurację jak Ty (bez dedykowanej karty graficznej). Może udostępnić swój config.plist i wszystkie zainstalowane kexty?
  5. KernelPM odpowiada za wykorzystanie odpowiednich rejestrów procesora. Jak widzicie, każdy z nas ma inny, więc być może w Waszej konfiguracji wymagany jest ten parametr.
  6. Możliwość jest, ale problemów też trochę: http://www.tonymacx86.com/mavericks-laptop-support/114657-osx-mavericks-asus-g750jx-installation-guide.html
  7. Problem z KP rozwiązany. Jeżeli jest ktoś zainteresowany konfigiem dla tej płyty, to wrzucam dla konfiguracji: MSI Z97 gaming 3 i5-4690K HD4600 2 x Crucial DDR3 1600Mhz 8GB 2 x Samsung EVO 840 (250GB) 2 x Toshiba 5400 rpm (250GB) w raid softwareowym Co zmieniono: dodano obsługę 21 portów XHC (USB 3.0 jest liczony jako 2 porty, a domyślnie można użyć 15 portów), dodano obsługę wszystkich portów jako USB 2.0 i 3.0 (oprócz tych czerwonych), dodano patch do usunięcia problemu podczas logowania (rozjeżdżające się logo), dodano obsługę TRIM z dysków SSD nie od Apple'a, usunięto kilka modułów kernela (kextów) nie związanych z tą płytą. Problem z czarnym ekranem przy restarcie okazał się problemem z wykorzystaniem DisplayPort. Poprzez HDMI działa bez zarzutu. Poniżej config.plist (/Volumes/EFI/CLOVER) i kext do obsługi USB (/Volumes/EFI/CLOVER/kexts/10.11/) config.plist.zip USB_Injector.kext.zip Miłego
  8. Wrzuca się na Onedrive. Rano powinien być obraz dmg.
  9. Ten kext USB-Inject... ma zmapowane dwa porty USB 2.0 z tyłu obudowy (czerwone w górnym rzędzie, podpinam tam tylko klawiaturę i mysz). Reszta portów 4 USB 3.0 z tyłu i 2 wyprowadzone na obudowie mam zmapowane tylko na USB 3.0, więc urządzenia w standardzie 2.0 raczej nie będą chodzić. Jeżeli chodzi o dźwięk, to spróbuj tego z zamontowaną partycją EFI: audio_cloverALC-110_v1.0h.command.zip Niestety z monitorem mam podobnie, ale tylko po restarcie i do momentu wyświetlenia menu logowania.
  10. config.plist.zip Powyżej masz mój config (do podmiany na partycji EFI w katalogu EFI/Clover). Musisz zmienić w nim nazwę swojego dysku, z którego uruchamiasz OSX (sekcja Boot, DefaultVolume): <key>Boot</key> <dict> <key>Arguments</key> <string>dart=0</string> <key>CustomLogo</key> <false/> <key>Debug</key> <false/> <key>DefaultVolume</key> <string>MacSSD</string> W katalogu /EFI/CLOVER/kexts/10.11 mam kext do audio i zmodyfikowany pod USB, też załączam kexts.zip Spróbuj z wykorzystaniem powyższego a ja w międzyczasie przygotuję Ci obraz swojego pena instalacyjnego.
  11. Najłatwiejszym sposobem byłoby udostępnienie obrazu z mojego pena instalacyjnego. Jest na nim El Capitan 10.11 (postaram się go wrzucić na skydrive'a). Wg mnie metoda z wykorzystaniem tego bootloadera (UniBootX) nie jest zbyt przyjazna dla użytkownika.
  12. Na tej płycie i procku El Capitan 10.11.1 śmiga u mnie elegancko.
  13. Mam tę samą płytę i w tej chwili wszystko działa sprawnie (łącznie z wszystkimi portami USB 3.0). Rozwiązaniem kłopotów z instalacją było dobranie odpowiedniego pliku konfiguracyjnego (takiego, który obsługuje procesory ze zintegrowaną grafiką HD4600 - ja mam i5 4690K). Podaj link do poradnika z którego korzystałeś, to sprawdzę czy różniła się moja instalacja. Wieczorem podeślę też listę kextów z których obecnie korzystam. Mogę też udostępnić ten do obsługi USB 3.0, który stworzyłem dla tej płyty.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.