Jump to content
314TeR

Uniwersalne Legacy AppleHDA dla ALC882 883 888 1200 892 1150 dla Yosemite 10.10 , El Capitan 10.11

Recommended Posts

Co do mojego posta odnośnie CodecCommandera dla ALC1150: http://hamac.pl/topic/10139-uniwersalne-legacy-applehda-dla-alc882-883-888-1200-892-1150-dla-yosemite-1010-el-capitan-1011/?p=119976

 

Na tej samej wersji mobo ale na różnych BIOSach jest inny efekt - obstawiam winę biosu albo obecność windowsa tylko na jednym kompie - na jednej mobo działa, na drugiej nie.

Zmieniłem w niedziałającej w probilu dla ALC1150 wartość "Sleep Nodes" na true. Poniżej zamieszczam tylko fragment z info.plist dotyczący ALC1150:

				<key>Realtek ALC1150</key>
				<dict>
					<key>Custom Commands</key>
					<array>
						<dict>
							<key>Command</key>
							<data>
							AgUABw==
							</data>
							<key>Comment</key>
							<string>0x20 SET_COEF_INDEX 0x07</string>
							<key>On Init</key>
							<true/>
							<key>On Sleep</key>
							<true/>
							<key>On Wake</key>
							<true/>
						</dict>
						<dict>
							<key>Command</key>
							<data>
							AgR8sA==
							</data>
							<key>Comment</key>
							<string>0x20 SET_PROC_COEF 0x7CB0</string>
							<key>On Init</key>
							<true/>
							<key>On Sleep</key>
							<false/>
							<key>On Wake</key>
							<true/>
						</dict>
					</array>
					<key>Send Delay</key>
					<integer>300</integer>
					<key>Sleep Nodes</key>
					<true/>
					<key>Update Nodes</key>
					<true/>
				</dict>

Sprawa jest cały czas w obserwacji ale wygląda na to, że działa.

Share this post


Link to post
Share on other sites

u mnie (Z97-C) widzi urządzenia audio, ale non przełącza słuchawki na głośniki i dźwięku brak. Wgrany eapdfix i codeccomander.

O dziwo działa audio przez hdmi, ale to miałem zrobione wcześniej. Pomoże ktoś?

Share this post


Link to post
Share on other sites

u mnie (Z97-C) widzi urządzenia audio, ale non przełącza słuchawki na głośniki i dźwięku brak. Wgrany eapdfix i codeccomander.

O dziwo działa audio przez hdmi, ale to miałem zrobione wcześniej. Pomoże ktoś?

 

Sprawdź czy masz wyłączony depop w biosie. 

Share this post


Link to post
Share on other sites

Przełączanie między źródłami to błąd Apple chyba. Wywal EAPDFix i CodecCommander bo ta płyta ich nie wymaga, ponadto nie powinny być oba jednocześnie !

 

Oba wywalone

 

Sprawdź czy masz wyłączony depop w biosie. 

 

depop wyłączyłem i bez zmian.

 

 

Najlepsze jest to, że teraz na windows też nie ma dźwięku i objawy identyczne. Skacze ciągle od słuchawek do głośników i brak dźwięku.

 

...

 

Przedni panel walnął na kompie.

 

...

 

Jednak nie jest to taka jasna sprawa. Po użyciu Waszego sposobu urządzenia są, ale dźwięku brak w głośnikach. Co ciekawe audio hdmi działa i ma się dobrze.

Próbowałem też użyć applehda patchera i tam była do wyboru (po wybraniu alc892) na jednym z nich (na 885 chyba) uwalało dźwięk na amen. Nawet po wejściu do windowsa miałem ten sam problem, że urządzenia się przełączały jak głupie. Ostatecznie musiałem wyjąć baterię z płyty i na windowsie wszystko działa i przedni panel też. Czy to możliwe, że majsterkowanie software'owe na macu może też szkodzić na windows?

Share this post


Link to post
Share on other sites

U mnie na Gigabyte Z97X Gaming 3 ( ALC1150 ) i El Capitan 10.11.2 po patchowaniu dźwięk jest tylko na przednim panelu. Po sleep/wake up dźwięk jest. Ale dlaczego nie ma na tylnym wyjściu dźwięku to nie wiem, na VoodooHDA był ten sam problem ... z tymże tam po sleep/wake up dźwięku już nie było.

 

OK sprawa z tylnym panelem rozwiązana. Automatycznie co prawda nie wykrywa do którego złącza został podłączony jack i trzeba ręcznie zmienić port w Settings->Sound na jedno z wyjść liniowych. Domyślnie jest Headphone i to jest tylko dla przedniego panelu.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.