Jump to content
Sign in to follow this  
wd3200dw

FSC Xi 1554 - instalator nie widzi dysku HDD

Recommended Posts

Witam,

 

po dość długiej przerwie coś mnie tchnęło żeby znowu powalczyć z Mac OS`em, niestety napotkałem na problem..

 

konfiguracja :

 

1. Fujitsu Siemens Amilo Xi 1554

2. Procesor Inter Core 2 Duo T7200 2GHz 64 Bit SSE2, SSE3

3. Inter 945PM

4. RAID bus controller: VIA Technologies, Inc. VT6421 IDE/SATA Controller

5. Ati mobility Radeon X1900 256 MB 1920x1200

6. Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller

7. Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet

8. Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection

9. Napęd DVD - ATA, Dyski (mogą być dwa - kontroler RAID :( - SATA, podpięty jeden 120GB)

10. Klawiatura i Mysz - PS2 - na czas instalacji dostępna klawiatura + mysz USB

 

Problem pojawia się już przy instalacji - użyłem UniBootX 1.4.3 standard oraz płytki z 10.6.3 Retail. Gdy instalator się odpali, w Disk Utility nie widać dysku twardego. UniBootX go widzi w momencie wymiany płytki na Reail.

 

Poczytałem i wiem, że jest problem z tym kontrolerem RAID. Gdzieś jednak znalazłem kext, który niby rozwiązuje problem tego kontrolera. Nie wiem jednak jak go użyć, jak zmodyfikować UniBootXa żeby ten kext działał.

 

Kext nazywa się ApplePCIIDE.kext (w załączniku). - niestety nie mogę załączyć żadnego pliku. Pobrałem go z :

 

http://download734.mediafire.com/z3c611mw3zhg/yfj3ejxnztx/ApplePCIIDE.zip

 

Czy ktoś może pomóc ? Podpowiedzieć jak, lub zmodyfikować UniBootXa tak, żeby spróbować odpalić instalatora z tym kextem.

A może ktoś wie jak obejść ten problem ?

 

Takie coś jak przejściówka cdrom - hdd raczej nie wchodzi w gre.. wolałbym użyć wbudowanego kontrolera.

 

Będę wdzięczny za podpowiedź.

Daniel

Share this post


Link to post
Share on other sites

Żeby zrobić własne BootCD niestety nie mam jeszcze wystarczającego doświadczenia i będzie to trudniejsze niż skorzystanie z innych metod.

Polecam użyć Clovera z moją paczką ( www.clover.rox.pl ). Tutek jest na forum. O ile się nie mylę tam właśnie wrzuciłem ApplePCIIDE.

Share this post


Link to post
Share on other sites

Żeby zrobić własne BootCD niestety nie mam jeszcze wystarczającego doświadczenia i będzie to trudniejsze niż skorzystanie z innych metod.

Polecam użyć Clovera z moją paczką ( www.clover.rox.pl ). Tutek jest na forum. O ile się nie mylę tam właśnie wrzuciłem ApplePCIIDE.

 

Nie wiem dlaczego ale Clover nie odpala na tym kompie, mruga sobie kursor i stoi. Już próbowałem :(

Share this post


Link to post
Share on other sites

 

Spróbowałem i :

 

zwykły iBoot z tej strony stawał na USB i wyłączał się ekran. Nagrałem film i zrobiłem zdjęcie zanim ekran padł - jest trochę niewyraźne.

iBoot Legacy z tej strony odpalił instalator ale nie nie widać dysku nadal ;(

 

Mam problem żeby coś tu załączyć, na ekranie przy iBoot był komunikat :

 

USBF: 4.931 AppleUSBUHCI: controller reset failed

 

właściwie cały ciąg tych komunikatów z różnymi cyframi. Próbowałem z flagą USBBusFix=Yes ale ekran znikł jeszcze szybciej i nic dalej się nie działo. Flagi -x czy npci lub PCIRootUid też nie przynosiły żadnych rezultatów

Dodatkowo wspomnę, że iBoot w ogóle nie chciał wystartować bez flagi GraphicsEnabler=No

Share this post


Link to post
Share on other sites

Sprawdź, dowiedz się czy w ogóle ta VGA da się odpalić w OS X. O ile stare desktopowe np X1950 dawało radę odpalić pod ~10.5, bo nie pamiętam czy mobilne też... Jeśli VGA nie do ruszenia, to szkoda czasu tracić na ten sprzęt...

Share this post


Link to post
Share on other sites

Sprawdź, dowiedz się czy w ogóle ta VGA da się odpalić w OS X. O ile stare desktopowe np X1950 dawało radę odpalić pod ~10.5, bo nie pamiętam czy mobilne też... Jeśli VGA nie do ruszenia, to szkoda czasu tracić na ten sprzęt...

 

Trudno stwierdzić, znalazłem kilka wpisów na "zagranicznych" forach, że ludzie odpalali na tym laptopie Mac OS`a.

 

http://www.insanelymac.com/forum/topic/75703-hardware-compatibility-list-leopard-1051/page-3

 

tu ktoś pisze, że karta działa z rozdzielczością 1600x1200 ale bez QE/CI, na Leopardzie 10.5

Teoretycznie jest to ta sama seria kart co X1600, a ona wspierana jest. Gdyby udało się uzyskać w miarę normalną rozdzielczość to jestem w stanie sobie odpuścić filmy czy gry ;) byle działały w miarę płynnie programy typu przeglądarka czy office.

 

Co do samego odpalenia znalazłem coś takiego jak "wstrzyknięcie" kextów do płytki z retailem (tak to zrozumiałem)

 

http://www.insanelymac.com/forum/topic/67713-injecting-drivers-into-an-install-dvd/?hl=custom+install+dvd

 

Próbował ktoś takiego zabiegu z sukcesem ?

 

Pozdrawiam.

Share this post


Link to post
Share on other sites

Tylko po co wstrzykiwać kexy-y jak można je wgrać po :), u Ciebie i tak nie rozwiąże problemu. Bez uruchomienia QE/CI system traci funkcjonalność i wygodę pracy, nawet na przeglądarce (próbowałem odpalić karte ATi4570 na lapku sony... bez w pełni odpalonego QE/CI, całkowicie niefunkcjonalne).

Z dawnych czasów pamiętam że na wirtualnej maszynie zmieniałem rozdzielczość jakimś płatnym programem, był dostępny trial 30dniowy, ale już niestety nie pamiętam jak się nazywał.

 

ps. przejrzałem jeszcze raz cały wątek, musisz zgodnie z radą @oswaldini powalczyć z Cloverem, szczególnie z ustawieniami przy instalacji Clovera na pendrive. Jak go odpalisz to i dograsz kext-a.

Share this post


Link to post
Share on other sites

Tylko po co wstrzykiwać kexy-y jak można je wgrać po :), u Ciebie i tak nie rozwiąże problemu. Bez uruchomienia QE/CI system traci funkcjonalność i wygodę pracy, nawet na przeglądarce (próbowałem odpalić karte ATi4570 na lapku sony... bez w pełni odpalonego QE/CI, całkowicie niefunkcjonalne).

Z dawnych czasów pamiętam że na wirtualnej maszynie zmieniałem rozdzielczość jakimś płatnym programem, był dostępny trial 30dniowy, ale już niestety nie pamiętam jak się nazywał.

 

Właśnie nie można ich wgrać po bo instalator nie widzi dysku i nie można zainstalować systemu. 

Nie wiadomo jak będzie z tą grafiką, na dwoje babka wróżyła jak to mówią, może ruszy całkowicie, może wcale.. Nie dowiem się, jak nie zainstaluje systemu :)

Share this post


Link to post
Share on other sites

Właśnie nie można ich wgrać po bo instalator nie widzi dysku i nie można zainstalować systemu. 

Nie wiadomo jak będzie z tą grafiką, na dwoje babka wróżyła jak to mówią, może ruszy całkowicie, może wcale.. Nie dowiem się, jak nie zainstaluje systemu :)

 

Jest postęp. Udało się zainstalować dystrybucję Niresh ML 10.8.5. 

Faktycznie jest problem z kartą grafiki, rozdzielczość jest ok - 1600x1200 ale skacze obraz, szczególnie na www :)

 

Generalnie gdyby ktoś miał problem z tym chipsetem, to ta dystrybucja - a bardziej zawarty w niej przerobiony ApplePCIIDE.kext rozwiązuje problem.

 

Pozdrawiam i dzięki za zainteresowanie tematem.

Daniel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.