Jump to content
Koval78

LENOVO Z710 - Yosemite 10.10.1 + Win 8.1 + Ubuntu

Recommended Posts

Witam

 

Chciałbym przedstawić  Yosemite + Win 8.1 + Ubuntu na laptopie Lenovo Z710.

post-2589-0-03468800-1419100117_thumb.jpg

Poniżej jego specyfikacja.

 

Intel Core i7 4700MQ 2.4-3.4Turbo Haswell

Intel HD 4600 + GF 745 (Optimus)

Chipset 8 Series HM86

RAM 8 Gb  1600 MHz ( 2x 4Gb)

Crucial 240 Gb SSD  + 1TB HDD (w kieszeni napędu DVD)

1920 x 1080 LED

2xUSB 2.0 + 2xUSB 3.0

Audio : IDT 92HD95

LAN:  Qualcomm Atheros QCA8171 Gigabit Ethernet

WiFi : Intel 7260 + BT 4.0 + USB Ralink RT2870 + USB BT 4.0 Orico

Clover UEFI :  10.10.1 + Win 8.1 + Ubuntu 14

http://shop.lenovo.com/pl/pl/laptops/lenovo/z-series/z710/#tab-specyfikacja

Z racji tego iż laptop kupiłem bez systemu i w domyśle z zamiarem instalacji na nim OSX dokupiłem SSD i potrzebne akcesoria tj. Kieszeń na drugi dysk w miejsce napędu, Wifi i BT na USB. Jak poradziłem sobie z USB pokażę później.

 

Dysk SSD przygotowałem pod OSX-em w GPT. Podział na partycje wg planu jaki sobie przyjąłem to 110 Gb na WIN 8, 70 Gb na OSX, 4 Gb Home , 4 Gb SWAP i 10 Gb na system Ubuntu. Wszystkie partycje w HFS – przy instalowaniu Win 8.1 usuwamy i tak partycję pod niego a pod Ubuntu podczas instalacji formatujemy na EXT.

 

Laptop posiada procesor Haswell więc konieczny patch w Cloverze – KernelPM.

Dodatkowo patch HD 4600 mobile pod Yosemite. Na czas instalacji można wyłączyć w biosie Nvidię ale nie koniecznie.

Potrzebne DSDT,  SSDT-6 i SSDT – 8 – dla grafiki i CPU. Dopracowanie tabel trochę mi zajęło i tak jeszcze nie dałem rady wyłączyć nvidii –ale nad tym obecnie pracuję J.

DSDT + SSDT:

https://www.dropbox.com/sh/43kwk36ybouei9f/AAAY-mtofksySDuduFL0AsdDa?dl=0

Na początku start Clovera z pendriva z FakeSmc i VoodooPS2Controller w folderze 10.10.

Flagi : -v -gux_defer_usb2 – do tej drugiej doszedłem potem bo były problemy z USB i Sleep.

Mój config.plist:

https://www.dropbox.com/s/zjfhn0jmx02q51q/config.plist?dl=0

Instalacja Yosemite przebiegła wzorowo. Następnie instalka Clovera na ESP w UEFI. Kopiujemy z pena DSDT i SSDT do ACPI / Patched nie zapominając o kextach i Config.plist.  Przy kolejnym rozruchu Clovera z USB dodajemy go do listy boot w UEFI laptopa. Wyłączamy laptopa żeby wejść do Bios (w Lenovo trzeba uruchomić go oddzielnym przyciskiem) i tam ustawiamy boot Clovera na pierwszym miejscu. Po tym wyciągamy pena, restart, i Clover startuje już z dysku.

 

Czas na Windows – przygotowujemy Pendriva np. Rufusem. Musi być przygotowany dla komputerów z UEFI i dysków GPT.

Ja instaluję Windows pod Cloverem ale może się zdarzyć, że nie mamy do wyboru rozruchu z UEFI na pendrivie. Ja wyszedłem z Clovera i z opcji boot wybrałem „boot from file”. Przechodzimy na pendriva z Windows i tam do folderu Efi/ boot/ Bootx64.efi.

Po tym zabiegu instalka wystartowała, przy wyborze partycji usuwamy wcześniej utworzoną w OSX i zostawiamy jako nieprzydzielone miejsce i klikamy dalej – instalator Windows sam sobie utworzy i sformatuje potrzebne partycje.

Ubuntu – proces przebiega podobnie jak przy Windows –pen z Ubuntu również przygotowywałem w Rufusie. Podczas instalacji wybieramy instalację użytkownika odnośnie przydziału partycji. W menagerze partycji formatujemy przygotowane partycje pod Linuxa i boot dla Gruba na partycję gdzie zamierzamy zainstalować Ubuntu „ / „.

 

Z racji tego, że laptop jest na gwarancji i nie ma jeszcze modyfikowanego Biosu bez Whitelist zdecydowałem się na WiFi i BT na USB.

Wybrałem Ralink RT2870 i BT Orico 4.0. W laptopie są 4 gniazda USB czyli dwa już mam zajęte do tego mysz bezprzewodowa i tracę trzecie. Oto jak rozwiązałem ten problem.

Kupiłem HUB USB czteroportowy jak najmniejszy, rozebrałem wtyczkę usb i spiłowałem ją do minimalnych wymiarów ale tak żeby dało się przylutować kabelki. Delikatnie poluzowałem śrubki od spodu laptopa tak aby wprowadzić przez szczelinę kabelek do środka (w razie czego można to usunąć bez śladu). Tam przylutowałem HUB-a. Ostatecznie mam zajęte jedno gniazdo z boku laptopa i cztery wolne w środku – tam wpiąłem WiFi, BT i nadajnik myszki.

 

post-2589-0-83474400-1419100123_thumb.jpgpost-2589-0-42173800-1419100133_thumb.jpg
 

Wracamy do Yosemite. Kexty potrzebne to:

https://www.dropbox.com/sh/86zl928b9uhxisx/AAA7I6vql0HW_fwqkkwr1VQoa?dl=0

FakeSMC

VoodooPS2Controller

AppleHDA pod IDT 92HD95

ACPIBatteryManager

Sterownik D-Link do RT2870 – Driver od Ralinka nie działa pod Yosemite.

GenericUSBXHCI

 

Kexty instalujemy KextWizardem a panel Dlinka kopiujemy do   \System\Library\PreferencePanels\   - naprawiamy uprawnienia .

 

Dodatkowo dołożyłem dysk 1TB, który był oryginalnie w laptopie do kieszeni w miejsce DVD. W razie potrzeby podłączam napęd przez adapter SATA-USB.

 

Wiem, że opisałem to dosyć apatycznie ale w razie potrzeby służę pomocą.

Link do wszystkich plików i większej ilości zdjęć:

https://www.dropbox.com/sh/5unse5mcwlw0vpb/AADp3fmKygJBrbk-Nfs9-jwLa?dl=0

Koval

Share this post


Link to post
Share on other sites

Witaj,

 

Super, że trafiłem na Twój post. Mam parę pytań...

Jaki konkretnie model adaptera WiFi kupiłeś? Większość ma taką ogromną antenke, czy Twój jest zamknięty w środku?

Czy doszedłeś do czegoś w sprawie whitelistu BIOSa?

 

Pozdrawiam,

Karol

Share this post


Link to post
Share on other sites

Cześć.

Teraz już nie jestem w stanie określić jaki to był konkretnie model. Aukcji już nie mam w wiadomościach a i maile pokasowałem.

 

Na aukcji było napisane, że jest zgodna z Mavericks 10.9. więc wziąłem :).  Chip Ralink RT2870

 

Tak jak widać na zdjęciu moja wifi jest bez dokręcanej antenki i wpięta do Huba schowanego w obudowie.  

 

Widziałem że pod moim postem na bios-mods napisałeś swój post - w sumie racja SLIC można odpuścić ważna Whitelista.

 

Próbowałem samodzielnie zdjąć whitelist wzorując się na blogu Donovan6000 ale to przerasta moje siły a głównie brak czasu żeby wszystko ogarnąć :)

 

 

W razie potrzeby służę pomocą przy instalacji OSX. 

Share this post


Link to post
Share on other sites

Cześć.

Teraz już nie jestem w stanie określić jaki to był konkretnie model. Aukcji już nie mam w wiadomościach a i maile pokasowałem.

 

Na aukcji było napisane, że jest zgodna z Mavericks 10.9. więc wziąłem :).  Chip Ralink RT2870

 

Tak jak widać na zdjęciu moja wifi jest bez dokręcanej antenki i wpięta do Huba schowanego w obudowie.  

 

Widziałem że pod moim postem na bios-mods napisałeś swój post - w sumie racja SLIC można odpuścić ważna Whitelista.

 

Próbowałem samodzielnie zdjąć whitelist wzorując się na blogu Donovan6000 ale to przerasta moje siły a głównie brak czasu żeby wszystko ogarnąć :)

 

 

W razie potrzeby służę pomocą przy instalacji OSX. 

Jakby co, to w sprawie Whitelista jest już pewien postęp, zobacz na forum :) Edit: widzę, że próbowałeś, cóż, trudno.

Share this post


Link to post
Share on other sites

Jakby co, to w sprawie Whitelista jest już pewien postęp, zobacz na forum :) Edit: widzę, że próbowałeś, cóż, trudno.

Próbowałem i poszedłem jeszcze dalej. Niestety już mam po gwarancji ale zaprogramowałem chip biosu i już nie mam Whitelisty. 

Laptop startuje z obojętnie jaką kartą WiFi.

Share this post


Link to post
Share on other sites

Próbowałem i poszedłem jeszcze dalej. Niestety już mam po gwarancji ale zaprogramowałem chip biosu i już nie mam Whitelisty. 

Laptop startuje z obojętnie jaką kartą WiFi.

Wrzucisz jakieś zdjęcia chipa po przeróbce, gdzie się on znajduje i jak do niego dotrzeć?

Share this post


Link to post
Share on other sites

Wrzucisz jakieś zdjęcia chipa po przeróbce, gdzie się on znajduje i jak do niego dotrzeć?

Aby dotrzeć do kości biosu trzeba niestety rozkręcić całego laptopa. Scalaki znajdują się od góry płyty głównej po lewej stronie od touchpada.

 

Oznaczenia na kostkach biosu:

 

KBC - 2048 KB -  W25Q16BV

PCH - 4096 KB - W25Q32BV - zrobiłem backup za pomocą universal backup tool - wprowadziłem zmiany, które podał BDMaster i następnie wgrałem programatorem.

 

5481489def69.jpg

 

ca94781b208c.jpg

Share this post


Link to post
Share on other sites

Dear Koval,

i need your help. I tried the same with my Z710. Yosemite is working well, but i cant get any Dualboot. I installed yosemite first and could choose Clover from BIOS. After installing Windows Clover was gone from BIOS (only Windows Boot Manager), even after trying to add it via Clover Boot-Options from Clover-USB there is only Windows Boot Manager. How did you do that? Our BIOS is very shitty, we cant add any entry manually  :cry: What are ur BIOS settings?

 

PS: Did you create new DSDT from the new BIOS-Update? I saw your posted DSDT is based on older BIOS-Version.

 

Thank you very much, greetings from Germany.

 

Taddy

Share this post


Link to post
Share on other sites

Dear Koval,

i need your help. I tried the same with my Z710. Yosemite is working well, but i cant get any Dualboot. I installed yosemite first and could choose Clover from BIOS. After installing Windows Clover was gone from BIOS (only Windows Boot Manager), even after trying to add it via Clover Boot-Options from Clover-USB there is only Windows Boot Manager. How did you do that? Our BIOS is very shitty, we cant add any entry manually  :cry: What are ur BIOS settings?

 

PS: Did you create new DSDT from the new BIOS-Update? I saw your posted DSDT is based on older BIOS-Version.

 

Thank you very much, greetings from Germany.

 

Taddy

Hi Teddy

 

After install Windows I boot notebook from usb device with Clover then add boot option from the SATA disk  to the Uefi boot list. You must add correct boot from Your SATA disk not from USB.

Share this post


Link to post
Share on other sites

Posiadam taki sam model laptopa i jak ty chciałbym zainstalować Win 8.1 / OS X / Xubuntu, mógłbyś wysłać kexty pod OS X do tego modelu?

Do tego mam dodatkowy monitor podpięty pod złącze VGA, czy są potrzebne jakieś pliki dodatkowe żeby zadziałał?

 

Mógłbyś zarzucić folder EFI z pendrive z potrzebnymi patchami/kextami do domyślnych sprzętów tego lapka?

 

Z góry dzięki za pomoc

Share this post


Link to post
Share on other sites

Posiadam taki sam model laptopa i jak ty chciałbym zainstalować Win 8.1 / OS X / Xubuntu, mógłbyś wysłać kexty pod OS X do tego modelu?

Do tego mam dodatkowy monitor podpięty pod złącze VGA, czy są potrzebne jakieś pliki dodatkowe żeby zadziałał?

 

Mógłbyś zarzucić folder EFI z pendrive z potrzebnymi patchami/kextami do domyślnych sprzętów tego lapka?

 

Z góry dzięki za pomoc

Cześć

W tej chwili myślę o aktualizacji poradnika ponieważ są nowe Kexty od Rehabman do uruchomienia HD 4600.

Jeśli dobrze zrobisz DSDT i SSDT to kextów za dużo nie ma.

Dołączam archiwum z kextami których używam i wybranymi folderami z Clovera (żeby zmniejszyć wielkość pliku)

10.10.3.zip

Share this post


Link to post
Share on other sites

Cześć

W tej chwili myślę o aktualizacji poradnika ponieważ są nowe Kexty od Rehabman do uruchomienia HD 4600.

Jeśli dobrze zrobisz DSDT i SSDT to kextów za dużo nie ma.

Dołączam archiwum z kextami których używam i wybranymi folderami z Clovera (żeby zmniejszyć wielkość pliku)

możesz napisać jak odblokowałeś bios, czy potrzebne ci było do tego jakieś urządzenie dodatkowe? za ile i jaki programator biosu kupiłeś

Share this post


Link to post
Share on other sites

Koval78, 

Clover odpala mi się bez problemu, widzi instalację MAC'a ale w momencie gdy odpalam ją, pojawia się czarny ekran i nic więcej. Sprawdzałem z Nvidia włączoną/wyłączoną bez zmian. Jakieś porady? Masz tego configa gdzieś? :) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.