Jump to content
Sign in to follow this  
EscobarPL

Klawiatura i mysz na USB

Recommended Posts

Witam wszystkich, mam taki problem z klawiaturą i myszką na USB.

Chodzi oto, że muszę za każdym razem przed załadowaniem mac os x wejść w cloverze w opcję PCI i zaznaczyć parametr USBInjection i USBFixOwnership bo w innym przypadku nie działa mi klawiatura i mysz po załadowaniu mac os x tzn. nie mogę wpisać hasła w oknie logowania. Próbowałem różnych wpisów w config.plist i nic mi nie wychodzi. Chyba jeszcze jestem za słaby w te klocki.

Jeżeli możecie to napiszcie co i jak wpisać w config.plist żeby te parametry były zaznaczone na stałe zaraz po uruchomieniu kompa.

 

Pozdrawiam

Share this post


Link to post
Share on other sites

Config ktory dodales w zalaczniku pozniej 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>Fixes</key>
			<dict>
				<key>AddDTGP_0001</key>
				<false/>
				<key>AddHDMI_8000000</key>
				<false/>
				<key>AddIMEI_80000</key>
				<false/>
				<key>AddMCHC_0008</key>
				<false/>
				<key>AddPNLF_1000000</key>
				<false/>
				<key>DeleteUnused_400000</key>
				<false/>
				<key>FIX_ACST_4000000</key>
				<false/>
				<key>FIX_ADP1_800000</key>
				<false/>
				<key>FIX_INTELGFX_100000</key>
				<false/>
				<key>FIX_RTC_20000</key>
				<false/>
				<key>FIX_S3D_2000000</key>
				<false/>
				<key>FakeLPC_0020</key>
				<false/>
				<key>FiX_TMR_40000</key>
				<false/>
				<key>FiX_WAK_200000</key>
				<false/>
				<key>FixAirport_4000</key>
				<false/>
				<key>FixDarwin_0002</key>
				<false/>
				<key>FixDisplay_0100</key>
				<false/>
				<key>FixFirewire_0800</key>
				<false/>
				<key>FixHDA_8000</key>
				<false/>
				<key>FixHPET_0010</key>
				<false/>
				<key>FixIDE_0200</key>
				<false/>
				<key>FixIPIC_0040</key>
				<false/>
				<key>FixLAN_2000</key>
				<false/>
				<key>FixRegions_10000000</key>
				<false/>
				<key>FixSATA_0400</key>
				<false/>
				<key>FixSBUS_0080</key>
				<false/>
				<key>FixShutdown_0004</key>
				<false/>
				<key>FixUSB_1000</key>
				<false/>
				<key>NewWay_80000000</key>
				<false/>
			</dict>
			<key>Name</key>
			<string>DSDT.aml</string>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>HaltEnabler</key>
		<false/>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>Generate</key>
			<dict>
				<key>CStates</key>
				<false/>
				<key>PStates</key>
				<false/>
			</dict>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>dart=0 kext-dev-mode=1</string>
		<key>DefaultVolume</key>
		<string>MacOS</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>Log</key>
		<true/>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>5</integer>
		<key>XMPDetection</key>
		<string>NO</string>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>12</string>
		</dict>
		<key>FakeID</key>
		<dict>
			<key>ATI</key>
			<string>0x0</string>
			<key>IMEI</key>
			<string>0x0</string>
			<key>IntelGFX</key>
			<string>0x0</string>
			<key>LAN</key>
			<string>0x0</string>
			<key>NVidia</key>
			<string>0x0</string>
			<key>SATA</key>
			<string>0x0</string>
			<key>WIFI</key>
			<string>0x0</string>
			<key>XHCI</key>
			<string>0x0</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>FixOwnership</key>
			<true/>
			<key>Inject</key>
			<true/>
		</dict>
		<key>UseIntelHDMI</key>
		<false/>
	</dict>
	<key>DisableDrivers</key>
	<array>
		<string>Nothing</string>
	</array>
	<key>GUI</key>
	<dict>
		<key>Hide</key>
		<array>
			<string>Windows</string>
			<string>\EFI\BOOT\BOOTX64.EFI</string>
		</array>
		<key>Language</key>
		<string>pl:30788</string>
		<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<string>First</string>
			<key>Tool</key>
			<true/>
		</dict>
		<key>TextOnly</key>
		<dict>
			<key>Enabled</key>
			<true/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>Theme</key>
		<string></string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<true/>
		</dict>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleRTC</key>
		<true/>
		<key>AsusAICPUPM</key>
		<true/>
		<key>KernelPm</key>
		<true/>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>External icons patch</string>
				<key>Find</key>
				<data>
				RXh0ZXJuYWw=
				</data>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Replace</key>
				<data>
				SW50ZXJuYWw=
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>LogEveryBoot</key>
		<string>10</string>
		<key>LogLineCount</key>
		<integer>3000</integer>
		<key>MountEFI</key>
		<string>Yes</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>Trust</key>
		<false/>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Detect</string>
		<key>InjectSystemID</key>
		<true/>
	</dict>
</dict>
</plist>
 

USBInjection i USBFixOwnership sa zalaczone na stale w configu ktory udostepniles

		<key>USB</key>
		<dict>
			<key>FixOwnership</key>
			<true/>
			<key>Inject</key>
			<true/>
		</dict>

Ps dodaj liste sprzetu zgodna z forum.

Share this post


Link to post
Share on other sites

Jeżeli są włączone to dlaczego tak się dzieje jak napisałem na wstępie?

 

1. Gigabyte GA-Z68AP-D3 (Rev. 2.0)

2. Intel Core i5-2320 3.00 GHz

3.

4.

5. ASUS GeForce GTX 550 (monitor połączony kablem HDMI, działa dzwięk na monitorze po kablu HDMI)

6. ALC 889

7. Realtek RTL 8111E

8.

9. HDD na SATA

10. Mysz i kalwiatura na USB

Share this post


Link to post
Share on other sites

Która to rewizja sprzętowa 1.0 czy 2.0? do 2.0 jest BIOS UEFI i jeśli nie boisz się wyzwań, to możesz go wgrać. Tylko pamiętaj że powrót może być problematyczny i musisz samemu poczytać jak zrobić backup obecnego i jak przywrócić go w razie problemów z UEFI. Niestety Gigabyte olał userów Z68 i biosów UEFI nie udostępnił jak inni producenci i czasami do niektórych płyt rzucił ochłapy w wersjach beta.

 

Do rzeczy gigafaile na Z68 d radę spacyfikować, w UEFI i w starcie z UEFI działają znośnie, jedynie wypluwają pendnraki w czasie sleep, poza tą ułomnością są znośne. No i najważniejsze z UEFI nie musisz już poprawiać DSDT - zmory gigafaili.

Share this post


Link to post
Share on other sites

Mam ta sama mobo tez rev 2.0 ale nie pod hacka - klient ma do grania. Zrobiłem update ze zwykłego biosu do biosu uefi - jest na stronie www. Ponoć ta mobo w uefi pod os x działa znosnie bez dsdt.

 

Ps zrobiłem update w dos, nie pod win (strzelał Focha). Płyta ma dualbios wiec jakieś pocieszenie i zabezpieczenie.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.