Jump to content
Zuker

Asrock Z87 Pro3 - config.plist kexts

Recommended Posts

Witam wszystkich.

Aktualnie jestem posiadaczem macmini 2012 i7 16gb ram i ssd

Wszystko bylo ok do momentu kupna 27" nec-a o rodzielczosci ponad 2500px. Zintegrowana z prockiem grafa nie wyrabia do tego caly maczek spowolnil. Jestem fotografem i potrzebuje sprzetu do lightrooma i photoshopa.

Niestety na dzień dzisiejszy alternatywy brak. Macmini 2014 jest wolniejszy od 2012 Emotikon frown a mac pro zaczyna się od 13k Emotikon wink

Jedyna opcja jaka mi została to hackintosh.

 

Poczytałem sporo i wybrałem płytę Asrock Z87 Pro3, do tego mam i7 4790k i 16gb ram

Znalazłem tutorial z instalacją OS X 10.10 Yosemite i doszedłem do punktu 2.

Gdzie mogę znaleźć config.plist i kexts do tej właśnie płyty. Widzę, że kilka osób ma tą płytę a nie potrafię znaleźć tego co mi potrzeba do dalszej instalacji.

 

Proszę o pomoc

 

Share this post


Link to post
Share on other sites

Dałem standardowy config i fakeSmc.kexts

Instalacja dochodzi do momentu "pozostało około sekundy" i tak już jest z 30min :( pendrive miga jak by się coś instalowało.

 

Co może być nie tak ? Jak sprawdzić na czym się wysypuje ?

Share this post


Link to post
Share on other sites

Postawiłem system ale na rozwiązaniu tonymac :(

 

Odpaliło chyba wszystko: lan dział, audio działa, sleep działa, procek zwalnia i przyśpiesza.

Także można !

 

Wracam teraz zaczynam wszystko od nowa krok po kroku na clover.

Mam nadzieje, że powstanie w tym miejscu poradnik jak postawić hacka dla kompletnych laików - posiadaczy oryginalnym makówek.

 

Na początek zaczynam od tego poradnika http://hamac.pl/topic/10178-instalacja-os-x-1010-yosemite-krok-po-kroku/

Dochodzę do momentu gdzie powinienem ustawić config.plist i dodanie kexts

 

Potrzebuję audio alc 892

Lan intel AppleintelIE1000e v3.1.0a

FakeSMC - gdzie pobrać ?

Grafiki jeszcze nie mam ale będzie GTX780 pewnie w przyszłości.

 

Ściągnąłem też clover configurator jak to ustawić do mojego sprzętu ?

Share this post


Link to post
Share on other sites

System postawiony !

 

Niestety z grafiką coś poszło nie tak. Nie wykryło jej. Internet działa. Dźwięku brak :(

 

Najpierw grafika: jak mam wejść teraz na partycje EFI/Clover na pendrive żeby dostać się do config.plist?

Na pendrive widzę tylko "Instalacja OS X Yosemite"

Share this post


Link to post
Share on other sites

Musisz zamontować tą partycję (wszystko jest na forum opisane).

 

Wejdź do terminala i wpisz komendę:

 

diskutil list

 

Zidentyfikuj nazwę partycji EFI na pendrive - najprawdopodobniej będzie to disk1s1 (jeśli masz kilka dysków w komputerze, to oczywiście numer będzie inny).

 

Teraz wpisz w terminalu:

 

mkdir /Volumes/EFI

 

a następnie:

 

sudo mount -t msdos /dev/disk1s1 /Volumes/EFI

 

(będziesz musiał podać hasło)

Tyle - partycja się zamontuje i powinieneś widzieć na pulpicie jej ikonę.

Share this post


Link to post
Share on other sites

Dziękuje !

EFI zamontowana

 

Zdaje sobie sprawę, że wszystko jest na forum - jednak ciężko coś znaleźć jeżeli nie do końca wiem czego szukam :(

 

Walczę dalej :)

 

PS

 

Grafika działa !

Zmieniłem

 

<key>Intel</key>

<true/> było false

Share this post


Link to post
Share on other sites

Nie mogę odpalić tego dźwięku nieszczęsnego :(

 

Zrobiłem wszystko z instrukcji podanej przez oswaldini

kexty zainstalowałem programem:

Kext Helper B7

 

Gdzieś znalazłem, że powinienem skasować plik /System/Library/Extensions.mkext żeby zresetować cache - ale nie mam takiego pliku w systemie.

 

Mój config z pendrive clover z którego bootuję:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>Fixes</key>
			<dict>
				<key>AddDTGP_0001</key>
				<true/>
				<key>AddHDMI_8000000</key>
				<true/>
				<key>AddPNLF_1000000</key>
				<true/>
				<key>DeleteUnused_400000</key>
				<true/>
				<key>FIX_ACST_4000000</key>
				<true/>
				<key>FIX_ADP1_800000</key>
				<true/>
				<key>FIX_RTC_20000</key>
				<true/>
				<key>FIX_S3D_2000000</key>
				<true/>
				<key>FixAirport_4000</key>
				<true/>
				<key>FixDarwin_0002</key>
				<true/>
				<key>FixDisplay_0100</key>
				<true/>
				<key>FixFirewire_0800</key>
				<true/>
				<key>FixHDA_8000</key>
				<true/>
				<key>FixHPET_0010</key>
				<true/>
				<key>FixIPIC_0040</key>
				<true/>
				<key>FixLAN_2000</key>
				<true/>
				<key>FixRegions_10000000</key>
				<true/>
				<key>FixSBUS_0080</key>
				<true/>
				<key>FixShutdown_0004</key>
				<true/>
				<key>FixUSB_1000</key>
				<true/>
				<key>NewWay_80000000</key>
				<true/>
			</dict>
			<key>Name</key>
			<string>DSDT.aml</string>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>DropTables</key>
		<array>
			<dict>
				<key>Signature</key>
				<string>DMAR</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>CpuPm</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>Cpu0Ist</string>
			</dict>
		</array>
		<key>HaltEnabler</key>
		<true/>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>Generate</key>
			<true/>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-v npci=0x2000 kext-dev-mode=1</string>
		<key>Debug</key>
		<false/>
		<key>DefaultLoader</key>
		<string>boot.efi</string>
		<key>DefaultVolume</key>
		<string>LastBootedVolume</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>5</integer>
		<key>XMPDetection</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>7</string>
		</dict>

		<key>ResetHDA</key>
			<true/>
			
		<key>USB</key>
		<dict>
			<key>AddClockID</key>
			<true/>
			<key>FixOwnership</key>
			<true/>
			<key>Inject</key>
			<true/>
		</dict>
	</dict>
	<key>GUI</key>
	<dict>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<false/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>Scan</key>
		<true/>
		<key>ScreenResolution</key>
		<string>1280x1024</string>
		<key>Theme</key>
		<string>bootcamp</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<false/>
		</dict>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		

		<dict>
				<key>Comment</key>
				<string>ALC892 patch</string>
				<key>Find</key>
				<data>ixnUEQ==</data>
				<key>Name</key>
				<string>AppleHDAController</string>
				<key>Replace</key>
				<data>kgjsEA==</data>
		</dict>

		<key>AppleRTC</key>
		<true/>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>MLB</key>
		<string>C02032109R5DC771H</string>
		<key>ROM</key>
		<string>UseMacAddr0</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>06/12/13</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>MP61.88Z.0116.B04.1312061508</string>
		<key>Board-ID</key>
		<string>Mac-F60DEB81FF30ACF6</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardType</key>
		<integer>11</integer>
		<key>ChassisAssetTag</key>
		<string>Pro-Enclosure</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>06</string>
		<key>Family</key>
		<string>Mac Pro</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>Mobile</key>
		<false/>
		<key>ProductName</key>
		<string>MacPro6,1</string>
		<key>SerialNumber</key>
		<string>C02LHHZYF693</string>
		<key>Trust</key>
		<false/>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Detect</string>
		<key>InjectSystemID</key>
		<true/>
	</dict>
</dict>
</plist>

Share this post


Link to post
Share on other sites

:(

 

Wiem, że takich pytań jest milion ale nie wiem co poprawić. Dostałem od oswaldini bazę ale nie wiem co mam dodać co usunąć. 

 

Jeeeeeeeee !

 

Cofnąłem się do postu oswaldini i zacząłem dumać o co w nim chodzi :) no i wydumałem :)

Skopiowałem baze do config.plist i zaimportowałem ją do clover configurator 

 

Tam zaznaczyłem imac 14.1 i wyłączyłem injekcje dla nvidii

Zapisałem na EFI/CLOVER i zapodałem restarcik :)

 

Dźwięk działa, internet działa, usypianie i wybudzanie działa !!!

 

Tak to wygląda teraz 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>DropTables</key>
		<array>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>Cpu0Ist</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>DMAR</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>CpuPm</string>
			</dict>
		</array>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>Generate</key>
			<true/>
			<key>MinMultiplier</key>
			<integer>7</integer>
			<key>PluginType</key>
			<integer>1</integer>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-gux_defer_usb2 -gux_no_idle kext-dev-mode=1</string>
		<key>Debug</key>
		<false/>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>3</integer>
		<key>XMPDetection</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>7</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>FixOwnership</key>
			<false/>
			<key>Inject</key>
			<false/>
		</dict>
	</dict>
	<key>DisableDrivers</key>
	<array>
		<string>DataHubDxe</string>
		<string>OsxAptioFix2Drv</string>
		<string>OsxLowMemFixDrv</string>
		<string>PartitionDxe</string>
		<string>EmuVariableUefi</string>
		<string>CsmVideoDxe</string>
	</array>
	<key>GUI</key>
	<dict>
		<key>CustomIcons</key>
		<true/>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<false/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<false/>
			<key>Tool</key>
			<false/>
		</dict>
		<key>Theme</key>
		<string>Universe</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<false/>
		</dict>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleRTC</key>
		<false/>
		<key>AsusAICPUPM</key>
		<true/>
		<key>ForceKextsToLoad</key>
		<array>
			<string>\System\Library\Extensions\IONetworkingFamily.kext</string>
		</array>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>TRIM</string>
				<key>Find</key>
				<data>
				QVBQTEUgU1NEAA==
				</data>
				<key>Name</key>
				<string>IOAHCIBlockStorage</string>
				<key>Replace</key>
				<data>
				AAAAAAAAAAAAAA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>ALC892</string>
				<key>Find</key>
				<data>
				ixnUEQ==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				kgjsEA==
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>ROM</key>
		<string>xxxxxxxxxxxx</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>09/03/2013</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>IM141.88Z.0118.B00.1309031248</string>
		<key>Board-ID</key>
		<string>Mac-031B6874CF7F642A</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardType</key>
		<integer>10</integer>
		<key>ChassisAssetTag</key>
		<string>iMac-Aluminum</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>13</string>
		<key>Family</key>
		<string>iMac</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>Mobile</key>
		<false/>
		<key>ProductName</key>
		<string>iMac14,1</string>
		<key>SerialNumber</key>
		<string>C02LXB47F8J2</string>
		<key>Trust</key>
		<false/>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Yes</string>
	</dict>
</dict>
</plist>

Share this post


Link to post
Share on other sites

To jeszcze na chłopski rozum:

 

żeby teraz działało botowanie z dysku a nie z pendrive to muszę skopiować folder EFI z partycji EFI (pendrive) do ukrytej partycji EFI (jej katalogu głównego) na ssd ?

Share this post


Link to post
Share on other sites

Tak.

A jeśli to nie zadziała to zamontuj partycję EFI dysku, zainstaluj na niej Clovera i później skopiuj zawartość EFI pendrive'a na EFI dysku.

Powinno zadziać, w przypadku UEFI bootloader jest zawsze uruchamiany, o ile tylko plik z nim znajduje się w odpowiednim miejscu na partycji EFI.

Share this post


Link to post
Share on other sites

Naprawiło się samo :)

 

Skoro wszystko już działa to kolejne pytanie jak zrobić kopię zapasową najlepiej całego dysku ssd wraz z partycjami ukrytymi? Tak, że w razie jak padnie dysk czy wysypie się system można było przywrócić hackintosha do teraźniejszego stanu ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.