Jump to content
oswaldini

UniBootX Clover - MSI Z77A-G43 Z77A-G45 Z77MA-G45 H77MA-G43 ZH77A-G45

Recommended Posts

NIE MAM JUŻ TEGO SPRZĘTU, TEMAT NIE ROZWIJANY, NALEŻY WYKONAĆ KILKA AKTUALIZACJI I POPRAWEK ABY DOBRZE DZIAŁAŁO POD 10.11.x

 

 

 

 

Kompletny pakiet do wrzucenia na USB w FAT32 i bootowania w UEFI.

Zastosowana wersja Clovera 3292.

 

 

Załączona paczka instalacyjna MacMaker mojego autorstwa, zawiera:

- sterowniki audio

- HWMonitor

- synchronizację czasu Win-Mac

- wrzuca bootloader z całą paczką na partycję EFI - jeśli używasz CoreStorage/Fusion Drive nie zaznaczaj tej opcji ! Konieczne jest ręczne przeniesienie katalogu EFI na partycję EFI.

 

Paczka kompatybilna z:

- płytami głównymi MSI: Z77A-G43, Z77A-G45, Z77MA-G45, H77MA-G43, ZH77A-G45.

- grafikami AMD/ATI Radeon, GeForce GT(X)6xx, GT(X)7xx, GTX9xx - dla nie wspieranych natywnie kart konieczne są sterowniki nVidii z ich strony internetowej! Jeżeli posiadasz starszy model karty GeForce koniecznie trzeba włączyć injekcję w pliku config.plist.

 

Dla kart GeForce nie ma konieczności wpisywania nv_disable=1 do instalacji oraz odpalenia RecoveryHD - te opcje są dodane. Jeżeli karta tego wymaga parametr ten trzeba wpisać tylko pierwszy raz przy odpaleniu systemu, przed zainstalowaniem driverów nVidii.

 

- natywny PowerManagament, nie wymagane pliki SSDT ! Generowanie stanów z Clovera.

 

post-388-0-93710000-1439978628_thumb.png post-388-0-33348000-1439978637_thumb.png

 

Zastosowane kexty:

- FakeSMC.kext
- GenericUSBXHCI.kext
- HDMIAudio.kext
- IntelRAID.kext (umożliwia bootowanie OS X z kontrolerem ustawionym w tryb RAID)
- RealtekRTL8111.kext
 
Zastosowane kexty w sekcji 10.6:
- AppleACPIPlatform.kext
- AppleSMC.kext
- FakeSMC.kext
- IOACPIFamily.kext
- IONetworkingFamily.kext
- IOPCIFamily.kext
- IOPlatformPluginFamily.kext
- mach_kernel (umożliwia odpalenie Snowa na Ivy Bridge i Haswell)
- NullCPUPowerManagement.kext
- PXHCD.kext
- RealtekR1000SL.kext
 
Oznaczenia i wytłumaczenia nazw katalogów w sekcji OEM:
MS-7752 dla Z77A-G45
MS-7756 dla H77MA-G43
MS-7758 dla Z77A-G43 oraz ZH77A-G45
MS-7759 dla Z77MA-G45

 

Postępowanie:

- Katalog EFI i plik MacMaker.pkg wgrywamy na klucz USB sformatowany w FAT32

- Odpalamy komputer klikając F11 aby wejść do Boot Menu

- Wybieramy UEFI: nazwa pendrive z Cloverem

- Po zainstalowaniu OS X i paczki MacMaker w BIOSie do bootowania na stałe wybieramy UEFI OS

 

Pliki do pobrania:

http://hamac.pl/files/file/5-%7B%3F%7D/

Share this post


Link to post
Share on other sites

Rozumiem, że w ramach tego będzie trzeba ewentualnie dostosować config.plist (numer seryjny?) czy to jest po prostu "głupkoodporne"?.

 

No i jeśli mam FiiO E10K i w UEFI wyłączyłem integrę (Mikrofon mam na USB) to mogę sekcję Audio kompletnie pominąć?

Share this post


Link to post
Share on other sites

No to grubo muszę przyznać :)

 

Jak już mam partycję bootującą z działającym Cloverem to najlepiej nie zaznaczać opcji wrzucania automatycznego tylko po prostu wygenerować folder EFI i Copy->Paste? :)

 

 

PS. Na sourceforge jest clover 3259 - kompilowałeś specjalnie "dla nas" 3261? :)

Share this post


Link to post
Share on other sites

Tak, zawsze sam kompiluję. Widzę, że zapomniałem dodać boot-flag do USB 3.0, jak się uda wieczorem będzie drobny update. Postaram się jeszcze wychwycić ew. błędy.


 


Wystarczy, że skopiujesz folder EFI z załącznika na partycję EFI. Instalator wrzuca właśnie ten folder samodzielnie, nie trzeba ręcznie montować EFI.


 


EDIT: Paczka zaktualizowana.


Share this post


Link to post
Share on other sites

Panowie czy dobrze rozumuję. Instaluję OSX za pomocą Clover'a na pendrive i na działającym OSX stosuję powyższą paczkę dzięki czemu rozruch systemu będę mieć bezpośrednio z dysku? Pytam bo od dwóch lat bootuję system z pen'a.

Pozdrawiam!

 

EDIT: Ok już doczytałem w wątku "UniBootX Clover - oficjalny uniwersalny bootloader haMac.pl"

Dawno mnie na forum nie było #-o  stąd moje poprzednie pytanie.

Pozdro!

Share this post


Link to post
Share on other sites

Mam płytę Z77A-G45, postawiłem os x za pomocą UniBootX Clover + pakiet z tego tematu, doaałem tylko legacy kext żeby wifi działało (AR9285). Wszystko działa ok tylko jest jeden problem, w ogóle nie mogę wyłączyć systemu. W momencie gdy kliknę na wyłącz, komp się resetuje i włącza od nowa.

Co powoduje błąd podczas logowania - „Komputer został uruchomiony ponownie z powodu problemu”.

Jak z temu zaradzić ? w załączniku raport

raport.zip

Share this post


Link to post
Share on other sites

Miałem ten problem już kilkanaście razy właśnie w połączeniu z GTX650. Po zmianie z AptioFix2 na AptioFix problem znikał, nie mniej w MSI Z77A jest ustawiony AptioFix bo na AptioFix2 nie startuje bodaj ta mobo. Wywal z Driverów EFI wszystko poza HFSPlus, FSInject, OsxFatBinary oraz AptioFix, odpal ponownie 2 razy i daj znać czy jest zmiana.

 

Aha jak coś przywróć stan pierwotny i wywal HDMIAudio, ono też czasem dobrze psoci.

Share this post


Link to post
Share on other sites

Mam kilka pytań do posiadaczy tej płyty. Czy reasumując możesz polecić tą płytę pod OS X? W szczególności czy dźwięk działa bez problemu, czy działa SPDIF, HDMI (HD 4000) i tylny zielony jack? Ponadto gdzieś czytałem, że trzeba patchować BIOS bo inaczej są problemy z powermanagement, czy to potwierdzasz? Ponadto jak na tej płycie wygląda kwestia zapisu do NVRAM?

Share this post


Link to post
Share on other sites

Powiem tak, pakujesz moją paczkę i działa wszystko. Żadne patchowanie biosu nie potrzebne, audio działa na driverach admina (cyfra nie testowana ale na 99% działa, jest widoczna), HD4000 działa (HDMIAudio nie testowałem na niej - zapewne trzeba popchnąć), zapis do nvram działa, itd itp... Polecam.

Share this post


Link to post
Share on other sites

Chcesz nową płytę pod OS X, czy masz już CPU ix-3xxx... jak masz CPU to Czy to MSI, Asus czy ASRocka na Z77 to nie ma większego znaczenia, ale jak chcesz kupić nową płytę + cpu, to pakowanie się w Z77 trochę jest bez sensu... to stara platforma a do tego kapryśna czasami i w niektórych wypadkach z USB 3.0. 

Share this post


Link to post
Share on other sites

Chcesz nową płytę pod OS X, czy masz już CPU ix-3xxx... jak masz CPU to Czy to MSI, Asus czy ASRocka na Z77 to nie ma większego znaczenia, ale jak chcesz kupić nową płytę + cpu, to pakowanie się w Z77 trochę jest bez sensu... to stara platforma a do tego kapryśna czasami i w niektórych wypadkach z USB 3.0. 

To pytanie było do mnie? Jeśli tak to.... mam już CPU i problemy z obecną płytą... nie tylko pod OS X ale w ogóle jako taką... niestety teraz znaleźć cokolwiek konkretnego na rynku to jest jakaś masakra, tego MSI co przygotowana jest paczka all in one nie ma w ogóle po za jedną uszkodzoną na allegro a w ogóle jeśli coś znalazłem na Z77 to raczej jakiś low end... dlatego, postanowiłem kupić całkiem nową platformę... nie chcę inwestować w coś co już teraz jest przestarzałe de facto nie wiele mniej niż za nową płytę współczesną dzisiaj... Nie ukrywam też, że chodzi za mną skylake... w sumie +/- 200 zł różnicy między haswell a skylake daje do myślenia... OS X też nie jest dla mnie jakimś priorytetem bardziej to kwestia używania go okazjonalnie więc gdybym tylko miał pewność, że kiedyś doczekamy się obsługi skylake lub jeśli nawet teraz dałoby się odpalić OS X ale np. bez sleepu czy nie do końca w 100% stabilnie to chętnie rozważę i Z170, tyle tylko, że nie chcę popełnić błędu jak kiedyś kupując buldozera, który w ogóle nie chciał działać z OS X, nie tylko vanilla ale nawet żadne modowane distro. Jak myślicie jest szansa na skylake kiedyś czy raczej zostać przy Z97?

Share this post


Link to post
Share on other sites

Super. W końcu działa mi PM. Niestety mam problem aby Clover działał na 1920x1080.

 

Strasznie mi spłaszcza i ustawia jakaś małą rozdzielczość - załączam foto.

Ktoś podpowie co przestawić w configu?

 

Monitor LG S22C300, grafika, GeForce GTX 660 OC 2048MB

post-3897-0-27149700-1443962737_thumb.jpeg

Share this post


Link to post
Share on other sites

Nie wina configu, a karty graficznej. Znajdź w necie uefi gop bios dla twojej karty, wgraj go i wyłącz CSM, problem minie. Miałem to samo, moja karta to GTX 660 od MSI. A i pamiętaj, że ten uefi gop bios musi być do twojego modelu twojej firmy. Nie możesz użyć np. uefi gop biosu dla asus gtx 660 jeśli masz kartę msi gtx 660. I nawet u tego samego producenta często są różne modele, np. u MSI tak było, ale napisałem na ich forum i mi dali do downloadu, wgrałem i jest git.

Share this post


Link to post
Share on other sites

Dzięki @arnon to chyba sobie odpuszczę to uefi gop bigos, bo zakładam że flashowanie tylko pod windowsem - nie mam :( co do samej grafiki to ja mam Gigabyte chyba z tego co pamietam.

 

Poczekam jeszcze na paczkę ze zaktualizowanym Cloverem.

 

P.S próbowałem zainstalować 10.11, ale wywala mi błąd

post-3897-0-63468300-1443983924_thumb.jpeg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.