Jump to content
Sign in to follow this  
AdamiPL

UniBootX Clover - MSI Z97 Gaming 5 + i7-4790K + GTX980TI

Recommended Posts

Robilem wlasnie klientowi kompa, wszystko dziala idealnie wiec podziele sie z innymi.

 

#

 

Wersja systemu: El Capitan 10.11.1

Płyta MSI Z97 Gaming 5 )

Chipset Z97

Procesor Intel CORE I7-4790K  (W moim przypadku)

Grafika zintegrowana: HD4600 (w moim przypadku NVIDIA GeForce GTX 980TI 6GB)

Audio: Intel High Definition Audio (ALC1150)

LAN: Killer E2205 (niby wedlug specyfikacji, ale jest Killer E2200)

 

 

  • W paczce załączone są kexty niezbędne do przeprowadzenia instalacji. Wypakowany katalog Z97 GAMING 5 (MS-7917) należy skopiować do /EFI/CLOVER/OEM/
    Dwuetapowa Instalacja przebiega bezproblemowo!

Karta sieciowa

Powinna ruszyć od strzała, odpowiedni kext umieszczony jest w Kexts/10.11
 

WIFI i BT

Nie do ruszenia..

Wsadziłem tu BCM94360CD + adapter :)

 

 

Dźwięk

http://hamac.pl/topic/10139-uniwersalne-legacy-applehda-dla-alc882-883-888-1200-892-1150-dla-yosemite-1010-el-capitan-1011/

 

 

DSDT & SSDT

Ta płyta główna nie potrzebuje patchy do DSDT, Wszystko działa OOTB.

Natomiast SSDT w zależności od Twojego procesora, wygeneruj skryptem Piker'a

https://github.com/P...ha/ssdtPRGen.sh

 

Wygenerowane SSDT.aml wrzucamy do 

 

/EFI/CLOVER/OEM/Z97 GAMING 5 (MS-7917)/ACPI/patched/

 

 

Grafika (nVidia)

Po instalacji systemu, w zależności jaką kartę graficzną posiadasz, warto zainstalować sterowniki do GeForca.

Pobrać je można np. stąd: http://www.insanelym...-capitan/page-1

 

​W configu ustawiona jest flaga: nv_disable=1 jesli nie potrzebujesz tej flagi, a Twoja karta dziala OOTB usun ten argument z configa.

 

 

Config zawiera również patch do włączenia TRIM na dyskach SSD

 

 

Po instalacji systemu na dysku, warto skopiować całą zawartość EFI z klucza UniBootX na partycję EFI dysku twardego. Zamontować ją można np. poprzez Clover Configurator.

 

Pamiętaj, any klucz UniBootX bootować w UEFI!

 

Na koniec, musisz wygenerować odpowiedni smbios, np poprzez Clover Configurator.

 

Dziala wszystko, oprocz wbudowanego WIFI, musisz je wylaczyc w ustawieniach.

 

USB 3.0 smiga jak szalone :)

 

 

 

post-2022-0-34171600-1445456209_thumb.png

post-2022-0-25258800-1445456219_thumb.png

post-2022-0-13571800-1445456227_thumb.png

post-2022-0-59165400-1445456233_thumb.png

post-2022-0-09418800-1445456399_thumb.png

Share this post


Link to post
Share on other sites

AdamiPL, a próbowałeś coś w tym porobić? Czy geekbench, coś tam, a pozatym niewiele....? :) Mam ten config, i u mnie też system instaluje się i działa, ale ubija dysk ssd po kilku/kilkunastu uruchomieniach - Invalid node structure (czyli zwalone btree). Dysk jest ok (Sandisk Ultra II) bo probowałem z innym egzemplarzem i dokładnie to samo. Może model, ale pomijając dysk - przypadkowe i nieoczekiwane Kernel Panic, albo po prostu restarty pojawiają się randomowo nie wiadomo czemu.

Share this post


Link to post
Share on other sites

ja tu miałem dysk Samsung EVO850 Pro 512GB, testowałem w różnych benchmarkach, pograłem trochę w wieśka 2, tomb rider, pobawiłem się w FCPX etc.. ogólnie ostro testowałem około 4dni,

nic takiego się nie pojawiło..

 

Sprawdzałeś dysk narzędziami systemowymi z poziomu HD Recovery?

Share this post


Link to post
Share on other sites

Oczywiście, fsck_hfs z przebudowaniem btree nawet go (je) pare razy uratowało. Jestem makowy od... 20 lat. i raczej mam problem z PC, Maca znam dobrze - pamiętam system 7 i pierwszego X-a też. Natomiast to mój pierwszy hamac i błądzę :).

 

Ale problem się rozwiązał - zaskakująco to nie dysk tylko kość RAM firmy Goodram. W końcu namierzyłem winowajcę memtestem i po wymianie wszystko działa jak złoto - POLECAM TEN SETUP :) chociaż tani nie był to i tak tańszy niż podstawowy pro 6,1 (nie do porównania, mam w tej cenie 3 monitory i 6 dysków - 2 ssd na systemy mac/win i 4 na raid10). Były chwile, że zwątpiłem ale jak widać niesłusznie!

 

Dzieki wielkie dla AdamiPL za dobry config - bez niego nie drążyłbym przyczyn awarii dysków i zwaliłbym je na mobo.

I dla Oswalidi'iego - od którego nabyłem na znanym serwisie aukcyjnym kartę WiFi i Bluetooth - ograniczyły mi do minimum ilość siwich włosów :) co prawda bluetooth nie lubi się naraz z myszką i słuchawkami, ale za to audio mam z głowy - po bluetoocie audio działa bez przeróbek :)

Share this post


Link to post
Share on other sites

AdmiPL:

Czy płyta MSI Z97 Gaming 3 może zastąpić plug&play tę z Twojego setupu ?

Zależy mi na DisplayPort, bo nie planuję karty graficznej, tylko zintegrowaną,

więc płyta musi mieć ten port.

 

Oczywiście WiFi i BT do wymiany, tak jak piszesz.

 

Nie będzie problemów ?

 

--

Piotrek

Share this post


Link to post
Share on other sites

Jeśli ten config działa na Twojej płycie raczej nie powinno być problemu, kwestia późniejszego ustawienia biosu chyba.. nie robiłem takich myków więc nie wiem na 100%

 

AdamiPL:

 

Próbuję użyć twojego configa na:

MSI z97 gaming 3 (praktycznie to samo co gaming 5)

i7-4790k

16GB DDR3 2400MHz

SSD Crucial MX100 256GB

Grafika zintegrowana Intel HD 4600

 

Inject dla Intel dałem na "true"

 

Nazwę płyty odpowiednio zmieniłem (Z97 GAMING 3 (MS-7918), odpala się Clover, ale po wybraniu

instalacji dostaje coś takiego:

 

sxAptioFixDrv: Starting overrrides for System\Library\CoreServices\boot.efi

Using reloc block: no, hibernate wake: no

 

I następuje reset kompa.

 

ae31d402806a7fadmed.jpg

 

Usunąłem z drivers64UEFI pliki:

OsxAptioFix2Drv-64.efi

OsxAptioFixDrv-64.efi

 

To komp stoi na czarnym ekranie.

 

Podpowiesz, co z tym zrobić ?

 

Twój config powinien 1:1 pasować do mojej płyty, pewnie jakaś drobnostka.

 

--

pozdrawiam

Piotrek

Share this post


Link to post
Share on other sites

Jeśli jest taka sama jak Gaming-5 to użyj OsxAptioFix2Drv-64.efi (OsxAptioFixDrv-64.efi możesz wyłączyć w configu albo wyrzucić) i sprawdz czy masz w driverach HFSPlus.efi zamiast VBoxHFS.efi (z VBoxHFS.efi ta płyta Ci nie pójdzie)

 

Na Gaming-5 inject na intela działa ok. więc na Gaming-3 zapewne też.

Share this post


Link to post
Share on other sites

Niestety, żadna z tych rad nie zmienia stanu rzeczy.

Kurcze... kupiłem tę płytę specjalnie, żeby postawić system na configu AdamiPL do gaming 5 (wziąłem gaming 3 bo ma DisplayPort,

a ja chcę używać grafiki zintegrowanej, reszta to to praktycznie to samo).

Robię klucz dokładnie wg poradnika, wgrywam config AdamiPL, zmieniam nazwę płyty na taką

jak dostaję w preboot.log, wyłączam w configu OsxAptioFixDrv-64.efi, wrzucam HFSPlus.efi zamiast VBoxHFS.efi

i dalej kupa :-(

Ludzie, niech ktoś pomoże, przecież to musi się dać wystartować !

--

Piotrek

Share this post


Link to post
Share on other sites

Pytanko czy ta konfiguracja ma szanse działać pod:

 

Wersja systemu: El Capitan 10.11.3

Płyta Gigabyte Z97x Gaming 5

Chipset Z97

Procesor Intel CORE I7-4790K

Grafika: NVIDIA GeForce GTX 970

LAN: Killer E2200

 

Zainstalowałem system z domyślną konfiguracją na unibootx "haswell z97", oczywiście system odpaliłem ale nie działa między innymi sieć i dźwięk :(

Share this post


Link to post
Share on other sites

Pobrałem tą paczkę zainstalowałem od nowa system, sieć działa bez problemów nawet z raspberry-pi mi się łączy :) Zainstalowałem sterowniki nvidia i też śmiga jak ta lala więc odpalam już bez bootflag nv_disable. Jedyny problem jaki mam to brak sterowników dla karty dźwiękowej ktoś wie jak to załatwić gdzie i czego szukać?

Share this post


Link to post
Share on other sites

Pytanko, czy wszystkie patche w kext patches muszą zostać czy można coś pousuwać żeby nie uwalić systemu?
Dodam, że system już mi działa jedyne co to mam problemy z audio.

 

 

 

<key>KernelAndKextPatches</key>
<dict>
<key>AppleRTC</key>
<false/>
<key>ForceKextsToLoad</key>
<array>
<string>\System\Library\Extensions\IONetworkingFamily.kext</string>
</array>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>ALC1150 patch</string>
<key>Find</key>
<data>
ixnUEQ==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
AAnsEA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>t1-HD4600_HDMI_Audio-1of2</string>
<key>Find</key>
<data>
PQsMAAA=
</data>
<key>Name</key>
<string>AppleHDAController</string>
<key>Replace</key>
<data>
PQwMAAA=
</data>
</dict>
<dict>
<key>Comment</key>
<string>t1-HD4600_HDMI_Audio-2of2</string>
<key>Find</key>
<data>
PQwKAAA=
</data>
<key>Name</key>
<string>AppleHDAController</string>
<key>Replace</key>
<data>
PQwMAAA=
</data>
</dict>
<dict>
<key>Comment</key>
<string>t1-10.11-AppleHDA/Realtek ALC...</string>
<key>Find</key>
<data>
gxnUEQ==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
AAAAAA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>t1-AppleHDA/Resources/xml>zml</string>
<key>Find</key>
<data>
eG1sLnps
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
em1sLnps
</data>
</dict>
<dict>
<key>Comment</key>
<string>t1-10.9-10.11-AppleHDA/Realtek ALC1150</string>
<key>Find</key>
<data>
ixnUEQ==
</data>
<key>Name</key>
<string>AppleHDA</string>
<key>Replace</key>
<data>
AAnsEA==
</data>
</dict>
<dict>
<key>Comment</key>
<string>TRIMM Enabler</string>
<key>Find</key>
<data>
QVBQTEUgU1NEAA==
</data>
<key>Name</key>
<string>IOAHCIBlockStorage</string>
<key>Replace</key>
<data>
AAAAAAAAAAAAAA==
</data>
</dict>
</array>
</dict> 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.