Jump to content
Sign in to follow this  
kormoran

Dell E7440 - nie włącza się instalacja

Recommended Posts

Witam serdecznie,

 

mam problem z w/w dellem.

 

Chciałem postawić na nim El Capitana.

 

Robiłem to wg tego poradnika:

http://forum.osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/

 

Tylko zamiast tamtych DSDT wygenerowałem swoje, następnie nałożyłem poprawki wg tego pliku

https://www.dropbox.com/s/du6ee0eislnzan2/Dell%20E7x40%20patches.txt

 

Bez poprawek miałem still waiting for root, z poprawkami jest lepiej, tzn. po bardzo długim czasie czekania pojawia mi się screen jak w załączniku. Czekałem ponad 1h ale nic dalej nie ruszyło.

 

post-3500-0-56845700-1494628664_thumb.jpg

 

Podstawowa konfiguracja:

i7-4600U

8gb ram

HD4400

1920x1020

 

Config:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>DropOEM_DSM</key>
			<false/>
			<key>Name</key>
			<string>DSDT.aml</string>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<true/>
			<key>Generate</key>
			<dict>
				<key>CStates</key>
				<false/>
				<key>PStates</key>
				<false/>
			</dict>
			<key>PluginType</key>
			<string>1</string>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>-v dart=0 kext-dev-mode=1</string>
		<key>CustomLogo</key>
		<false/>
		<key>Debug</key>
		<false/>
		<key>DefaultVolume</key>
		<string>El Capitan</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>-1</integer>
		<key>XMPDetection</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>FakeID</key>
		<dict>
			<key>IntelGFX</key>
			<string>0x04128086</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>FixOwnership</key>
			<false/>
			<key>Inject</key>
			<false/>
		</dict>
	</dict>
	<key>GUI</key>
	<dict>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<false/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>8</integer>
		</dict>
		<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<false/>
			<key>Linux</key>
			<false/>
			<key>Tool</key>
			<false/>
		</dict>
		<key>Theme</key>
		<string>orange</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>DualLink</key>
		<integer>0</integer>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<false/>
		</dict>
		<key>NvidiaSingle</key>
		<false/>
		<key>ig-platform-id</key>
		<string>0x0a260006</string>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleRTC</key>
		<true/>
		<key>AsusAICPUPM</key>
		<true/>
		<key>Debug</key>
		<false/>
		<key>KernelCpu</key>
		<false/>
		<key>KernelHaswellE</key>
		<false/>
		<key>KernelLapic</key>
		<false/>
		<key>KernelPm</key>
		<true/>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>AppleHDA #4</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				gxnUEQ==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				AAAAAA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AppleHDA ALC 292 #3</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				hQjsEA==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				AAAAAA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AppleHDA ALC 292 #2</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				hAjsEA==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				AAAAAA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>External Icon Patch</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				RXh0ZXJuYWw=
				</data>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Replace</key>
				<data>
				SW50ZXJuYWw=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>0x0a260006 9MB cursor bytes patch</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				BgAmCgEDAwMAAAACAAAwAQAAYAA=
				</data>
				<key>Name</key>
				<string>AppleIntelFramebufferAzul</string>
				<key>Replace</key>
				<data>
				BgAmCgEDAwMAAAACAAAwAQAAkAA=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>HDMI-audio</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AQUJAAAEAACHAAAA
				</data>
				<key>Name</key>
				<string>AppleIntelFramebufferAzul</string>
				<key>Replace</key>
				<data>
				AQUSAAAIAACHAAAA
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>AppleHDA ALC 292 #1</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				hBnUEQ==
				</data>
				<key>Name</key>
				<string>AppleHDA</string>
				<key>Replace</key>
				<data>
				kgLsEA==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>SecondStagePatch 10.11</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AQAAdRc=
				</data>
				<key>Name</key>
				<string>IOGraphicsFamily</string>
				<key>Replace</key>
				<data>
				AQAAdBc=
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>Enable TRIM for SSD</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				AEFQUExFIFNTRAA=
				</data>
				<key>Name</key>
				<string>IOAHCIBlockStorage</string>
				<key>Replace</key>
				<data>
				AAAAAAAAAAAAAAA=
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>BooterConfig</key>
		<string>0x28</string>
		<key>CsrActiveConfig</key>
		<string>0x67</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>05/24/13</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>MBA61.88Z.0099.B04.1305241529</string>
		<key>Board-ID</key>
		<string>Mac-7DF21CB3ED6977E5</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardType</key>
		<integer>10</integer>
		<key>ChassisAssetTag</key>
		<string>Air-Enclosure</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>10</string>
		<key>Family</key>
		<string>MacBook Air</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>Mobile</key>
		<true/>
		<key>ProductName</key>
		<string>MacBookAir6,2</string>
		<key>SerialNumber</key>
		<string>CK252E3ZF5V8</string>
		<key>Trust</key>
		<false/>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Yes</string>
	</dict>
</dict>
</plist>

Kexty:

ACPIBatteryManager.kext
FakePCIID_HD4600_HD4400.kext
FakePCIID.kext
FakeSMC_ACPISensors.kext
FakeSMC_CPUSensors.kext
FakeSMC_GPUSensors.kext
FakeSMC_LPCSensors.kext
FakeSMC.kext
IntelBacklight.kext
IntelMausiEthernet.kext
VoodooPS2Controller.kext

 

Wywalałem wszystko inne zostawiając tylko FakeSMC.kext ale to samo.

 

Clover  4051. Próbowałem konfig rehabmana do hd4400 ale też jest to samo.

 

Może macie jakiś pomysł co zrobić. Z góry dzięki.

 

Share this post


Link to post
Share on other sites

Dziwi mnie coraz częściej logika ludzi. Większość nie umie szukać informacji w internecie.

 

Wracając do tematu. Dlaczego nie rusza ci instalacja ? Nie wiadomo. Dlaczego ? Bo nawet nie sprawdziłeś. Próbujesz na ślepo usuwać, zmieniać i liczysz na to, że może instalacja ruszy. Jak sprawdzić co jest przyczyną ? Najczęściej tryb Verbose wszystko wyjaśnia.

 

Poza tym, moim zdaniem umieszczanie zmodyfikowanego, gotowego DSDT jest kiepskim pomysłem na dłuższa metę, chyba, że masz je naprawdę dobrze przygotowane. 

 

btw. W regulaminie albo gdzieś przypięta powinna być informacja aby załączać screen z verbose i plik .config jak ktoś ma problem

Share this post


Link to post
Share on other sites

A dlaczego od razu ze nie chce mi się czytać? W verbose nie ma żadnych komunikatów - to jest pierwsza rzecz jaką sprawdzałem - jak kończą się komunikaty ładuje się to okienko i stoi. Aż taki leniwy nie jestem żeby tego nie sprawdzić.

 

Wyżej napisałem ze nie używam gotowego DSDT tylko wygenerowałem swój z clovera po czym dorzuciłem poprawki zgodnie z zawartością pliku tekstowego (dokładnie w nim są standardowe poprawki zalecane przez RehabMan do dołożenia do DSDT tylko zebrane w jednym pliku tekstowym). I sprawdziłem ze dopiero naniesienie poprawek do USB umożliwia dojście do tego momentu co przedstawiłem na screenie. Bez tego nawet w verbose nic co mogło by pomóc nie ma.

Share this post


Link to post
Share on other sites

Ok,

 

wszystko działa. Zastosowałem Unibootx najnowszy, wziąłem konfig z Haswela H87. Wygenerowałem swój DSDT spod tego Clovera, naniosłem poprawki DSDT i instalacja ruszyła. Następnie poprawki do odpalenia HD4400 i system stoi. Teraz tylko doprawianie.

 

PS miałem następne Kernel Panic - w jednym przypadku pomogła aktualizacja FakeSMC, w drugim przypadku okazało się że VoodooPS2Controller.kext też jest nie kompatybilny i aktualizacja pomogła (mimo że w verbose nic na temat tego kexta nie pisało).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.