Jump to content
Sign in to follow this  
Bryk

Problem z 892

Recommended Posts

Witam.

Używałem wcześniej asus xonar u5 na usb więc się nie bawiłem w audio na płycie ale widzę pod windows że słuchawki mocniej grają na integrze niż na tym xonarze więc próbuję to ogarnąć.

 

  • Płyta: Asus Z97-A-USB31
  • CPU: Intel Core i7-4790K
  • GPU: Palit GTX 970 4 GB
  • Audio: Realtek ALC892

w Clover inject 7

 

config https://pastebin.com/eTtuR970

 

W linkach okienko z ustawień audio oraz lista kextów

Niby wyświetla wyjścia audio nawet zmienia wyjście po podłączeniu słuchawek do przedniego panelu ale dźwięku nie ma.  

 

A jeszcze jedno po dodaniu potrzebnego FixHDA_8000. w clover następuje kp systemu zaraz przy starcie więc jestem w kropce.

audio dump.tiff

kext list.tiff

Share this post


Link to post
Share on other sites

Poprawka.

Po podgłośnieniu poziomu głośności oraz głośniczków na maxa stwierdzam że słychać dźwięk lecz tak minumum.

Dalej się głowie co zrobić aby wystartować z parametrem fixhda_8000 gdyż zawsze następuje kp systemu.

Share this post


Link to post
Share on other sites

FixHDA odpowiada za zmianę nazwy na HDEF i wstrzyknięciu parę innych rzeczy, wątpię żebyś bez tego słyszał dźwięk przez AppleHDA (chyba że Clover sam uaktywniania sobie Fixa jak znajdzie Inject Audio).

 

Wywal patche do AppleHDA z config.plist.

Share this post


Link to post
Share on other sites

Prawdopodobnie nie stratują wzmacniacze, dość częsty problem na Z97. Dorzuć EAPDFix, Przetestuj pozostałe inject np 1. 

 

PS Raczej żadna pokładówka nie zagra lepiej niż Xonar U5 - być może głośniej, ale nie lepiej. 

Share this post


Link to post
Share on other sites

Coś mi się wydaje że ta na tej płycie nie uruchomie pokładówki . Po dodaniu EAPDFix znowu kp systemu. Testowałem wszystkie injecty od 1-7 dźwięk był bardzo cichy ale po podgłośnieniu na max wszystkiego .

Szkoda że w tym U5 nie można zbostować słuchawek jak pod windows - jest sporo głosniej.

Dzięki za pomoc.

Share this post


Link to post
Share on other sites

Mam ten kodek na z97-c, dźwięk odpalony metoda z lilu. Podczas uruchamiania systemu dźwięk nie startuje raz na jakieś 20 razy. Czym to może być spowodowane?

W 10.12 mam codeccomander bo po sleepie dźwięk charczał.

Share this post


Link to post
Share on other sites

Dźwięk działa na layount 1,2,3,4,5,7... potem 28,31,92,99 

ale różnią się ilością urządzeń audio. Dlaczego w raporcie systemowym widziane jest urządzenie hdmi/DP audio, a w menedżerze brak?

 

6411df6c5baa0.png

Share this post


Link to post
Share on other sites

Dlaczego w raporcie systemowym widziane jest urządzenie hdmi/DP audio, a w menedżerze brak?

Bo to WYJŚCIE a nie wejście i pokazuje się tylko jak masz monitor/TV podłączony z obsługą audio po złączu np DP/HDMI.

Share this post


Link to post
Share on other sites

Zaczerpnąłem wiedzy i podobno moja karta to pascal i tam nie da się odpalić hdmi audio. To prawda?

Bzdura. Zarówno na GTX1060 jak i GTX1080Ti (na tym potwierdzam, bo miałem możliwość sprawdzić :) ) HDMI audio działa bez większych problemów.

Share this post


Link to post
Share on other sites

Możesz się podzielić tą wiedzą? Próbowałem przed ssdt, ale efekt ten sam. Urządzenie widziane w raporcie systemowym, a w urządzeniach audio brak.

 

Edit:

 

Postęp. Dźwięk pojawia się wówczas gdy na uruchomionym systemie zmienię źródło z hdmi na DP i odwrotnie. Źródło, na którym uruchomił się system nie podaje dźwięku.

 

9af8962efc574.jpg

 

Dlaczego dźwięk nie startuje podczas uruchamiania systemu, a dopiero po przepięciu źródła?

 

Uruchamiam metodą hdmiaudio.kext i ssdt (PEG0)

 

***

 

To jest właśnie pomoc... ktoś wie, ale nie powie bo jeszcze ktoś inny też uruchomi i wtedy będzie skandal. Brak słów.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.