Jump to content
Sign in to follow this  
OneGhost

iMessage na GA965p-S3

Recommended Posts

Przeglądnąłem i wypróbowałem już chyba wszystkie możliwe tutoriale na temat iMessage / Facetime i nadal nie działa. Jestem praktycznie pewny, że jest wszystko skonfigurowane tak jak było podane w instrukcjach. Mam dodaną kartę kredytową do konta. Używam w clover definicji SMBIOS iMac10,1. Ethernet jest na en0. Serial Number ma 11 znaków, Board Serial Number 13. Na Rt Variables mam ustawione:
ROM: Wygenerowany w nowym Clover Configurator (chyba dzisiaj był update) z opcją Hack

MLB: Pusty (wydaje mi się, że to się wczytuje ze strony SMBIOS z Board Serial Number)

BooterConfig: 0x28

CsrActiveConfig: 0x67

 

Na prawdziwym macbooku mogę się zalogować na to konto, a na hackintosh dostaję zawsze komunikat, że muszę zadzwonić do Apple i podać wyświetlany kod. Czy da się z tym coś zrobić?

Share this post


Link to post
Share on other sites

http://hamac.pl/topic/14042-generowanie-indywidualnych-numer%C3%B3w-smbios-uruchomienie-imessage/

 

Nie wszystko masz prawidłowo ustawione. 

 

PS Zdecyduj się w którym wątku piszesz. 

Szczerze już nie mam pojęcia co mogę mieć tutaj źle. Wydaje mi się, że jednak (może od niedawna) wygenerowane klucze seryjne nie działają, bo Apple musi dodać je do swojej bazy. W każdym razie, tutaj jest mój plik config.plist, być może ktoś może mi powiedzieć co tutaj mogę mieć źle?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Debug</key>
			<false/>
			<key>Fixes</key>
			<dict>
				<key>FixHeaders_20000000</key>
				<true/>
			</dict>
			<key>Name</key>
			<string>DSDT.aml</string>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>DropTables</key>
		<array>
			<dict>
				<key>Signature</key>
				<string>DMAR</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>CpuPm</string>
			</dict>
			<dict>
				<key>Signature</key>
				<string>SSDT</string>
				<key>TableId</key>
				<string>Cpu0Ist</string>
			</dict>
		</array>
		<key>HaltEnabler</key>
		<true/>
		<key>SSDT</key>
		<dict>
			<key>Generate</key>
			<dict>
				<key>CStates</key>
				<true/>
				<key>PStates</key>
				<true/>
			</dict>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Debug</key>
		<false/>
		<key>DefaultLoader</key>
		<string>boot.efi</string>
		<key>DefaultVolume</key>
		<string>Macintosh HD</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>NeverDoRecovery</key>
		<true/>
		<key>Timeout</key>
		<integer>3</integer>
	</dict>
	<key>BootGraphics</key>
	<dict>
		<key>EFILoginHiDPI</key>
		<integer>1</integer>
		<key>UIScale</key>
		<integer>1</integer>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>ResetHDA</key>
			<true/>
		</dict>
		<key>USB</key>
		<dict>
			<key>AddClockID</key>
			<true/>
			<key>FixOwnership</key>
			<true/>
			<key>Inject</key>
			<true/>
		</dict>
	</dict>
	<key>GUI</key>
	<dict>
		<key>Language</key>
		<string>pl:0</string>
		<key>ScreenResolution</key>
		<string>1920x1080</string>
		<key>Theme</key>
		<string>embedded</string>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleRTC</key>
		<true/>
		<key>AsusAICPUPM</key>
		<false/>
		<key>Debug</key>
		<false/>
		<key>DellSMBIOSPatch</key>
		<false/>
		<key>KernelCpu</key>
		<false/>
		<key>KernelHaswellE</key>
		<false/>
		<key>KernelLapic</key>
		<false/>
		<key>KernelPm</key>
		<false/>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>External icons patch</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				RXh0ZXJuYWw=
				</data>
				<key>Name</key>
				<string>AppleAHCIPort</string>
				<key>Replace</key>
				<data>
				SW50ZXJuYWw=
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>BooterConfig</key>
		<string>0x28</string>
		<key>CsrActiveConfig</key>
		<string>0x67</string>
		<key>ROM</key>
		<string>UseMacAddr0</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BiosReleaseDate</key>
		<string>06/26/17</string>
		<key>BiosVendor</key>
		<string>Apple Inc.</string>
		<key>BiosVersion</key>
		<string>IM101.88Z.00CD.B01.1706261549</string>
		<key>Board-ID</key>
		<string>Mac-F2268CC8</string>
		<key>BoardManufacturer</key>
		<string>Apple Inc.</string>
		<key>BoardSerialNumber</key>
		<string>YM04005PE1KHC</string>
		<key>BoardType</key>
		<integer>10</integer>
		<key>ChassisAssetTag</key>
		<string>iMac-Aluminum</string>
		<key>ChassisManufacturer</key>
		<string>Apple Inc.</string>
		<key>ChassisType</key>
		<string>0x13</string>
		<key>Family</key>
		<string>iMac</string>
		<key>LocationInChassis</key>
		<string>Part Component</string>
		<key>Manufacturer</key>
		<string>Apple Inc.</string>
		<key>Mobile</key>
		<false/>
		<key>ProductName</key>
		<string>iMac10,1</string>
		<key>SerialNumber</key>
		<string>YM0418ZM5PE</string>
		<key>SmUUID</key>
		<string>E76DEBBB-6437-4E9D-A1E4-11715C69E64B</string>
		<key>Version</key>
		<string>1.0</string>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Detect</string>
		<key>InjectSystemID</key>
		<true/>
	</dict>
</dict>
</plist>

Share this post


Link to post
Share on other sites

Wszystko - takiego configu nawet nie chce mi się przeglądać, ani wyłapywać, co jest wyłączone, a co nie. 

 

Było dużo jakichś komentarzy w pliku, usunąłem je jeśli o to chodzi, teraz jest krótszy. Tutaj jest w formie pliku do otwarcia w Clover Configurator

https://www.dropbox.com/s/fqwbdpe4hdc34lw/config.plist?dl=1

Obecnie BoardSerialNumber jest wygenerowany automatycznie przez nową wersję Clover Configurator, dlatego jest inny niż SerialNumber z dodanymi znakami. Wcześniej próbowałem dopisywać 2 znaki hex, ale efekt był taki sam.

Share this post


Link to post
Share on other sites

Możliwe że Clover nie wczytuje poprawnie Macaddresu karty sieciowej. Spróbuj wpisać tam ręcznie macaddress.

 

BooterConfig i CsrActiveConfig zbędne - clover sam wstawia właściwe wartości.

 

Reszta opisana tu: http://hamac.pl/topic/14042-generowanie-indywidualnych-numer%C3%B3w-smbios-uruchomienie-imessage/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.