Jump to content
Sign in to follow this  
yabba235

Kaby Lake dual monitor setup

Recommended Posts

WItam !

Mam proste pytanie - czy na grafice hd630 z procka i5-7500hq działa konfiguracja z dwoma monitorami ?

 

Nie chodzi mi o jedoczesną pracę tylko podłączenie kablem i przełączanie z jednego na drugi ?

 

Dodam ,ze w kompie mam dwa wyjścia video; display port i hdmi ( ten drugi jest zrobiony z dp i czipa ), wiec ioreg pokazuje dwa porty DP, ale choć wszystko mi działa ( audio i akceleracja ) to tylko na wyjściu HDMI ( DP 2 ), kiedy bootuję kompa z podłaczonym minitorem pod DP 1 ( poprzez przejściówkę dp>hdmi ) to mam logo apple i [potem czarny ekran , jak by zanikał sygnał video ), jak podłączę tylko wyjście hdmi to botuje normalnie.

 

 Ten typ tak ma i musze pzrełaćzać kable czy jest jakaś porada na to ?

debug_7434.zip

Share this post


Link to post
Share on other sites

Wbudowane grafiki intela nie obsługują Hot Plug.

Jesteś pewny ?

W/g tonymacx96 to działą na hd530, niestety, nie odpowiedzieli mi czy to samo dotyczy HD630.

Sam miałem przypadek podczas zabaw z różnymi konfigami że mogłem soebie podłaczac raz sam monitor, potm receiver av , potem pracowąły oba naraz a ja miałem w właściwościach dwa połączenia hdmi. Niestety, nie udało mi sie tego powtórzyć ( teraz juz wiem, że jak coś dziaął to nie ruszać konfigu :)

Obecnie mam podłączone jdno wyjście hdmi, jak chcę podłaćzyć dp z adpaterem hdmi to mam reset. a na samym dp mam czarny ekran ( wyjście hdmi byo wtedy wyłączone ).

Podobno na hd630 ni działa boot na dwóch monitorach, al to mnei nie interesuje.

Share this post


Link to post
Share on other sites

Ok, a więc tak: dual monitor @ hotplug działa na configu iMac18,3 id-platform 0x5912000, plus patch dp2hdmi i patch black screen.

FakeID musi być 59168086. No i trzeba uzyć useintelhdmi aby było audio: ja mam dp do receivera  i hdmi do tv samsunga.

 

Oczyiwiśie dotyczy to mojego kompa, czyli zotac-a MI553 :)

 

 

Spokojnie mogę przełączać pomiędzy tv a marantzem AV.

post-10596-0-53013500-1513962320_thumb.png

Share this post


Link to post
Share on other sites

Gratuluję zacięcia i sukcesu. Przy moich walkach z HD4600 to niestety dostawałem KP przy podłączaniu/odłączaniu kabla. Być może dla systemu wyjście którym się bawiłem było rozpoznawane jako np wbudowane i tam faktycznie Hot Plug nie powinien mieć miejsca.

Share this post


Link to post
Share on other sites

@yabba235 usypianie nadal nie działa prawidłowo zgadza się ?

Szczerze, to nie wiem :) nigdy z tego nie korzystałem.

 

Ok, dual monitor działa, ALE nie działa mi acceleracja poprzez videotoolbox w kodi  :cry: .

Ale accelerację jako taka w macosie mam przecież ??

 

Najlepsze jest to, że działa mi ( ale nie na plikach vc-1) na smbiosie macbookpro14,3. Tylko wtedy nie mam dual monitors :).

 

No i jeszcze jedna sprawa, niby nic takiego ale....system  ładuje ale nie za każdym razem, czasem muszę kilka razy robić reboot, wybierać ręcznie plik configa i wtedy "zaskakuje".

 

I mam jeszcze jedna ciekawostke ( tylko na configu imac-a ) przy bootowaniu systemu mam długą przerwę ( widac jakieś artefakty na ekranie - wtedy wiem, że config zaskoczył ) po czym pojawia sie jabłko i pasek postępu dochodzi do ekranu logowania  - jest to lekko wkurzające, bo system startuje mi naprawde szybko ( choć mam ssd nvme evo ) - być może system czeka na inny monitor czy cuś  :?: .

Share this post


Link to post
Share on other sites

Z tego co ja widzę to nadal masz dobrze namotane niestety :/

Pewnie tak - jedno pytanko - czy kexty zawsze trzeba instalować via kextutil w folderach s/l/e i l/e * nawet nie wiem, co to za różnica ).

Ja mam w l/e/: USBInjectAll.kext a w s/l/e:USBInjectAll.kext,AHCIPortInjector.kext,FakePCIID_XHCIMux.kext,FakePCIID_Intel_HD_Graphics.kext,FakePCIID.kext,FakePCIID_Intel_HDMI_Audio.kext.

Z drugiej strony po co te kexty skoro macos 10.13.2 na pewno obsługuje natywnie już grafikę ( chyba tylko te odd usb są potrzebne ), nie wiem też, czy te patche do grafiki są potrzebne ( j/w).

Ale ogólnie jest ok, tylko musze kilka razy robić restart aby config zaskoczył  :evil: .

l

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.