Jump to content
Maidenman

10.12.6 zawiesza się po bezczynności

Recommended Posts

Cześć, od kilku miesięcy (mniej więcej od aktualizacji UniBootX do najnowszej wersji, chyba z września) mam problem z zawieszaniem się systemu po kilkunastominutowym okresie bezczynności systemu. Nie ważne, czy odejdę od komputera w połowie oglądania filmu czy świeżo po nowym uruchomieniu systemu, to kiedy wracam po kilkunastu minutach, system strasznie zamula i przez około minutę reaguje na cokolwiek z -5-10 sekundowym opóźnieniem. Jak dam mu się "rozpędzić" to dalej jest już OK. Dopóki aktywnie pracuję i używam hackintosha, to wszystko działa jak należy. Ale wystarczy, że zadzwoni telefon, wyjdę na obiad czy cokolwiek, to już po powrocie mam efekt jak opisałem wyżej.

 

Początkowo myślałem, że to coś z usypianiem, ale nie mam włączonego wygaszacza, ekranu, usypianie systemu i monitorów ustawiłem na 1h, ale pomimo tego problem nadal występuje.

 

Pracuję na najnowszej wersji UniBootX z 8 grudnia 2017 oraz Clover 4334. Domyślna konfiguracja dla Z-97, bez żadnych dodatkowych kextów. Ma ktoś jakiś pomysł? Poniżej kopia mojego config.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>ACPI</key>
	<dict>
		<key>DSDT</key>
		<dict>
			<key>Patches</key>
			<array>
				<dict>
					<key>Comment</key>
					<string>change EHC1 to EH01</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					RUhDMQ==
					</data>
					<key>Replace</key>
					<data>
					RUgwMQ==
					</data>
				</dict>
				<dict>
					<key>Comment</key>
					<string>change EHC2 to EH02</string>
					<key>Disabled</key>
					<false/>
					<key>Find</key>
					<data>
					RUhDMg==
					</data>
					<key>Replace</key>
					<data>
					RUgwMg==
					</data>
				</dict>
			</array>
			<key>ReuseFFFF</key>
			<false/>
		</dict>
		<key>DropTables</key>
		<array>
			<dict>
				<key>Signature</key>
				<string>DMAR</string>
			</dict>
		</array>
		<key>SSDT</key>
		<dict>
			<key>DropOem</key>
			<false/>
			<key>Generate</key>
			<dict>
				<key>APLF</key>
				<false/>
				<key>APSN</key>
				<false/>
				<key>CStates</key>
				<false/>
				<key>PStates</key>
				<false/>
				<key>PluginType</key>
				<true/>
			</dict>
		</dict>
	</dict>
	<key>Boot</key>
	<dict>
		<key>Arguments</key>
		<string>kext-dev-mode=1</string>
		<key>Debug</key>
		<false/>
		<key>DefaultVolume</key>
		<string>OS X</string>
		<key>Legacy</key>
		<string>PBR</string>
		<key>NeverHibernate</key>
		<true/>
		<key>Secure</key>
		<false/>
		<key>Timeout</key>
		<integer>2</integer>
		<key>XMPDetection</key>
		<false/>
	</dict>
	<key>CPU</key>
	<dict>
		<key>UseARTFrequency</key>
		<false/>
	</dict>
	<key>Devices</key>
	<dict>
		<key>Audio</key>
		<dict>
			<key>Inject</key>
			<string>11</string>
		</dict>
		<key>USB</key>
		<dict>
			<key>FixOwnership</key>
			<false/>
			<key>Inject</key>
			<false/>
		</dict>
	</dict>
	<key>DisableDrivers</key>
	<array>
		<string>PartitionDxe</string>
		<string>DataHubDxe</string>
		<string>VBoxHfs</string>
		<string>OsxLowMemFixDrv</string>
		<string>DumpUefiCalls</string>
		<string>FSInject</string>
		<string>CsmVideoDxe</string>
		<string>OsxAptioFixDrv</string>
		<string>EmuVariableUefi</string>
	</array>
	<key>GUI</key>
	<dict>
		<key>CustomIcons</key>
		<true/>
		<key>Language</key>
		<string>pl:30788:0</string>
		<key>Mouse</key>
		<dict>
			<key>DoubleClick</key>
			<integer>500</integer>
			<key>Enabled</key>
			<true/>
			<key>Mirror</key>
			<false/>
			<key>Speed</key>
			<integer>2</integer>
		</dict>
		<key>Scan</key>
		<dict>
			<key>Entries</key>
			<true/>
			<key>Legacy</key>
			<false/>
			<key>Linux</key>
			<false/>
			<key>Tool</key>
			<true/>
		</dict>
		<key>Theme</key>
		<string>bootcamp</string>
	</dict>
	<key>Graphics</key>
	<dict>
		<key>Inject</key>
		<dict>
			<key>ATI</key>
			<false/>
			<key>Intel</key>
			<true/>
			<key>NVidia</key>
			<false/>
		</dict>
	</dict>
	<key>KernelAndKextPatches</key>
	<dict>
		<key>AppleIntelCPUPM</key>
		<false/>
		<key>AppleRTC</key>
		<false/>
		<key>Debug</key>
		<false/>
		<key>ForceKextsToLoad</key>
		<array>
			<string>\System\Library\Extensions\IONetworkingFamily.kext</string>
		</array>
		<key>KernelCpu</key>
		<false/>
		<key>KernelLapic</key>
		<false/>
		<key>KernelXCPM</key>
		<false/>
		<key>KextPatchesAllowed</key>
		<true/>
		<key>KextsToPatch</key>
		<array>
			<dict>
				<key>Comment</key>
				<string>change 15 port limit to 26 in XHCI kext</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g72M/v//EA==
				</data>
				<key>MatchOS</key>
				<string>10.11.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
				<key>Replace</key>
				<data>
				g72M/v//Gw==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>change 15 port limit to 26 in XHCI kext</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g710////EA==
				</data>
				<key>MatchOS</key>
				<string>10.12.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
				<key>Replace</key>
				<data>
				g710////Gw==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>change 15 port limit to 26 in XHCI kext</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				g32MEA==
				</data>
				<key>MatchOS</key>
				<string>10.13.x</string>
				<key>Name</key>
				<string>com.apple.driver.usb.AppleUSBXHCIPCI</string>
				<key>Replace</key>
				<data>
				g32MGw==
				</data>
			</dict>
			<dict>
				<key>Comment</key>
				<string>TRIMM Enabler</string>
				<key>Disabled</key>
				<false/>
				<key>Find</key>
				<data>
				QVBQTEUgU1NEAA==
				</data>
				<key>Name</key>
				<string>IOAHCIBlockStorage</string>
				<key>Replace</key>
				<data>
				AAAAAAAAAAAAAA==
				</data>
			</dict>
		</array>
	</dict>
	<key>RtVariables</key>
	<dict>
		<key>ROM</key>
		<string>XXXXXXXXX</string>
	</dict>
	<key>SMBIOS</key>
	<dict>
		<key>BoardSerialNumber</key>
		<string>XXXXXXXXX</string>
		<key>SerialNumber</key>
		<string>XXXXXXXXX</string>
		<key>SmUUID</key>
		<string>XXXXXXXXX</string>
		<key>ProductName</key>
		<string>iMac14,2</string>
		<key>Trust</key>
		<true/>
	</dict>
	<key>SystemParameters</key>
	<dict>
		<key>InjectKexts</key>
		<string>Yes</string>
	</dict>
</dict>
</plist>

Share this post


Link to post
Share on other sites

Sterowniki webowe nvidii. Nic nie zrobisz. Problem zauważony już dobre parę miesięcy temu. Precyzyjnie mówiąc nie zawiesza się, a przymula na paręnaście/dziesiąt sekund a potem już jest OK. 

Share this post


Link to post
Share on other sites

Sorry za post pod postem, ale nie dawało mi to spokoju i pomogłem sam sobie. Myślę, że warto podzielić się wiedzą z innymi użytkownikami. Okazuje się, że faktycznie problem jest znany, ale u mnie nie ma powiązania ze sterownikami nVidii. Występuje jednak regularnie na Macach i był poruszany na forum Apple. Wystarczyło jedynie usunąć jeden plik ze ścieżki /System/Library/LaunchAgents/com.apple.mediaanalysisd.plist

 

A co robi i dlaczego nagle zaczął robić problemy? Takie wytłumaczenie znalazłem na Reddicie:

 

 

It analyses the media (especially your Photo's library) on your Mac. Since the process "lives" in 'LaunchAgents' the process should start every time you start your Mac.

 
It was probably analysing your media when something "bad" happened, what caused the process to use extraordinary amounts of your CPU (a 'fake CPU load').
 
Since the configurations for the process reside in 'com.apple.mediaanalysisd.plist' removing the file will cause the file to be regenerated on startup. This starts the process completely clean (without it being persistently damaged from a previous misconfiguration).

 

Skoro proces odpala się tylko w trakcie bezczynności komputera, można też dać mu trochę czasu, aby sam dokończył analizowanie mediów (co u niektórych zajmowało nawet 2 dni). Tak czy inaczej - problem rozwiązany.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.