Jump to content
Sign in to follow this  
olej7777

Fcpx slaba wydajnosc haca na i7-8700k

Recommended Posts

Witam.

Bylem zadowolony z hacintosha zbudowanego na i7-8700k @4.7GHz ram 32GB 2666 radeon rx580 8GB raid nmve 512gb... Macos Sierra

Ale juz nie jestem... Zmontowalem projekt na macbook pro 15 touch bar radeon pro 450 macos high sierra.

Poscilem eksport filmu ponad 2h do h264 izaskoczylo mnie to ze skonczyl sie po niecalej h... Zawsze robilem eksport na hacu i trwal dluzej. Postanowilem ten sam projekt wrzucic na ssd pod usb3.0 i porownac wydajnosc...

I tu jest problem bo macbook pro ponad 2x szybciej eksportuje film! Ma mniej ram ma 2 rdzenienie mniej i nizej taktowane... W testach cinebench czy geekbench uzyskuje wyniki dwa razy gorsze od haca...

O co chodzi?


edit

zrobiłem kolejne testy np sprawdzajac wydajnosc stabilizacji, imperiacam obciaza grafike i jest dwa razy szybciej na hacu, smoothcam obciaza procesor i jest o polowe szybciej na hacu... wiec gdzie problem z eksportem?

edit 2

bruceX do h264 na hacu 3x szybciej !! ktoś mi powie co jest nie tak z tym haciem przy eksporcie normlanego projektu? Gdzie szukać?

Share this post


Link to post
Share on other sites

Podepnę się pod temat, bo odkryłem podobną sytuację - tyle, że bez macbooka. Po odpaleniu iGPU hd4600, FCPX koduje timeline do h264 ponad 2x szybciej niż na samym RX580. Wygląda to tak, jakby przy pracy olewał radeona.

Share this post


Link to post
Share on other sites

Wydaje mi się że ja mam odpalonego samego radeona (w raporcie systemowym widnieje tylko on). Nie ogarniam chyba tego tematu za dobrze :/ pozwole sobie wrzucić mój konfig konfiguracja ze stopki. Kexty jakie mam wrzucone to AppleALC, AtherosE2200Ethernet, CodecCommander, FakeSMC_ACPISensor, FakeSMC_CPUSensor, FakeSMC_GPUSensor, FakeSMC_LPCSensor, FakeSMC, IntelGraphicsFixup, RealtekRTL8111, Shiki, USBInjectAll, WhateverGreen, XHCI-200-series-injector...

Zapewne mam coś skopane :/

Share this post


Link to post
Share on other sites

Rozumiem masz odpalone grafiki tą metodą: http://hamac.pl/topic/14928-prawid%C5%82owa-konfiguracja-pod-imac-i-inne-smbiosy-z-igpudgpu/?hl=dgpu ?

Czy jest różnica w działaniu kiedy odpalony jest tylko radeon ?

 

Tak dokładnie tą metodą. Różnica jest kolosalna. W ogóle zająłem się odpalaniem dodatkowo hd4600 ze względu na "oporną pracę" FCPX 10.4. Program strasznie przycinał przy odtwarzaniu klipów na timeline. Po odpaleniu hd4600 wszystko wróciło do normy - płynne odtwarzanie klipów i .... co odkryłem przypadkiem błyskawiczne kodowanie timeline do h264. Tak szybko to jeszcze nigdy tego nie robił :) Czyli symptomy wskazują, że zaczął się posiłkować quicksync z iGPU. Jednocześnie wskazywało by to na fakt, że radeon się nudzi. Jak go zmusić do pracy, nie mam pojęcia.

Share this post


Link to post
Share on other sites

Wydaje mi się że ja mam odpalonego samego radeona (w raporcie systemowym widnieje tylko on). Nie ogarniam chyba tego tematu za dobrze :/ pozwole sobie wrzucić mój konfig konfiguracja ze stopki. Kexty jakie mam wrzucone to AppleALC, AtherosE2200Ethernet, CodecCommander, FakeSMC_ACPISensor, FakeSMC_CPUSensor, FakeSMC_GPUSensor, FakeSMC_LPCSensor, FakeSMC, IntelGraphicsFixup, RealtekRTL8111, Shiki, USBInjectAll, WhateverGreen, XHCI-200-series-injector...

 

Zapewne mam coś skopane :/

Poczytaj wątek podlinkowany przez Oswaldiniego. Cała sztuka odpalenia iGPU polega właśnie na tym, żeby nie był widoczny w systemie, a działał. Od momentu jak zastosowałem ten myk, praca w FCPX znacznie się poprawiła. Niemniej lepiej by było wyłączyć intela a zmusić do wydajnej pracy RX. Jest jeszcze kwestia samego FCPX w wersji 10.4. W internetach sporo ludzi narzekało na jego gorszą kulturę pracy niż 10.3.x i właśnie przymulanie na prawdziwych macach, podobno ma wyjść jakaś większa poprawka - z naciskiem na podobno :) Co do Twoich kextów... nie widzę Lilu

Share this post


Link to post
Share on other sites

Dobra zainstalowalem istat menu zeby moc podejzec dokladnie obciazenie podzespolow.

Eksport do h264 na macbooku powoduje obciazenie grafiki w 80% procesora w 40% (zapewne przez hypertreting takie wartosci bo 4 rdzenie pracuja prawie na maxa)
Eksport do h264 na hacu powoduje mizerne obciazenie grafiki w okolo 10%... odpalonego mam samego radeona wylaczone multi gpu, wywalone kexty od intela wylaczony inject intela, wychodzi na to że mój radeon nie chce coś działać jak powinien. Czy trzeba moze zmienic framebuffer czy cos?

Share this post


Link to post
Share on other sites

Pogrzebałem w configu pozmienialem troche patchy i w system info nie widac juz UHD w istat menu jest widoczna, przy eksporcie jednak obciazenie radeona dalej mam minimalne :/ poniżej link do mojego clovera

whitedreamstudio.pl/photo/CLOVER.zip

będę mega zobowiązany jeżeli ktoś zerknie, nawet jest w stanie zapłacić bo kurcze nie po to wydawałem kase na tego radeona zeby on nic nie robił...

Share this post


Link to post
Share on other sites

Też zrobiłem testy. U mnie jest tak: 

1. MacPro i RX580 -  obciąża grafikę ( też pobrałem istat) w różnym stopniu, przy teście BruceX bardziej, przy kodowaniu testowego 20sek fragmentu studniówki (z kilkoma filtrami) mniej. Czas kodowania studniówki do h264 - 40 sek

2. iMac i RX 580 - też grafika pracuje, nie na maxa ale więcej niż 1/4, czasem spadnie do zera i podnosi się.  czas kodowania 40 sek

3.iMac RX580 +HD4600 Radeon pracuje intel nie ! czas kodowania 35 sek

4. MacPro RX580+HD4600 Radeon pracuje intel nie! czas kodowania 35 sek.

Przy wyłączeniu iGPU program macx-video-converter-pro pokazuje, że akceleracja jest "not suported", a przy włączonym iGPU pokazuje "suported" i wskazuje intela HD4600. Używam tego programu do sprawdzenia wspierania akceleracji, bo tak mi prościej. VDAChecker pokazuje mi w każdym powyższym konfigu, że jest OK.

Teraz nie wiem na ile iStat jest wiarygodny. W zasadzie wygląda to podobnie, aczkolwiek z wyłaczonym iGPU kultura pracy Finala jest dla mnie nie do przyjęcia. Może program ma jakieś bugi... nie wiem.

 

Zapomniałem dodać, że testy robiłem na 10.12.6. Teraz odpaliłem sobie 10.13.3 i tu czas kodowania testowej studniówki wyniósł 25 sekund w konfiguracji iMac+HD4600+RX580. Nie mam niestety na tym systemie iStat, więc nie wiem jak z obciążeniami grafik.

Edited by Najrad

Share this post


Link to post
Share on other sites

Robie to samo czyli przesiadam sie na High Sierre i zrobie testy na fcpx 10.4 i 10.3.4. Teraz mam sierre i fcpx 1.4.

 

Czas renderowania pliku przy single pass i bitrate ok 16mb/s wynosiu u mnie w przyblizeniu czas trwania klipu. Pliki avchd z sony a7s2.

Share this post


Link to post
Share on other sites

Sierra FCPX 10.3.4 radeon także leży odłogiem wiec ewidetnie cos mam w konfigu zwalone :/


Dodam tylko że w luxmarku mam 13000 tys punktow, podczas testu jest w pelni obciazany, stabilizacja imperiacam grafika w pelni obciazaona, eksport do h264 grafika stoi :/ bruceX 14s

Gdzie jest problem w tym że FCPX nie kożysta z mocy radeona?

 

Share this post


Link to post
Share on other sites

Czy pliki z a7s masz na timeline gołe czy ponakładane fx-y? Zauważyłem, że obciążenie grafiki skoczyło do 75% przy eksporcie pliku który miał kilka fx-ów a przy normalnym eksporcie procesor idzie na 100% a grafika tak jak u ciebie na 1/10 mocy i się nudzi.

Sprawdziłem 2 karty rx580+r9270x+hd4600 o ile czasami wykorzystywana jest rx580 ( do niej dopięte są monitory) o tyle 270X stoi cały czas na 0%

Monitoruje teraz eksport do proresa wspomnianej studniówki i czasami obciążenie karty wzrasta prawie do 75%, więc w jakiś sposób jest wykorzystywana na klipach obłożonych FX-ami. Może FCPX jakoś zarządza wspomaganiem karty  - nie mam pojęcia. Nie można jednak powiedzieć, że jest niewykorzystywana w ogóle. 

 

post-743-0-73523700-1518863765_thumb.png

Share this post


Link to post
Share on other sites

Przy fx czy stabilizacji obciazenie skacze na maksa. Gole pliki grafika sie nudzi... A ten sam projekt na macbooko pro 15 touch bar dostaje wsparcie grafiki tez przy eksporcie golych plikow! Cos chyba jednak z obsluga rx580 jest nie tak pod fcpx, kazdy robi brucex i sie cieszy ze mega wydajnosc a przy eksporcie klops... Fajnie jakby ktos jeszcze usiebie to przetestowal. Bo narazie wyglada to na niezly klops...

Share this post


Link to post
Share on other sites

Jest wykożystywana przy FX, stabilizacji itd. Natomiast gdy dochodzimy do golego fragmentu, 10% obciążenia gdy w macbooku obciążenie grafiki jest cały czas prawie na maksa. 

Eksport trwa prawie 3x krócej... Kurcze musi coś tu być nie tak pytanie co i czy każdy hacintosh tak ma...

obciazenie macbook
whitedreamstudio.pl/photo/macbook.png


obciazenie hac (ten pik to zapetlony BruceX, a za nim odrazu eksport do h264)
whitedreamstudio.pl/photo/hac.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.