Jump to content
meeron

Idzie nowe, Mojave 10.14.X

Recommended Posts

Nowa wersja systemu macOS 10.14 Mojave zmienia wymagania dość znacznie w stosunku do High Sierra.

 

Jeśli posiadacie komputer z procesorem wcześniejszym niż 3 generacja Intel Core i3/i5/i7 (oznaczone numerami 3XXX) wasz komputer nie obsłuży nowego systemu a do tego wymagane jest posiadanie karty graficznej która wspiera API Metal (Intel HD4000+, AMD bazujące na GCN+ oraz Nvidia Kepler+).

 

Metal działa na kartach graficznych:

Nvidia – GeForce gtx 4xx I nowsze
Intel – HD4000 and newer (ivy bridge I nowsze)
AMD – HD7000 i nowsze

 

Nowa wersja macOS 10.14 Mojave wspiera urządzenia Apple:

MacBook (od 2015 roku)

MacBook Air (mid 2012 i nowsze)

MacBook Pro (mid 2012 i nowsze)

Mac Mini (late 2012 i nowsze)

iMac (Late 2012 i nowsze)

iMac Pro (2017)

Mac Pro (late 2013, mid 2010, mid 2012 z kartami graficznymi obsługującymi silnik Metal)

 

 

 

Nie obsługiwane modele:

 

var nonSupportedModels = ['MacBookPro4,1','MacPro2,1','Macmini5,2','Macmini5,1','MacBookPro5,1','MacBookPro1,1','MacPro4,1','MacBookPro5,2','iMac8,1','MacBookPro5,4','MacBookAir4,2','Macmini2,1','iMac5,2','iMac11,3','MacBookPro8,2','MacBookPro3,1','Macmini5,3','MacPro5,1','Macmini4,1','iMac9,1','iMac6,1','Macmini3,1','Macmini1,1','MacBookPro6,1','MacBookPro2,2','MacBookPro2,1','iMac12,2','MacBook3,1','MacPro3,1','MacBook5,1','MacBook5,2','iMac11,1','iMac10,1','MacBookPro7,1','MacBook2,1','MacBookAir4,1','MacBookPro5,3','MacBookPro6,2','iMac12,1','MacBook1,1','MacBookPro5,5','iMac11,2','MacBookPro1,2','iMac4,2','Xserve2,1','MacBookAir3,1','MacBookAir3,2','MacBookAir1,1','Xserve3,1','iMac4,1','MacBookAir2,1','Xserve1,1','iMac5,1','MacBookPro8,1','MacBook7,1','MacBookPro8,3','iMac7,1','MacBook6,1','MacBook4,1','MacPro1,1',];

 

 

Wymagany jest clover najnowszy, do pobrania np. tu https://github.com/Dids/clover-builder/releases , pobranie -> Clover 4522

 

Aktualizujcie do najnowszych wydań kexty, apfs.efi, config.plist dla SMBIOS i ewentualne patche

Share this post


Link to post
Share on other sites

Jeszcze jedna ważna sprawa - wszystkie karty WiFi Atherosa zostały wycięte, więc m.in. niezawodny i ogólnodostępny TP-Link TL-WDN4800 idzie na emeryturę, przynajmniej oficjalną, bo pewnie można kombinować z kextami z High Sierra.

Share this post


Link to post
Share on other sites

Jeszcze jedna ważna sprawa - wszystkie karty WiFi Atherosa zostały wycięte, więc m.in. niezawodny i ogólnodostępny TP-Link TL-WDN4800 idzie na emeryturę, przynajmniej oficjalną, bo pewnie można kombinować z kextami z High Sierra.

I tu mnie zmartwiłeś :( Trzeba będzie przerzucić się na Broadcoma.

Share this post


Link to post
Share on other sites

Wygląda, że w końcu można zbudować Fusion Drive na systemie plików APFS. U mnie zmieniło samo, zauważyłem dopiero dzisiaj.

Ciekawi mnie czy można same dyski HDD na których nie ma systemu używać dla APFS. Bo ja np. trzymam na takim dysku różne dane tylko, że na partycji w HFS+. Z tego co piszesz to powinno się teraz dać, skoro Fusion Drive = SSD + HDD.

Share this post


Link to post
Share on other sites

Tak, beta, GM w październiku. Zmiany na plus ale trochę ich mało. Microsoft wciąż ze swoim cyklem produkcyjnym wygrywa. Wdparcie dla CFL jesienią. Idzie nowe ale powoli a z nim MacBookPro14,3 na sześciu rdzeniach :) 

Share this post


Link to post
Share on other sites

U mnie na laptopie prawie wszystko działało od razu po aktualizacji. Musiałem tylko wgrać nowszą wersję Lilu i AppleALC by dźwięk powrócił. Na kompie niestety Nvidia i spatchowane Web Drivery nie dają akceleracji.

Share this post


Link to post
Share on other sites

A Metal nie działa tylko na Keplerach i nowszych? Mi kiedyś na GTX 550 Ti (Fermi) nie śmiagała High Sierra.

Nowa wersja systemu macOS 10.14 Mojave zmienia wymagania dość znacznie w stosunku do High Sierra.

 

Jeśli posiadacie komputer z procesorem wcześniejszym niż 3 generacja Intel Core i3/i5/i7 (oznaczone numerami 3XXX) wasz komputer nie obsłuży nowego systemu a do tego wymagane jest posiadanie karty graficznej która wspiera API Metal (Intel HD4000+, AMD bazujące na GCN+ oraz Nvidia Kepler+).

 

Metal działa na kartach graficznych:

Nvidia – GeForce gtx 4xx I nowsze
Intel – HD4000 and newer (ivy bridge I nowsze)
AMD – HD7000 i nowsze

 

Nowa wersja macOS 10.14 Mojave wspiera urządzenia Apple:

 

 

Nie obsługiwane modele:

 

 

Wymagany jest clover najnowszy, do pobrania np. tu https://github.com/Dids/clover-builder/releases , pobranie -> Clover 4522

 

Aktualizujcie do najnowszych wydań kexty, apfs.efi, config.plist dla SMBIOS i ewentualne patche

Share this post


Link to post
Share on other sites

Mogę się pochwalić, że testuję od tygodnia (aktualinie beta 8) i działa bardzo stabilnie - w porównaniu do high sierry w której karta graficzna łapała zwiechy jest rewelacyjnie  =D>

 

Konfiguracja sprzętowa:

Xeon x5660

Asus P6T SE

Grafika: GeForce GT 640 (GK208 na rdzeniu kepler)

 

Jedyna rzecz która nie działa to filevault - apple zrobiło ograniczenie i na Mac Pro 5.1 (mid 2010) nie można włączyć szyfrowania dysku.

Share this post


Link to post
Share on other sites

To napisz jeszcze, czy Finder i Preview otwiera jpg.

 

Mogę się pochwalić, że testuję od tygodnia (aktualinie beta 8) i działa bardzo stabilnie - w porównaniu do high sierry w której karta graficzna łapała zwiechy jest rewelacyjnie  =D>

 

Konfiguracja sprzętowa:

Xeon x5660

Asus P6T SE

Grafika: GeForce GT 640 (GK208 na rdzeniu kepler)

 

Jedyna rzecz która nie działa to filevault - apple zrobiło ograniczenie i na Mac Pro 5.1 (mid 2010) nie można włączyć szyfrowania dysku.

Share this post


Link to post
Share on other sites

U mnie otwiera bez problemu - czy to na rMBP15 (mid2015/mid2017/mid2018), czy to na haMacach (T3600, T7910 + kilka maszyn na Z370).

 

 

No widzisz. A u mnie - nie. I zachodzę w głowę, o co tu chodzi... Pojęcia nie mam. Spróbuję zmniejszyć wartość SMBIOS na niższą. Standardowo mam 17.1

 

Zmiana wartości SMBIOS nie pomaga, a gdzieś czytałem, że tak. 

Ciekawe, nie otwiera tylko jpg-ów, wszystkie inne pliki (gif, png, bmp, itd., a nawet stary typ JPG) czyta bez problemu. JPG otwierają się w aplikacji Photos, a także w ColorSync.

Edited by Ian

Share this post


Link to post
Share on other sites

Pewnie, że kartą graficzną. Tylko chodzi o to, że RX560 działa bezbłędnie z HighSierrą i Sierrą bez driverów, jak np. NVidia, a z Mojave już są problemy, choć tylko z jpg i w dodatku nie wszystkimi typami. Ale może to przejściowe, Grafika w tej becie jeszcze nie jest dopracowana. Jak zwykle z resztą.  :/

Share this post


Link to post
Share on other sites

 

 

Pomogło. Wprawdzie nieco inaczej, bo mój BIOS to ASUS, ale wystarczyło tylko w BIOS wyłączyć Auto przy PCIE i włączyć iGPU Multi-Monitor. To wszystko. Dzięki @reyder, za zwrócenie mi uwagi na ten post w InsanleyMac. On mnie naprowadził. 

Share this post


Link to post
Share on other sites

O też miałem z tym problem na najnowszej becie. Na płycie Asus Maximus VII Hero z RX'em 480 pomogło zmienienie z auto na PEG. 
Edit: Sprawdziłem z .png zamiast .jpg. Zmiana w biosie z Auto na PCI-E lub PEG nic nie daje.

Share this post


Link to post
Share on other sites

Ja akurat w procesorze nie mam integry więc to bardziej dla @lan.
Ah wcześniej się walnąłem i sprawdziłem .png, .jpg dalej nie działa. Ustawiałem w biosie na PEG i PCI-E ale bez zmian. Używam WhateverGreen do tego RX'a 580 od Sapphire Nitro+
Edit: Ustawiłem smbios iMacPro1,1 i działa, PM też śmiga.

Share this post


Link to post
Share on other sites

Ja akurat w procesorze nie mam integry więc to bardziej dla @lan.

Ah wcześniej się walnąłem i sprawdziłem .png, .jpg dalej nie działa. Ustawiałem w biosie na PEG i PCI-E ale bez zmian. Używam WhateverGreen do tego RX'a 580 od Sapphire Nitro+

Edit: Ustawiłem smbios iMacPro1,1 i działa, PM też śmiga.

 

Miałem i3 potem i7, a następnie xeon bez integry. Zastanawiałem się na przejście na ósmą generację z uwagi na blokadę starszych konfiguracji i obserwuję od dłuższego czasu 10.14, ale za szybko się nie przerzucę, w ostatnich latach traciłem mnóstwo czasu za zbyt szybkie wchodzenie w nowsze systemy. Co mnie zaciekawiło, że działa ci na iMacPro1,1.

 

A testowałeś identyfikację MacPro 6,1, powinno też działać?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.