Jump to content
Sign in to follow this  
Smartek

Niewidoczność dysków (i pendrive z instalką macOS) pod Cloverem

Recommended Posts

Witajcie

Sprzęt:  core i3-4170 + asus hd7770 + Gigabyte GA-H81M-S1

CloverBootX wrzucony na pendrive, widoczny pod UEFI w BIOS-ie i startuje bez problemów, F2 dało zrzut z nazwą płyty: H81M-S1. Zmieniłem nazwę folderu Z87 na nazwę mojej płyty.

Drugi pendrive przygotowany za pomocą TransMaca - "format disc for Mac", a następnie skutecznie przeprowadzony "restore" z czystego obrazu dmg Mojave 10.14.3.

 

BootCamp startuje (w BIOSie priorytet boot ustawiony z dopiskiem ("UEFI:"), ale nie widzi żadnego dysku ani tym bardziej pendrive'a z instalką Mojave. 

W BIOSie widoczne oba dyski HDD i oba pendrive'y, jeden z Cloverem i drugi z Mojave, ale ten drugi bez dopisku UEFI. Też musi mieć? Jeśli tak to jak to zrobić, skoro TransMac nie sformatował go w ten sposób? Czy to jest przyczyna tego, że jest on niewidoczny? 

 

Ostatecznie próbowałem zmieniać różne opcje w BIOS UEFI/Legacy, ale nic nie pomaga.

Dodam, że dodałem w boot args parametr, o którym wspominał @314TeR, tj "radpg=15" oraz uaktywniłem "KernelPm" za radą kolegi @javazlaz, ale jak mniemam opcje te na obecnym etapie nie mają wpływu na (nie)widoczność dysków.

 

Co mogę zrobić? Config.plist nie był ręcznie ruszany, innych opcji nie ustawiałem i nie grzebałem. Transmac zakończył odtwarzanie obrazu poprawnie i nic nie wskazywało na problemy.

 

Share this post


Link to post
Share on other sites

Aha, czyli kolega DKnoto specjalizuje się w instalacjach macOSów na maszynach wirtualnych? Narzędzia i obraz naszykowane i jutro będę działał. Czym najlepiej przygotować pendrive z instalką? Sprawdziłem dla pewności inny pendrive, zarówno z unibootx em i z instalacją, ale dało to zupełnie identyczny efekt.

Share this post


Link to post
Share on other sites

Na wstępie witam na nowym, ładniejszym forum :-).

Piszę kolejnego posta, ponieważ zrobiłem sporo rzeczy za ostatnimi radami:

1. Zainstalowałem VMware,
2. Udało mi się odpalić wirtualną maszynę z Mojave,
3. Przygotowałem na macOS Mojave na pendrive

Ale niestety sytuacja wygląda tak samo. Czego próbowałem:

1. Sprawdziłem pendrive również na drugim PC, sytuacja jest identyczna, z tą różnicą, że Clover widzi Windowsowe dyski.
2. Sprawdzałem różne porty USB w obu PC, 
3. Grzebałem w BIOSie zmieniając na różne sposoby Legacy/UEFI oraz kombinując z wirtualizacjami Intela. 

Niestety, nie udało mi się w żaden sposób posunąć ani trochę do przodu. Jedyna różnica jest taka, że tym razem w BIOSie pendrive z instalką Mojave widoczny jest z przedrostkiem "UEFI: ". Nie dało to żadnego efektu.

 

Co jeszcze mogę sprawdzić, zrobić lub zmienić, żeby wreszcie Clover zobaczył pendrive z instalką? Pendrive'y są nowe, ponieważ kupiłem dwa do eksperymentów kilka dni temu, zamieniłem niedawno clovera z instalką (przed próbą z VMWare), żeby upewnić się, że nie jest to wina żadnego z nich, ale bezskutecznie. Proszę o pomoc.

Share this post


Link to post
Share on other sites

Przygotowałem klucz przez Narzędzie Dyskowe robiąc wymaż, a następnie korzystając z opcji "Odtwórz". To była moja pierwsza styczność z macOSem, w jaki sposób inaczej mogę odtworzyć obraz na pendrive? Proszę o linka lub szersze wyjaśnienie :).

Share this post


Link to post
Share on other sites
10 minut temu, 314TeR napisał:

Jak przygotowałeś klucz? Użyłeś metody createinstallmedia?

Przygotowałem klucz przez Narzędzie Dyskowe robiąc wymaż, a następnie korzystając z opcji "Odtwórz". To była moja pierwsza styczność z macOSem, w jaki sposób inaczej mogę odtworzyć obraz na pendrive? Proszę o linka lub szersze wyjaśnienie :).

 

Share this post


Link to post
Share on other sites

OK, to zrób tak:

1. Pendrive wymaż w narzędziu dyskowym do FAT** i jako schemat partycji wybierz Główny rekord rozruchowy. Jako nazwę dysku wybierz "Untitled"

2. Pobierz z Mac App Store instalator Mojave

3. wejdź do niego poprzez taką komendę (w terminalu):

cd /Applications/Install\ macOS\ Mojave.app/Contents/Resources/

a następnie zacznij tworzenie instalatora komendą:

sudo ./createinstallmedia --volume /Volumes/Untitled

 

Share this post


Link to post
Share on other sites
9 minut temu, 314TeR napisał:

MS-DOS FAT i tak później createinstallmedia przeformatuje pendrive na właściwy format.

Z niewiadomego powodu otrzymuję obecnie komunikat jak na screenie, próbowałem 3x.

Przechwytywanie.PNG

Share this post


Link to post
Share on other sites

Rada z przełączeniem widoku pomogła :-). Pendrive sformatował się.

Udało się również pobrać instalator Mojave, właśnie kopiuje się na USB za pośrednictwem terminala i polecenia createinstallmedia.

 

Dam znać czy tym razem wreszcie będzie widoczny :D. Pytanie na później: czy te wirtualizacje Intela powinny być w BIOS-ie wyłączone czy włączone? Są bodajże co najmniej dwie.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.