Jump to content
Sign in to follow this  
pablo1975

Dziwne z trasfery po LAN - Mac OS - Windows

Recommended Posts

Witajcie, pytanko do zorientowanych w tematyce sieci i kart sieciowych... najpewniej do Amina :)

Mam w studio dwie stacje spięte na krótko po LAN i ostatnio połączyłem je przez switch, w związku z czym postanowiłem przetestować szybkość tego 1Gb połączenia za pomocą iPerf i potwierdziły się moje poprzednie przypuszczenia. Otóż transfery z Win do MAC są na poziomie 780 Mbit/s a w drugą stronę połowę wolniej czyli ok 300Mbit/s. Co też obija się na szybkości kopiowaniu plików. z Win do Mac idzie ok 100MB/s a w drugą stronę ok 50MB/s. Co ciekawe jak kopiuję z Maca do Win ale pod Win 7 do też idzie szybciej. Tak jakby Windows coś akcelerował?

MacPro:~ Pablo$ /Volumes/Dane/Unclutter/iperf3 -c 10.0.0.11
Connecting to host 10.0.0.11, port 5201
[  4] local 10.0.0.10 port 49168 connected to 10.0.0.11 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  31.0 MBytes   260 Mbits/sec                  
[  4]   1.00-2.00   sec  49.1 MBytes   412 Mbits/sec                  
[  4]   2.00-3.00   sec  43.9 MBytes   368 Mbits/sec                  
[  4]   3.00-4.00   sec  68.8 MBytes   577 Mbits/sec                  
[  4]   4.00-5.00   sec  13.9 MBytes   117 Mbits/sec                  
[  4]   5.00-6.00   sec  16.9 MBytes   142 Mbits/sec                  
[  4]   6.00-7.00   sec  24.0 MBytes   201 Mbits/sec                  
[  4]   7.00-8.00   sec  24.2 MBytes   203 Mbits/sec                  
[  4]   8.00-9.00   sec  32.0 MBytes   269 Mbits/sec                  
[  4]   9.00-10.00  sec  59.3 MBytes   497 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   363 MBytes   305 Mbits/sec                  sender
[  4]   0.00-10.00  sec   363 MBytes   305 Mbits/sec                  receiver

iperf Done.
MacPro:~ Pablo$ /Volumes/Dane/Unclutter/iperf3 -c 10.0.0.11 -R
Connecting to host 10.0.0.11, port 5201
Reverse mode, remote host 10.0.0.11 is sending
[  4] local 10.0.0.10 port 49170 connected to 10.0.0.11 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  85.7 MBytes   719 Mbits/sec                  
[  4]   1.00-2.00   sec  85.8 MBytes   720 Mbits/sec                  
[  4]   2.00-3.00   sec  85.9 MBytes   720 Mbits/sec                  
[  4]   3.00-4.00   sec  85.8 MBytes   720 Mbits/sec                  
[  4]   4.00-5.00   sec  85.9 MBytes   720 Mbits/sec                  
[  4]   5.00-6.00   sec  85.8 MBytes   720 Mbits/sec                  
[  4]   6.00-7.00   sec  85.9 MBytes   720 Mbits/sec                  
[  4]   7.00-8.00   sec  85.8 MBytes   720 Mbits/sec                  
[  4]   8.00-9.00   sec  85.9 MBytes   720 Mbits/sec                  
[  4]   9.00-10.00  sec  85.8 MBytes   720 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   858 MBytes   720 Mbits/sec                  sender
[  4]   0.00-10.00  sec   858 MBytes   720 Mbits/sec                  receiver

iperf Done.
MacPro:~ Pablo$


To samo dokładnie dzieje się przez switch. Czyli wina jest po stronie kompa z Mac OS raczej. Dodam, że test robiłem za pomocą kabelków zwykłych CAT 5e oraz crossowanych.

 

Share this post


Link to post
Share on other sites

Nie pamiętam po której stronie (czy Win czy macOS), ale SMB w najnowszych systemach jest skopane i muli. Po Twoich testach wychodzi, że problemem jest nowszy Windows. Np problem też masz jak masz karty 10Gb/s - tam już w ogóle jest masakra, bo okazuje się, że z 10Gb/s osiągasz maks 2-3Gb/s. 😵

Coś mi dzwoni w głowie, że winna jest opcja szyfrowania połączenia? Kurczę nie pamiętam, ale powinieneś szybko odnaleźć podobne problemy w google. Co ciekawe problemu nie ma jeśli używasz AFP, albo SBM z samby w połączeniu do np NASa.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.