Jump to content
314TeR

OpenCore - dyskusja ogólna

Recommended Posts

14 godzin temu, AlPaczino napisał:

Nie mogę wyłączyć tego, bo nie mam w biosie:

CFG Lock(MSR 0xE2 write protection)
If this can't be turned off in the BIOS(or even found) please consider patching it out. See Fixing CFG Lock for more info.

Myślicie, że to może restartować komputer?

Restarty z MSR to restarty zaraz na początku wczytywania kernela. Czy masz zablokowane rejestry MSR łatwo sprawdzić robiąc np preboot.log cloverem - tam w logu masz napisane czy jest blokada MSR czy nie.

14 godzin temu, AlPaczino napisał:

Jak mogę wyłączyć serial port? Jest jakiś patch?

Ustawienie w BIOS - musisz mieć na 100%.

Share this post


Link to post
Share on other sites

Opcja wyłączenia serial portu została usunięta z GUI w najnowszych biosach. Przejrzałem wzdłuż i wszerz i nie ma jej. Na forum na "T" też jest ten wątek poruszony:

https://www.tonymacx86.com/threads/ssdt-or-clover-patch-to-disable-super-i-o-serial-port-on-gigabyte-z390-m-gaming.287471/

U mnie serial port nie powoduje problemów, wyłączyłem go w ustawieniach macOS i tyle.

Share this post


Link to post
Share on other sites

Na F4 były te opcje, zrobiłem upgrade do F8 i faktycznie wszytko jest inaczej. Przekopałem cały bios i nie ma.

Clover też się restartuje. Masakra!

 

Nie da się pracować. Mam wrażenie, że nie da się już dobrze zrobić Hakintosha.

 

Pierwszego, dawno temu zrobiłem tony-makiem i używałem 4 lata i nic, a teraz co chwila problemy.

Wiem co napiszecie, że to złe narzędzia itd. Ale działało.

Share this post


Link to post
Share on other sites
Teraz, AlPaczino napisał:

A tak się da? Myślałem, że to jest niemożliwe.

Spróbuj. Fak w niektórych płytach się nie dało po przejściu na wyższą wersję, ale jak sam system wgrywania BIOSu nie zablokuje to można wgrać starszą wersję.

Share this post


Link to post
Share on other sites
2 godziny temu, AlPaczino napisał:

A tak się da? Myślałem, że to jest niemożliwe.

Nawet jeśli producent na to nie pozwala to zawsze pozostaje własnoręczne zaprogramowanie EPROM. Każdy szanujący się serwis komputerowy ci to zrobi.

Edited by wujek_bogdan

Share this post


Link to post
Share on other sites

Takie ustawienia biosu  https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/creating-the-usb są polecane na tej stronie pod OC.

Może komuś się to przyda, ja pod Cloverem niektóre rzeczy miałem inaczej.
 
Większość ustawiłem, zobaczcie co warto jeszcze zmienić.
 
PROFIL 1 -TAK

Disable:
Fast Boot -TAK
VT-d(can be enabled if you set DisableIoMapper to YES, AMD users will need to disable SVM in the BIOS) -TAK 
CSM -TAK
Thunderbolt -NIE MAM
Intel SGX -TAK
Intel Platform Trust -TAK
CFG Lock(MSR 0xE2 write protection)If this can't be turned off in the BIOS(or even found) please consider patching it out. See Fixing CFG Lockfor more info. -NIE MAM, Czy to jest istotne?

Full Screen LOGO SHOW -TAK

------------------------------------------------------------------------------ 

Enable
 
INTEL Graphics -TAK
DVMT PRE-Alloc - 32M -TAK   (Inni maja 64M)
DVMT Total Gfx Mem - 128M -TAK (Inni maja 256M)

VT-x  -NIE MAM, Czy to jest istotne?
Above 4G decoding -TAK
Hyper-Threading -TAK
Execute Disable Bit  -NIE MAM, Czy to jest istotne?
EHCI/XHCI Hand-off -TAK
Legacy USB Support -TAK
OS type: Windows 8.1/10 -TAK
 
------------------------------------------------------------------------------ 
 
Czy te ustawienia są istotne:
 
Parallel Port - Disable  -NIE MAM, Czy to jest istotne?
Serial Port - Disable  -NIE MAM, Czy to jest istotne?
 
Aggressive LPM SUPPORT - Enebled -TAK było? To potrzebne?
 
Security Davice Support - Enebled -TAK było? To potrzebne?
 
Tak mają inni na tej płycie:
Network Stack - Disable -TAK, Czy to jest istotne?
 
Pawer:
Erp - Disable -TAK
RC6 (Render Standby) - Enebled -TAK
Port 60/64 Emulation - Enebled -TAK
 
Czy te ustawienia są istotne:
USB Mass Storage Driver Support - Enable -TAK

W Z170 mam TH:
TBT Vt-d Base Securite - Disable -TAK, to jest OK?
Th Boot Supportet - Disable -TAK, to jest OK?
Security Level - No security -TAK, to jest OK?
 
Dzięki za pomoc.
 
Edited by AlPaczino

Share this post


Link to post
Share on other sites

Wszystko zależy od producenta płyty (rodzaju BIOS), platformy, procesora, vga itd...

Jest parę zasad "żelaznych" - ustawienie tych opcji inaczej niż poniższe ZAWSZE będzie powodowało problemy:

  • Execute Disable Bit - Enable
  • VT-d - Disable
  • CFG Lock (MSR 0xE2 write protection) - Disable

Poniższe są mocno rekomendowane, chyba że ustawienie ich w sposób jak niżej będzie powodować błędnie działanie macOS.

  • CSM - Disable
  • Fast Boot lub Ultra Fast Boot - Disable
  • Above 4G decoding - Enable

Reszta ZAWSZE w zależności od płyty, tego jak USB jest zaimplementowane - czasami XHCI Handoff trzeba włączyć, niekiedy nie trzeba, podobnie jak zmiana ustawień dla iGPU czy portów szeregowych. Niektóre płyty poprawnie działają dopiero z wyłączonym portem RS232, a inne śmigają OK. Kluczowe zawsze są tylko 3 z pierwszego akapitu, reszta zależy jaka płyta, jaki kontekst. W niektórych płytach NIE należy włączać Above 4G decoding, w innych np wyłączenie CSM uwala część wyjść obrazu z dGPU i trzeba zostawić włączone CSM. Ja np na mojej płycie mogę korzystać z Fast Boota - ale widziałem wypadki, że na na podobnej płycie lub z odrobinkę innym sprzętem nie chciał on działać OK... W każdej płycie należy też samemu odnaleźć jak pod jaką nazwą kryje się dana funkcja - niekiedy może to być pod innymi nazwami niż wyżej. Sztandarowym przykładem jest ustawianie CSM, w ASUSach jest po prostu CSM Enable/Disable, w Gigabyte, dopiero jak włączysz coś w stylu OS type: Windows 8.1/10 na Enable powinna pojawić się podobna opcja, w innych płytach np DELL, ma się sekcje ładowania ROMów Legacy i Uefi - odznaczając Legacy przełączasz płytę w czyste UEFI (czyli wyłączasz CSM). Tak czy siak nie ma jeden recepty, trzeba wiedzieć i umieć odnaleźć daną opcję w BIOS i ustawić ją tak aby odniosło to oczekiwany skutek.

 

Share this post


Link to post
Share on other sites

@314TeR  DZIĘKI.

 

@danielosx86 gdzie wyłączyłeś serial port w ustawieniach macOS?

 

@314TeR Czy CFG jest na disable? Znalazłem takie wpisy:

0:110  0:000  MSR 0xE2 before patch 1E008000
0:110  0:000  MSR 0xE2 is locked, PM patches will be turned on

55:055  0:000  CSR_CFG: CSR_ALLOW_UNTRUSTED_KEXTS | CSR_ALLOW_UNRESTRICTED_FS | CSR_ALLOW_TASK_FOR_PID | CSR_ALLOW_UNRESTRICTED_DTRACE | CSR_ALLOW_UNRESTRICTED_NVRAM
55:055  0:000  Will not patch boot.efi
55:055  0:000  EmuVariable InstallEmulation: orig vars copied, emu.var.services installed, CreateEvent VirtualAddressChange = Success, CreateEvent ExitBootServices = Success, set Status=Success

 

Co z Execute Disable Bit? Mogę to jakoś sprawdzić?

 

Dzięki za pomoc.

Edited by AlPaczino

Share this post


Link to post
Share on other sites

Cześć,

Nie wiem czy zakładać nowy watek, bo może odpowiedź jest prosta.

Przy uruchomianiu, zawsze wyskakuje mi taki błąd:
No Arguments are initialised for method [_STA]
ACPI Error: Method parse/execution failed [\_TZ.TZ10._STA] (Node ffffff804f171090)), AE_AML_UINITIALIZED_LOCAL (20160938/psparse-632)
ACPI Error: Method execution failed [\_TZ.TZ10._STA] (Node ffffff804f171090)), AE_AML_UINITIALIZED_LOCAL (20160938/uteval-183)

Ktoś ma tu podobny problem, niestety nie udało mi się znaleśc, by ktoś rozwiązał ten problem.

https://github.com/tspng/gigabyte-z390-m-gaming-clover


Spotkał się ktoś z tym? Co muszę dodać?
Dzięki za pomoc.

Share this post


Link to post
Share on other sites

Te błędy są związane z monitorowaniem temperatur (TZ=Thermal Zone). Chyba większość ma ten błąd, czytałem gdzieś, że może mieć to związek z VirtualSMC albo iStat Menus, ale nigdy nie chciało mi się sprawdzać czy po zmianie na FakeSMC lub usunięciu iStat Menus też występuje. W skrócie - nie ma się czym przejmować.

Edited by danielosx86

Share this post


Link to post
Share on other sites
W dniu 9.02.2020 o 12:01, danielosx86 napisał:

Te błędy są związane z monitorowaniem temperatur (TZ=Thermal Zone). Chyba większość ma ten błąd, czytałem gdzieś, że może mieć to związek z VirtualSMC albo iStat Menus, ale nigdy nie chciało mi się sprawdzać czy po zmianie na FakeSMC lub usunięciu iStat Menus też występuje. W skrócie - nie ma się czym przejmować.

Dzięki.

Z tego co pamiętam nie miałem tego na Clover. Na OC mam.

Do kompa wracam za kilka tygodni, to sprawdzę.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.