Jump to content

Recommended Posts

Witam, wszystkich proszę o informację 
Chciałbym odpalić OSX w możliwie najnowszej wersji na takim sprzęcie. 
MB: Z8NA-D6 (Intel 5500) 
CPU: 2x Intel(R) Xeon(R) CPU E5504  @ 2.00GHz 
RAM: 16GB RAM
Karta Graficzna - chcę kupić jakąś Sapphire na kilka monitorów. proszę o sugestię.

- Na jaką wersję OSX się mierzyć? 

- Jaka karta graficzna 2 do 4 monitorów nie korzystam z programów graficznych.

 - Docelowo na tej maszynie będę korzystał z VirtualBox i uruchamiał kilka maszyn virtualnych ale doczytałem że uruchomienie osx wymag wyłaczenia wsparcia dla VT w bios (?) czy ma to w ogóle sens w takim razie? 

Pozdrawiam i dziękuję za pomoc

Share this post


Link to post
Share on other sites

Czy ten sprzęt już posiadasz, czy może dopiero planujesz kupić? Jeśli to pierwsze, to okej, można się z tym bawić, ale jeśli to drugie, to raczej poszukaj czegoś nowszego. Ten sprzęt to LGA1366, czyli w zasadzie odpowiednik MacPro5,1 - powinno się dać odpalić Mojave (10.14), zakładając oczywiście, że będziesz mieć odpowiednią (czytaj: wspieraną) GPU. Niemniej, trzeba pamiętać, że 10.14 to jest max dla tej platformy, ponadto wydajnościowo wciąga ją nosem w zasadzie każdy sprzęt na coffee lake. Co do GPU, RX570/RX580 są w tej chwili dość tanie i działają bezproblemowo. 

 

Co do wyłączania VT, wirtualizacja, czyli VT-x, powinna być włączona. Jedyne, co jest do wyłączenia, to VT-d, czyli VT for Directed I/O. VT-d potrzebne jest tylko wtedy, gdy chce się robić PCIe passthrough.

Share this post


Link to post
Share on other sites

Hej :) dzięki za odpowiedz.
Taki sprzęt już mam i działa pod linux.
Dzięki z info o VT chyba nie doczytałem. sr-iov /vd-t nie używam i tak.  
Klasa sprzętu 5.1 to dla mnie aż nadto. 

Próbuje się dowiedzieć jak ustawić parametry w config.plist większość opisów dotyczy właśnie nowszych platform i trudno to ogarnąć z takim dziadkiem. 
Na chwilę obecną mam tak że przy odpalaniu systemu po chwili sprzęt się wyłącza i kaplica odcięcie zasilania dopiero pozwala ponownie go uruchomić. 

 

Share this post


Link to post
Share on other sites

Wyzwanie zaakceptowane.

To nie będzie proste stawianie, ponieważ jest to bardzo niszowa płyta i na 100% trzeba będzie rozwiązywać problemy jakich nie spotkamy w konsumenckich płytach.

OK do rzeczy. Pomożemy Ci odpalić macOS na tej maszynie - ja chętnie pomogę ponieważ lubię wyzwania, a to coś innego niż kolejny Z97/Z370 etc... Maks bezproblemowy dla tej maszyny to 10.14.6, minimalna VGA to np Radeon HD7770 - pociągnie na 100% 2 wyjścia, ale więcej nie wiem. Z wyższych modeli jak wspomniał @Estrax RX570/580. Na pokładzie jest LAN intela który powinien działać OOTB, taki same karty były w maczkach. ICH10R też był w maczkach i porty SATA do ruszenia - pozostałe kontrolery - NIE wiem. Trzeba szukać czytać co to faktycznie jest i czy te układy występowały w jakiejkolwiek formie dla Mac Pro. Identyfikacja MacPro5,1. Na pewno będą potrzebne poprawki do DSDT. A reszta... wyjdzie w praniu.

Musisz tylko odpowiedzieć sobie na jedno pytanie - jak bardzo chcesz mieć macOS na tej maszynie? Potrzebna będzie cierpliwość i samozaparcie z Twojej strony.

 

Share this post


Link to post
Share on other sites

Dziękuję za deklarację i chęci :)

Producent karty ma znaczenie? Chciałem szukać Sapphire.  
Ta o której piszesz 
HD7770  są ASUS`y? te o którch pisał @Estrax po cirka 650pln nowe sztuki ale jest wybór 
Czacha mi paruje... z jednej strony szkoda kasy a z drugiej jest wybór...

Załączę preboot.log może się przyda mam jakąś starą quadro tak włożyłem na sztukę. 

preboot.log

Edited by lipa

Share this post


Link to post
Share on other sites

Ustalmy dane wejściowe - co to za VGA?

Na tym sprzęcie maks 10.14.6 - do 10.14.x potrzeba jakąś VGA AMD - minimalny sensowony model do Radeon HD 7770 (Cape Verde) - były jeszcze niższe jakieś 7750 i nawet chyba 7730 - ale to są karty ciężko dostępne. Osobiście odpalałem zarówno VGA od ASUSa - 2 x DVI + Pełny DP + HDMI jak i Gigabyte 1 x DVI + 2 x mini DP + HDMI. 2 Wyjścia na 7770 na 100% działały, czy udało mi się odpalić kiedykolwiek 3 wyjścia - zabij ale nie pamiętam. Ze względu na jakość wykonania, cicho i przyjemnie pracują karty ASUSa z chłodzeniem Direct CU. Gigabyte znów ma układ wyjść identyczny jak podobne modele zaprojektowane do klasycznego Mac Pro 2010/2012 jakiego będziesz udawać.

Wracając do VGA - na jakim jest ona chipie? Być może da radę popchnąć ją w 10.13.6 - to ostatnia wersja macOS gdzie są dostępne sterowniki webowe nvidii i można w nim odpalić wiele kart z rodzin od Keplera 6xx to Pascali 10x0.

EDIT - VGA o której wspomniałeś to  NVIDIA Quadro FX 580? Jeśli tak, to ta karta może i raczej będzie za leciwa do odpalenia, pewnie by poszła, ale maks w 10.11.x.

Share this post


Link to post
Share on other sites

 

Poczytałem w temacie i kupiłem na znanym serwisie aukcyjnym: ASUS Radeon RX 580 Dual OC 8GB GDDR5 czekam na paczkę, 
Zakładałem że jakąś grafikę kupić trzeba bo to co mam jest żałosne.
Jeśli by się udało ogarnąć to zmienić też chcę procesory i dodać więcej RAM. 
Tak z moich śmieci wygrzebałem i mam ją chwilowo FX580 512Mb
Na płycie jest chyba coś takiego ASPEED Video Controller AST2050. ale to chyba bez znaczenia.

Share this post


Link to post
Share on other sites
11 godzin temu, lipa napisał:

Producent karty ma znaczenie? Chciałem szukać Sapphire.  

Saphire są montowane w makach, te karty podobno działają natywnie nawet bez WhateverGreen.kext. Niestety są dosyć głośne. Ja uważam, że najlepszy wybór jeśli chodzi o kulturę pracy i temperatury to MSI Gaming X oraz ASUS ROG Strix.

Share this post


Link to post
Share on other sites
9 godzin temu, lipa napisał:

Poczytałem w temacie i kupiłem na znanym serwisie aukcyjnym: ASUS Radeon RX 580 Dual OC 8GB GDDR5 czekam na paczkę, 

Powinna działać.

9 godzin temu, lipa napisał:

Jeśli by się udało ogarnąć to zmienić też chcę procesory i dodać więcej RAM. 

Rób takie roszady jak faktycznie da się odpalić macOS - wcześniej mogą być niopłacalne. Jeśli ta płyta obsługuje pamięci Registred - a zapewne tak jest - to obecnie na alledrogo jest sporo ofert takich pamięci wyjmowanych z złomowanych serwerów - powinieneś spokojnie coś znaleźć. CPU znów najlepiej szukaj na alliexpres - powinieneś znaleźć najtaniej. Najmocniejszy CPU jaki wsadzisz to Six-Core Intel Xeon X5675(3.06GHz, 12MB,6.4GT/s,B1) - pytanie ile by kosztował, ewentualnie sprawdź cpu oczko wolniejsze - często są o połowę tańsze, a wiele wolniejsze nie są.

9 godzin temu, lipa napisał:

Tak z moich śmieci wygrzebałem i mam ją chwilowo FX580 512Mb
Na płycie jest chyba coś takiego ASPEED Video Controller AST2050. ale to chyba bez znaczenia.

Żadnej z tych VGA nie odpalisz pod macOS 10.13.x/10.14.x.

Share this post


Link to post
Share on other sites

Witam,

Karta dotarła :) -> ASUS Radeon RX 580 Dual OC 8GB GDDR5

Użyłem forumowego  UniBootX Clover zmieniłem nazwę katalogu 0 ASUS P5E P5Q series  na Z8NA-D6(C) i model maszyny na MacPro5,1 podnosi się z błędami do czasu startu grafiki potem ekran jest różowy/purpurowy (nie znam się na kolorach :)) i wisi restartuje się. 

Proszę o info jak mogę dalej popchnąć temat wiele dziś czytałem ale mam chyba jeszcze więcej pytań niż odpowiedzi... 

Pozdrawiam

IMG_20191118_165340.jpg

Edited by lipa

Share this post


Link to post
Share on other sites
W dniu 19.11.2019 o 10:30, lipa napisał:

Niestety nie ma czym się pochwalić.. 10.13 i 10.14 nie odpala na 10.13 pokazuje się jabłko jak nie zrobię -v przy starcie.
F5 powoduje podobny efekt jak wyżej. Jesteś pewien że w tej paczce są patche do ACPI nie mam pojęcia? 
System startuje jak podnosi grafikę ekran robi się różowy...

 

Edited by lipa

Share this post


Link to post
Share on other sites

Też z tym kombinowałem. 

1) brakowało mi portów USB, klawiatura/mysz i port USB bezpośrednio na płycie -> wgrałem UniBootX na dysk ssd z którego się startowałem na USB był OS - wynik ekran różowy.
2) znalazłem jakiś kabel z portem USB i podłączyłem do płyty startuje z jednego Pena UniBootX a OS jest na innym. 10.14 i 10.13 są na różnych penach. 

UEFI nie sądzę, najnowszy BIOS wgrałem i jest z 2012r.  ale jest spora ilość ustawień jak dla mnie nietypowych dla ACPI i innych, dla RedHat i Ubuntu nie mają znaczenia więc nie wnikałem i tak tylko terminal mi był potrzebny.

Tak się zastanawiam może zostawię te graty tak jak były na linux`ie.
I poproszę Ciebie/Was o jakąś podpowiedz w kwestii sprzęt który powinien pójść bez bólu. 
W przyszłym tygodniu są czarne piątki może coś upoluję :)

MB: GIGABYTE H370N/Gigabyte Z390 GAMING X/ASROCK jakiś?
- dwa porty M2 NVMe i 4 na kości pamięci to priorytet w tej konfiguracji. czy da radę puścić instalację osx na tych płytach po NVMe M2? 
CPU: jak dam radę to i5-9400F
RAM - czy ma jakieś znaczenie do instalacji czy tylko MHz do pogonienia chcę 32GB jak sie wyrobię z kasą
może być wolniejszy ale by było go więcej często uruchamiam maszyny wirtualne z Linux`ami. 


Dyski mam M2.NVMe i SATA 
Grafika jest ASUS Radeon RX 580 Dual OC 8GB GDDR5
Obudowa/zasilacze też mam.

Edited by lipa

Share this post


Link to post
Share on other sites

Znalazłem jakiś ktoś już kiedyś ogarną ustawienia pod OSX na tej płycie :)  2011 rok... 
https://www.insanelymac.com/forum/topic/219169-guide-how-to-install-snow-leo-on-asus-z8na-d6/?page=7

Advanced

CPU Configuration

C1E Support= Enabled
Hardware Prefetcher=Enabled
Adjacent Cache Line Prefetch=Enabled
MPS and ACPI MADT ordering=Modern Ordering
Max CPUID Value Limit=Disabled
Intel ® Virtualization Tech=Enabled
CPU TM Function=Enabled
Execute Disable Bit Capability=Enabled
Intel ® HT Technology= Enabled
Active Processors=All
A20M=Disabled
L1 IP Prefetcher=Enabled
L1 Data Prefetcher=Enabled
Intel ® TurboMode tech=Enabled
Intel ® C-State Tech=Enabled
C3 State=ACPI3
C6State=Enabled
C State package limit setting=C6
C1 Auto Demotion=Disabled
C3 Auto Demotion=Enabled
ACPI T State=Enabled

Chipset Configuration

CPU Bridge Configuration

           CSI Links Speed=Full-Speed
           CSI Frequency=Auto
           CSI Isochronus=Disabled
           CSI L1=Enabled
           Memory Frequency=Auto
           Memory Mode=Independent
           Memory ECC Function=Enabled
           Double Rate Refresh=Auto
           Demand Scrubbing=Enabled
           Patrol Scrubbing=Disabled
           NUMA Aware=Auto
           Page Policy=Open
           Adaptive Page=Disabled
           Channel Interleaving=6:1
           Rank Interleaving=4:1
           Memory Thermal Throttling=Disabled
           DDR3 Voltage Level=Auto
           DRAM DLL OFF=Enabled

North Bridge Configuration

           Crystal Beach / DMA=Enabled
           Crystal Beach / DCA=Enabled

South Bridge Configuration

           USB Functions=5 USB Ports
           USB Port Configure=6+6 Ports
           HDA Controller=Disabled
           SLP_S4# Min. Assertion Width= 2 to 3 seconds

Intel VT-d Configuration

Intel Vt-d=Disabled

Legacy Device Configuration

Onboard Floppy Controller=Disabled
Serial Port1 Address=Disabled
Serial Port2 Address=Disabled

USB Configuration

Legacy USB Support=Enabled
USB 2.0 Controller Mode=HiSpeed
Bios EHCI Hand-Off=Enabled

Advanced PCI/PnP Settings

Plug and Play OS=Yes
PCI Option ROM Scan Order= Bus 0 First
Onboard LAN1 Chip=Enabled
Onboard LAN2 Chip=Enabled
Onboard LAN1 Boot=Disabled
Onboard LAN2 Boot=Disabled

Power On Configuration

Restore on AC POwer Loss= Last State
Resume ON PCIE Wake#=Disabled
Resume On Ring=Disabled
Resume On RTC Alarm=Disabled

I/O Virtualization

SR-IOV Supported=Disabled

PCI Express Configuration

Active State Power Managment=Disabled

ACPI Configuration

ACPI 2.0 Support =Enabled
ACPI APIC support=Enabled
BIOS-->AML ACPI table=Enabled
Headless mode=Disabled

Chipset ACPI Configuration

APIC ACPI SCI IRQ=Disabled
USB Device Wakeup From S3/S4=Enabled
High Performance Event Timer=Enabled
HPET Memory Address=FED00000h

General WHEA Configuration

WHEA Support=Disabled

Share this post


Link to post
Share on other sites

Dla macOS generalnie większość ostawień zwykle poprawna jest domyślna.

Kluczowe to:

Intel Vt-d=Disabled

Execute Disable Bit Capability=Enabled

Legacy USB Support=Enabled

Warto pobawić się:

Bios EHCI Hand-Off=Enabled lub Disabled

Jak masz ACPI 2.0 - ustaw na Enabled.

 

Sprawdź różne porty USB.

 

Generalnie powinieneś móc odpalić Clovera i aby pokazał się z Theme "bootcamp" - tak jak w temacie o UniBootX. Zmienia na domyślą tapetę na tapetę bootcamp?

Share this post


Link to post
Share on other sites

Clovera  odpalam theme ze smokiem też mam :) potem startuje instalka 10.13/10.14 mieli mieli wali CPU UNSUPPORTED jedno pod drugim i błysk ciemno i błysk róż...  i tak już od 3 dni :)
Zmienia na domyślą tapetę na tapetę bootcamp jeśli chodzi ci o zmianę po utworzeniu katalogu zgodnego z nazwą systemu to myślę że jest ok.

Edited by lipa

Share this post


Link to post
Share on other sites

Różem może walić na domyślnym configu.

Natomiast ważne czy wczytuje config z OEM. Czy na tapecie bootcamp - jak wczyta się config pod płytę, można zrobić zrzut zmodyfikowanej tabeli DSDT (F5)?

Poprawki do DSDT masz w configu, ona powinny w locie poprawić sekcje HPET, TMR, RTC i TMR.

Share this post


Link to post
Share on other sites

Po zakupieniu karty grafiki Sapphire 570 Nitro+ 8GB wykonałem instalacje z użyciem UniBeast 9.3.0 - Mojave bez najmniejszego problemu na T5500 Dell 2x5650 z ciekawości przepiołem dysk z systemem do do ASUS - Z8NA-D6 boot`je się bez problemu. 
Jedyna komplikacja to podczas instalacji to czarny ekran Monitor był przypięty do DVI użyłem Display Port hula bez problemu. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.