Jump to content
danielosx86

NVRAM na Z390 - jak uruchomić

Recommended Posts

Godzinę temu, Najrad napisał:

Na moim Asusie Prime Z390 A (bios 0903) SSDT nie działa. Tylko DSDT z patchem załatwia sprawę.

U mnie BIOS 1302. Najnowszy Clover + Lilu + WG. config.plist (SMBIOS 19,2 - numery losowe)

 1734395808_Zrzutekranu2020-01-19o17_24_47.png.cd0c2e2cf8314913cd8716ec1fb3502b.png

Edited by mosquito

Share this post


Link to post
Share on other sites
2 godziny temu, danielosx86 napisał:

Spróbuj ładować SSDT w określonej kolejności


	<key>SortedOrder</key>
		<array>
			<string>SSDT-PM.aml</string>
			<string>SSDT-EC.aml</string>
			<string>SSDT-USBX.aml</string>
			<string>SSDT-UIAC.aml</string>
		</array>

 

OK spróbuję za godzinkę i dam znać.

Edited by Najrad

Share this post


Link to post
Share on other sites

Po sortowaniu istotnie zaczyna działać. Niepokoi mnie tylko ubogi wpis w IOregu, przy DSDT był taki jak pokazywał danielosx86, teraz został wykastrowany.Tak ma być? Test NVRAM przechodzi poprawnie, po restarcie wszystko jest w pamięci. 

Zrzut ekranu 2020-01-19 o 19.49.43.png

Share this post


Link to post
Share on other sites

Działa tak samo, PPMC jak się okazuje nie jest niezbędne, ale też w niczym nie przeszkadza. Kluczowe okazało się umieszczenie urządzenia PMCR pod _SB.PCI0.LPCB, skąd szybciej się ładuje, w "naszym" SSDT też tak było. To też wyjaśnia, dlaczego umieszczone w DSDT działało, bo w pierwszej wersji SSDT-NVRAM urządzenie ładowało się trochę za późno by działać prawidłowo.

Share this post


Link to post
Share on other sites

Najważniejsze, że działa. Myślałem, że nigdy nie będzie natywnego NVRAM na Z390 dlatego "wróciłem" na Z370 i myślałem poczekam na następne generacje... a tu taka niespodzianka :)

Share this post


Link to post
Share on other sites
W dniu 19.01.2020 o 16:36, danielosx86 napisał:

Spróbuj ładować SSDT w określonej kolejności


	<key>SortedOrder</key>
		<array>
			<string>SSDT-PM.aml</string>
			<string>SSDT-EC.aml</string>
			<string>SSDT-USBX.aml</string>
			<string>SSDT-UIAC.aml</string>
		</array>

 

Po zmianie kolejności nie restartuje się. Będę testował, czy wszystko ok.

Czy to dobra kolejność?

SSDT-PM.aml
SSDT-EC.aml
SSDT-USBX.aml
SSDT-AWAC.aml
SSDT-XOSI.aml

 

Jednak się restartuje:(

Jakiś pomysł?

 

Edited by AlPaczino

Share this post


Link to post
Share on other sites
9 godzin temu, jabi napisał:

Hej, u mnie zapis i odczyt działa, ale zawiesza sie przy restarcie. Jest na to jakas rada?

Używam SSDT-PMC z repo OpenCore.

Ty pewnie masz inny problem.

Ja miałem problem z restartowaniem się kompa po wybudzeniu, zrobiłem nowe mapowanie portów  USB i nowy kext. 

Teraz wszystko działa.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.